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1 Document Information 

1.1 Purpose and Scope 

This document provides a step by step description on how to integrate EtherNet/IP and PROFIBUS PA 

devices with the Schneider Electric Modicon system. All content of this document is jointly developed, 

reviewed and approved by Schneider Electric and Endress+Hauser as a common deliverable of Open 

Integration. 

1.2 Document History 

This is version 1.00.00 of this document. Version history: 

Version Released Description 

1.00.00 2021-03 Initial version 

 

1.3 Related Documents 

Please refer to related documents as listed below: 

Document Description 

SD02678S/04/EN/01.20 Reference Topology SE03 

SD02680S/04/EN/01.20 Integration Test Summary SE03 

SD02681S/04/EN/01.20 List of Tested Devices and Versions SE03 

 

2 Pre-Requisites 

Readers of this document should be familiar with related documents as listed in chapter 1.3 and basics on 

how to work with the Rockwell Automation ControlLogix System as well as EtherNet/IP and HART in 

general. Please refer to recommended literature as listed in chapter 2.1. 
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2.1 Recommended Literature 

2.1.1 Schneider Electric 

Document Description 

EIO0000001578.10 Modicon M580 Hardware Reference Manual 

EIO0000000482.02 TCSESM-E Extended Managed Switch  

Web-based Interface Reference Manual 

HRB62665.11 Modicon M580 BMENOC0301/0311 Ethernet Communications Module 

Installation and Configuration Guide 

2.1.2 Softing 

Document Description 

EN-062020-1.00 Users Guide EtherNet/IP Gateways 

2.1.3 Endress+Hauser 

Document Description 

BA00065S/04/EN/11.20 Operating Instructions FieldCare SFE500 

2.2 Operable Control System 

This document assumes an operable Schneider Electric System as defined by Reference Topology SE03. 

Please refer to the manuals listed in chapter 2.1.1 for an explanation on how to use hard- and software 

provided by Schneider Electric. 

2.3 Operable Asset Management System 

This document assumes an operable Endress+Hauser PAM System as defined by Reference Topology 

SE03. Please refer to manuals listed in chapter 2.1.3 for installing of software provided by 

Endress+Hauser. 

2.4 Operable Field Devices 

This document assumes an operable selection of Endress+Hauser EtherNet/IP and PROFIBUS PA devices, 

as defined by Reference Topology SE03. Each field device is powered if needed and adequately connected 

to the network infrastructure components. If required, please refer to individual device manuals for further 

advice.  
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3 Basic Integration 

This chapter describes the main workflow for integration of EtherNet/IP and PROFIBUS PA devices in 

combination with Phoenix Contact and Softing network infrastructure components into the Schneider 

Electric System. As a result, the EtherNet/IP cyclic communication is running, and all process values are 

available within the control strategy of the system for further processing. 

3.1 PROFIBUS PA Network Configuration 

3.1.1 Hardware Configuration 

In this example, the Endress+Hauser PROFIBUS PA field devices of the reference topology are split in two 

PA segments as shown on following picture (Two PROFIBUS PA segments are available on the Softing 

epGate PB gateway): 

 

• Each PROFIBUS PA segment is connected to a Softing epGate PB channel and externally supplied 

by a Phoenix Contact power supply FB-PS. The powered bus is then connected to a Phoenix 

Contact Trunk module FB-ET, which communicates to the different PA couplers FB-ISO of the 

segment.  

• FB-ET and FB-ISO modules communicate via ME 17.5 TBUS connectors. 

• Each PROFIBUS PA device is connected to one FB-ISO module. 
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• The table below lists all PROFIBUS devices configured address with the used method: 

 

3.1.2 Softing epGate PB Configuration 

Refer to chapter 3.2.2.2 for more details. 

 

 

  

Network Configured Address IPAdress Configuration Method

epGate PA 1 Addresed Automatically

Deltabar S 13 Device DIP switch 

Gammapilot M 20 FieldCare + Softing CommDTM

iTHERM 21 Device Display DIP switch 

Promag50 24 Device DIP switch 

Cerabar M 11 Device DIP switch 

Levelflex 15 Device DIP switch 

Prosonic M 16 Device DIP switch 

Micropilot 19 Device DIP switch 

 Component

Segment PA0

Segment PA1

PROFIBUS PA
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3.2 EtherNet/IP Network Configuration 

The table below lists all IP addresses to configure with the used method: 

 

3.2.1 Network Overview 

The SE03 topology is using two networks, a supervisory network and an I/O network: 

 

New components might be delivered without or with default IP addresses. This chapter explains among 

others how the IP addresses have been configured.  

Network Configured IP Address Subnet Mask IP Configuration Method

Supervisor Network Ethernet Module BMENOC0311 10.126.97.88 255.255.252.0 UnityPro + USB

Control System BMEP582040 192.168.12.30 255.255.255.0 UnityPro + USB

ETAP 1783 192.168.12.61 255.255.255.0 Web server

DRS TCSE 192.168.12.21 255.255.255.0 Web server

Gateway epGate PA 192.168.12.40 255.255.255.0 Web server

Liquiline CM44x 192.168.12.33 255.255.255.0 Device display

Promag500 192.168.12.34 255.255.255.0 Web server

Promass300 192.168.12.35 255.255.255.0 Web server

Memograph RSG45 192.168.12.36 255.255.255.0 Device display

AUMA actuator 192.168.12.37 255.255.255.0 Device display

EtherNet/IP

IO Network

Field Devices

 Component

Switch

192.168.12.XXX 

 

 

 
10.126.105.XXX 
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There exist different methods for setting the modules IP Addresses (via Commissioning Tool, USB, DIP 

switch or Web server) depending of course on the components to configure. 

3.2.2 I/O Network Configuration  

3.2.2.1 DRS Switch Configuration 

3.2.2.1.1 IP Address 

• Connect the managed switch to a laptop with a EtherNet cable and start the Schneider Electric tool 

“Ethernet Switch Configurator 2.3.0.3”: 

 
 

• A scan is automatically performed, and the connected switch is found with the IP address 0.0.0.0: 

 
 

• Select the managed switch and click on the button “Properties”: 

 
 

• Configure the IP address according to your network settings: 

 
 

In this example, the switch IP address is 192.168.12.21.  
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• This configures the IP settings: 

 

3.2.2.1.2 Switch Settings 

• Click now on the shortcut button “www”: 

 
 

• This opens the managed switch web browser: 

 

Remark 

• The Web-based interface works with Java Version 1.6.x. Configure this version adequately in your 

operating system 
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• Connect the session with the administrator rights and click on the button “OK”: 

 
 

The default administrator Login is “admin” with the Password “private”. 

 

• This displays following window: 
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• Click on the menu “Basic Settings” and configure the System Time, by clicking on the button “Set 

Time from PC” and then on the button “Set”: 

 
 

• Click on the menu “Redundancy→Ring Redundancy” and configure these settings: 
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In this example, the ring is configured between Port 1.1 and Port 1.2 with the option “Fast HIPER-

Ring”. The managed switch is the ring master and there are 2 participants in the ring (Switch and 

PLC). Select the option “Operation ON” and click on the button “Set” to save the configured 

parameters in the switch. 

 

• Click on the button “Reload” to check if the parameter settings was successful: 

 
 

• Select the menu “Global” of the Spanning Tree menu: 

 
 

• Enable the Spanning Tree Protocol by clicking on the option “Operation ON” and click on the 

button “Set” to save the configured parameters in the switch. 

 

• Click on the button “Reload” to check if the parameter settings: 
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3.2.2.2 Softing epGate PB Configuration 

3.2.2.2.1 Web Server IP Address 

• Connect the epGate PB gateway to a laptop with a EtherNet cable and start the Softing tool 

“Search and Configure:” 

 
 

• Click on the button search to scan the network: 

 
 

• The epGate PA gateway is found with default Web server IP settings. 

 

• Click on the button “Configure”: 

 
 

• Configure the new IP settings according the network: 
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• Then enter the default logins, Username “Administrator“ and the Password „FGadmin!1” and click 

on the button “Submit”. 

 

• Click on the button “Yes”: 

 
 

• epGate Web server IP address is now configured: 

 
 

• Open a browser and enter the configured Web server IP address, 192.168.12.41, in this example: 
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• Select the administrator mode, enter the default Password “FGadmin!1” and click on the button 

“Login”: 

 
 

• This opens the Information menu: 

 

 

  



 

 

 Reference Topology SE03 Version 1.00.00 
 

SD02679S/04/EN/01.20 19/92 

3.2.2.2.2 PROFIBUS GSD Files Import 

• Click on the menu “PROFIBUS” : 

 
 

• On the left side of the window, click on the menu “Import GSD” : 

 
 

Then select the GSD file to import and click on the button “Open”. 
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• In this example, the Micropilot GSD file has been successfully imported: 

 
 

Proceed as well for all other relevant GSD files of the SE03 topology. 

 

• Available field device modules can be displayed by expanding the small arrow : 
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3.2.2.2.3 PA Segments Configuration 

• The epGate PB has two PA segments PA0 and PA1. In the menu “PROFIBUS”, select the segment 

PA0 and click on the “+” symbol of the field device to add a field device: 

 
 

This inserts in this example the Deltabar S in the Segment PA0. Tag name and  PROFIBUS address 

can be updated. 

 

• All IO modules of the device are automatically configured. 

 

• Proceed as well for all field devices of the SE03 topology: 

    

  



 

 

 Reference Topology SE03 Version 1.00.00 
 

SD02679S/04/EN/01.20 22/92 

• The Bus Timing parameters are automatically calculated and cannot be modified. Click on the 

small shortcut button of each PA segment to display them: 

 
 

• Bus Timing parameters for Segment PA0: 

 
• Confirm the configuration by clicking on the field “Apply Configuration” and then click on the 

button “OK”: 
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• Save as well the PROFIBUS PA segments configuration: 

 
 

• Click on the button “Create Report”. This generates a *.html file with the complete PROFIBUS 

configuration: 

  

  

The configuration is automatically saved on the Laptop in a *.json file, 

called “PROFIBUS-Cfg.son”. It is recommended to save the PROFIBUS 

configuration because after a reboot of the epGate PB gateway the 

Web server PROFIBUS configuration is not displayed anymore.  
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• Extract of the file “Create Report”: 

 

3.2.2.2.4 Network Settings 

• Click on the menu “Settings” to display the Web server network settings: 

 
 

• Click on the button “Apply”. A reboot of the gateway is required.  
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Remark 

• The configured IP address of this menu corresponds to the Web server IP address. 

• Enter an IP address for the NTP Server field. This will helpful for the diagnosis to get the correct 

date and time information. 

3.2.2.2.5 epGate PB EtherNet/IP Address Configuration 

• Click on the menu “EthernetIP” and configure the EtherNet/IP address of the epGate PB gateway. 

This IP address must be different as this used for the Web server (as described in previous 

chapter): 

 
 

• The mapping of PROFIBIUS data into the EtherNet/IP telegrams is automatically generated and 

the mapping overview is available on the left side of the window by clicking on the button 

“Mapping”: 
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3.2.2.2.6 epGate PB Exports 

• In the menu “EthernetIP”, select the field “Control Expert” in the list box “Engineering”: 

 
 

• Export the EDS file of the epGate PB gateway corresponding to the PROFIBUS mapping by clicking 

the field “Create EDS” for further use in the integration strategy: 

 
 

• By clicking on the field “Export Control Expert FBs”, a specific function block is generated to decode 

the PROFIBUS data of the EtherNet/IP in Control Expert logic.  

 
 

The function block must be exported after each PROFIBUS mapping update. 
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3.2.2.3 Endress+Hauser IP Address Configuration 

IP addresses of Endress+Hauser EtherNet/IP devices may be configured directly on the display if available 

or by using the web server. 

This example describes the main steps for configurating the IP address of a Promass 300 by using the 

Web server. Refer to the device manual for further details. 

• Power off the device. 

 

• Set the device DIP switch 2 to ON in order to select the default IP address 192.168.1.212. 

 

• Reboot the device. 

 

• Connect a laptop with private network settings (192.168.1.1/24) to the Promass300 with an 

Ethernet cable.  

 

• Open a browser and enter the IP address 192.168.1.212: 

 
Enter the access code “0000” and click on the button Login. 

 

• Click on the button “Menu→Setup→Communication”: 
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• Disactivate the option “DHCP client” and set the new IP addresses.  

 

Remark 

• Once done, the connection to the Web server is lost. 

• Reconfigure the DIP switch 2 to OFF. 

3.2.3 Network Connection 

All components IP addresses have now been configured. Connect all EtherNet/IP field devices as defined 

in reference topology SE03. 

3.3 System Configuration 

3.3.1 New Project 

• Start the software Control Expert: 

 
 

• Create a new project by clicking on “File→New…” 
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• Select the PLC/Rack type and click on the button “OK”: 

 
 

• Following window is displayed: 

 
 

Define a password if required and click on the button “OK”. 

 

• Project structure is created: 
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3.3.2 System Offline Configuration 

This chapter describes the configuration of the Schneider Electric system environment. 

3.3.2.1 M580 PLC 

3.3.2.1.1 Power Supply Module 

• Expand the menu “Configuration” and double-click on the field “0:PLC bus”: 

 
 

• The PLC module is automatically inserted with the power supply module CPS4002: 

 
 

• In our example, the used Power Supply is the CPS2010 module. Delete the current one by right-

clicking on the symbol CPS2000 and by selecting the menu “Delete Module”: 
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• The power supply module is now deleted. Double-click on the empty module: 

 
 

• Select the correct power supply module. In this case, it is the module BMXCPS2010. Click on the 

button “OK”: 

 
 

• This inserts the BMXCPS2010 power supply module: 

 

3.3.2.1.2 Network Settings 

• Double+-click on the Ethernet ports of the M580: 
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• This opens the RIO DIO Communicator Head window. Select the tab “Security”: 

 
 

• In this example, all services are enabled by clicking on the button “Unlock Security”: 
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• Select the tab “IPConfig” and update the PLC IP settings according to your network: 

 
 

• Save the configuration by clicking on the symbol “Validate” in the toolbar or in the menu 

“Edit→Validate”: 

 

3.3.2.2 BMENOC311 Communication Module 

In our example, a communication module is implemented on the M580 backplane in order to separate IO 

and supervisory networks. 

3.3.2.2.1 Module Insertion 

• Double-click on Slot 2: 
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• Select the module BMENOC311.3 and click on the button “OK”: 

 
 

• This displays following window. Update the name if required and click on the button “OK”: 

 
 

• This inserts the BNOC0311 module on the backplane.  

3.3.2.2.2 Network Settings 

• Double click on the BNOC0311 module: 
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• Configure the IP settings according your network settings: 

 
 

• Save the configuration by clicking on the symbol “Validate” in the toolbar or in the menu 

“Edit→Validate”: 

 
 

• Click on the link “Service Configuration”: 
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• This opens the security settings of the communication module. In this example, the access control 

is disabled. Click on the button “Unlock Security”: 

 
 

• Select the menu “Channel Properties” an select the PC network interface, on which the 

BMENOC0311 is physically connected: 

 
 

• Then click on the button “Apply” to validate the configuration: 

 
 

• Close the windows “BMENOC0311_2 Communication” and Factory Cast “Ethernet Module”. 

3.3.2.3 System Configuration Download 

• Download the configuration into the PLC. Please refer to chapters 3.6.1, 3.6.2 and 3.6.3 to 

proceed. 
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3.4 EtherNet/IP Field Device Configuration  

3.4.1 Control Expert Field Device Library 

3.4.1.1 Hardware Catalog 

• Open the menu “Tools→Hardware Catalog”: 

 
 

• All installed field devices EDS files are displayed by clicking on the tab “DTM catalog” and by 

filtering the protocol “CIP (EtherNet/IP)”: 

 

3.4.1.2 EDS File Import 

• Open the menu “Tools→DTM Browser”: 
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• Right-click on the PLC DTM “BMEP58_ECPU_EXT” and select the menu “DTM 

Browser→Additional functions→Add EDS to library”: 

 
 

• This displays following window. Click on the button “Yes” to proceed: 
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• The EDS Import wizard is started: 

  
 

In this example, select the option “Add File(s)”, browse the EDS file to import and click on the 

button “Next”: 

 

• Then follow the wizard: 
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• Go back in the Hardware Catalog and update the DTM catalog: 

 
 

• Field device EDS appears in the Hardware Catalog: 

 
 

• The EDS file is converted in a DTM format by the Schneider Electric environment. Other field 

devices of SE03 topology have been successfully imported as well: 

  



 

 

 Reference Topology SE03 Version 1.00.00 
 

SD02679S/04/EN/01.20 41/92 

3.4.2 Softing epGate PB Gateway  

The epGate PB Softing Gateway may be integrated either with the Softing EDS file or with the Schneider 

Electric Advanced Generic EDS file. 

3.4.2.1 Gateway Integration with Softing EDS File 

• In the DTM Browser, right-click on the PLC DTM and select the menu “Add…”: 

 
 

• Select the driver “epGate PB Revision 1.10” and click on the button “Add DTM”: 

 
 

• Enter a name for the instance and click on the button “OK”: 
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• This inserts the gateway in the project. Double-click on this object: 

 
 

• In this example, select the connection “Exclusive Owner” and change the Input mode from 

“Multicast” to “Point to Point”: 

 
 

• Valid the configuration by clicking on the button “Apply” and close the window. 

 

• Double-click on the PLC DTM: 
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• Go to the epGate PB tab “Address Setting” and update the IP address to the needed one: 

 
 

Click on the button “Apply” and close the window. In this example, the EtherNet/IP address of the 

gateway is 192.168.12.40, as defined in chapter 3.2.2.2.5. 

 

Compile and download the project configuration as described in chapter 3.6. 

3.4.2.2 Gateway Integration with Schneider Electric Advanced Generic EDS File  

• In the DTM Browser, right-click on the PLC DTM and select the menu “Add…”: 

 
 

• Select the driver “Advanced Generic DTM” and click on the button “Add DTM”: 
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• Enter a name for the instance and click on the button “OK”: 

 
 

• This inserts the gateway in the project. Double-click on this object: 

 
 

• In this example, select the connection “Exclusive Owner” and change the Input/Output size to 255 

and the Input mode from “Multicast” to “Point to Point” in the tab ”Connection”: 
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• Select the tab “Configuration Settings” and configure the Input/Output instances: 

 
 

• Valid the configuration by clicking on the button “Apply” and close the window. 

 

• Double-click on the PLC DTM: 

 
 

• Go to the epGate PB tab “Address Setting” and update the IP address to the needed one: 

 
 

Click on the button “Apply” and close the window. In this example, the EtherNet/IP address of the 

gateway is 192.168.12.40, as defined in chapter 3.2.2.2.5. 

 

Compile and download the project configuration as described in chapter 3.6.  
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Remark 

Information about Connection and Configuration settings can be found in the Exported EDS file. Use for 

example the ODVA tool EZ-EDS. This tool can be downloaded on https://www.odva.org/ : 

• Start the software EZEDS.exe: 

  
 

• Select the menu “File→Open…”: 

 
 

• Select the generated EDS file (Refer to chapter 3.2.2.2.6) and click on the button “Open”: 

 
 

• Select the format “EtherNet/IP EDS” and click on the button “OK”: 

 
 

  

https://www.odva.org/
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• Select the configured connection “Exclusive Owner” in the connection Manager menu: 

 
 

The input instance configured in the Advanced Generic EDS corresponds to the “Producing I/O 

Path” Assembly value 100 and the output instance to the “Consuming I/O Path” value 

Assembly150. 

 

• The Input/Output Assembly size can be found in the menu Assembly. Click for example on the 

Input assembly 100 to display the size parameter: 
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3.4.3 E+H Promass300 Flowmeter 

3.4.3.1 Field Device Insertion 

• In the DTM Browser, right-click on the PLC DTM and select the menu “Add…”: 

 
 

• Select the driver “Promass300 500 Revision 1.1” and click on the button “Add DTM”: 

 
 

• Enter a name for the instance and click on the button “OK”: 
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• This inserts the Promass300 in the project. Double-click on this object: 

 
 

• This opens the field device FDT Configuration window: 

 
 

The Promass300 is inserted in the project with the connection “Fix in + Fix out + Config”  

In this example, the input mode is changed from “Multicast” to “Point to Point”. 
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• A further tab “Configuration Settings” is available because the configured connection is “Fix in + 

Fix out + Config”. 

 
 

• The Assembly “Config” allows the user to configure the default values of relevant device settings, 

as for example the system units: 

.  

 

• All “Config” parameters are written in the device every time that a new CIP Forward Open 

communication is performed, this happens either in case of a device restart or if the device is 

physically disconnected and reconnected in the network. 

 

• Click on the button “Apply” to save the configuration and close the window: 
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3.4.3.2 Other Connections  

The default connection “Fix in + Fix out + Config” can be changed by another one. 

• Click on the button “Remove Connection” to delete the current connection and then click on the 

button “Add Connection”: 

   
 

• This allows the user to select another connection via the list box: 
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3.4.3.3 IP Settings  

• Double-click on the PLC DTM: 

 
 

• Go to the Promass300 tab “Address Setting” and update the IP address to the needed one: 

 
 

Click on the button “Apply” and close the window. In this example, the EtherNet/IP address of the 

Promass300 is 192.168.12.35, as defined in chapter 3.2.2.2.5. 

 

Compile and download the project configuration as described in chapter 3.6.  
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3.5 Control Strategy  

A specific Control Expert *.xdb function block can be generated directly from the epGate PB Web server. 

Once imported and implemented in a Control Expert program, this function block decodes automatically 

the EtherNet/IP mapping and provides the user, status information and process values of the PROFIBUS 

PA field devices. 

This function block must be generated after each updates of the data mapping in the epGate PB gateway. 

Please refer to chapter 3.2.2.2.6 for more details about the function block export. 

Following chapter describes the workflow to import and configure the function block in the Control Expert 

environment. 

3.5.1 epGate PB Function Block Import 

• In the Project Browser view, right-click on the menu “Derived FB Types” and select the menu 

“Import”: 

 
 

• Click on the button “Yes” to confirm the modification: 

 
 

• In this example, the current project state is not saved: 
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• Select the *.XDB function file: 

 
 

• This import following structure in the menus “Derived Data Types” and “Derived FB types”: 

 
 

Remark 

• Pay attention during the function block export that the PROFIBUS and EtherNet/IP configuration 

is displayed in the Web server. (Both configurations are for example not displayed anymore after a 

gateway restart). Otherwise no Derived FB Types will be imported, as below, and the configuration 

next steps will not be possible: 
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3.5.2 New Program 

• Expand the menu “Programs→Tasks→MAST”, right-click on the menu “SR Sections” and select the 

menu “New SR Section”: 

 
 

• Enter a name and select the language, “FBD” in this example and click on the button “OK”: 

 
 

• This inserts the new program in the project view: 
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• In the program, right-click in the field and select the menu “FFB Input Assistant…”: 

 
 

• Search the function block epGate_PB_192_168_12_41_I1: 

 
 

• Then click on the button “OK”: 
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• Click in the program to insert the function block: 

 
 

• Click on the Input label and then on the shortcut browse Button: 

 
 

• This displays following window: 

 
 

Click at first on the checkbox “Inside structure”  to display the data in the variable table, then select 

the field “epGate_PB_Advanced_Generic_EDS.Inputs.Free0”, which corresponds to the array 

buffer of the EtherNet/IP inputs and click on the button “OK”. 

 

• This assigns the input variable to the function block (but red marked): 

 

Remark 

At this point, one further modification must be done inside the function block due to a mismatch 

between the EtherNet/IP data input array (256 bytes) and the function block data input (255 

bytes). This error can be checked by compiling the project: 
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• In the menu “Derived FB Types”, double click on the function block 

“epGate_PB_192_168_12_41_I1” and identify the input array: 

 
 

• Modify the array length to [0..255], to get as well 256 bytes and click on the button “Yes”: 

 
 

• This updates the input array: 

 
 

• With this modification, no errors occur in the compilation anymore and the variable is not 

underlined anymore: 
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• Click on the Output label and enter a variable name: 

 
 

• Click on the button “Yes”: 

 
 

• Confirm the variable creation: 

 
 

• New variable is created and assigned: 

 
 

• Download the configuration into the PLC. Please refer to chapter, 3.6.2 and 3.6.4 and 3.6.5 to 

proceed.  
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3.6 Commissioning of the Control Project  

3.6.1 Project Variables Settings 

• Click on the menu “Tools→Project Settings”: 

 
 

• Select the menu “Variables” and then the option “Allow dynamic arrays”. Then, click on the buttons 

“Apply” and “OK” to validate the configuration: 
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3.6.2 Project Compilation 

• Select the menu “Build→Rebuild All Project”: 

 
 

• Compilation is succesful: 

 

3.6.3 First Download Configuration 

The first download is realized via USB in order to set the IP settings of the system.  

• Connect the PLC via USB to the Engineering station. 

 

• Select the menu “PLC→Set Address…” in the tool bar: 

 
 

• Select the PLC parameters “SYS” and “USB”, then click on the button “Test Connection”: 

 
 

• Following message appears. Click on the button “OK”: 
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• Close the window “Set Address” by clicking on the button “OK”. 

 
 

• Go to chapter 3.6.5 to download the configuration in the PLC. 

3.6.4 Download Configuration 

The system IP settings have already been downloaded in the PLC. In this example, the other downloads 

are realized via the communication module BMENOC0311, with IP address 10.126.97.88. 

• Select the menu “PLC→Set Address…” in the tool bar: 

 
 

• Select the PLC parameters “10.126.97.88” and “TCPIP”, then click on the button “Test Connection”: 

 
 

• Following message appears. Click on the button “OK”: 

 
 

• Close the window “Set Address” by clicking on the button “OK”. 
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3.6.5 Project Download in PLC 

• Select the menu “PLC→Connect” in the tool bar: 

 
 

• Once connected, select the menu “PLC→Transfer Project to PLC”: 

 
 

• Following Message Box is displayed. Select the option “PLC Run after Transfer” if needed: 

 
 

• Following Message Box is displayed. Confirm by clicking on the button “OK: 

 
 

• The PLC is in run mode. 
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3.7 Monitoring of Process Values and Status Information 

3.7.1 epGate PB Gateway Data 

3.7.1.1 Integration with Softing EDS File 

• In the Project Browser view, right-click on the field “Animation table” and select the menu “New 

Animation Table”: 

 
 

• Enter a name and click on the button “OK”: 

 
 

• This opens this new Animation Table: 
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• Click first in the cell, then click on the shortcut button to select the data structure 

“epGate_PB_Revision_1_10_EDS”: 

 
 

• Cyclic communication is established: 

 
 

• Expand the field “Inputs” to see the Online values: 

 
 

Refer to the EtherNet/IP epGate PB mapping to decode the data manually, as described in chapter 

3.2.2.2.5.  
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• Pay attention by using these data because there is a byte offset introduced by Control Expert in the 

data structure: 

 
 

In consequence, due to this 1-byte shift, the function block provided by Softing cannot be used. 

Otherwise, wrong values will be displayed. 

  

2nd received byte 

1st received byte 
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3.7.1.2 Integration with Schneider Electric Advanced Generic EDS File 

• Add a new animation table, for example  “cookedData_epGate” as done in the previous chapter. 

 
 

• Add the function block output variable “cookedData_epGate”. This displays the decoded values: 

 
 

• The DeviceStatus value is “4”. This means that the cyclic data exchange is activated for the device. 

 

Please refer to the Softing User Guide for further details about the status. 

 

 

  

PA0 Segment device status 

PA1 Segment device status 

Process values and Status: 

Field Device Address 13 

 

 

Address 13 

 

 

Address 20 

 

 

Address 21 

 

 

Address 24 

 

 

Address 11 

 

 

Address 15 

 

 

Address 16 

 

 

Address 19 
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3.7.2 Promass300 E/IP Data 

• Add a new animation table, for example  “cookedData_epGate” as done in the previous chapter. 

 

3.7.2.1 Process Values 

• Add the Promass300 data structure: 
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3.7.2.2 Field Devices Diagnostics 

• In this example, the error F882 has been simulated on the device: 

 
 

• The field device diagnostic is part of the input assembly telegram in a double Integer Format. In 

this example, the received Diagnostics value is (66418)10: 

 
 

• The Diagnostic telegram is built as below: 

(66418)10 = (0x0001_0372)16  

     0x0372 → (882)10 = Event Number 

 

0x01 → NAMUR Status 

 0x00 No Failure detected 

      0x01 Failure (F) 

      0x02 Function Check (C) 

      0x04 Maintenance Required (M) 

      0x08 Out of Specification (S) 
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Remarks about Diagnostics of other E+H field devices 

The Liquiline diagnostics are automatically decoded in the assembly telegram. 

• Example of a failure F100: 

 
 

In this example, no sensor is connected. This activates the error F100: 

 
 

• Example of a simulation C215: 

 
 

 
 

  

Diagnostic Number 
NAMUR status 

NAMUR status 
Diagnostic Number 
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The same principle is used for the Memograph. 

• Example of a failure F105: 

 
 

This corresponds to following error: 

 
       

 

  

NAMUR status 
Diagnostic Number 
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4 Specific Integration 

This chapter explains how to handle EtherNet/IP explicit messages from the control strategy. 

To evaluate and document the workflow, we have implemented this by example for reading and resetting 

the totalizer of a Promass300 E/IP device. Further examples, like triggering a Heartbeat Verification, may 

be based on this concept.  

The Promass300 E/IP is connected to the Schneider Electric switch in Star, as defined in Reference 

Topology SE03. Cyclic communication is running with the M580 PLC. 

4.1 Principle 

Sending Explicit Messages is possible by using the function block “DATA_EXCH”. Two Device Specific 

function blocks for the Promass300 have been developed by using the “DATA_EXCH” function block: 

The function block “readTotalizer1_Promass300” is used to read the Totalizer1 value. 

The function block “resetTotalizer1_Promass300 is used to reset the Totalizer1 value. 

4.2 Read Totalizer Function Block 

4.2.1 Request Telegram 

• The request telegram is made of two parts, one regarding the EtherNet/IP header and the other 

one regarding the device specific parameter:  

Request Telegram Offset Value Comment 

Part1 
Header Ethernet IP 

Byte 0 0x0E Get Attribute Single service 
Byte 1 0x03 Size of the Link path in Words (6 bytes = 3 Words) 

Part2 
Device parameter 

Byte 2 0x20 

Link path of Parameter  
“Process variables - Totalizer value 1” 
 

Byte 3 0x73 
Byte 4 0x24 
Byte 5 0x01 

Byte 6 0x30 
Byte 7 0x0C 
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• The parameter “Process variables – Totalizer value 1” Link path can be found in the EDS file: 

 
 

4.2.2 Response Telegram 

• The response telegram is made of two parts, one regarding the EtherNet/IP Explicit Messages and 

the other one regarding the device specific parameter:  

Response Telegram Offset Value Comment 

Part1 
Header Ethernet IP 

Byte 0 0x8E 

Explicit Message Service 
Byte 1 0x00 
Byte 2 0x00 

Byte 3 0x00 

Part2 
Device parameter 

Byte 4 0x.. 

Totalizer 1 value 
Byte 5 0x.. 

Byte 6 0x.. 
Byte 7 0x.. 
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4.2.3 Function Block “readTotalizer1_Promass300” 

• In Control Expert, the function block has been created in the “Derived FB Types” library: 

   
 

• Mandatory Inputs 

o The parameter “startRead” corresponds to the function block start bit. 

o The parameter “IPaddress” corresponds to the Promass300 IP address. 

 

• Outputs 

o The parameter “valueTOT1” corresponds to the Promass300 totalizer 1 value. 

 

• Implemented Function bloc logic 

 
 

This  program shows just the basic workflow to get the totalizer value. The error handling of the 

DATA_EXCH function block is not implemented. 
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4.2.4 Online Monitoring 

• If the cyclic communication is established (bit Promass300_FW010005.freshness = TRUE) and the 

start bit “triggerRead” is enabled, then the function block is enabled as well and the output value 

(totalizer 1 value)is updated: 

 

4.3 Reset Totalizer Function Block 

4.3.1 Request Telegram 

• The request telegram is made of three parts, one regarding the EtherNet/IP header and the two 

others regarding the device specific parameter:  

Request Telegram Offset Value Comment 

Part1 
Header Ethernet IP 

Byte 0 0x10 Set Attribute Single service 
Byte 1 0x03 Size of the Link path in Words (6 bytes = 3 Words) 

Part2 
Device parameter 1 

Byte 2 0x20 

Link path of Parameter “Totalizer1-Control Totalizer1” 
 

Byte 3 0x72 
Byte 4 0x24 
Byte 5 0x01 

Byte 6 0x30 
Byte 7 0x09 

Part3 
Device parameter 2 

Byte 8 0xC6 Command “Reset and Totalize” →0xC6 = (198)10 

Byte 9 0x00  
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• The parameter “Totalizer 1 – Control Totalizer 1” Link path as well the “Reset+Totalize” Command 

can be found in the EDS file: 

 

4.3.2 Response Telegram 

• The response telegram is made of one part regarding the EtherNet/IP Explicit Messages:  

Response Telegram Offset Value Comment 

Part1 
Header Ethernet/IP 

Byte 0 0x90 
Explicit Message Service 

Byte 1 0x00 

4.3.3 Function Block “readTotalizer1_Promass300” 

• In Control Expert, the function block has been created in the “Derived FB Types” library: 

   
 

• Mandatory Inputs 

o The parameter “startReset” corresponds to the function block start bit. 

o The parameter “IPaddress” corresponds to the Promass300 IP address.  
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• Implemented Function bloc logic 

 
 

This  program shows just the basic workflow to reset the totalizer value. The error handling of the 

DATA_EXCH function block is not implemented. 

4.3.4 Online Monitoring 

• If the cyclic communication is established (bit Promass300_FW010005.freshness = TRUE) and the 

start bit “triggerReset” is enabled, then the function block is enabled as well and this resets the 

totalizer value 1: 
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5 Bypassed Tool Integration 

This chapter describes the main workflow for integration of EtherNet/IP and PROFIBUS PA devices to the 

Endress+Hauser Plant Asset Management (PAM System) by means of Communication DTMs. 

5.1 FieldCare New Project 

• Start the application FieldCare: 

 
 

• Select “Create Project” and click on the button “Open”: 
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5.2 EtherNet/IP Field Device Integration 

5.2.1 CommDTM Configuration  

• Right-click on the Network Tag “Host PC” and select the menu ”Add Device…”: 

 
 

• Select the CommDTM “EtherNet/IP Comm Adapter” from Schneider Electric and click on the button 

“OK”: 

 
 

• CommDTM is inserted in the project view: 
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• Double-click on the CommDTM and configure the Host Address: 

 
 

• Select the tab “Scan” and configure for example Scan Mode “Range”: 

 
• Click on the button “Apply” and close the CommDTM configuration window: 

 
 

5.2.2 Network Scanning  

• Select the CommDTM and click on the button Create Network: 
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• Select the Promass300 DTM and click on the button “OK”: 

 
 

Other devices have been found by the scanner but no DTMs exist and are installed in FieldCare 

environment for them. That’s why the DTM Quality signal is “6”. 

 

• EtherNet/IP field device is successfully inserted in the project: 

 

5.2.3 Online Connection 

• Select the deviceDTM and click on the button “Connect”: 
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• Then double-click on the deviceDTM to open the Online Parameterization window: 

 
 

5.3 PROFIBUS PA Field Device Integration 

5.3.1 Driver Configuration 

• Open the program “Softing PROFIBUS→Driver configuration” from the Windows Start menu:

 
 

• Click on the button “Yes”: 
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• This opens following program: 

 
 

• Select the menu “pnGate PB / mbGate PB” and click on the button “Add…”: 
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• Enter a name for this node, “Segmenr_PA0” in this example and click on the button “Next”: 

 
 

• Enter the IP address epGate PB configured in chapter 3.2.2.2.1, select the Bus segment “PA0” and 

click on the button “Next”: 
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• Let the default “Timeout” parameters and click on the button “Finish”:

 
 

• Select the created connection “Segment_PA0” and click on the button “Apply”: 

 
 

• Confirm the configuration by clicking on the button “Yes”: 
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• Connection is successfully configured: 

 
 

• Proceed as well for the other PA segments. In our example, we have the PA1 segment as well: 

 
 

Click on the button “OK” to close the configuration. 
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5.3.2 CommDTM Configuration  

• Right-click on the Network Tag “Host PC” and select the menu ”Add Device…”: 

 
 

• Select the CommDTM “PROFIdtm DPV1” from Softing and click on the button “OK”: 

 
 

• CommDTM is inserted in the project view. Double click on it: 

 
 

  



 

 

 Reference Topology SE03 Version 1.00.00 
 

SD02679S/04/EN/01.20 88/92 

• Both configured connections appear in the list box of the menu “Board Name”: 

 
 

Select for example “Segment PA0” and click on the button “OK” 

5.3.3 PROFIBUS PA Segments Scanning 

• Select the CommDTM and click on the button Create Network: 

 
 

• PROFIBUS PA field devices connected are succesfully inserted in the project: 
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• Repeat previous steps to insert the field devices connected to segment PA1 as well: 

 
 

5.3.4 Online Connection  

• Select the deviceDTM and click on the button “Connect”: 
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• Then double-click on the deviceDTM to open the Online Parameterization window: 
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