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 Diese Anleitung ist eine Kurzanleitung. 
Ausführliche Informationen entnehmen Sie bitte der Betriebsanleitung. 

Die komplette Produktdokumentation besteht aus: 
• Der vorliegenden Kurzanleitung 
• Der in die Software integrierten Betriebsanleitung 

 

<  These instructions are Brief Operating Instructions. 
For detailed information, please read the Operating Instructions. 

The complete product documentation comprises: 
• These Brief Operating Instructions 
• The Operating Instructions integrated in the software 
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1 Field Data Manager Software 

1.1 Versionen 

Die nachfolgende Tabelle zeigt die Funktionen der verschiedenen 
Softwareversionen. 

 

Funktion Essential Version 
(Freeware) 

Professional Version (60 Tage 
Demoversion + 30 Tage auf Anfrage) 

Unterstützte Datenbanken: 

PostgreSQL TM
 x x 

Microsoft SQL-Server TM
 

 x 

Unterstütze Geräte: 

Ecograph RSG20  x 

Ecograph A RSG22  x 

Ecograph C RSG24  x 

Ecograph T RSG30 x x 

Ecograph T RSG35 x x 

Memograph RSG10  x 

Memograph S RSG12  x 

Memograph M RSG40 x x 

Memograph M RSG45 x x 

EngyCal RH33  x 

EngyCal RS33  x 

RA33  x 

Liquiline CM44x  x 

Liquistation CSFxx  x 

Liquiline System CA80xx  x 
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Funktion Essential Version 

(Freeware) 
Professional Version (60 Tage 
Demoversion + 30 Tage auf 

Anfrage) 

 
Unterstütze Funktionen: 

Benutzerverwaltung; LDAP- Funktion  x 

Zugriffe von verschiedenen PCs auf 
die Datenbank gleichzeitig möglich 

 x 

Daten mehrerer Geräte in einem 
Template (Vorlage) 

 x 

Automatisches Auslesen x x 

Automatisches Löschen x x 

Automatischer Binär-Export x x 

Automatischer XLS/CSV- und PDF-
Export 

 x 

Export ready for Energy Software  x 

Import von ReadWin 2000 Daten x x 

Online-Visualisierung von 
Momentanwerten ("Live Data") 

 x 

E-Mail Benachrichtigung  x 

Update-Suche  x 

iTHERM TrustSens Calibration 
Automatik-Funktion 

x x 

 
Beachten Sie, dass die Demoversion nach Ablauf des Testzeitraums aktiviert 
werden muss, um diese als Professional oder Essential Version (Freeware) 
nutzen zu können. 
Ein Wechsel von der Essential Version (Freeware) zu einer kommerziellen 
Version ist mittels Eingabe einer Software-ID und anschließender 
Produktaktivierung jederzeit möglich. 
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Ein Wechsel von der Demoversion auf die Essential Version (Freeware) kann 
zur Folge haben, dass bestimmte Funktionen nicht mehr zur Verfügung 
stehen. So werden z. B. angelegte Templates (Vorlagen) mit Daten von 
mehreren Geräten und auch automatische Exporte nicht mehr 
funktionieren. 
Geräte, die nur in der Professional Version enthalten sind, können in der 
Essential Version (Freeware) nicht mehr ausgelesen werden. 

 

1.2 Eigenschaften 

Field Data Manager (FDM) ist eine Software, die eine zentrale 
Datenverwaltung mit Visualisierung für aufgenommene Daten bietet. 

Diese ermöglicht die lückenlose Archivierung der Daten einer Messstelle, 
z. B.: 
• Messwerte 
• Diagnoseereignisse 
• Protokolle 

FDM speichert Daten in eine SQL-Datenbank. Die Datenbank kann lokal oder 
im Netzwerk betrieben werden (Client / Server). 

Folgende Datenbanken werden unterstützt: 
• PostgreSQL™ bis einschließlich Version 12.22 (bei Essential-, Demo- 

und Professional-Version): 
Sie können die auf der FDM-DVD mitgelieferte, freie PostgreSQL 
Datenbank installieren und nutzen. Hierzu ist keine manuelle Installation 
und Konfiguration notwendig. Die Datenbank wird bei der Installation 
automatisch konfiguriert. 

• Microsoft SQL Server1) (bei Demo- und Professional-Version): Version 
Bis einschließlich Version 2022. 
Zur Einrichtung der Software mit dem Microsoft SQL Server wenden Sie 
sich bitte an Ihren Datenbankadministrator. 

 

1) Die genannten Produktnamen sind eingetragene Marken der jeweiligen Hersteller. 
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1.3 Systemanforderungen 

Für die Installation und den Betrieb der PC-Software müssen folgende 
Hardware- und Software-Voraussetzungen erfüllt sein: 

Hardwarevoraussetzungen für die FDM-Software: 
• PC mit PentiumTM 4 (≥2 GHz) 
• PC mit PentiumTM M (≥1 GHz) 

• PC mit AMDTM (≥1,6 GHz) 
• Minimum 1 GB RAM Cache 
• Minimum 20 GB freier Festplattenspeicher 
• Bildschirmauflösung mindestens 1024 x 800 Pixel 
• CD/DVD-Laufwerk (bei Computern ohne Laufwerk kann die Software auch 

über das Endress+Hauser Software Portal heruntergeladen werden (siehe 
Kapitel 2 Installation)) 

Betriebssystem/Software für die FDM-Software: 
• MicrosoftTM WindowsTM Server 2019 
• MicrosoftTM WindowsTM Server 2022 
• Windows 10TM 

• Windows 11TM 

• WindowsTM .NET 2.0/3.5 

2 Installation 
Der Installationsassistent führt durch die Installation der Field Data Manager 
Software. 

 Für die Installation werden Administratorrechte benötigt. 

 
Bei Computern ohne Laufwerk kann FDM auch vom Endress+Hauser Soft- 
ware Portal heruntergeladen werden. Sie benötigen hierzu ein Konto im Soft- 
ware Portal unter: https://software-products.endress.com 

1. ZIP-Datei herunterladen und lokal speichern 
2. ZIP-Datei entpacken 
3. Setup.exe starten und den Anweisungen des Installationsprogramms 

folgen 

2.1 Installation der Software 

1. Legen Sie die DVD in Ihr CD/DVD-Laufwerk. 
Die Installation startet automatisch. 
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Falls der Autostart nicht aktiv ist, starten Sie Setup.exe von der DVD. 
2. Wählen Sie im angezeigten Dialogfenster die gewünschte Sprache. 

Klicken Sie auf OK. 
3. Starten Sie anschließend den Installationsassistenten mit Weiter. 

4. Die Lizenzvereinbarung erscheint. 
– Lesen Sie die Lizenzvereinbarung. 
– Falls Sie die Vereinbarung nicht akzeptieren, klicken Sie auf Abbrechen. 
– Falls Sie die Vereinbarung akzeptieren, klicken Sie auf Weiter. 

 Die Endbenutzer-Lizenzvereinbarung kann jederzeit nach der 
Installation im Hauptmenü unter „Hilfe -> Lizenzvereinbarung“ 
aufgerufen werden. 

 
5. Wenn Sie die FDM Professional-Version haben, geben Sie hier die 

Software-ID ein. Sie finden diese Angabe auf der DVD-Hülle. 
Falls Sie die FDM Essential-Version (Freeware) haben oder die 
Angaben zu einem späteren Zeitpunkt eingeben möchten, lassen Sie 
das Eingabefeld leer. 

Später können Sie die Software-ID über den Menüpunkt "Hilfe -> 
Lizenzinformationen -> Lizenzinformationen -> Software-ID" 
eingeben. Hier können Sie auch von der FDM Essential-Version 
(Freeware) ohne Eingabe einer Software-ID einmalig auf eine 
Demoversion mit vollem Funktionsumfang wechseln. Diese 
Demoversion ist dann für den Testzeitraum aktiv. 

 
 Die Demoversion kann nach Ablauf des Testzeitraums durch 

Aktivierung in eine Essential-Version (Freeware) umgewandelt 
werden, sofern kein Upgrade zur Professional-Version durch 
Eingabe einer Software-ID erfolgt. 

Da bestimmte Funktionen dann nicht mehr zur Verfügung stehen, 
werden z. B. angelegte Templates mit Daten von mehreren Geräten und 
auch automatische Exporte nicht mehr funktionieren. 
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6. Geben Sie das Zielverzeichnis an, in welches die Field Data Manager 
Software installiert werden soll. 

 

Es wird ein Standardverzeichnis für die Installation vorgeschlagen. 
Falls Sie das Programm in ein anderes Verzeichnis installieren 
möchten, klicken Sie auf Ändern und wählen Sie das gewünschte 
Verzeichnis. 
Klicken Sie auf Weiter. 
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7. Wählen Sie aus, ob die mitgelieferte freie PostgreSQL Datenbank 
installiert werden soll. Die Datenbank wird bei der Installation 
automatisch konfiguriert. 
Klicken Sie auf Weiter. 

8. Wählen Sie aus, ob die Softwarekomponenten für Automatische 
Aktionen installiert werden sollen. 
Bestätigen Sie die Installation der Automatik-Komponente, so wird 
zusätzlich ein Windows Systemdienst eingerichtet. Dieser Systemdienst 
ermöglicht es, automatische Aktionen durch die Field Data Manager 
Software auszulösen und zu steuern - wie z. B. automatisches Auslesen 
von Geräten, automatischer Druck von Reports, automatisches 
Generieren von Reports. 

 

 
Klicken Sie auf Weiter. 

9. Der Installationsassistent ist nun zur Installation bereit. 
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Zur Korrektur Ihrer Angaben klicken Sie auf Zurück. Klicken Sie auf 
Installieren, um die Installation zu starten. 

 

Klicken Sie auf Fertig stellen, um die Installation zu beenden. 
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2.2 Verwendung der FDM-Software mit einer Microsoft 
SQL Server Datenbank 

 Nur bei Demo- und Professional-Version. 
Wenden Sie sich für die Konfiguration der Microsoft SQL Server 
Datenbank an Ihren Datenbankadministrator. Die folgenden Schritte 
können nur vom Administrator der Datenbank durchgeführt werden. 

1. Installieren Sie die FDM-Software, wie im Abschnitt 
"Installation" beschrieben. 

2. Legen Sie auf der Microsoft SQL Server Datenbank einen User an, unter 
dem sich die FDM-Software auf der Datenbank einloggen und zugreifen 
kann. Der Benutzer muss zum Anlegen der Tabellen über die 
Berechtigung "db_ddladmin" verfügen: 
Für den späteren Zugriff auf die Datenbank muss der Benutzer 
mindestens die Rollen "db_datareader" und "db_datawriter" haben. 
Zudem muss der Benutzer die EXECUTE-Berechtigung auf der 
Datenbank haben. 

3. Starten Sie zum Einrichten der notwendigen Tabellen in der Datenbank 
die mitgelieferte Software "InitSqlServer.exe". Die Software befindet sich 
im Installationsverzeichnis. 
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4. Geben Sie die Verbindung zur Datenbank ein (Servername \ 

Instanzname). Der Servername ist der Hostname des Rechners, auf 
dem der Datenbankserver läuft. Der Instanzname kann bei der 
Installation angegeben werden und lautet für die SQL Express 
Installation standardmäßig "SQLEXPRESS". Sie können die installierten 
Instanznamen auch aus der Registrierung erfahren 
(HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL 
Server\<Instance Name>). 

5. Tragen Sie den Datenbanknamen ein, den Sie zuvor am Server angelegt 
haben (z. B. mit Hilfe des ‚Microsoft SQL Server Management Studio’ 
Tools). 

6. Geben Sie den Benutzernamen und das Passwort für den Benutzer ein, den 
die FDM-Software für das Login auf die Datenbank verwenden soll. 
Benutzen sie hierzu "Benutzerdefiniertes Login" 

7. Betätigen Sie die Schaltfläche "Test". Nach kurzer Zeit erscheint eine 
Meldung, ob die Software auf die Datenbank zugreifen kann oder nicht. Ist 
der Zugriff nicht möglich, prüfen Sie bitte die Verbindungseinstellungen und 
die Schreibweise des Benutzernamens und des Passworts. Erst wenn nach 
Betätigen der Schaltfläche "Test" eine positive Rückmeldung kommt, kann 
auf die Datenbank zugegriffen werden. 

8. Wenn der Zugriff auf die Datenbank möglich ist, betätigen Sie die 
Schaltfläche "Erzeuge Schema". Jetzt werden die notwendigen Tabellen für 
das Speichern der Daten in der Datenbank eingerichtet. Dies dauert einige 
Sekunden. Das Fenster der Software wird automatisch geschlossen, wenn 
die Tabellen angelegt sind. 

9. Starten Sie die Field Data Manager Software. 

10. Im Menüpunkt "Extras -> Einstellungen -> Datenbank": Wählen Sie 
"Microsoft SQL Server" aus und tragen Sie die Verbindung zur Datenbank, 
den Benutzernamen und das Passwort ein. 
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11. Prüfen Sie mit der Schaltfläche „Test“, ob die FDM-Software auf die 
Datenbank zugreifen kann und die notwendigen Tabellen eingerichtet 
sind. Ist der Zugriff nicht möglich, prüfen Sie die 
Verbindungseinstellungen und die Schreibweise des Benutzernamens 
und des Passworts. Erst wenn nach Betätigen der Schaltfläche "Test" 
eine positive Rückmeldung kommt, kann auf die Datenbank 
zugegriffen werden. 

12. Wenn eine positive Meldung kommt, beenden Sie die Konfiguration mit 
OK. Die Auswertesoftware ist jetzt für den Betrieb mit der Microsoft 
SQL Server Datenbank fertig eingerichtet. 

2.3 Remoteverbindungen auf den Datenbankserver 

2.3.1 Remote-Verbindungen für PostgreSQL Server ermöglichen 

Zuerst müssen Sie das Datenbank-Administrationstool "pgAdmin III" 
installieren, das sich auf der Setup-DVD befindet. 
1. Starten Sie das pgAdmin-Tool. 
2. Öffnen Sie "Werkzeuge -> Serverkonfiguration -> postgresql.conf". 
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3. Öffnen Sie die Einstellung "listen_addresses" mit einem Doppelklick und 

tragen Sie einen Stern (*) ein. Damit erlauben Sie alle eingehenden 
TCP-Verbindungen zu diesem Server. Sie können aber auch einzelne 
IP-Adressen zulassen. 

4. Standardmäßig werden alle Verbindungen von entfernten Adressen 
abgewiesen. Um diese zu erlauben, öffnen Sie "Werkzeuge -> 
Serverkonfiguration -> pg_hba.conf" und fügen Sie folgenden Eintrag 
hinzu: host all all 0.0.0.0/0 md5 
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5. Starten Sie den PostgreSQL durch einen PC-Neustart. 
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Beachten Sie folgende Hinweise: 
• Sie können die Konfiguration der Zugriffsrechte auch direkt in den Dateien 

"postgresql.conf" und "pg_hba.conf" vornehmen, die Sie im 
Installationsverzeichnis des PostgreSQL Server und "data" finden. 

• Überprüfen Sie die Änderungen sorgfältig. Falsche Konfigurationen 
können dazu führen, dass der Zugriff auf den Server nicht mehr möglich 
ist (Bsp. falsche IP-Adresse). 

Weiterführende Informationen (Englisch) finden Sie unter: 
http://www.postgresql.org/docs/9.2/interactive/client-authentication.html 

2.3.2 Remoteverbindungen für Microsoft SQL Server ermöglichen 

Sie müssen Remoteverbindungen für jede Instanz von SQL-Server 
ermöglichen, zu der Sie eine Verbindung von einem Remote-Computer 
herstellen möchten. Gehen Sie hierzu folgendermaßen vor: 
1. Start -> Programme -> Microsoft SQL Server 2005 -> 

Konfigurationstools -> SQL Server-Oberflächenkonfiguration. 
Das Fenster "SQL Server 2005-Oberflächenkonfiguration" erscheint. 

2. Wählen Sie "Oberflächenkonfiguration für Dienste und Verbindungen". 
3. Öffnen Sie in "Database Engine" die "Remoteverbindungen". 

Aktivieren Sie "Lokale Verbindungen und Remoteverbindungen" und 
das gewünschte Protokoll.  
Klicken Sie auf Anwenden. 

http://www.postgresql.org/docs/9.2/interactive/client-authentication.html
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4. Folgende Meldung erscheint: 
"Änderungen der Verbindungseinstellungen werden erst nach einem 
Neustart des Datenbank-Moduldiensts wirksam." 
Klicken Sie auf OK. 

5. Öffnen Sie in "Database Engine" den Menüpunkt "Dienst". 
Klicken Sie auf "Beenden" und warten Sie, bis der Dienst "MSSQLSERVER" 
beendet wird. 
Klicken Sie auf "Start", um den Dienst "MSSQLSERVER" neu zu starten. 

 Überprüfen Sie die Änderungen sorgfältig. Falsche Konfigurationen 
können dazu führen, dass der Zugriff auf den Server nicht mehr möglich 
ist (Bsp. falsche IP-Adresse). 

 
Weiterführende Informationen finden Sie unter: 
http://support.microsoft.com/kb/914277 

 

http://support.microsoft.com/kb/914277
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2.4 Erweiterungen SQL Server und Automatik: 

Bei Verwendung der Windows-Authentifikation sind zusätzliche 
Konfigurationen notwendig: 

1. Starten Sie "SQL Server Management Studio". Sollte diese kostenlose 
Software nicht vorhanden sein, müssen Sie diese, entsprechend Ihrer 
SQL-Server Version nachinstallieren. Erhältlich ist das Programm bei 
Microsoft. 

2. Selektieren Sie den Knoten "Anmeldung" unter dem Verzeichnis 
"Sicherheit". 

3. Legen Sie über die rechte Maustaste auf diesem Verzeichnis eine neue 
Anmeldung mit dem Namen NT-AUTORITÄT\ANONYMOUS-
ANMELDUNG an oder englisch NT-AUTHORITY\ANONYMOUS. 

4. Selektieren Sie die Datenbank der FDM-Software unter dem Knoten 
"Datenbanken". 

5. Legen Sie dort unter "Sicherheit/Benutzer" einen neuen Benutzer mit 
dem Namen "FdmServerUser" und dem Anmeldenamen NT-
AUTORITÄT\ANONYMOUS-ANMELDUNG an. 

6. Abschließend weisen Sie diesem Benutzer unter "Mitgliedschaft in 
Datenbankrollen" Besitzerrechte zu (db-owner). 

Zu diesen Konfigurationsschritten finden Sie auf der Endress+Hauser Seite 
www.endress.com/ms20 ein kurzes Video. 

2.5 Update der FDM-Software auf eine neue Version 

Bei der Verwendung des mitgelieferten Postgre-DB-Servers lokal auf Ihrem 
PC wird bei der Installation der neueren Version die Datenbank bei Bedarf 
automatisch auf die neue Version gebracht. In diesem Fall (Standardfall) 
müssen Sie nach der Installation der neuen Version keine weiteren Aktionen 
durchführen. Alle Daten stehen nach dem Update wieder zur Verfügung. 
Verwenden Sie den mitgelieferten Postgre-DB-Server im Netzwerk (remote) 
oder eine Microsoft SQL Server Datenbank (lokal oder im Netzwerk), kann 
nach dem ersten Start der FDM-Software der DB-Konfigurationsdialog mit 
einem Hinweis erscheinen, dass die Datenbank nicht auf dem aktuellen 
Stand ist. 
In diesem Fall muss der Datenbank-Administrator wie oben beschrieben das 
jeweilige Tool für Ihren Datenbankserver starten und damit die Daten der 
Datenbank auf den aktuellen Stand bringen. Die Daten in der Datenbank 

http://www.endress.com/ms20
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bleiben dabei erhalten. Bitte beachten Sie, dass alle Client-Installationen auf 
die neue Version der FDM-Software upgedatet werden. 

3 Schnelleinstieg 
Dieser Schnelleinstieg gibt einen kurzen Überblick über die ersten Schritte 
beim Arbeiten mit der Field Data Manager Software. 

 
 Um die Professional-Version nutzen zu können, muss zunächst eine 

gültige Software-ID unter "Hilfe -> Lizenzinformationen" eingegeben und 
die Software aktiviert werden. 

 
 Detaillierte Informationen zur Softwareaktivierung und Hilfe zu den 

Funktionen finden Sie in der integrierten Online-Hilfe unter "Hilfe -> 
Field Data Manager Software Hilfe” bzw. in den Anleitungen im 
Installationsverzeichnis z. B. unter C:\Program Files 
(x86)\Endress+Hauser\Field Data Manager Software\Documentation. 

3.1 Bedienoberfläche 

Die Bedienoberfläche von FDM ist in drei Bereiche aufgeteilt: 
• Oben befindet sich die Menüleiste mit Funktionsgruppen für 

Softwareeinstellungen. 
Datei -> Programm beenden 
Ansicht -> Einstellungen zur Ansicht 
Extras -> Einstellungen zur Datenbank, Sprache, Benutzerverwaltung, 
Audit Trail Hilfe -> Online-Hilfe starten, Lizenzinformationen 

• Links befindet sich die Aufgabenleiste. Durch Klicken auf eine Aufgabe 
öffnet sich diese. Die enthaltenen Funktionen werden angezeigt: 
Visualisierung -> Visualisierungstemplate neu erstellen, öffnen oder 
löschen 
Daten auslesen -> Auslesen über Speicherkarte oder Online-Verbindung 
zum Gerät 
Datenverwaltung -> Anlagenansicht, Export und Import von Gerätedaten 

• Rechts befindet sich der Arbeitsbereich 
Alle aktiven Aufgaben werden hier geöffnet. Sind mehrere Aufgaben 
aktiv, so werden diese in Tabs hintereinander geöffnet. 
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3.2 Bedienung 

Bei allen gewählten Funktionen führt ein Assistent durch die benötigten 
Angaben. Zur Korrektur Ihrer Angaben können Sie jederzeit auf Zurück 
klicken oder den Assistenten beenden durch Abbrechen. 
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4 Field Data Manager Software 

4.1 Versions 

The following table shows the different functions of the diverse versions of 
the Field Data Manager Software. 

 

Function Essential Version 
(Freeware) 

Professional Version (Trial period: 60 
days + 30 on request) 

Supported databases: 

PostgreSQL TM
 x x 

Microsoft SQL Server TM
 

 x 

Supported devices: 

Ecograph RSG20  x 

Ecograph A RSG22  x 

Ecograph C RSG24  x 

Ecograph T RSG30 x x 

Ecograph T RSG35 x x 

Memograph RSG10  x 

Memograph S RSG12  x 

Memograph M RSG40 x x 

Memograph M RSG45 x x 

EngyCal RH33  x 

EngyCal RS33  x 

RA33  x 

Liquiline CM44x  x 

Liquistation CSFxx  x 

Liquiline System CA80xx  x 
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Function Essential Version 

(Freeware) 
Professional Version (Trial 

period: 60 days + 30 on request) 

 
Supported functions: 

User administration; LDAP 
function 

 x 

Several accesses to the 
database from various PCs at 
the same time possible 

 x 

Data of more than one device 
inside a template 

 x 

Automatic readout x x 

Automatic deletion x x 

Automatic binary export x x 

Automatic XLS/CSV and PDF 
export 

 x 

Export ready for Energy Software  x 

Import of ReadWin 2000 data x x 

Online visualization of current 
measured values ("Live Data") 

 x 

E-mail notification  x 

Update search  x 

TrustSens calibration automatic 
function 

x x 

 
Please note that to use the Demo version as a Professional or Essential 
version (freeware), it must be activated after the trial period has elapsed. It is 
possible to switch from the Essential version (freeware) to a commercial 
version at any time by entering a software ID and then activating the product. 



Field Data Manager Software FDM 

24 Endress+Hauser 

 

 

Switching from the Demo version to the Essential version (freeware) may 
result in certain functions no longer being available. For example, templates 
created with data from multiple devices will no longer work and neither will 
automatically export. Devices that are included only in the Professional 
version can no longer be read out in the Essential version (freeware). 

4.2 Features 

Field Data Manager (FDM) is a software package offering central data 
management and visualization of stored data. This allows complete 
documentation of the data from a measuring point, e.g.: 
• measurement values 
• diagnostics events 
• protocols 

FDM stores the data in an SQL database. The database can be installed locally 
or in a network (Client/Server). 

The following databases are supported: 
• PostgreSQL1) up to version 12.22 (for the Essential, Demo and 

Professional versions): 
You can use the PostgreSQL database provided on the Field Data Manager 
Software DVD. During installation the database will be automatically 
configured. That means there is no need for manual installation and 
configuration. 

• Microsoft SQL Server1) (for the Demo and Professional version): 
Up to version 2022. For the login account please contact your database 
administrator. For installation instructions see chapter "Installation". 

 
 
 
 

 

2) The products referred to are trademarks of their respective companies. 
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4.3 System requirements 

For installation and use of the software, the following hardware and 
software requirements must be fulfilled: 

Hardware prerequisites for FDM software: 
• PC with PentiumTM 4 (≥2 GHz) 
• PC with PentiumTM M (≥1 GHz) 

• PC with AMDTM (≥1.6 GHz) 
• At least 1 GB RAM cache 
• At least 20 GB free hard disk space 
• Display resolution at least 1024 x 800 pixel 
• CD/DVD drive (For computers without a drive, the software can also be 

downloaded via the Endress+Hauser Software Portal (see chapter 5 
Installation)) 

Operating system/software for FDM software: 
• MicrosoftTM WindowsTM Server 2019 
• MicrosoftTM WindowsTM Server 2022 
• Windows 10TM 

• Windows 11TM 

• WindowsTM .NET 2.0/3.5 
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5 Installation 
The installation wizard guides you through the installation of the Field Data 
Manager Software. 

 You need administrator rights for the installation. 

 
For computers without a CD/DVD drive, FDM can also be downloaded from 
the Endress+Hauser Software Portal. To do this, you need an account on the 
Software Portal at: https://software-products.endress.com 

1. Download ZIP file and save locally 
2. Unzip the ZIP file 
3. Start Setup.exe and follow the instructions of the installation program 

5.1 Installation of the software 

1. Insert the DVD into your CD/DVD-drive. The Installation 
starts automatically. 
If autostart is not active, start Setup.exe directly from the DVD. 

2. In the dialog window select the language for the installation. 
Click OK. 

3. Start the installation wizard with Next. 

4. The licensing agreement appears. 
– Please read the license agreement carefully. 
– Mark, if you accept or do not accept the licensing agreement. 
– If you do not accept the licensing agreement, click on Cancel. 
– If you do accept the licensing agreement, click on Next. 

 The end-user license agreement can be called up any time after 
installation in the main menu under "Help -> License 
agreement". 

 
5. If you use the Professional version enter the software ID of your FDM 

software. You can find the information on the DVD cover of the 
software. 
If you use the Essential version (Freeware) or want to enter this 
information later, please leave the entry field empty. 
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You can enter the software ID any time in the menu "Help -> License 
Information -> License Information -> software ID". Here also you 
can once-only switch to the Trial version. The Trial version runs for the 
trial period with full functionality. 

 
 If the Demo version is not upgraded to the Professional version by 

entering a software ID, it can be converted to an Essential version 
(freeware) after the trial period by activating it. 

This means that certain functions will no longer be available. For 
example, templates created with data from multiple devices will no 
longer work and neither will automatically export. 

 

6. Enter the destination folder in which you want to install the Field Data 
Manager Software. 
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A default location will be displayed. If you want to install the software 
in a different folder, click Change and choose the desired folder. 
Change and choose the desired folder. Click on Next. 

7. Select if you want to install the free of charge PostgreSQL database. The 
database is configured automatically during the installation. 
Click on Next. 

8. Select if you want to install software components for automatic actions. 
If you select the installation, a Windows system service will be 
configured. This service enables Field Data Manager Software to start 
automatic actions, e.g. automatic read out of device data, automatic 
printing of reports or automatic generation of reports. 
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Click on Next. 

9. The installation wizard is ready for the installation. 
 

To review or change any of your installation settings click Back.  
Click Install to start the installation. 
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The installation is completed. 
Click on Finish. 

5.2 Operation of the FDM software with Microsoft SQL 
Server database 

 Only at Trial and Professional version. 
For the configuration of the database and the FDM software please contact 
your database administrator. The following steps should only be taken by the 
administrator of the database. 

1. Install the FDM software. Please refer to the chapter "Installation". 
2. Create a user in the Microsoft SQL server database which FDM software 

may use for login and access to the database. 
For the creation of the tables the user must have the following right 
"db_ddladmin" in the database. Later after the initialization of the 
database the user must have at least the roles "db_datareader" and 
"db_datawriter" to access the database. The user must also have 
EXECUTE authorization on the database. 

3. In the installation folder of the FDM software the program 
"InitSqlServer.exe" supports the creation of the tables and schemas on 
the Microsoft SQL server database. After starting the program, the 
following window appears: 



FDM Installation 

Endress+Hauser 31 

 

 

 

4. Please configure the connection to the database (server 
name\instance). The server’s name is the hostname of the computer 
on which the database server is running. The instance can be set during 
the installation of the database server and is for SQL Express by 
default "SQLEXPRESS". You can see the installed name of the instance 
in the registration 
(HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL 
Server\<Instance Name>). 

5. Configure the name of the database, which you created in the database 
server before (i.e. with Microsoft SQL Server Management Studio’ 
tools). 

6. Set username and password which the FDM software will use for login 
onto the database. Please use the "user custom login". 

7. Click on the test button. After a few seconds a message will show 
whether the software is able to access the database or not. If access is 
not possible, please verify the settings of the connection and the 
spelling of username and password. The software can only access the 
database when there is a positive message after clicking the "test" 
button. 

8. After access to the database is established, please click on the button 
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"Create schema". The necessary tables for the storage of the data will be 
created in the database. After a few seconds, when all tables are 
created, the window is closed automatically. 

9. Launch the FDM software. 
10. In the menu "Extras -> Settings -> Database" select "Microsoft SQL 

Server" and configure the connection to the database. Enter the 
username and password. 

 

 
11. Click on the "test" button and check whether the FDM software can 

connect to the database and whether the necessary tables are created. 
If access to the database is not successful, please verify the settings of 
the connection and the spelling of the username and password. Only in 
the case of a positive message is access to the database possible. 

12. After a positive message please click on OK to close the configuration 
dialog. The FDM software is now configured to access the Microsoft 
SQL Server. 
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5.3 Enable remote connections to the database server 

5.3.1 Enable remote connection to PostgreSQL server 

First install the database administration tool "pgAdmin III". The tool is located 
on the setup DVD. 
1. Start the "pgAdmin III" tool. 
2. Open "Tools -> Server Configuration -> postgresql.conf". 
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3. Open the settings "listen_addresses" with double click and enter an 
asterisk (*). This enables all incoming TCP connections to this server. It 
is also possible to accept individual IP addresses. 

4. Per default all connections to remote addresses are rejected. To allow 
these, open "Tools -> Server Configuration -> pg_hba.conf" and add the 
following entry: host all all 0.0.0.0/0 md5 
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5. Start "PostgreSQL" with PC new start. 

Pay attention to: 
• The configurations which are described in the steps above can directly be 

done in the files "postgresql.conf" and "pg_hba.conf". These files are in the 
installation folder of PostgreSQL Server under "data". 

• Check the changes you made very carefully. Wrong settings can disable 
access to the server (e.g. wrong IP address). 

For further information see: 
http://www.postgresql.org/docs/9.2/interactive/client-authentication.html 

5.3.2 Enable remote connection for Microsoft SQL server 

You have to enable remote connections to every instance of SQL server you 
want access to from a remote computer. Perform the following steps: 
1. Start -> Programs -> Microsoft SQL Server 2005 -> Configuration tools  

-> SQL Server surface configuration. 
The window "SQL Server 2005 Surface Area Configuration" opens. 

2. Select "Surface configuration for services and connections". 
3. In "Database Engine" open "Remote connections". 

Activate "Local connections and remote connections" and the 
appropriate protocol. Click on Apply. 
 

 

http://www.postgresql.org/docs/9.2/interactive/client-authentication.html
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4. The message opens: 
"Changes of the connection settings become effective after a restart of 
the database module service." 
Click on OK. 

5. On "Database Engine" open "Services". 
Click on Finish and wait until the service MSSQLSERVER terminates. 
Click on Start, to restart the service MSSQLSERVER. 

 Check the changes you made very carefully. Wrong settings can disable 
access to the server (e.g. wrong IP address). 

 
For further information see: 
http://support.microsoft.com/kb/914277 

5.4 Configuration of Microsoft SQL Server and automatic 
actions: 

When using Windows Authentication, additional configurations are 
necessary: 

1. Start the "SQL Server Management Studio". If this software is not 
installed on your PC you can download the software from the website of 
Microsoft free of charge. Please take care that you download the 
software for your version of the SQL Server. Install the software on your 
PC. 

2. Select the node "Login/Account" in the folder "Security". 
3. Create with the right mouse click in this folder an additional account 

NT-AUTHORITY\ANONYMOUS. 
4. Now select the database of the reporting software in the node 

"databases". 
5. Please create in "Security/User" a new user with the name 

"FdmServiceUser" and the name NT_AUTHORITY\ANONYMOUS. 
6. Finally assign to the user in "member of database roles" the rights 

db-owner. 

For these configuration steps you can find a video on the website of 
Endress+Hauser: http://www.endress.com/ms20 

http://support.microsoft.com/kb/914277
http://www.endress.com/ms20
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5.5 Update of the FDM software to a new version 

When the FDM software works with the delivered Postgre DB Server local on 
your computer, the database is updated to the new version, if necessary, 
automatically. In this case (standard case) it is not necessary that you take 
any additional steps after the installation. The data in the database 
remains available after the update. 
When you use the delivered Postgre DB Server in the network (remote) or a 
Microsoft SQL Server database (local or remote) it may be that after the first 
start of the FDM software the configuration dialog of the database 
connection comes up with a hint that the database is not updated to the 
current version. 
In this case the administrator of the database must run the corresponding 
tool for the database server to update the database schema to the new 
version. The database administrator should follow the steps described 
above. After the update all data remains available in the database. 

 Make sure that all client PCs of the FDM software are updated to the 
new version. 

 

6 Getting started 
This introduction provides a brief overview of the first steps using Field Data 
Manager Software. 

  To use the Professional version, a valid software ID must first be entered 
under "Help -> License Information" and the software is activated. 

 
 Detailed information on software activation and help for the functions 

can be found in the integrated online help under "Help -> Field Data 
Manager software help" or in the instructions in the installation folder 
e.g. under C:\Program Files (x86)\Endress+Hauser\Field Data Manager 
Software\Documentation. 

6.1 User interface 

The user interface of FDM is divided into three areas 
• At the top is the menu bar with function groups for the settings: 

File -> Program end 
View -> Settings of the display 
Extras -> Settings of database, language, user administration, audit trail 
Help -> Online help, License Information 
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• On the left-hand side is the task pane. By clicking on a task, the contained 
functions are displayed: 
Visualization -> Visualization template new, open or delete 
Read out data -> read out data from a mass storage or online connection 
to the device 
Data management -> open plant view, export or import of device data 

• On the right-hand side is the working area: 
All active tasks are opened here. If multiple tasks are open, they are 
displayed in different tabs. 
 

 
 

 
6.2 Usage 

With all functions a wizard guides you through the input needed. To correct 
your inputs, click on Back. To abort the wizard, click on Cancel. 
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