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Revision History

Product Version

The table below indicates the product versions of the main components of ControlCare Field-based 
Control System. More details on the individual components can be seen in About ControlCare 

Registered Trademarks

PROFIBUS® 

Registered trademark of the PROFIBUS User Organisation, Karlsruhe Germany. 

FOUNDATIONTM Fieldbus
Trademark of the Fieldbus Foundation, Austin, TX 78759, USA
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Registered trademark of the HART Communication Foundation, Houston, USA
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All other brand and product names are trademarks or registered trademarks of the companies and 
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1 Safety

1.1 Designated use

ControlCare is a field-based control system comprising hardware and software components. It can 
be used to visualize, monitor and control production processes. The approved usage of the 
individual units used in the system can be taken from the corresponding parts of the operating 
instructions.

The software described in this particular manual allows a network connected to a ControlCare 
SFC173 PROFIBUS Field Controller to be engineered, configured and commissioned. In addition, 
appropriate control strategies can be built using the function blocks contained in the controller and 
connected devices.

1.2 Installation, commissioning and operation 

ControlCare Field Controllers have been designed to operate safely in accordance with current 
technical safety and EU directives. Essential to their use is the ControlCare Application Designer 
software suite, which allows control strategies to be created for FOUNDATION Fieldbus and 
PROFIBUS I/O applications. Field devices, links, junction boxes, cables and other hardware 
comprising the Fieldbus sytem must also be designed to operate safely in accordance with current 
technical safety and EU directives. 

If devices are installed incorrectly or used for applications for which they are not intended, or if the 
controller is not configured correctly, it is possible that dangers may arise. For this reason, the system 
must be installed, connected, configured, operated and maintained according to the instructions in 
this and the associated manuals: personnel must be authorised and suitably qualified.

1.3 Operational safety

Location Field Controllers must be mounted in a permanent and weather-protected location in a safe area. 
The environment shall be a metal cabinet or an installation frame with a well grounded mounting 
plane. The environment shall be protected. 

Hazardous areas The controller must be connected to networks operating in explosion hazardous areas via barriers 
or other safety components. When installing components in explosion hazardous areas:

•  Ensure that all installion and maintenance personnel are suitably qualified
•  Check that all equipment has the appropriate safety certificates
•  Observe the specifications in the device certificates as well as national and local regulations.

This topic is discussed in BA013S (FF Guidelines) and BA034S (PROFIBUS Guidelines).

EMC All modules are suitable for industrial use and conform with the following standard, see Appendix:

•  EN 61326: 1997/A1: 1998
Interference emmision: Class A apparatus
Interference immunity: as per Annex A, industrial environment

Depending upon the environment in which the bus is operating, particular attention should be paid 
to the grounding of the bus cables. This topic is discussed in BA013S (FF Guidelines) and BA034S 
(PROFIBUS Guidelines).
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IP Address A ControlCare Field Controller is normally configured from a workstation connected into the 
control system backbone. You will require a unique IP address to set it up.

Warning
The use of IP addresses is strictly controlled. Usually your system administrator will be authorised 
to allocate unique addresses. Assigning an unauthorised address to a Field Controller may result in 
conflicts within your system and the failure of the associated devices!

Since the system can be accessed and manipulated through the various ControlCare tools, it is 
advisable to control access both to the workstation and the folders in which the configuration is 
stored. Always make a back-up of the project.

Technical improvement Endress+Hauser reserves the right to make technical improvements to its software and equipment 
at any time and without prior notification. Where such improvements have no effect on the 
operation of the equipment, they are not documentated. If the improvements effect operation, a 
new version of the operating instructions is normally issued. 

1.4 Conventions and icons

In order to highlight safety relevant or alternative operating procedures in the manual, the following 
conventions have been used, each indicated by a corresponding icon in the margin. 

Safety conventions Icon Meaning

A note highlights actions or procedures which, if not performed correctly, may indirectly affect operation 
or may lead to an instrument response which is not planned

Caution!
Caution highlights actions or procedures which, if not performed correctly, may lead to personal injury or 
incorrect functioning of the instrument

Warning!
A warning highlights actions or procedures which, if not performed correctly, will lead to personal injury, 
a safety hazard or destruction of the instrument

Warnung!
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1.5 ControlCare documents

Table 1.1 indicates the documents, planned and realized, containing safety relevant information, 
installation, commissioning and operating instructions for the equipment and software associated 
with ControlCare.

All documentation available at the time of release is included on the ControlCare CD-ROM and is 
installed in Start=>Programs=>Endress+Hauser=ControlCare=Manuals during set-up.

Tab. 1-1: ControlCare Documentation

Component Description Document type Designation Order No.

System ControlCare System Overview Operating manual BA016S/04/en 56004883

ControlCare System Design Operating manual BA039S/04/en Planned

ControlCare System Specifications Operating manual BA040S/04/en 56004888

Software Application Designer Overview Operating manual BA017S/04/en 71014301

Application Designer Drawing Tool Operating manual BA032S/04/en Planned

Application Designer: FF Tutorial Operating manual BA019S/04/en 70101151

Application Designer: PROFIBUS Tutorial Operating manual BA036S/04/en 70101152

Application Designer: MODBUS Tutorial Operating manual BA037S/04/en 70101153

Application Designer: IEC 61131 Tutorial Operating manual BA038S/04/en 70101386

Field Control (OPC) Servers Operating manual BA018S/04/en 71031428

Field Controller Hardware Installation Guide Operating manual BA021S/04/en 56004885

Commissioning and Configuration Operating manual BA035S/04/en 56004887

Function Blocks Function Block Manual Operating manual BA022S/04/en 56004886

Set-Up Getting Started Operating manual BA020S/04/en 56004884

General FOUNDATION Fieldbus Guidelines Operating manual BA013S/04/en 70100707

PROFIBUS Guidelines Operating manual BA034S/04/en 56004242



2 Task Description ControlCare Application Designer: PROFIBUS Tutorial

6 Endress+Hauser

2 Task Description

This tutorial describes all steps necessary for setting up the project described below. It does not aim 
to give an exhaustive account of Application Designer functions, but rather shows you one of a 
number of methods to reach your goal. The tags and names used in the tutorial are imaginary and 
will be different in a proper application. A full description of Application Designer functions is to be 
found in Application Designer Overview BA017S/04/en and Drawing Tool BA032S/04/en (in 
preparation). Function block descriptions are to be found in BA022/04/en, Function Block manual.

2.1 Application

For this tutorial, the case of cascade control for a heat exchanger will be used, see Fig. 2-1. 

Fig. 2-1:  Schemetic diagram of heat exchanger application

A liquid flows through the heat exchanger and is heated by condensing steam. The controlled 
variable is the exit temperature of the liquid flowing through the exchanger. The manipulated 
variable is the steam flow to the exchanger. The temperature of the product defines the set point of 
the steam flow, which is controlled by a valve in order to avoid excessive waste of energy (=steam). 

The corresponding control strategy is shown in Fig. 2-2.

Fig. 2-2  Cascade control strategy for heat exchanger application
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2.2 Network

For the purposes of demonstrating as many aspects of PROFIBUS engineering as possible, the 
network is assumed to be constructed as shown in Fig. 2-3. 

•  The flowmeter is assumed to be a PROFIBUS DP device
•  The valve is assumed to be a PROFIBUS PA device connected to the PROFIBUS DP network 

via a segment coupler
•  The temperature transmitter is assumed to be an analog device connected to the PROFIBUS DP 

network via a Remote I/O unit.

Fig. 2-3  Network for application example

In the case chosen, the connection to the PROFIBUS PA segment is made via a transparent P+F SK1 
segment coupler. This does not have to be engineered in the PROFIBUS configurator because the 
default settings are used. For a Siemens Link or P+F SK2 Power Link, however, the bus parameters 
have to be changed to conform with those used by the SFC173 PROFIBUS Field Controller. 
Instructions on how to do this are to be found in the operating instructions supplied by the 
manufacturer. More information on PROFIBUS DP/PA communcation is to be found in operating 
instructions BA034S/04/en, PROFIBUS Guidelines.
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2.3 Preliminaries

2.3.1 Installation and commissioning
Before you can start the PROFIBUS tutorial, Application Designer must be installed on your 
computer, the SFC173 PROFIBUS Controller installed and commissioned and a connection made 
to your computer. Instructions on how to do this are to be found in:

•  Operating Instructions BA020S/04/en, Getting Started
•  Operating Instructions BA021S/04/en, Field Controller: Hardware Installion
•  Operating Instructions BA035S/04/en, Field Controller: Commissioning and Configuration

2.3.2 Address and tag list
For a PROFIBUS system, each device that communicates must have a unique bus address. It is 
recommended that the addresses are set at the DIP switches on the devices or via software, e.g. 
FieldCare, before they are installed in the plant. 

•  SFC173 Field Controller is supported in FieldCare via the SFC173 CommDTM. Chapter 7 
gives a short description of its use. Additional information is to be found in the FieldCare and 
DeviceDTM online helps.

A PROFIBUS address must also be assigned to the master before it can become active on the bus. 
The address of the SFC173 Field Controller is set by software. Normally, it is set off-line in 
Application Designer and implemented when the project is downloaded to the controller. 

To aid the engineering of the network, it is necessary to keep a record of the device addresses and 
tags, often as an Excel sheet. Table 2-1 below provides an example of how this might look for the 
application at hand. 

Tab. 2-1: Address and tag list for tutorial application

2.3.3 PROFIBUS parameters
The SFC173 Field Controller can be used with both P+F and Siemens couplers and links. The bus 
parameters differ according to the equipment used. 

This tutorial describes the parameters of the P+F SK1 coupler and P+F SK2 power link. If you are 
using Siemens equipment, please consult the manufacturer’s instructions regarding suitable 
parameters. They are set as described in Chapter 3.5.

Another case in which bus parameters may differ from those descibed in this tutorial is when a 
Fieldgate FXA720 is operating as a Class II master in the network. Again, the manufacturer’s 
instructions should be consulted regarding suitable bus parameters.

Area/Process Cell/
Control Module

Device Vendor Tag Unit Address Task

Pasteurization
Heat Exchanger

Temperature control

TMT162 HART
/Pt100

E+H TT100 °C 119 Product temperature

Promass 73 DP E+H FT101 t/h 5 Steam flow

ND9000PA Metso FCV102 % 6 Steam valve positioner

SFC173 E+H CO104
-TIC100
-FIC101

1 Controller
Temperature PID
Flow PID
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3 Create a PROFIBUS Network

3.1 Create a new project

1 Start ControlCare Application Designer by clicking on the icon on your destop or via Start => 
Programs => Endress+Hauser => ControlCare => ControlCare Application Designer

2 The project starts from a blank application screen
– With the right mouse key select Project File=>New

3 The Document Type box appears: Click the option Project

4 The New Project dialog box opens:

1. Choose the folder where the project will be saved.
2. Type the name of the project in the File Name box.
3. Click Save. 
If the new project is not to be created, click Cancel.

5 ControlCare Application Designer automatically creates a folder with the entered file name 
within the selected folder.
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3.2 Determine the naming preferences

Before you start, you can set preferences for the way your project is created. Of particular interest 
at this stage is the labelling of the function blocks.

1 Press Project File => Preferences
– The Preferences Dialog appears

Tag Policy Tag Policy determines how the blocks are labelled by default if no tag names are entered

1 Select the folder Block and the subfolder Tag Policy, then check the following buttons
– Device
– Update Block Tag

2 Press OK to confirm your selection
– Application Designer will now automatically rename any blocks created in the control

strategy window as they are assigned to the devices by adding the device tag as prefix.

Tag Composition Tag Composition determines how the block identifiers are added to the block tag if no block name 
is entered.

1 Select the subfolder Tab Composition:
– Enter a mnemonic separator: for this manual the setting was "-"

Default setting is "_" and mandatory if flexible function blocks are to be used
– Check Prefix

2 Press OK to confirm your selection
– Application Designer will now automatically compose the blocks according to your

selection, e.g. TagName-Block-n or TagName_Block_n.

Export Tag Export Tag causes tags to be automatically exported every time the project goes online

1 Select the subfolder Export Tag
– Check the Automatic button

– Press OK to confirm your selection
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3.3 Add a gateway (SFC173)

1 On saving, ControlCare Application Designer automatically creates a project, adding the HSE 
fieldbus network and the HSE Host
– Click on + to expand the tree:

2 Now right-click on the HSE Network leaf and select New=>Gateway

3 The New Gateway dialog box appears:
Select the SFC173 Field Controller and type in a device TAG = CO104

If you do not type in a tag, the default will be "Gateway n", where n is a consecutive number. 
At this point, the Fieldbus Network does not have a direct correspondence to any of the 
existing controllers.

4 Press OK to create the Gateway.
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3.4 Add a PROFIBUS segment

1 The project now looks like this:

2 Right click on the gateway you just created, here "Gateway 1", and select New Profibus.

3 The New Profibus dialog box appears:

– At this point you can enter a PROFIBUS segment TAG
– If you do not type in a tag, the default will be "Profibus n", where n is a consecutive number. 

At this point, the Fieldbus Network does not have a direct correspondence to any of the 
existing controllers.

4 Press OK to create the PROFIBUS segment.

5 The ControlCare PROFIBUS Configurator opens with the SFC173 Controller inserted as 
PROFIBUS master/host with the default address 1
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3.5 Set the PROFIBUS parameters

1 Click on the SFC173 master, select the menu Settings => Profibus Settings...
– The Bus Parameter dialog appears

2 For the SK1 coupler select 93.75 kbit/s (default) and optimize By User, then press Edit
– The Edit Bus Parameters dialog appears

3 Check and if necessary enter the following parameters (P+F SK1 coupler):

– Slot time: 4095
– Min station delay: 22
– Max station delay: 1000
– Set-up time: 250
– GAP update factor: 100
– Max retry limit: 3
– Token rotation time: 90000
– Press OK to store the parameters followed by OK to exit the Edit dialog

4 As devices are added to the bus, see Chapter 3.7, the Master checks whether they support the 
selected baudrate

– PROFIBUS DP slaves normally listen to the bus and adjust automatically to the baudrate. 
If this is not the case, their baudrate must be changed to that of the coupler.

– Standard GSD files for PROFIBUS PA slaves support baudrates 93.75 kbit/s (P+F SK1) and 
45.45 kbit/s (Siemens coupler) by default

– If a PROFIBUS DP master is added to the bus, e.g. FXA720 Class 2 Master, then its bus 
parameters must be set to those of the Field Controller.

P+F SK2 Power Link 1 For the P+F SK2 power link device. 

– Select the Baudrate you require
– Select optimise Standard to automatically set the SK2 parameters for the selected baudrate.

2 As devices are added to the bus, see Chapter 3.7, the Master checks whether they support the 
selected baudrate

– A warning message appears if a device does not support the selected rate
– For PROFIBUS PA devices the special GSD file "Yxxx ...." must be used
– For PROFIBUS DP devices, a master baudrate supported by all devices must be selected



3 Create a PROFIBUS Network ControlCare Application Designer: PROFIBUS Tutorial

14 Endress+Hauser

3.6 Configure the PROFIBUS master

1 Double-click on the SFC173 Node, the Master Configuration dialog box opens:

– Enter the controller tag in the Description, i.e. CO104 
– Set the Station Address to 1

2 A click on the DP Master Settings... button opens the DP Master Settings dialog:

– A description of the parameters is to be found in the on-line help
– For our application no changes need be made
– Press OK to close the dialog and return to the Master Configuration dialog

3 Press OK to confirm the changes in the configuration and to return to the PROFIBUS 
Configurator workspace
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3.7 Add the PROFIBUS devices

Note! 
• GSD files of 3rd party devices can be added to the library by selecting File=>Copy GSD

1 Select Insert =>Slave... a large S appears as cursor. 
Move this to the position on the PROFIBUS line, below the SFC173 Field Controller icon, 
where you want to place the device. 

2 Right-click to begin placing: the Insert Slave dialog box appears

– Select the Vendor and if required Type of Slave (All, General, I/O Slave)
– Select a device from the Available Slaves list
– Press Add to move it to the Selected Slaves list
– Designate a unique slave address >3 (0 - 2 are reserved for masters)
– Enter a symbolic slave name, e.g. Slave 1
– Press OK to add the slave to the segment

3 For the tutorial, add a Promass 83 DP device, a Metso ND9000PA device and a Stahl Remote 
I/O IS1

– For the SK1 (and Siemens) coupler, select the normal files (PROFIBUS DP or PA)
– You can also configure the slave, see Chapter 3.8, before adding the next one.

4 Your project should now look something like this:

P+F SK2 Power Link The P+F SK2 link requires special GSD files for PROFIBUS PA devices
– Select the files with the suffix "Yxxx" or "SK2"
– For information on GSD files, see the PDF ContentCC_GSD_Library which installed 

automatically during setup in the Manuals folder 
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3.8 Configure the PROFIBUS slaves

The device configuration is done in the Slave Configuration dialog box. Although the basic actions 
are identical, it varies slightly according to the type of slave. 

3.8.1 Transmitter configuration

1 Double-click on the Promass Node, the Slave Configuration dialog box opens:

– The General box contains the parameters as set in the Insert Slave dialog (these can be 
changed if required - use underscores instead of spaces, as the latter and invalid characters)
– Enter the preset Station Address = 5
– Enter the device tag as Decription = FT101

– In the Parameter Box you can select the GSD modules to be sent to and from the Controller
– The parameters for the Promass 83 must be configured in a fixed order, see BA064F
– Use Empty_Module/Free_Space parameters to fill gaps made by unused parameters

– Select the AI parameter (= Mass flow in t/h) and press the Append Module button, the 
parameter is added to the I/O parameters box

2 Press DPV1 Settings... and make sure that DPV1 Activated checkbox is not checked
– Press OK to confirm your settings

3 Press OK to complete the configuration
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3.8.2 Positioner configuration

1 Double-click on the ND9000PA Node, the Slave Configuration dialog box opens:

– The General box contains the parameters as set in the Insert Slave dialog (these can be 
changed if required - use underscores instead of spaces, as the latter and invalid characters)
– Enter the preset Station Address = 6
– Enter the device tag as Decription = FCV102

– In the Parameter Box select the GSD modules to be sent to the Controller
Select the SP+READBACK+POS_D+CHECKBACK parameter and press the Append 
Module button: the parameter is added to the I/O parameters box
Note: PROFIBUS Configurator uses PROFIBUS notation here, the FF equivalents are shown 
in brackets when the function block is opened in the control strategy window

– Press DPV1 Settings... and make sure that DPV1 Activated checkbox is not checked
– Press OK to confirm your settings

2 Press OK to complete the configuration
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3.8.3 Remote I/O configuration

1 Double-click on the STAHL IS1 Node, the Slave Configuration dialog box opens:

– The General box contains the parameters as set in the Insert Slave dialog (these can be 
changed if required - use underscores instead of spaces, as the latter are invalid characters)
– Enter the preset Station Address = 4
– Enter the device tag as Decription = TT100

– In the Parameter Box select all modules that are used in the Remote I/O:
In our example select:
1) 9440/15-01-11CPM Z2 (no status byte) and press the Append Module button:
2) 9461/12-08-11 AIMH 8 and press the Append Module button: 
the modules are added to the I/O parameters box

– Press DPV1 Settings... and make sure that DPV1 Activated checkbox is not checked
– Press OK to confirm your settings

2 Now select the AIMH module in the I/O parameter list and press the Parameter Data 
button, the Parameter Data dialog appears

– This has no relevance to the Parametrization, but can be used later to check the raw data 
offered by the Remote I/O when the project is on-line.
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3 Press the Common button – the parameters common to the entire I/O can be modified, e.g. 
redundancy of CPM or wiring: see manufacturer’s instructions for more details

– A double-click on the parameter calls a list of possible options
– Press OK to confirm your choice
– After all common parameters have been configured, press OK to confirm your selections

4 Now press the Module button 

– Set the I/O module parameters, see Remote I/O manufacturer’s instructions
– A double-click on the parameter calls a list of possible options, e.g. 0..20 mA or 4..20 mA

– For our example set Input 0 = 4 .. 20 mA; Fault Monitoring Input 0 = yes, 1–7 = no
– Press OK to confirm your choice
– After the module has been configured, press OK to confirm your selections and close the 

Parameter Data dialog

5 Press OK to complete the configuration: your project should now look like this:
– Select Save then Exit to close PROFIBUS configuration
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3.9 PROFIBUS I/O mapping

The PROFIBUS I/O mapping connects the GSD modules, which are responsible for cyclic 
communication with the PROFIBUS devices, to function blocks. Depending upon device type these 
may be simple Input/Output blocks with one OUT or IN value, or Multiple Input/Output blocks 
with several OUT or IN values. In the latter case, the values are connected the order they appear in 
the Mapping dialog, i.e. Value 1 = OUT_1/IN_1 etc. ThePROFIBUS function blocks can then be 
used to create the control strategy, see Chapter 4.

6 The PROFIBUS I/O Mapping dialog appears, showing Device/Function Block and Module/
Submodule views

– For most PROFIBUS PA and PROFIBUS DP devices, the function blocks are preconfigured 
and appear in the Device/Function Block View as yellow boxes. If the parameter in the 
right-hand pane has a question mark, it must be configured, see Chapter 3.9.1.

– For Remote I/Os you will always see a series of question marks: this means that the 
submodule data format must be configured

3.9.1 Configuring the Remote I/O
Before you begin to map a component, it is important that you read the appropriate operating 
manual, since it is necessary to know what parameters are offered by the device and in what format 
they are transmitted across the PROFIBUS network.

1 Click on the first submodule leaf of the Remote I/O - a bit map appears at the top of the page

– Click on Bit 0, then right-click over the bit map and select the output type and data format
– For 9461/12-08-11 AIMH select Analog Values and 2 byte value without status

("Without status" means no status bytes are sent - the status may still be present as a bit)
– Repeat for all other submodules 
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2 On selection, the question mark disappears and the appropriate Function Block appears in the 
Device/Function Block view

3 Now right-click on 2 Byte bar (green) and select Attributes - the Parameter Attributes 
dialog box appears:

– Select Slave Status: MSB_WORD_STATUS_0_GOOD (see Remote I/O manual)
– Select the data format: Integer 16 (see Remote I/O manual)
– You can also enter a Parameter Tag - this will appear in the project tree
– Press OK to confirm your choice and close the dialog box. 

Note!
• If the slave sends no status bit or byte

– Select Slave Status = SLAVE_VALUE_WITHOUT_STATUS
– Select Status Value = Good NonCascade or Good Cascade, depending on role in loop

4 Select OK to close the dialog - the project data is imported to Application Designer

– The mapped devices are added to the Profibus network
– The block TT100-DP_MAI_1 is added to the TT100 device

The block FT101-PA_AI_1 is added to the FT101 device
The block FCV102-PA_AO_1 is added to the FCV102 device

– The temperature value is mapped to OUT_1 of the TT100-DP_MAI_1 block
The flow value is mapped to the OUT value of the FT101-PA_AI_1 block
The position value is mapped to the READBACK value of the FCV102-PA_AO_1 block

5 Open Project File, then press Save, to save the project.
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3.10 Add Function Blocks to the Controller

The blocks that are always necessary for the Field Controller (RS, PBTR0, HC and DIAG) are created 
automatically when it is added to the Fieldbus Network. Do not delete these blocks! 

Application-specific blocks are created manually as shown below. They can also be created in the 
Control Strategy window for later assignment to a field device or Field Controller. The order of 
assignation determines the order of execution (can be changed by drag&drop).

1 In the Profibus workspace expand the Profibus tree until you see all function blocks

2 Now right-click on the FB VFD leaf of the SFC173 Controller and select New Block
– The New Block dialog for the SFC173 appears

– Select Block Type PID Control from the the dropdown menu
– Enter a Block Tag, e.g. CO104-TIC100 (Default is TAG_Description-PID-n)
– Press OK to confirm your choice

3 Repeat the procedure to add a second PID Block wth the Block Tag CO104-FIC102

4 Open Project File, then press Save, to save the project, it should look like this
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3.11 Export tags

Note! 
• You should use the Export Tags function everytime you change the configuration of the project, 

so that the OPC server information is always up-to-date.
• Application Designer can be set to automatically export the tags every time the project goes 

online, see Chapter 3.2.

1 Activate the project view by clicking in its workspace

2 Right click on the project name, a context menu appears

3 Select the option Export Tags...
– The Export Tags dialog confirms the successful export

– Press OK to close the dialog

4 Open Project File, then press Save to save the project
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4 Create a Control Strategy

Having created a physical view of the process instrumentation, the next step is to create control 
strategy. This is done in the logical view of the plant. This represents the plant as Areas/Process 
Cells in accordance with ISA S88/IEC 61518. Only one Area is allowed in the project, but this may 
have any number of Process Cells.

4.1 Add a Process Cell

1 Click on the "Area 1" leaf in the project and select Attributes...

2 The Attributes dialog box appears

– Enter a name for the area, e.g. Pasteurization (see Table 2-1, Chapter 2.3)
– Click OK to store your changes

3 Click on the Area leaf again and select New Process Cell...

4 The Process Cell dialog box appears

– Enter a name for the process cell, e.g. Heat Exchanger (see Table 2-1, Chapter 2.3)
– Click OK to store your changes

5 Your project should now look something like this:

6 Open Project File, then press Save Entire Configuration, to save the project.
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4.2 Add a Control Module

1 Double-click on the Process Cell leaf - a new window with the name of the leaf opens

2 Right-click on the top leaf and select New Control Module

3 The Control Module dialog box appears

– Enter a name for the control module, e.g. Temperature Control (see Table 2-1, Chapter 2.3)
– Click OK to store your changes

4 The project now looks something like this:

5 For a real project, Step 2 and 3 would be repeated until all the required control modules for a 
particular process cell have been added. This allows each control loop or control loop group to 
be set up and viewed in its own control strategy window.

6 Double-click on the control module leaf to open the Control Strategy workspace - this has the 
same name as the leaf
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4.3 Add Function Blocks to the Control Strategy

1 Take the Profibus workspace and expand the Profibus tree until you see all function blocks. 
Place the workspace next to the Control Strategy workspace

2 Now drag and drop the following function blocks from the Profibus tree into the Control 
Strategy workspace

– TT100 analog input block: TT100-DP_MAI_1
– FT101 analog input block: FT101-PA_AI_1
– FCV102 analog output block: FCV102-PA_AO_1
– 2x Controller PID blocks: CO104-TIC100, CO104-FIC101

3 As you do this, you will see that the function blocks also appear in the Control Module 
workspace

4 Open Project File, then press Save Entire Configuration, to save the project.
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4.4 Add the Function Block links

When you are adding the links you will notice that some AO parameters have two names. The main 
name is that provided in the PROFIBUS GSD, the one in parentheses is the corresponding parameter 
in the FOUNDATION Fieldbus Function Block standard.

1 In the Control Strategy workspace position the blocks according to your strategy

– The blocks can be dragged and dropped by selecting and holding down the right mouse key
– The blocks can be aligned by selecting, then via Tools => Alignment => e.g. Middle 

followed by a click on the block to which the alignment is to be made
– The Tools menu also contains other standard drawing functions such as toolbars, standard 

shapes, line thickness, colours etc.

2 Click on Function Block Link  button in the tool bar, the cursor changes to a cross
– Select the TT100-DP_MAI_1 block (Temperature AI block) with the cross: 

the Output Parameter Selection dialog appears

– OUT_1 contains the temperature value, see Chapter 3.9

3 Click the box next to OUT_1 – it changes color – then click on OK

– The Output Parameter Selection dialog closes
– The cursor is now connected to a blue dotted line
– Place the Cursor in the Controller PID Block 1 and click to make the link
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4 When the link is made, the Input Parameter Selection dialog for the PID block appears

– Click the box next to IN – it changes color – then click on OK

5 When the Input Parameter Selection dialog changes, the link is made and appears as below:

– You may have to move the parameter legends "IN" and "OUT" by selecting and positioning 
with the left mouse key depressed

6 Repeat steps 2 to 5 and make the following links between the function blocks

– PID1 and PID2 = OUT to CAS_IN (RCAS_IN)
– PID2 and PID1 = BKCAL_OUT to BKCAL_IN
– Flow AI to PID2 = OUT_1 to IN
– PID2 to Valve AO = OUT to SP (CAS_IN)
– Valve AO to PID2 = READBACK (BKCAL_OUT) to BKCAL_IN

7 Your Control Strategy now looks something like this

8 Click on the Project View workspace and Export Tags..., see Chapter 3.10
– Open Project File, then press Save Entire Configuration, to save the project.
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5 Characterize the Devices

How the devices are characterized (set up) depends upon their type:

•  For both PROFIBUS DP and PROFIBUS PA devices, the essential step is made in the selection 
Analog Input and/or Analog Data to be transmitted across the bus, see Chapter 3.7. 

•  The devices are then parameterized (zero, span, unit etc.) using the device display, service 
software or e.g. FieldCare, see Chapter 7. 

•  For Remote I/O the inputs and outputs must be scaled: this is done in Application Designer
•  For all devices the Mode Block Target must be set according to their role in the cascade loop.

5.1 Profibus DP device (flow)

For the Tutorial, we must check that the Mode Block Target has the status "Auto"

1 In the Profibus network workspace, expand the FT101 tree 
– Right click on the FT101-PA-AI-1 block and select Off Line Characterization...

2 The Off Line Characterization dialog opens
– Expand the Mode Block parameter tree

3 The Mode Block Target must be set to Auto. If this is not the case
– Double-click on the "Value space" next to the Target parameter
– Select "Auto" from the drop-down menu
– Press End Edit to register your change
– Press Close to quit the Characterization dialog

4 Open Project File, then press Save Entire Configuration, to save the project



5 Characterize the Devices ControlCare Application Designer: PROFIBUS Tutorial

30 Endress+Hauser

5.2 PROFIBUS PA device (positioner)

For the Tutorial, we must change the Mode Block Target to "Auto"

1 In the Profibus network workspace, expand the FCV102 tree
– Right click on the FCV102-PA-AO-1 block and select Off Line Characterization...

2 The Off Line Characterization dialog opens
– Expand the Mode Block parameter tree

3 Set the Mode Block Target to Auto.

– Double-click on the "Value space" next to the Target parameter
– Select "Auto" from the drop-down menu
– Press End Edit to register your change
– Press Close to quit the Characterization dialog

4 Open Project File, then press Save Entire Configuration, to save the project.
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5.3 Remote I/O (temperature)

For the Tutorial, we must check that the Mode Block Target has the status "Auto" and scale the 
input parameter TT100 DP-MAI-1

5.3.1 Set the Block Mode Target

1 In the Profibus network workspace, expand the TT100 tree
– Right click on the TT100 DP-MAI-1 block and select Off Line Characterization...

2 The Off Line Characterization dialog opens
– Click on All to display all available parameters
– Expand the Mode Block parameter tree

3 Check that the Mode Block Target is set to Auto. If this is not the case
– Double-click on the "Value space" next to the Target parameter
– Select "Auto" from the drop-down menu
– Press End Edit to register your change
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5.3.2 Scale the output
In the manufacturer’s instructions for the Remote I/O you will find a table of parameters showing 
how the signals are transported across the PROFIBUS DP bus. Table 5.1 below is an extract:

Tab. 5-1: Relationship between 4–20 mA signal and PROFIBUIS DP parameter

The output must be scaled according to the binary values for 4 mA and 20 mA.

1 Expand the SCALE_LOC_OUT_1 parameter

2 Set the following parameters: 
– FROM_EU_0 = 0
– FROM_EU_100 = 27648
– TO_EU_0 = 0 (temperature that corresponds to 4 mA)
– TO_EU_100 = 100 (temperature that corresponds to 20 mA)
– The other parameters were set during the mapping process, do not change them
Double-click on the "Value space" next to the parameter => Enter the value => 
Press End Edit to register your change

3 Press Close to quit the Characterization dialog

4 Click on the Project View workspace and Export Tags..., see Chapter 3.10
– Open Project File, then press Save Entire Configuration, to save the project.

Range 
4–20 mA

Units % Parameter
Range limits 
to NAMUR

Range Alarm/
Diagnosis

decimal Hex

>22.814 mA
> 21 mA

see 
instructions

see 
instructions

No (Nein)
Yes (Ja)

Short-cicuit

22.814 mA
21 mA

32511
29376

7EFF
72C0

117.6%
106.25%

No (Nein)
Yes (Ja)

Overrange

20 mA
12 mA
4 mA

27648
13824
0

6C00
3600
0

100%
50%
0%

Nominal range

3.999 mA
3.6 mA
2.4 mA

-1
-691
-2765

FFFF
FD4D
F533

-2.5%
-10%

Yes (Ja)
No (Nein)

Underrange

<3.6 mA
<2.4 mA

see 
instructions)

see 
instructions

Yes (Ja)
No (Nein)

Broken wire
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5.4 Field Controller (PID blocks)

5.4.1 Basic parameters
The Field Controller PID blocks must now be characterized. In practice, the values for the GAIN, 
RESET and RATE as well as the setpoint value SP for the temperature loop must be calculated or 
will be known to the process engineer. The other values determine the the way the PID cascade 
control is handled when the block moves from auto/cas or a process value has a bad status. See also 
ControlCare Function Block manual BA022S/04/en.

Tab. 5-2: Basic parameters for temperature and flow PID blocks

Note! 
• A full description of the PID function block parameters is to be found in Operating Instructions 

BA022S/04/en, ControlCare Function Blocks.

5.4.2 Order of parameters
Some block parameters have a write check based on the value of others parameters. It is therefore 
important to set the parameters in the order shown in Table 5-2 (the same order in which they are 
displayed in the Off Line Characterization dialog. 

After characterization of the block, the parameters will appear in the PROFIBUS tree. If you find a 
parameter in the wrong position, it can be move by dragging and dropping to the correct one. 

Parameter Nmenomic Function Value
Temperature 
CO104-TC100

Value
Flow 
CO104-FC101

MODE BLOCK/TARGET Normal operating mode of block AUTO CAS

SP/VALUE Setpoint for product temperature 40% –

PV_SCALE/EU_100
PV_SCALE/EU_0
PV_SCALE/UNITS_INDEX

Upper range limit for process variable
Lower range limit for process variable
Unit of process variable

100
0
%

18 (URL)
0 (LRL)
t/h (unit)

OUTSCALE/EU_100
OUTSCALE/EU_0
OUTSCALE/UNITS_INDEX

Upper range limit for output variable
Lower range limit for output variable
Unit of output variable

100
0
%

100
0
%

CONTROL_OPTS Sets control options for bad input Bypass Enable Bypass Enable

BYPASS When ON, SP value is transferred to the OUT 
without the calculation of PID terms. 

OFF OFF

SP_RATE_DN
SP_RATE_UP

Rate of change from old to new, higher SP
Rate of change from old to new, lower SP

0
0

0
0

GAIN
RESET
RATE

Tuning constants for the P, I and D terms, of 
the PID block respectively.

1.5
0.1
0.5

2
0.2
0.6

SHED_OPT Behaviour when shedding from remote mode Normal shed, 
normal return 

Normal shed, 
normal return 
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5.4.3 Characterize the function block

1 In the PROFIBUS network workspace, expand the CO104 tree
– Right click on the CO104-TIC100 block and select Off Line Characterization...

2 The Off Line Characterization dialog opens
– Click on All to display all available parameters

3 Set the parameters according to the values in Table 5-2. For each parameter:
– Double-click on the "Value space" next to the parameter
– Enter the value or select a parameter from the dropdown menu
– Press End Edit to register your change

– Press Close when all parameters have been entered

4 Now repeat the procedure for the CO104-FIC101 block.
– At the end the parameters appear in the Profibus tree

5 Click on the Project View workspace and Export Tags..., see Chapter 3.10
– Open Project File, then press Save Entire Configuration, to save the project.
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6 Go On-line

6.1 Connect to the Field Controller

After the Field Controller and other components have been physically installed in the Fieldbus 
network (subnet), connection must be established. 

The Field Controller SFC173 is delivered with a default IP address of 192.168.164.101. For the 
purpose of this tutorial, it is suffience to connect to this address, however in practice it would be 
normal to change this address to one allocated by your IT system administrator.

Warning
• The use of IP addresses is strictly controlled. Usually your system administrator will be authorised 

to allocate unique addresses. Assigning an unauthorised address to a Field Controller may result 
in conflicts within your system and the failure of the associated devices!

6.1.1 Change the IP address of your computer

1 Open the Windows Control Panel by pressing Start => Settings => Control Panel and 
choose the option Network Connections

2 Double-click on Local Area Connection and in the Local Area Connection Status dialog 
select Properties

3 Select Internet Protocol TCP/IP then select Properties again

Note! 
If "TCP/IP protocol" is not included in the Network, it must be installed by using the Windows 
setup before you proceed with Step 4.

4 Note the original property settings (e.g. make a screen shot and store it in a Word document) of 
so that they can be restored at end of the operation. 
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5 Change the IP address and the Subnet Mask of the computer, so that it is in the same subnet as 
the Field Controller. 

– IP Address 192.168.164.XXX and network mask (Subnet Mask) 255.255.255.0.
– Do not use the addresses 192.168.164.100 or 101,as these are reserved as default addresses 

for the Field Controllers SFC162 and SFC173 respectively

– Click on the OK button to confirm your settings

6.1.2 Set the Field Controller IP address

1 Now call FC Tools: Programs =>Endress+Hauser=>ControlCare=>Tools=>FC Tools

2 Choose the Field Control (OPC) Server path, default Local, then press Connect
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3 Select the desired Field Controller module option Module using its serial number as reference. 
The serial number is printed on the inside of the module door.

4 Press the Hold button to interrupt any control activities being executed in the module

– A confirmation window appears, press Yes to continue
– Any application running on the Field Controller will be stopped at this point

5 Check that the HOLD LED on the Controller module is lit, then press Connect to continue 
with the procedure. 

– If the HOLD LED does not light, there is a communication problem: 
Type PING 192.168.164.101 in the DOS command window and check whether the Field 
Controller is found. If there is a reply, replace the Ethernet cable by a cross-cable and try 
Step 4 again.
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6 Reselect the desired Controller module, then click on the IP Properties button. 
Now check the option Specify an IP address, then enter the IP Address and the Subnet Mask

– Answer Yes to the confirmation box
– Now enter the Field Controller address given to you by your system administrator

(in our example we have kept the default address 196.168.164.101)
– Make a note of the IP addesses and the corresponding Controller serial number. This will 

help in the identification and diagnosis of possible faults.

7 Click on OK to finish the operation

8 Now change the address of your computer as described in Chapter 6.1.1 to the new domain, 
so that it can continue to communicate with the Field Controller at its new address:
(Note: if the address domain has not changed, the computer address does not need resetting)

– Start =>Settings =>Control Panel =>Network Connections
– Local Area Connection => Properties
– Protocol (TCP/IP)=>Properties
– Enter an unused IP address and the subnet work address of the new domain
– Press OK to finish the process

9 Now return to FC Tools and click on Refresh

10 When the Refresh is complete, press Run to start the execution of the Field Controller 
firmware
– Confirm the action with Yes

11 Check that the HOLD LED on the Field Controller has extinguished, then press Close.

12 The Computer is now connected to the Field Controller
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6.2 Generate the live lists

6.2.1 HSE live list
Once the Computer and Field Controller are able to communicate with each other, the connection 
to the network can be checked by creating a live list. 

1 Press the On-Line button  in the menu toolbar
– The project goes on on-line

– Red crosses appear against the Field Controller and PROFIBUS network in the 
Project workspace

2 In the Project workspace, right click on HSE Network and select Live List

– A live list is generated of the devices on the HSE network

Note! 
• It may take sometime to generate the live list. 

– The devices found first go grey. 
– They are then assigned a HSE address after which the live list is refreshed with the new data.
– Address shows the last three digits of the IP address in hexadecimal format
– The devices then appear in full color. 
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6.2.2 Assign the Field Controller tag

1 In the project workspace, right click on the Field Controller (CO104) and select Attributes...

2 The Attributes dialog opens
– Open the drop-down menu of the Device ID and select the Field Controller associated

with the displayed TAG (in our case CO104) - the serial number is on the front panel
– Do this even though the correct ID is already displayed - the program expects it!

– Confirm your choice with OK
– After a period of time, the red crosses disappear from the devices in the Profibus network
– If several SFC173 were in use, Steps 1 and 2 would be repeated for all.

3 Open Project File, then press Save, to save the project

6.2.3 PROFIBUS live list

1 In the PROFIBUS network workspace, right-click on Profibus 1and select the option Live List

2 The PROFIBUS live list is created

– Check that all the devices in your project appear and that the addresses (shown in 
hexadecimal format) correspond to those used in your project. 
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6.3 Download the project

Note! 
• The procedure below describes the initial download for the entire HSE network. 
• Partial downloads can be made later from lower leaves, when changes are confined to this level
• Incremental downloads can be made to a running project by checking the boxes Incremental 

Download and Compare Parameters: Unaffected Local I/Os will hold their last values.

When the devices in the PROFIBUS live list correspond to those configured in the project, the 
download can begin.

1 In the Project workspace right-click on HSE Network and select Download

2 The Download dialog appears

– Press Start to start the download

3 The download will be interrupted if the project has not been configured properly, e.g.

– The Project tags are not up-to-date => Export Tags, Chapter 3.10
– The Controller Tag has not been assigned correctly => Assign Field Controller tags, 

Chapter 6.2.2
– The "DPV1 activated" box in the PROFIBUS Configurator has been checked for a device,

Chapter 3.8.1 etc.

4 When the download is successfully completed, the dialog is closed, and you are ready to test 
the control strategy
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6.4 Check the control stategy

1 Click in the Control Strategy workspace (Temperature control) and press the button  in the 
menu toolbar – the control strategy also goes "on-line"

– Values appear in green when the status is good
– Values appear in red if the status is bad - at this stage this is an indication of a communiction, 

PROFIBUS configuration, strategy configuration or device parametrization error

2 Check that the loop is working by changing the Setpoint parameter in the temperature PID 
CO104-TT100

– Double-click on the Temperature PID block CO104-TT100 (Master/Primary PID), 
the On-line Characterization dialog appears

– Press the All icon to reveal all parameters
– Open the SP leaf and double-click in the space next to Value
– Enter a new SP value – for T > SP, set SP < T or vice versa
– Click End Edit to set the parameter
– Press Close to store the value (if you are prompted - answer with Yes)

3 Now check that the control loop has responded properly
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6.5 Modify the project

Warning
• Do not change the PROFIBUS configuration parameters in the PROFIBUS Function Blocks. These 

may be changed with the PROFIBUS Configurator only. Application Designer then extracts the 
information it requires from the device GSD files. 

• If you change the PROFIBUS configuration in PROFIBUS Configurator, the project must be 
downloaded again

6.5.1 On-line characterization
Once the project is on-line you may want to change parameters to e.g. tune the control-loop or 
eliminate configuration errors. With the exception of the SP parameter, the function block must be 
put out of service before the parameter is changed:

1 In the Control strategy workspace double-click on the function block you want to modify, or in 
the PROFIBUS network or Control module workspace, right-click on the function block and 
select On-line Characterization

2 The function block On-line Characterization dialog appears:

– Open the Mode leaf and double-click in the space next to Target
– Set the Target to OOS (Out of Service)
– Click End Edit to set the parameter

3 Change the parameters you wish to modify

– If appropriate, open the parameter leaf and double-click in the space next to the parameter 
you require

– Enter the new parameter or select it from the drop-down menu
– Click End Edit to set the parameter
– Repeat the procedure for all the parameters you wish to modify

4 Put the function block back into standard operating mode

– Open the Mode leaf and double-click in the space next to Target
– Set the Target back to the original value (Auto (Automatic) or Cas (Cascade))
– Click End Edit to set the parameter
– Check that the Mode really changes to the Target Mode (failure to do so indicates a 

configuration error)
– Press Close to store the values (if you are prompted - answer with Yes)

5 Click on the Project View workspace and Export Tags..., see Chapter 3.10
– Open Project File, then press Save Entire Project to save the project

6 Put the Control stategy back "on-line" to check the results of your modification, Chapter 6.4.
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6.5.2 Off-line characterization
You may prefer to change parameters off-line, e.g. when modifying the control strategy or adding 
new functions to the project. 

1 If you are on-line, press the Off-line button  in the menu toolbar
alternatively, in the PROFIBUS network or Control module workspace, right-click on the 
function block and select Off-line Characterization
– The function block Off-line Characterization dialog appears

2 Change the parameters you wish to modify

– If appropriate, open the parameter leaf and double-click in the space next to the parameter 
you require

– Enter the new parameter or select it from the drop-down menu
– Click End Edit to set the parameter
– Repeat the procedure for all the parameters you wish to modify
– Press Close to store the values

3 Click on the Project View workspace and Export Tags..., see Chapter 3.10
– Open Project File, then press Save Entire Project to save the project

4 Press the On-line button  in the menu toolbar to go on-line again

5 Download the modified project
– In the Project workspace right-click on HSE Network and select Download
– Follow the procedure in Chapter 6.3

6 Put the Control stategy back "on-line" to check the results of your modification, Chapter 6.4.
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6.6 Pack and Go

In order to install the project at the customer’s site, the project can be packed and unpacked. It is 
important to remember, especially if you have not been using the actual project devices to test your 
project, that the instruments on site may be have newer (or even older) DD/CFF/GSD files than 
the ones you use. The latest DD/CFF/GSD files must then be uploaded to the project and 
corresponding corrections must be made to configuration, before it is downloaded to the SFC173 
Field Controller.

6.6.1 Pack the project

1 Select Project File => Pack Project...

2 Answer "OK" to the query about missing DD/CFF files

3 Browse to the place where you want the packed files folder, 
e.g. Endress+Hauser => ControlCare

4 Press OK to pack the project

6.6.2 Unpack the project

1 Select Project File => Unpack Project...

2 Browse to the packed files folder, e.g. Endress+Hauser => ControlCare

3 Browse to the desination folder

4 Press GO to start unpacking
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6.7 Export the configuration

For documentation purposes, the project configuration can be exported to an existing ODBC file 
data source, e.g. Oracle, a machine database, e.g. Excel to provide a record of the current status of 
the project or to an XML sheet for viewing with a browser.

6.7.1 File data source folder
The file data source must have been created before the export.

1 In the Project window, right-click on the Project icon and select Export Configuration:

2 The Select Data Source dialog box appears

3 In the File Data Source folder, select the source that describes the driver that you wish to 
connect to. You can use any file data source that refers to an ODBC driver which is installed on 
your machine.
– Use the New... button and Look In dropdown menu to browse or 
– Click the data source icon to select the driver:

– Press OK to make the connection
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6.7.2 Machine data source folder
The Machine Data Source is specific to the machine, and cannot be shared. "User" data sources 
are specific to a user on the machine; "System" data sources can be used by all users on the machine, 
or by a system-wide service. The Machine Data Source must have been created before export.

Procedure 1 In the Project window, right-click on the Project icon and select Export Configuration:

2 The Select Data Source dialog box appears
– Click on the Machine Data Source tab to open the folder
– Double-click the data source name to select the machine, e.g. Excel:

3 The Select Workbook dialog box will appear:
– Select the folder where the data file is and double-click the workbook icon.

– Your project configuration will be exported to the workbook file.
– A message box appears on completion - press OK

4 Open the Excel file to check the result:
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6.7.3 XML file

1 Click in the Project workspace and select Project File =>Export => Configuration as XML
– The Export Configuration as XML dialog appears

2 Enter a File Name and Save In location, then press Save
– The project is saved as an XML file at the selected location
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6.8 Close Application Designer

When you have completed your session, close Application Designer

1 If you are on-line, press the Off-line button  in the menu toolbar

2 If you have made any modifications while you were on line, you will be prompted to store 
them
– If appropriate answer with Yes

3 Close the project by clicking on Project File => Close

4 Exit Application Designer by clicking on Project File => Exit

5 The Field Controller continues to operate with the project configured according to the last 
download/on-line correction

– If you switch off the Controller, the project remains stored in its memory
– It is initialized and re-executed as soon as the Controller is switched on again

6.8.1 Reconnecting
Provided your computer is operating in the same IP address domain as the Field Controller, you can 
reconnect at any time.

1 Start up Application Designer and select the Project you require

2 Press the On-line button  in the menu toolbar

3 Expand the various workplaces as required

4 Click in the Control Strategy workspace and press the button  in the menu toolbar – the 
control strategy goes "on-line" with the last configuration that was downloaded.
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7 Parametering Devices with FieldCare

The SFC173 CommDTM allows the SFC173 Field Controller to use PROFIBUS acyclic services to 
access the device parameters of the connected PROFIBUS devices. By using FieldCare as FDT frame 
application, it is then possible to configure the devices centrally by using the device DTMs. 

7.1 Installing the SFC173 CommDTM

7.1.1 Setup
The SFC173 CommDTM is supplied with the FieldCare CD. 

•  It is installed as a separate component from the setup dialog. 
•  Follow the setup instructions to install it on your computer. 

7.1.2 Adding to DTM library

1 Start FieldCare and Login with Administrator rights

2 Open a new project by double-clicking on the new project icon, enter a Name and press OK

– FieldCare opens up with a Network View and Plant View

3 Right-click on the menu DTM Catalog select the option Update...

– The Catalog dialog opens, press the Update button
– The computer searches for new DTMs, and finds SFC173 CommDTM
– The new DTMs are listed in the left-hand pane
– Click on the SFC173 CommDTM (and any others you require), then press Move>>
– Press OK to confirm the changes and exit the catalog

4 The SFC173 CommDTM is now installed and can be used in FieldCare projects involving the 
SFC173 Field Controller.
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7.2 Creating a SFC173 Project

1 In Network View, right-click on the Host Icon and select Add Device

– A dialog offering CommDTMs opens, select SFC173 CommDTM and press OK

– The SFC173 CommDTM is added to the Host
– You can change the name by overwriting and pressing Enter on your keyboard

2 Right-click on the SFC173 CommDTM leaf and select Configuration

– The SFC CommDTM opens

3 Enter the last three digits of the Field Controller IP address in the Device Address box
– Press Enter to register the change
– The language of the DTM can be changed by clicking on Language
– Close the DTM by clicking on the X in the top corner of the DTM window

4 Now right-click on the SFC173 CommDTM leaf and select Generate Device List

– The network is scanned for all connected PROFIBUS devices
– You are asked to confirm the assignment of the Device DTMs to the devices found on the bus

(Since the DTM catalog is updated regularly, in most cases the correct DTM will be found)
– On confirmation, the devices appear below the SFC173 with the PROFIBUS addresses 

assigned to them by Application Designer

5 Select each device in turn, go Online and parametrize each device according to the operating 
instructions of the device manufacturer. Close the DeviceDTM after use.
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7.3 Additional Functions

The SFC173 CommDTM offers a number of functions that can be accessed when it is put online.

1 Right-click on the SFC173 CommDTM leaf and select Go Online

– The SFC CommDTM opens
– You will notice that the Device, Device Tag and Manufacturer boxes are now filled

2 Right-click on the SFC173 CommDTM leaf and select Additional Functions 

– Select one of the options About, HSE Live List, PROFIBUS Live List or 
Master Configuration

7.3.1 About
About contains information about the SFC173 CommDTM

7.3.2 HSE Live List
HSE Live List shows the HSE devices connected to the HSE network

– Status shows if the Gateway is already online for other CommDTM. 
(Gateway can be online for only one CommDTM at any given time)

– Address contains the HSE node address of the Gateway (last three digits).
– Device indicates the device type
– Vendor shows the vendor description
– Tag shows the tag name of the device
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7.3.3 PROFIBUS Live List
The PROFIBUS live list shows the devices currently connected to the PROFIBUS DP network.

– Status shows if the PROFIBUS device is already online
– Address contains the PROFiBUS address of the Gateway.
– Device indicates the device type (GSD)
– Vendor shows the vendor description
– Tag shows the tag name of the device

7.3.4 Master Configuration
Master Configuration shows the settings of the PROFIBUS DP parameters. It is read-only: the 
parameters themselves are set in PROFIBUS Configurator, Chapter 3.6
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8 Trouble-Shooting

8.1 Factory initialisation and reset

Warning!
• Do not use the pushbuttons located in the Field Controller unless you are certain that you want 

to reset the system.

Two pushbuttons located on the SFC173 module, see Fig 8.1, allow the system to be initialised and 
reset. The function and effect of the buttons is described in the table below.

• To "click " the pushbuttons use a pointed instrument (e.g. a ballpoint pen). 

Other functions of the two buttons are to be found Chapter 7 of the Operating Instructions 
BA035S/04/en, Field Controller: Commissioning and Configuration..

Function Effect Procedure

Reset Resets system: the last 
configured IP Address 
is used

• Click the right pushbutton - the system resets (takes several seconds)
• If no IP Address is found, a new one is assigned automatically
• Verify that the RUN and ETH LNK LEDs are lit.

Factory Init Deletes application, 
the last configured IP 
Address is retained

• Keeping the left pushbutton pressed, click the right pushbutton
• Check that the FORCE LED flashes once a second. 
• Release the left push button. The system resets, see above.
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8.2 Field Controller 

Problem Remedy

FC Tools does not show all the Field Controllers that are in 
the sub-network

There is probably an IP address conflict in this sub-Network.
• Disconnect all the Field Controllers from the sub-

Network and execute the procedure "Connecting the 
Field Controller to its Sub-Network" for each module, 
assuring that the address to be used is not associated with 
other equipment of the network.

FC Tools does not find the Field Controller • Make sure that the initial connection procedure was 
followed and the Field Controller is operating in the same 
subnet and not with the default address 
192.168.164.100/101

• Check that the Ethernet cable, see above
• Check if the network adapter is on and OK: Execure a 

PING command to its own IP, via DOS PROMPT.
• Check if the Ethernet connection is OK: Execute a PING 

command to the Field Controller.

FC Tools does not put the Field Controller in HOLD Use the Mode HOLD procedure of Factory Init/Reset. 
• With the Field Controller in HOLD mode, execute the 

firmware update procedure, Section 7.3, using the steps 
of item 2.  

• If the problem persists, check the related TCP/IP 
connection (check the cables and ETH LNK LED)

Firmware begins to execute but after a certain time it stops It might be a configuration problem. 
• Use the Factory Init procedure and configure the Field 

Controller again. 
• If the problem persists, download the firmware again as 

described in Chapter 7.3

HOLD LED remains lit If the HOLD LED remains lit after the Field Controller has 
been turned on, the firmware may be invalid. 
• Update the firmware as described in Chapter 7.3

ETH LNK LED does not light Check if the cable is connected correctly, or that the cable is 
not damaged. Check the specification of the cables:
• SFC 954 - Cable Standard.  To be used in a network 

between the Field Controller and a Switch/HUB. 
• SFC 955 - Crossed Cable (Cross).  To be used point to 

point between a PC and the Field Controller

ERR LED is lit PROFIBUS DP error
• PROFIBUS DP connection has been lost, check 

connections
• One or more slaves have not been correctly configured 

for cyclic data exchange, see BA036S/04/en, 
Application Designer, PROFIBUS tutorial

FRC LED is flashing (Force) Field Controller is in reset mode
• Complete the RESET procedure

STDBY LED is lit Field Controller is in stand-by mode (redundant application)
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8.3 PROFIBUS Configurator

Problem Remedy

Error message on trying to leave the configuration dialog Configuration not correct
• Device name has spaces instead of underscores

How are the cyclic I/O data configured? • For Endress+Huaser devices each parameter has a fixed 
position in the confuguration list, see the manuals. If you 
want to see Parameters 1 and 5 only, for example, free 
spaces must be appended at slots 2, 3 and 4.

• For other devices, see operators instructions

What baudrates are supported? The SFC173 Field Controller supports all baudrates

What baudrate should I use? Only baudrates supported by all devices can be used:
• For a P+F SK1 coupler = 93.75kbit/s
• For a Siemens coupler = 45.45 kbit/s
• For a P+F or Siemens link, check what baudrates are 

supported by all DP devices

Where do I set the device baudrates? Only PROFIBUS DP devices must be set
• Most PROFIBUS DP slaves sense the baudrate and do not 

need to be set up
• For others, check the manufacturer’s instructions

What bus parameters should I use? Use the parameters recommended by the coupler/link 
manufacturer or those in this manual
• For the P+F SK2, the parameters are automatically set 

according to the rate selected in the Configurator
• For the P+F SK1 use the ones in this tutorial

Can I go on-line in PROFIBUS Configurator? Yes. 
• Select the appropriate menu, enter the IP address of the 

Field Controller and generate a live list

Can I change a bus address in the PROFIBUS configurator? Yes. 
• You can go online and change a bus address by selecting 

the device followed by the the appropriate menu and 
typing in the old, then the new address

• The device must support software address setting
• Software address setting must be enabled
• The address must be unique to the bus

A device does not appear in the live list Communication error
• Another device has the same address
• The device is not powered up
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8.4 Application Designer

Problem Remedy

Field Controller does not appear in HSE live list No connection to Field Controller
• Field Controller is on HOLD, set it to RUN mode
• IP address is not configured correctly, use PING to check, 

see above

Red cross appears on HSE Network No connection to Field Controller
• Field Controller is on HOLD, set it to RUN mode
• IP address is not configured correctly, use PING to check, 

see above

A device does not appear in the live list Communication error
• Another device has the same address
• The device is not powered up
• The project has been updated but no download has been 

made yet

Configuration will not download, why? You have either a communication problem or the 
configuration is not complete
• Check that you are on-line - press the On-line button
• Check that your computer is in the same address domain
• Check that you have assigned the Field Controller tag
• Check that you have exported all tags OPC server
• Check that the parameters are in the recommended order
• Check that the OPC server is running (look for icon in 

bottom line)
• Check that DPV1 has not been activated in the device, 

see Chapter 3.7

A parameter appears red in my on-line control strategy, 
why?

The parameter has a bad status
• Check that the Block Mode is Auto (or Cas)
• Check that the block has been correctly configured
• Check that the device is still live (live list)
• Check that the device address is the same as that you 

have in your configuration (live list)
• Check that the parameter has been correctly configured 

in the PROFIBUS Configurator
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For your notes



ControlCare Application Designer: PROFIBUS Tutorial 8 Trouble-Shooting

Endress+Hauser 59

For your notes
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