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Revision History

Product Version

The table below indicates the product versions of the main components of ControlCare Field-based 
Control System. More details on the individual components can be seen in About ControlCare 

Registered Trademarks

PROFIBUS® 

Registered trademark of the PROFIBUS User Organisation, Karlsruhe Germany. 

FOUNDATIONTM Fieldbus
Trademark of the Fieldbus Foundation, Austin, TX 78759, USA

Microsoft® , Windows® , Windows 2000® ,Windows XP®, Windows 2003 Server® and the 
Microsoft logo are registered trademarks of the Microsoft Corporation.

Acrobat Reader® is a registered trade mark of the Adobe Systems Incorporated.

All other brand and product names are trademarks or registered trademarks of the companies and 
organisations in question

Product 
version

Manual Changes Remarks

2.01.xx BA038S/04/en/08.05 Original manual

2.02.xx BA038S/04/en/07.06 Program (Open PCS) • FBD language now available
• CC libraries always active (Chapter 5.2.2)
• Optimize for speed now default (Chapter 5.2.9)

Program 
(Application Designer)

• FB schedule configured by drag&drop (Chap. 4.5)
• Incremental download (Chap. 6.3)

Editorial • Update Version and documentation tables

Product Version Component Version

V2.02.xx ControlCare Application Designer Suite Version 2.02.xx

ControlCare PROFIBUS Configurator Version 2.9xx

ControlCare Field Control (OPC) Server Version 3.11.xx

ControlCare Device Libraries* Version 2.02.xx

ControlCare Manuals Version 2.02.xx

*Version No. may increase independent of Product Version as 
the latest devices are added to the library
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1 Safety

1.1 Designated use

ControlCare is a field-based control system comprising hardware and software components. It can 
be used to visualize, monitor and control production processes. The approved usage of the 
individual units used in the system can be taken from the corresponding parts of the operating 
instructions.

The software described in this particular manual allows the programming of the hybrid function 
block in IEC 61131-3 language as well as the engineering, configuring and commissioning of a 
ControlCare SFC162 FOUNDATION Fieldbus or SFC173 PROFIBUS Field Controller. Two 
languages have been taken as examples, and the building of appropriate control strategies using 
these and the function blocks contained in the Field Controller and connected devices are described.

1.2 Installation, commissioning and operation 

ControlCare Field Controllers have been designed to operate safely in accordance with current 
technical safety and EU directives. Essential to their use is the ControlCare Application Designer 
software suite, which allows control strategies to be created for FOUNDATION Fieldbus and 
PROFIBUS I/O applications. Field devices, links, junction boxes, cables and other hardware 
comprising the Fieldbus sytem must also be designed to operate safely in accordance with current 
technical safety and EU directives. 

If devices are installed incorrectly or used for applications for which they are not intended, or if the 
controller is not configured correctly, it is possible that dangers may arise. For this reason, the system 
must be installed, connected, configured, operated and maintained according to the instructions in 
this and the associated manuals: personnel must be authorised and suitably qualified.

1.3 Operational safety

Location Field Controllers must be mounted in a permanent and weather-protected location in a safe area. 
The environment shall be a metal cabinet or an installation frame with a well grounded mounting 
plane. The environment shall be protected. 

Hazardous areas The controller must be connected to networks operating in explosion hazardous areas via barriers 
or other safety components. When installing components in explosion hazardous areas:

•  Ensure that all installion and maintenance personnel are suitably qualified
•  Check that all equipment has the appropriate safety certificates
•  Observe the specifications in the device certificates as well as national and local regulations.

This topic is discussed in BA013S (FF Guidelines) and BA034S (PROFIBUS Guidelines).

EMC All modules are suitable for industrial use and conform with the following standard, see Appendix:

•  EN 61326: 1997/A1: 1998
Interference emmision: Class A apparatus
Interference immunity: as per Annex A, industrial environment

Depending upon the environment in which the bus is operating, particular attention should be paid 
to the grounding of the bus cables. This topic is discussed in BA013S (FF Guidelines) and BA034S 
(PROFIBUS Guidelines).
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IP Address A ControlCare Field Controller is normally configured from a workstation connected into the 
control system backbone. You will require a unique IP address to set it up.

Warning
The use of IP addresses is strictly controlled. Usually your system administrator will be authorised 
to allocate unique addresses. Assigning an unauthorised address to a Field Controller may result in 
conflicts within your system and the failure of the associated devices!

Since the system can be accessed and manipulated through the various ControlCare tools, it is 
advisable to control access both to the workstation and the folders in which the configuration is 
stored. Always make a back-up of the project.

Technical improvement Endress+Hauser reserves the right to make technical improvements to its software and equipment 
at any time and without prior notification. Where such improvements have no effect on the 
operation of the equipment, they are not documentated. If the improvements effect operation, a 
new version of the operating instructions is normally issued. 

1.4 Conventions and icons

In order to highlight safety relevant or alternative operating procedures in the manual, the following 
conventions have been used, each indicated by a corresponding icon in the margin. 

Safety conventions Icon Meaning

A note highlights actions or procedures which, if not performed correctly, may indirectly affect operation 
or may lead to an instrument response which is not planned

Caution!
Caution highlights actions or procedures which, if not performed correctly, may lead to personal injury or 
incorrect functioning of the instrument

Warning!
A warning highlights actions or procedures which, if not performed correctly, will lead to personal injury, 
a safety hazard or destruction of the instrument
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1.5 ControlCare documents

Table 1.1 indicates the documents, planned and realized, containing safety relevant information, 
installation, commissioning and operating instructions for the equipment and software associated 
with ControlCare.

All documentation available at the time of release is included on the ControlCare CD-ROM and is 
installed in Start=>Programs=>Endress+Hauser=ControlCare=Manuals during set-up.

Tab. 1-1: ControlCare Documentation

Component Description Document type Designation Order No.

System ControlCare System Overview Operating manual BA016S/04/en 56004883

ControlCare System Design Operating manual BA039S/04/en Planned

ControlCare System Specifications Operating manual BA040S/04/en 56004888

Software Application Designer Overview Operating manual BA017S/04/en 70104301

Application Designer Drawing Tool Operating manual BA032S/04/en Planned

Application Designer: FF Tutorial Operating manual BA019S/04/en 70101151

Application Designer: PROFIBUS Tutorial Operating manual BA036S/04/en 70101152

Application Designer: MODBUS Tutorial Operating manual BA037S/04/en 70101153

Application Designer: IEC 61131 Tutorial Operating manual BA038S/04/en 70101386

Field Control (OPC) Servers Operating manual BA018S/04/en 71031428

Field Controller Hardware Installation Guide Operating manual BA021S/04/en 56004885

Commissioning and Configuration Operating manual BA035S/04/en 56004887

Function Blocks Function Block Manual Operating manual BA022S/04/en 56004886

Set-Up Getting Started Operating manual BA020S/04/en 56004884

General FOUNDATION Fieldbus Guidelines Operating manual BA013S/04/en 70100707

PROFIBUS Guidelines Operating manual BA034S/04/en 56004242
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2 Task Description

This tutorial describes the steps necessary for setting up the project described below. It does not aim 
to give an exhaustive account of Application Designer functions, but rather shows you one of a 
number of methods to reach your goal. The tags and names used in the tutorial are imaginary and 
will be different in a proper application. A full description of Application Designer functions is to be 
found in Application Designer Overview BA017S/04/en and Drawing Tool BA032S/04/en (in 
preparation). Function block descriptions are to be found in BA022/04/en, Function Block manual.

2.1 Application

For this tutorial, the case of pump control for a tank level will be used, see Fig. 2-1. 

Fig. 2-1:  Overview of pump control for tank filling

A centrifugal pump is used to fill the tank with liquid. The level of liquid in a tank is monitored by 
a level transmitter which outputs a corresponding 4 mA to 20 mA signal. When the tank is full 
(=95%) the pump must be switched off. In order to provide overspill protection for the tank, should 
the level transmitter fail, a level limit switch with relay output is built in at an appropriate height. 
The pump itself provides Overheat and Running signals, and a switch is provided for pump reset. 

The signals are acquired as follows:
•  4 mA to 20 mA level to AI-0 input of a SFC444 Analog Input module
•  Level Overflow, Pump Reset, Pump Overheat and Pump Running signals to DI-0 to DI-3 inputs 

of a SFC432 Mixed Discrete I/O module: 0 V = False, 24 V = True
•  Pump output current from DO-0 output of the SFC432 Mixed Discrete I/O module:

NO relay, False = Pump ON, True = Pump OFF, Fail Safe = Pump OFF

For the tutorial the control is done in a PROFIBUS SFC173 Field Controller, but since there is no 
PROFIBUS DP network connected to it, the procedure described also applies to the FOUNDATION 
SFC162 Fieldbus Controller.

SFC444

SFC432

AI-0

DI-0
DI-1
DI-2
DI-3
DO-0

Level 4...20 mA

Tank Overflow

Pump Reset

Pump Overheat

Pump Running

Pump Power

0%

95%
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Fig. 2-2 shows a schematic diagram of the pump control application. The analog level input is fed 
to an Analog Alarm block that generates a true signal when the "full" level is reached. This is a 
standard function block, and eliminates the need to provide a similar signal conditioning program 
within the hybrid block. All discrete signals are connected directly to the hybrid function block 
which generates an output signal according to the status of the application. 

Fig. 2-2:  Schematic diagram of pump control application

2.1.1 Control strategy
Fig. 2-3 shows the corresponding control strategy. The level signal is fed to the Analog Input block, 
and after scaling to 0% to 100% is passed on to the Analog Alarm block. This generates a true or 
false signal according to the level in the tank. The discrete input signals are collected in a Multiple 
Discrete Input block and the pump output control signal is fed to a Multiple Discrete Output block. 
The control algorithm is programmed in the hybrid block. 

It should be noted that the control strategy can also be created with 4x Discrete Input blocks and 
and 1x Discrete Output block.

Fig. 2-3  Control strategy for pump control application
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2.1.2 Control algorithm
The truth table for the hybrid function block has is as follows:

The tank overflow and pump overheat conditions must lead to immediate switch off of the pump. 
The pump running signal is automatically generated by the pump itself, and is provided, e.g. for a 
visualization of the application. 

2.1.3 Network
The project uses a PROFIBUS SFC173 Field Controller with local I/O. The procedure for a 
FOUNDATION Fieldbus SFC162 is exactly the same. The network is assumed to be constructed as 
shown in Fig. 2-4. 

•  The level signal is acquired via a SFC444 Analog Input module
•  The level overspill and pump signals are acquired by a SFC432 Discrete Input/Output module
•  The pump is connected to a SFC432 Discrete Input/Output module.

Fig. 2-4  Network for application example

Function IN_D0 IN_D1 IN_D2 IN_D3 IN_D4 OUT_D0

Tank "Empty" – – – – False False

Tank Full – – – – True True

Tank Overflow – True – – – True

Pump Reset True – – – – True

Pump Overheat – – True – – True

Pump Running – – – True – False

High Speed Ethernet

SFC173
PROFIBUS 
Field Controller
with local I/O

ControlCare
Application
Designer

FC_01

Level transmitter

Level limit switch

Pump
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2.2 Preliminaries

2.2.1 Installation and commissioning
Before you can start the IEC 61131-3 tutorial, Application Designer and OpenPCS must be installed 
on your computer, the SFC173 PROFIBUS Controller installed and commissioned and a connection 
made to your computer. Instructions on how to do this are to be found in:

•  Operating Instructions BA020S/04/en, Getting Started
•  Operating Instructions BA021S/04/en, Field Controller: Hardware Installion
•  Operating Instructions BA035S/04/en, Field Controller: Commissioning and Configuration

Not all project steps are described in detail, so it is recommended that you also have the PROFIBUS 
or FOUNDATION Fieldbus tutorials at hand:

•  Operating Instructions BA019S/04/en, Application Designer: FOUNDATION Fieldbus tutorial
•  Operating Instructions BA036S/04/en, Application Designer: PROFIBUS tutorial

2.2.2 Rack assembly
The SFC173 Field Controller, SFC444 Analog Input module and SFC432 Discrete I/O module have 
combined power demand of 67 mA @ 24 VDC and 940 mA@ 5 VDC. Even allowing for a tolerance 
of 20%, this is easily covered by a SFC050 or SFC056 rack power module (300 mA @ 24 VDC and 
3000 mA @ 5 VDC). See Chapter 10 of BA040S/04/en, ControlCare, System Specifications.

The Field Controller and local I/O are mounted on a SFC901A rack assembly with address = 1 
(I/O cannot be mounted on a rack with the address "0".) The parameters for commissioning the 
Field Controller are shown in Table 2-1.

Tab. 2-1: Parameter settings for rack in hardware configuration and function blocks

Note!
• The channels used to connect to the modules to the function blocks are given by the 

Rack (R), Slot (S), Group (G) and I/O point (P) indices = RRGSP, whereby counting starts at "0". 
• Since Multiple Discrete Input and Output blocks are being used for the discrete signals, the I/O 

point index is "9", see BA035S/04/en, Field Controller, Commissioning and Configuration.

Rack 1 Slot 0 Slot 1 Slot 2 Slot 3

Module SFC050 SFC173 SFC444 SFC432

IO_TYPE_Rx No I/O No I/O 8 Analog Input 8 DiscIn 4 DiscOut

Channel Group A – – 1200 1309

Channel Group B – – – 1319
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3 Create a PROFIBUS Network

3.1 Create a new project

1 Start ControlCare Application Designer by clicking on the icon on your destop or via Start => 
Programs => Endress+Hauser => ControlCare => ControlCare Application Designer

2 The project starts from a blank application screen
– With the right mouse key select Project File=>New

3 The Document Type box appears: Click the option Project

4 The New Project dialog box opens:

1. Choose the folder where the project will be saved.
2. Type the name of the project in the File Name box.
3. Click Save. 
If the new project is not to be created, click Cancel.

5 ON saving, ControlCare Application Designer 
– automatically creates a folder with the entered file name within the selected folder
– automatically creates a project, adding the HSE Network network and the HSE Host
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3.2 Determine the naming preferences

Before you start, you can set preferences for the way your project is created. Of particular interest 
at this stage is the labelling of the function blocks.

1 Press Project File => Preferences
– The Preferences Dialog appears

Tag Policy Tag Policy determines how the blocks are labelled by default if no tag names are entered

1 Select the folder Block and the subfolder Tag Policy, then check the following buttons
– Device
– Update Block Tag

2 Press OK to confirm your selection
– Application Designer will now automatically rename any blocks created in the control

strategy window as they are assigned to the devices by adding the device tag as prefix.

Tag Composition Tag Composition determines how the block identifiers are added to the block tag if no block name 
is entered.

1 Select the subfolder Tab Composition:
– Default setting is "_". 
– This is mandatory if hybrid function blocks are to be used
– Check Prefix

2 Press OK to confirm your selection
– Application Designer will now automatically compose the blocks according to your

selection, e.g. TagName_Block_n.

Export Tag Export Tag causes tags to be automatically exported every time the project goes online

1 Select the subfolder Export Tag
– Check the Automatic button
– Press OK to confirm your selection

2 Right-click on the Project File menu and select Save Entire Configuration to save your 
preferences.
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3.3 Add a gateway (SFC173)

Note!
• If you are using a FOUNDATION Fieldbus SFC162 Field Controller, the procedure is exactly the 

same, except that you must add a "bridge" not a "gateway".

1 In the project workspace, click on "+" to expand the tree:

2 Now right-click on the HSE Network leaf and select New=>Gateway

3 The New Gateway dialog box appears:
Select the SFC173 Field Controller and type in a device TAG = FC_01_DP

If you do not type in a tag, the default will be "Gateway n", where n is a consecutive number. 
At this point, the Fieldbus Network does not have a direct correspondence to any of the 
existing controllers.

4 Press OK to create the Gateway.

5 Right-click on the Project File menu and select Save Entire Configuration to save the 
project.
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3.4 Set up the Hardware Configuration block

1 Double click on the HSE Network leaf, the HSE Network window opens:
– Expand the FC_01_PB and FB_VFD leaves

2 Double-click on the FC_01_PB_HC_1 leaf to open the Off Line Characterization dialog
To change parameters: 

– Expand the parameter leaf
– Double click on value space
– Enter the parameter or select it from the drop-down menu
– Confirm with End Edit

3 Expand the MODE_BLK parameter left and check that Target is set to Auto

4 Expand the IO_TYPE_R1 parameter leaf and set the following parameters, see Table 2-1, 
Chapter 2.2.2
– Slot_0: No I/O
– Slot_1: No I/O
– Slot_2: 8 Analog Input
– Slot_3: 8 DiscIn 4 DiscOut

5 Click Close, then save the configuration 
– Right-click on the Project File menu and select Save Entire Configuration to save the

project, which now looks like this.
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4 Create a Control Strategy

Having created a physical view of the process instrumentation, in this case the Field Controller, the 
next step is to create control strategy. This is done in the logical view of the plant. This represents 
the plant as Areas/Process Cells in accordance with ISA S88/IEC 61518. Only one Area is allowed 
in the project, but this may have any number of Process Cells.

4.1 Add a Process Cell

1 Click on the "Area 1" leaf in the project and select Attributes...

2 The Attributes dialog box appears

– Enter a name for the area, e.g. East Side
– Click OK to store your changes

3 Click on the Area leaf again and select New Process Cell...

4 The Process Cell dialog box appears

– Enter a name for the process cell, e.g. Utilities
– Click OK to store your changes

5 Your project should now look something like this:

6 Open Project File, then press Save Entire Configuration, to save the project.
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4.2 Add a Control Module

1 Double-click on the Process Cells leaf - a new window with the name of the leaf opens

2 Right-click on the top leaf and select New Control Module

3 The Control Module dialog box appears

– Enter a name for the control module, e.g. Pump Control
– Click OK to store your changes

4 The project now looks something like this:

5 For a real project, Step 2 and 3 would be repeated until all the required control modules for a 
particular process cell have been added. This allows each control loop or control loop group to 
be set up and viewed in its own control strategy window.

6 Open Project File, then press Save Entire Configuration, to save the project.
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4.3 Add Function Blocks to the Control Strategy

Note! 
• The function blocks used in the tutorial are selected from the device manufacturer’s device list. 

It is also possible to select standard function blocks from the "Fieldbus Foundation" list. This 
ensures that the control strategy can be executed in any device that supports a particular standard 
block, irrespective of vendor.

• Endress+Hauser devices support standard function blocks and offer them in the manufacturer 
specific list.

1 Double-click on the control module leaf or right-click and select Expand to open the Control 
Strategy workspace - this has the same name as the leaf

2 Press the Function Block button  in the toolbar and click in the workspace
– The New Block dialog appears

– Select the Manufacturer = Endress+Hauser
– Select the Device Type = SFC173
– Select the Block Type = Analog Input
– Press OK to create the function block

3 The block now appears in the strategy window with the default name
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4 Repeat Steps 2 and 3 for the Analog Alarm, Multiple Discrete Input, Hybrid with Discrete I/Os 
and Multiple Discrete Output blocks

– Level Analog Alarm: 
Manufacturer = Endress+Hauser
Device Type = SFC173
Block Type = Analog Alarm

– Flow AI
Manufacturer = Endress+Hauser
Device Type = SFC173
Block Type = Multiple Discrete Input

– Flow PID
Manufacturer = Endress+Hauser
Device Type = SFC173
Block Type = Hybrid with Discrete I/Os

– Positioner AO
Manufacturer = Endress+Hauser
Device Type = SFC173
Block Type = Multiple Discrete Output

5 The control strategy now looks like this

6 Open Project File, then press Save Entire Configuration, to save the project.

°Note! 
• If you are using the FOUNDATION Fieldbus SFC162 Field Controller, select the blocks from the 

corresponding SFC162 Block Type list
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4.4 Add the Function Block links

1 In the Control Strategy workspace position the blocks according to your strategy

– The blocks can be dragged and dropped by selecting and holding down the right mouse key
– The blocks can be aligned by selecting, then via Tools => Alignment => e.g. Middle 

followed by a click on the block to which the alignment is to be made
– The Tools menu also contains other standard drawing functions such as toolbars, standard 

shapes, line thickness, colours etc.

2 Click on Function Block Link  button in the tool bar, the cursor changes to a cross
– Select the Pump Control_A1_1 block with the cross: 

the Output Parameter Selection dialog appears

– OUT contains the level value
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3 Click the box next to OUT – it changes color – then click on OK

– The Output Parameter Selection dialog closes
– The cursor is now connected to a blue dotted line
– Place the Cursor in the Pump Control_AALM_1 block and click to make the link

4 When the link is made, the Input Parameter Selection dialog for the Alarm block appears

– Click the box next to IN – it changes color – then click on OK

5 When the Input Parameter Selection dialog changes, the link is made and appears as below:

– You may have to move the parameter legends "IN" and "OUT" by selecting and positioning 
with the left mouse key depressed

6 Repeat steps 2 to 5 and make the following links between the function blocks

– Pump Control_AALM_1 to Pump Control_HY_MD_IO_1
OUT_ALM to IN_D5

– Pump Control_MDI_1 to Pump Control_HY_MD_IO_1= 
OUT_D1 to IN_D1
OUT_D2 to IN_D2
OUT_D3 to IN_D3
OUT_D4 to IN_D4

– Pump Control_HY_MD_IO_1 to Pump Control_MDO_1
OUT_D1 to IN_D1
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7 Your Control Strategy now looks something like this

8 By using the Tools => Drawings => Text option, you can now add text to the strategy to 
make clear the function of each block and parameter:

9 Click on the Project View workspace and Export Tags..., see Chapter 3.10
– Open Project File, then press Save Entire Configuration, to save the project.
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4.5 Attach the function blocks to the controller

The blocks that are always necessary for the Field Controller (RS, PBTR0, HC and DIAG) are created 
automatically when it is added to the Fieldbus Network. Do not delete these blocks! The order of 
assignation of the strategy function blocks to the controller determines the order of execution (can 
be changed by drag&drop).

1 Close the Control Strategy window and place the Utilities (Control Module) and 
HSE Network 1 dialogs side-by-side
– The function blocks and links you created have been added to the Utilities tree
– There is a question mark "?" in each function block icon

2 Drag and drop the Pump Control_AI_1 block from the Utilities into the HSE Network 1 dialog 
and place it on the FB VCF leaf
– The block is attached to the Field Controller
– The name changes (set to do so in Preferemces, see Chapter 3.2)
– The question mark disappears from the block in the Utilities dialog

3 Repeat step 2 for all blocks - your project now looks like this:

4 Open Project File, then press Save Entire Configuration, to save the project.
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4.6 Characterize the I/O function blocks

The Analog and Digital I/O blocks can now be characterized as follows.

1 In the HSE Network 1 dialog, double-click on the block leaf
– The Off Line Characterization dialog for the block appears

2 To change parameters: 

– Expand the parameter leaf
– Double click on value space
– Enter the parameter or select it from the drop-down menu
– Confirm with End Edit

3 Click Close to close the block and 

4.6.1 Analog Input block
The AI block is attached to the SFC444 Analog Input module. This delivers a 4 mA to 20 mA signal 
that must be scaled to 0 % to 100%. The channel parameter is that in Table 2-1, Chapter 2.2.2.

1 Double-click on FC_01_PB_AI_1 and enter the following parameters

– MODE_BLK
TARGET: Auto

– XD_SCALE
EU_100: 20
EU_0: 4
UNITS_INDEX: mA

– OUT_SCALE
EU_100: 100
EU_0: 0
UNITS_INDEX: %

– CHANNEL: 1200
– L_TYPE: Indirect

2 Press Close to close the dialog

3 Open Project File, then press Save Entire Configuration, to save the project.
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4.6.2 Analog Alarm block
The Analog alarm block monitors the incoming level signal. When the signal exceeds the HI limit 
= 95%, the OUT_ALM signal changes from FALSE to TRUE

1 Double-click on FC_01_PB_AALM_1 and enter the following parameters

– MODE_BLK
TARGET: Auto

– ALT_ALM_SUM: Hi
– HI_LIM: 95

2 Press Close to close the dialog

3 Open Project File, then press Save Entire Configuration, to save the project.

4.6.3 Multiple Discrete Input block
The MDI block is attached to the SFC432 Discrete Input/Output module. This delivers FALSE for 
a 0 VDC signal and TRUE for a 24 VDC signal. The channel parameter is that in Table 2-1, 
Chapter 2.2.2.

1 Double-click on FC_01_PB_MDI_1 and enter the following parameters

– MODE_BLK
TARGET: Auto

– CHANNEL: 1309

2 Press Close to close the dialog

3 Open Project File, then press Save Entire Configuration, to save the project.
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4.6.4 Multiple Discrete Output block
The MDO block is attached to the SFC432 Discrete Input/Output module to which the pump 
power is connected. A FALSE signal causes the relay to close and the pump runs. A TRUE signal 
causes the relay to open and the pump stops. The relays are Normally Open (NO) so that a in the 
event of a power failure, the pump fails to safe = stop. The channel parameter is that in Table 2-1, 
Chapter 2.2.2.

1 Double-click on FC_01_PB_MDO_1 and enter the following parameters

– MODE_BLK
TARGET: Auto

– CHANNEL: 1319

2 Press Close to close the dialog

3 Open Project File, then press Save Entire Configuration, to save the project.

4.6.5 Hybrid Discrete I/Os block
The HYDIO block adds the logic to the control strategy. It must be put into Auto. At this point the 
target execution time EXEC_TIME_TARGET should be left at the default value of 10 ms.

1 Double-click on FC_01_PB_HY_MD_IO_1 and enter the following parameter

– MODE_BLK
TARGET: Auto

2 Press Close to close the dialog

3 Open Project File, then press Save Entire Configuration, to save the project.
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4.7 Export tags

Note! 
• You should use the Export Tags function everytime you change the configuration of the project, 

so that the OPC server information is always up-to-date.
• Application Designer can be set to automatically export the tags every time the project goes 

online, see Chapter 3.2.

1 Activate the project view by clicking in its workspace

2 Right click on the project name, a context menu appears

3 Select the option Export Tags...
– The Export Tags dialog confirms the successful export

– Press OK to close the dialog

4 Open Project File, then press Save Entire Configuration, to save the project.
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5 Program the Hybrid Function Block

The hybrid function block can now be programmed. In this tutorial Ladder Logic will be used. 

5.1 Customize the IEC 61131-3 variables

1 In the HSE Network 1 tree, right click on the leaf FC_01_PB_HY_MD_IO_1 and select 
Program Hybrid Block

2 The Hybrid I/O Mapping dialog opens
– In the IEC 61131-3 Programming Language menu select LD (Ladder Logic)
– Confirm the change by pressing Yes in the query box that appears after selection
– The programmed links appear in green with the tick box ticked

3 Now customize the hybrid I/O mapping by changing the IEC 61131-3 Variable names
IN_D1: Pump_01_Reset
IN_D2: Tank_Level_01_Alarm
IN_D3: Tank_01_Overflow
IN_D4: Pump_01_Overheat_Signal
IN_D5: Pump_01_Running_Signal
OUT_D1: Pump_01_Output_Control

– Select the line by clicking over it with the mouse then click over the parameter
– Enter the new name: must start with a letter, use underlines not spaces
– Press Enter to store
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4 The Hybrid I/O Mapping now looks like this:

5 At this point you can also add parameters that are should receive an OPC Tag for use by e.g. a 
SCADA program
– Click the tick box to register the parameter
– Enter the variable name
– In our example: IN_D6 = Pump_01_Operator_Entry_Emergency

6 When all parameters have been customized, press OK to open the programming environment.
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5.2 Program the hybrid function block

5.2.1 OpenPCS programming tool

1 After the OK button has been pressed, the OpenPCS programming tool opens:

– The Files pane of the Project window shows the program files
– The Resources pane shows the hybrid block task attached to the Field Controller
– The Lib pane shows the libraries available
– The Help pane opens the Online help tree
– A Catalog window might also appear – it can be closed by pressing the "x"
– The Log window tracks program events – it can be closed by pressing the "x"

2 Double-click on FC_01_PB_HY_MD_IO_1.LDD: the editor opens with the declared external 
variables (the log window at the bottom was closed for this screenshot)
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5.2.2 Activate the libraries
The variables used in ladder diagram must be converted to a data type appropriate to ladder logic 
programming language. To this end ControlCare activates two libraries by default:

•  CC_FF_CUSTOM_LIB to map the custom FF function blocks
•  CC_FF_STANDARD_LIB to map the standard FF function blocks

These appear red in the library pane (select the Lib tab)

Note! 
• For ControlCare Product Version 2.01.xx, the libraries have to be activated by hand
• For SFC programming the sfclib must be activated, see below and the OpenPCS online help

Activating a library In order to activate additional libraries, e.g. sfclib for SFC programming, the following procedure is 
used:

1 Select the Lib pane:
– Right-click on e.g sfclib and select Use in Current Project
– The project book turns red = active

Installing a library If the libraries are not installed:

1 Right-click on Libraries, select Install New..., 

2 Browse to the folder containing the LIB files and select the library required

3 Press OK twice to install.
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5.2.3 Insert function block instance

1 Click on the Files tab and, if not already visible, go back to the Ladder Diagram programming 
tool by double clicking on the LDD file. 

2 Go to the first rung and right-click the first contact: select the Program Funktion Block… 

3 The Insert Function Block dialog opens
– Expand the Library Function Blocks tree
– Select the function block IN_D_To_Bool_Conv_LDD 

(Discrete Input to Boolean Conversion for Ladder Diagram Function Block)
– Press Insert

4 The function block Instance is inserted in the lower part of the workspace
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5.2.4 Declare the function block instance for data acquisition
In order to use this function block you must declare both a function block instance and the variables 
that will keep the values returned by it.

1 Declare the function block and variables in the upper pane of the programming window
– The format is VAR/FB and variable declaration/END_VAR, see figure

2 In the lower pane, right-click on the red XXXXXXX and select Insert Variable

3 Select the getData function block instance and press Insert

4 The red XXXXXX in the lower pane is changed to getData
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5.2.5 Assign the variables to the getData instance
The DS_66 variables must now be assigned to the left of the block, the Boolean variables to the 
right.

1 In the lower programming pane, right-click on the IN_D1 space and select Insert Variable

2 Select the variable associated with IN_D1 (Pump Reset) from the Variable list and press Insert

3 The variable is inserted into the block

4 Repeat Steps 1 and 2 for the variables IN_D2 to IN_D4: Tank_01_Overflow, 
Pump_01_Overheat_Signal, Pump_01_Running_Signal, Tank_01_Level_Alarm, 
Pump_01_Operator_Entry_Emergency

5 Now repeat the procedure for the corresponding boolean variables 
– BOOL_1 to BOOL_5 on the right-hand side of the block.
– IN_D_Status in the STATUS field.

6 Finally, right-click on the Coil symbol at the extreme right of the rung and select Delete.
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5.2.6 Create a boolean variable for the output
The inputs are now ready to be used easily in a ladder logic, they are all booleans so they can be 
directly inserted in the rungs. We are only missing a boolean variable to save the discrete output to 
be sent back to ControlCare as feedback. Declare it and we will be ready to start creating the ladder 
logic

1 Declare the variable Pump_01_Output_Control_B as a boolean in the top pane of the 
programming window

2 Now create another rung for the ladder by right-clicking blow at the right of the function block 
in the lower pane and selecting Insert Network

3 If required, insert a comment indicating the function performed by double clicking in the space 
below the scissors

4 Now insert the diagram elements by right clicking on the selected rung and selecting 
Insert Contact

– A contact can be negated by right-clicking on the contact and selecting Negate
– An OR can be created by right-clicking on the contact and selecting Insert Branch (OR)
– An AND can be created by right-clicking on the contact and selecting 

Insert Sequence (AND)
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5 Now proceed to create the logic sequence:
– OR Contact
– 4x negated contacts

6 Now right-click on the first contact and select Insert Variable
– The Insert variable dialog Opens, select Pump_01_Running_Signal_B
– The variable is assigned to the contact

7 Repeat Steps 1 and 2 for the variables Pump_01_Reset_B, Tank_01_Overflow_B, 
Pump_01_Overheat_Signal_B, Pump_01_Operator_Entry_Emergency_B, 
Tank_01_Level_Alarm_B, Pump_01_Control_Output_B

8 The logic is now complete
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5.2.7 Create an output block
We now need an output block to convert the boolean into a hybrid function block signal for the 
Field Controller I/O modules.

1 Declare the block sendData in the upper pane of the programming window

2 In the lower pane, right-click below Rung 0002 of the ladder and select Insert Network
– If required, insert a comment about the function of the rung

3 Right-click on the red XXXXXX and select Insert Function Block
– The Insert Function Block dialog appears
– Select the option BOOL_TO_OUT_D_CONV_LDD

4 Right-click on the XXXXXX at the top of the function block and select Insert Variable
– The Insert Variable dialog appears
– Select sendData
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5 Now right-click on the first space to the right of the function block and select Insert Variable
– Add the variables Pump_01_Output_Control_B to BOOL1

6 Repeat for 
– IN_D_Status to STATUS
– Pump_01_Output_Control to OUT_D1

7 The now block looks like this

8 Finally, right-click on the Coil symbol at the extreme right of the rung and select Delete.

9 Open the File menu and select Save All

5.2.8 Trouble-shoot the project 
Now that the project is complete, it is recommended that the project is checked for errors.

1 Open the File menu and select Check Syntax

2 OpenPCS runs a check on all syntax in your program and publishes a log at the bottom of the 
workspace.
– If errors are found eliminate them and check the syntax again
– You can move from error to error with the F4 and Shift F4 keys

3 When the program is free of errors, open the File menu and select Save All.
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5.2.9 Optimize performance
OpenPCS allows the hybrid function block to be optimized for speed or size during compilation. 
Default setting is optimized for speed. Optimizing for size causes the block to run slower than if it 
is speed optimized, and is recommended only when there are memory problems, e.g. when a large 
number of hybrid function blocks with long programs are in use. For our example, the default 
settings will be used, so that the project can now be compiled and downloaded, see Chapter 6.

Changing the performance 
settings

Should you decide to optimize for size, preceed as follows. The seetings are made in both the 
resources and the hybrid function block

1 Click on the Resources tab, then right-click on Controller leaf and select Properties

2 The Edit Resource Specifications dialog appears

– In the Optimization pull-down menu select e.g. "size only", then press OK

3 Now right-click on the Function Block leaf and select Properties
– The Edit Task Specifications dialog appears

– In the Optimization pull-down menu select e.g. "size only", then press OK
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6 Go On-line

6.1 Connect to the Field Controller

After the Field Controller and other components have been physically installed in the Fieldbus 
network (subnet), connection must be established. 

The Field Controller SFC173 is delivered with a default IP address of 192.168.164.101, the 
SFC162 with default address 192.168.164.100. For the purpose of this tutorial, it is suffience to 
connect to this address, however in practice it would be normal to change this address to one 
allocated by your IT system administrator.

Warning
• The use of IP addresses is strictly controlled. Usually your system administrator will be authorised 

to allocate unique addresses. Assigning an unauthorised address to a Field Controller may result 
in conflicts within your system and the failure of the associated devices!

6.1.1 Change the IP address of your computer

1 Open the Windows Control Panel by pressing Start => Settings => Control Panel and 
choose the option Network Connections

2 Double-click on Local Area Connection and in the Local Area Connection Status dialog 
select Properties

3 Select Internet Protocol TCP/IP then select Properties again

Note! 
If "TCP/IP protocol" is not included in the Network, it must be installed by using the Windows 
setup before you proceed with Step 4.

4 Note the original property settings (e.g. make a screen shot and store it in a Word document) of 
so that they can be restored at end of the operation. 
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5 Change the IP address and the Subnet Mask of the computer, so that it is in the same subnet as 
the Field Controller. 

– IP Address 192.168.164.XXX and network mask (Subnet Mask) 255.255.255.0.
– Do not use the addresses 192.168.164.100 or 101,as these are reserved as default addresses 

for the Field Controllers SFC162 and SFC173 respectively

– Click on the OK button to confirm your settings

6.1.2 Set the Field Controller IP address

1 Now call FC Tools: Programs =>Endress+Hauser=>ControlCare=>Tools=>FC Tools

2 Choose the Field Control (OPC) Server path, default Local, then press Connect
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3 Select the desired Field Controller module option Module using its serial number as reference. 
The serial number is printed on the inside of the module door.

4 Press the Hold button to interrupt any control activities being executed in the module

– A confirmation window appears, press Yes to continue
– Any application running on the Field Controller will be stopped at this point

5 Check that the HOLD LED on the Controller module is lit, then press Connect to continue 
with the procedure. 

– If the HOLD LED does not light, there is a communication problem: 
Type PING 192.168.164.101 in the DOS command window and check whether the Field 
Controller is found. If there is a reply, replace the Ethernet cable by a cross-cable and try 
Step 4 again.
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6 Reselect the desired Controller module, then click on the IP Properties button. 
Now check the option Specify an IP address, then enter the IP Address and the Subnet Mask

– Answer Yes to the confirmation box
– Now enter the Field Controller address given to you by your system administrator

(in our example we have kept the default address 196.168.164.101)
– Make a note of the IP addesses and the corresponding Controller serial number. This will 

help in the identification and diagnosis of possible faults.

7 Click on OK to finish the operation

8 Now change the address of your computer as described in Chapter 6.1.1 to the new domain, 
so that it can continue to communicate with the Field Controller at its new address:
(Note: if the address domain has not changed, the computer address does not need resetting)

– Start =>Settings =>Control Panel =>Network Connections
– Local Area Connection => Properties
– Protocol (TCP/IP)=>Properties
– Enter an unused IP address and the subnet work address of the new domain
– Press OK to finish the process

9 Now return to FC Tools and click on Refresh

10 When the Refresh is complete, press Run to start the execution of the Field Controller 
firmware
– Confirm the action with Yes

11 Check that the HOLD LED on the Field Controller has extinguished, then press Close.

12 The Computer is now connected to the Field Controller
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6.2 Generate the live lists

6.2.1 HSE live list
Once the Computer and Field Controller are able to communicate with each other, the connection 
to the network can be checked by creating a live list. 

1 Press the On-Line button  in the menu toolbar
– The project goes on on-line

– A red cross appears against the Field Controller in the Project workspace

2 In the Project workspace, right click on HSE Network and select Live List

– A live list is generated of the devices on the HSE network

Note! 
• It may take sometime to generate the live list. 

– The devices found first go grey. 
– They are then assigned a HSE address after which the live list is refreshed with the new data.
– Address shows the last three digits of the IP address in hexadecimal format
– The devices then appear in full color. 
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6.2.2 Assign the Field Controller tag

1 In the project workspace, right click on the Field Controller (FC_01_PB) and select 
Attributes...

2 The Attributes dialog opens
– Open the drop-down menu of the Device ID and select the Field Controller associated

with the displayed TAG (in our case FC_01_PB) - the serial number is on the front panel
– Do this even though the correct ID is already displayed - the program expects it!

– Confirm your choice with OK

3 Double-click on the HSE Network 1 leaf to open the HSE Network 1 dialog
– Right-click on the FC_01_PB leaf and select Assign Tag

4 The Tag FC_01_PB is assigned to the Field Controller
– The Field Controller in the HSE live list goes grey
– When the Tag has been assigned, it goes block again

5 Open Project File, then press Save, to save the project
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6.3 Download the project

Both the project in ControlCare Application Designer and that in Open PCS must be downloaded 
to the Field Controller. The downloads can be made in any order.

Note! 
• The procedure below describes the initial download for the entire HSE network. 
• Partial downloads can be made later from lower leaves, when changes are confined to this level
• Incremental downloads can be made to a running project by checking the boxes Incremental 

Download and Compare Parameters: Unaffected Local I/Os will hold their last values.

6.3.1 Download the control strategy

1 In the Project workspace right-click on HSE Network 1and select Download

2 The Download dialog appears

– Press Start to start the download

3 The download will be interrupted if the project has not been configured properly, e.g.

– The Controller Tag has not been assigned correctly => Assign Field Controller tags, 
Chapter 6.2.2

– The I/O moduels have not been correctly defined, see Chapter 4.6

4 When the download is successfully completed, the dialog is closed, and you are ready to 
download the hybrid block configuration
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6.3.2 Connect OpenPCS to the controller

1 If OpenPCS is still open, click on the icon to display your project,
otherwise
In the HSE Network 1 tree, right click on the leaf FC_01_PB_HY_MD_IO_1 and select 
Program Hybrid Block

– Click OK to open OpenPCS
– Open the File menu and click on Check Syntax, to check for program errors again

(at the moment, the program requires this action before every download) 

2 Open the PLC menu and select Connections, the Connection Setup dialog appears

3 Press the Edit button, the Field Controller Settings dialog appears
– The dialog immediately scans the HSE network and presents a list of devices

– Select the Field Controller from the list
The serial number on front panel comprises the second part of the ID

– Press OK to select the Field Controller
– When a Field Controller has been selected its tag and address appear in the dialog

4 Press OK twice to close the two open dialogs and return to the OpenPCS main workspace.
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6.3.3 Download the OpenPCS project
Now that connection has been made (the settings are stored, so that the connection need only be 
made once), OpenPCS can go online and the project can be downloaded. Compilation and 
download occur automatically when the resources are updated, see Step 2.

1 Open the PLC menu and select Online

2 OpenPCS ask whether the resources should be updates, answer Yes

– The project is downloaded to the Field Controller

3 Now check the project files
– You will see that the names in the ladder logic are now replaced by values

4 OpenPCS offers a number of options for monitoring values - see the on-line help for details.
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6.4 Check the control stategy

6.4.1 Control strategy

1 Click in the Control Strategy workspace (Pump control) and press the button  in the menu 
toolbar – the control strategy also goes "on-line"

– Values appear in green when the status is good
– Values appear in red if the status is bad - at this stage this is an indication of a communication, 

block configuration, strategy configuration or device parametrization error

2 If you have the possibility of changing the signals, change each input in turn and check the 
effect on your strategy.
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6.4.2 Hybrid block execution time

1 Open the HSE Network 1 dialog, then click on the "details" icon in the menu bar
– The execution times are shown next to each block
– The FC_01_PB_HY_MD_IO_1 block executes at the default time of 10 ms

2 Right-click on the FC_01_PB_HY_MD_IO_1 block and select On Line Characterization

– The parameter EXEC_TIME_ACTUAL shows the time in which the block is executing
– Observe the value for a couple of minutes and note the highest value

3 Press the Online button again to put Application Designer offline

4 Right-click on the FC_01_PB_HY_MD_IO_1 block and select Off Line Characterization
– Double-click on the "value space" next to the parameter EXEC_TIME_TARGET
– Enter a value 10% to 20% higher than the highest observed actual execution time
– Press End Edit to store the value and Close to quit the dialog.

5 Press the Online button to go online again
– Download the strategy once more, see Chapter 6.3.1
– The strategy now runs with the new target execution time

Note!
• Changing EXEC_TIME_TARGET online, see Chapter 6.5.1, causes the calculated value in the 

details view to change, but the actual schedule is unaffected. In this case too, a download must 
be made before the parameter becomes effective.
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6.5 Modify the project

6.5.1 On-line characterization
Once the project is on-line you may want to change parameters to e.g. tune the control-loop or 
eliminate configuration errors. With the exception of the SP parameter, the function block must be 
put out of service before the parameter is changed:

1 In the Control strategy workspace double-click on the function block you want to modify, or in 
the HSE network 1 or Control module workspace, right-click on the function block and select 
On-line Characterization

2 The function block On-line Characterization dialog appears:

– Open the Mode leaf and double-click in the space next to Target
– Set the Target to OOS (Out of Service)
– Click End Edit to set the parameter

3 Change the parameters you wish to modify

– If appropriate, open the parameter leaf and double-click in the space next to the parameter 
you require

– Enter the new parameter or select it from the drop-down menu
– Click End Edit to set the parameter
– Repeat the procedure for all the parameters you wish to modify

4 Put the function block back into standard operating mode

– Open the Mode leaf and double-click in the space next to Target
– Set the Target back to the original value (Auto (Automatic) or Cas (Cascade))
– Click End Edit to set the parameter
– Check that the Mode really changes to the Target Mode (failure to do so indicates a 

configuration error)
– Press Close to store the values (if you are prompted - answer with Yes)

5 Click on the Project View workspace and Export Tags..., see Chapter 3.10
– Open Project File, then press Save Entire Configuration to save the project

6 Put the Control stategy back "on-line" to check the results of your modification, Chapter 6.4.
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6.5.2 Off-line characterization
You may prefer to change parameters off-line, e.g. when modifying the control strategy or adding 
new functions to the project. 

1 If you are on-line, press the Off-line button  in the menu toolbar
alternatively, in the PROFIBUS network or Control module workspace, right-click on the 
function block and select Off-line Characterization
– The function block Off-line Characterization dialog appears

2 Change the parameters you wish to modify

– If appropriate, open the parameter leaf and double-click in the space next to the parameter 
you require

– Enter the new parameter or select it from the drop-down menu
– Click End Edit to set the parameter
– Repeat the procedure for all the parameters you wish to modify
– Press Close to store the values

3 Click on the Project View workspace and Export Tags..., see Chapter 3.10
– Open Project File, then press Save Entire Configuration to save the project

4 Press the On-line button  in the menu toolbar to go on-line again

5 Download the modified project
– In the Project workspace right-click on HSE Network 1and select Download
– Follow the procedure in Chapter 6.3

6 Put the Control stategy back "on-line" to check the results of your modification, Chapter 6.4.
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6.6 Pack and Go

In order to install the project at the customer’s site, the project can be packed and unpacked. It is 
important to remember, especially if you have not been using the actual project devices to test your 
project, that the instruments on site may be have newer (or even older) DD/CFF/GSD files than 
the ones you use. The latest DD/CFF/GSD files must then be uploaded to the project and 
corresponding corrections must be made to configuration, before it is downloaded to the SFC173 
Field Controller.

6.6.1 Pack the project

1 Select Project File => Pack Project...

2 Answer "OK" to the query about missing DD/CFF files

3 Browse to the place where you want the packed files folder, 
e.g. Endress+Hauser => ControlCare

4 Press OK to pack the project

6.6.2 Unpack the project

1 Select Project File => Unpack Project...

2 Browse to the packed files folder, e.g. Endress+Hauser => ControlCare

3 Browse to the desination folder

4 Press GO to start unpacking
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6.7 Export the configuration

For documentation purposes, the project configuration can be exported to an existing ODBC file 
data source, e.g. Oracle, a machine database, e.g. Excel to provide a record of the current status of 
the project or to an XML sheet for viewing with a browser.

6.7.1 File data source folder
The file data source must have been created before the export.

1 In the Project window, right-click on the Project icon and select Export Configuration:

2 The Select Data Source dialog box appears

3 In the File Data Source folder, select the source that describes the driver that you wish to 
connect to. You can use any file data source that refers to an ODBC driver which is installed on 
your machine.
– Use the New... button and Look In dropdown menu to browse or 
– Click the data source icon to select the driver:

– Press OK to make the connection
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6.7.2 Machine data source folder
The Machine Data Source is specific to the machine, and cannot be shared. "User" data sources 
are specific to a user on the machine; "System" data sources can be used by all users on the machine, 
or by a system-wide service. The Machine Data Source must have been created before export.

Procedure 1 In the Project window, right-click on the Project icon and select Export Configuration:

2 The Select Data Source dialog box appears
– Click on the Machine Data Source tab to open the folder
– Double-click the data source name to select the machine, e.g. Excel:

3 The Select Workbook dialog box will appear:
– Select the folder where the data file is and double-click the workbook icon.

– Your project configuration will be exported to the workbook file.
– A message box appears on completion - press OK

4 Open the Excel file to check the result:
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6.7.3 XML file

1 Click in the Project workspace and select Project File =>Export => Configuration as XML
– The Export Configuration as XML dialog appears

2 Enter a File Name and Save In location, then press Save
– The project is saved as an XML file at the selected location
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6.8 Close Application Designer and OpenPCS

When you have completed your session, close Application Designer and OpenPCS

6.8.1 Application Designer

1 If you are on-line, press the Off-line button  in the menu toolbar

2 If you have made any modifications while you were on line, you will be prompted to store 
them
– If appropriate answer with Yes

3 Close the project by clicking on Project File => Close

4 Exit Application Designer by clicking on Project File => Exit

5 The Field Controller continues to operate with the project configured according to the last 
download/on-line correction

– If you switch off the Controller, the project remains stored in its memory
– It is initialized and re-executed as soon as the Controller is switched on again

6.8.2 Open PCS

1 Open the PLC menu and select Offline

2 Open the File menu and select Exit
– You will be prompted to save if your project has been changed since the last download

6.8.3 Reconnecting Application Designer
Provided your computer is operating in the same IP address domain as the Field Controller, you can 
reconnect at any time.

1 Start up Application Designer and select the Project you require

2 Press the On-line button  in the menu toolbar

3 Expand the various workplaces as required

4 Click in the Control Strategy workspace and press the button  in the menu toolbar – the 
control strategy goes "on-line" with the last configuration that was downloaded.

6.8.4 Reconnecting Application Designer
Provided your computer is operating in the same IP address domain as the Field Controller, you can 
reconnect at any time.

1 Start up OpenPCS, open the File menu and select the project you require
– Open the File menu and run Check Syntax

2 Open the PLC menu and select Online
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7 Trouble-Shooting

7.1 Factory initialisation and reset

Warning!
• Do not use the pushbuttons located in the Field Controller unless you are certain that you want 

to reset the system.

Two pushbuttons located on the SFC173 module, see Fig 8.1, allow the system to be initialised and 
reset. The function and effect of the buttons is described in the table below.

• To "click " the pushbuttons use a pointed instrument (e.g. a ballpoint pen). 

Other functions of the two buttons are to be found Chapter 7 of the Operating Instructions 
BA035S/04/en, Field Controller: Commissioning and Configuration..

Function Effect Procedure

Reset Resets system: the last 
configured IP Address 
is used

• Click the right pushbutton - the system resets (takes several seconds)
• If no IP Address is found, a new one is assigned automatically
• Verify that the RUN and ETH LNK LEDs are lit.

Factory Init Deletes application, 
the last configured IP 
Address is retained

• Keeping the left pushbutton pressed, click the right pushbutton
• Check that the FORCE LED flashes once a second. 
• Release the left push button. The system resets, see above.
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7.2 Field Controller 

Problem Remedy

FC Tools does not show all the Field Controllers that are in 
the sub-network

There is probably an IP address conflict in this sub-Network.
• Disconnect all the Field Controllers from the sub-

Network and execute the procedure "Connecting the 
Field Controller to its Sub-Network" for each module, 
assuring that the address to be used is not associated with 
other equipment of the network.

FC Tools does not find the Field Controller • Make sure that the initial connection procedure was 
followed and the Field Controller is operating in the same 
subnet and not with the default address 
192.168.164.100/101

• Check that the Ethernet cable, see above
• Check if the network adapter is on and OK: Execure a 

PING command to its own IP, via DOS PROMPT.
• Check if the Ethernet connection is OK: Execute a PING 

command to the Field Controller.

FC Tools does not put the Field Controller in HOLD Use the Mode HOLD procedure of Factory Init/Reset. 
• With the Field Controller in HOLD mode, execute the 

firmware update procedure, Section 7.3, using the steps 
of item 2.  

• If the problem persists, check the related TCP/IP 
connection (check the cables and ETH LNK LED)

Firmware begins to execute but after a certain time it stops It might be a configuration problem. 
• Use the Factory Init procedure and configure the Field 

Controller again. 
• If the problem persists, download the firmware again as 

described in Chapter 7.3

HOLD LED remains lit If the HOLD LED remains lit after the Field Controller has 
been turned on, the firmware may be invalid. 
• Update the firmware as described in Chapter 7.3

ETH LNK LED does not light Check if the cable is connected correctly, or that the cable is 
not damaged. Check the specification of the cables:
• SFC 954 - Cable Standard.  To be used in a network 

between the Field Controller and a Switch/HUB. 
• SFC 955 - Crossed Cable (Cross).  To be used point to 

point between a PC and the Field Controller

ERR LED is lit PROFIBUS DP error
• PROFIBUS DP connection has been lost, check 

connections
• One or more slaves have not been correctly configured 

for cyclic data exchange, see BA036S/04/en, 
Application Designer, PROFIBUS tutorial

FRC LED is flashing (Force) Field Controller is in reset mode
• Complete the RESET procedure

STDBY LED is lit Field Controller is in stand-by mode (redundant application)
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7.3 Application Designer

Problem Remedy

Block cannot be attached to a particular device The block is not supported by that device. 
• Block assigned to wrong device?
• Latest device revision is not being used 

– Create a duplicate device following the latest revisions
– Attach the block to the duplicate device
– If the block attaches, delete the old device, and attach 

all other blocks to the duplicate device
– If necessary, characterize the blocks

• Device error, contact device manufacturer

Field Controller does not appear in HSE live list No connection to Field Controller
• Field Controller is on HOLD, set it to RUN mode
• IP address is not configured correctly, use PING to check, 

see above

Red cross appears on HSE Network No connection to Field Controller
• Field Controller is on HOLD, set it to RUN mode
• IP address is not configured correctly, use PING to check, 

see above

A device does not appear in the live list Communication error
• Another device has the same address
• The device is not powered up
• The project has been updated but no download has been 

made yet

Configuration will not download, why? You have either a communication problem or the 
configuration is not complete
• Check that you are on-line - press the On-line button
• Check that your computer is in the same address domain
• Check that you have assigned the Field Controller tag
• Check that you have exported all tags OPC server
• Check that the parameters are in the recommended order
• Check that the OPC server is running (look for icon in 

bottom line)
• Check that DPV1 has not been activated in the device, 

see Chapter 3.7

A parameter appears red in my on-line control strategy, 
why?

The parameter has a bad status
• Check that the Block Mode is Auto (or Cas)
• Check that the block has been correctly configured
• Check that the device is still live (live list)
• Check that the device address is the same as that you 

have in your configuration (live list)
• Check that the parameter has been correctly configured 

in the PROFIBUS Configurator
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For your notes
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