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• Make sure the document is stored in a safe place such that it is always available when
working on or with the device.

• To avoid danger to individuals or the facility, read the "Basic safety instructions" section
carefully, as well as all other safety instructions in the document that are specific to
working procedures.

• The manufacturer reserves the right to modify technical data without prior notice. Your
Endress+Hauser sales organization will supply you with current information and updates
to this manual.
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Change history
BA00396G/13.10
• Valid for software version: 18.0.0
• Initial version

BA00396G/14.14
• Valid for software version: 18.0.2 and 18.0.3
• Changes to the previous version:

New layout; Enhanced Product, Tank and Movement functionality; Additional functions
for Grid view

BA00396G/15.16
• Valid for software version: 18.0.2 and 18.0.3
• Changes to the previous version:

New features

BA00396G/16.17
• Valid for software version: 18.1.1
• Changes to the previous version:

Unification of the W&M and the non W&M software packages.

BA00396G/17.22
• Valid for software version: 18.3.2
• Changes to the previous version:

Pipeline volumes as part of tank volumes selectable.

BA00396G/18.24
• Valid for software version: 18.3.3
• Changes to the previous version:

Compatibility with Windows 11 and Windows Server 2022. Minor changes to existing
functionality.
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1  About this document

1.1  Document function
This manual should support during the installation of Tankvision Professional NXA85.

It deals with the basic functions Operators have to perform during daily operation.

Beside basic PC operating knowledge no special training is needed to perform the
Tankvision Professional System operations. Nevertheless it is recommended receiving a
training on the system by Endress+Hauser.

1.2  Software versions and certification
Due to the certification process with weights and measures agencies, the latest
software version might only be certified at a later stage. Also some features might be
incompatible with the weights and measure regulations and can therefore not be
combined.

1.3  Symbols

1.3.1  Safety symbols
DANGER

This symbol alerts you to a dangerous situation. Failure to avoid this situation will result in
serious or fatal injury.

WARNING

This symbol alerts you to a dangerous situation. Failure to avoid this situation can result in
serious or fatal injury.

CAUTION

This symbol alerts you to a dangerous situation. Failure to avoid this situation can result in
minor or medium injury.

NOTICE

This symbol contains information on procedures and other facts which do not result in
personal injury.

1.3.2  Symbols for certain types of information and graphics
 Tip

Indicates additional information

Reference to documentation

Reference to graphic

Notice or individual step to be observed

1. , 2. , 3.

Series of steps

Result of a step

1, 2, 3, ...
Item numbers
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A, B, C, ...
Views

1.4  Documentation
For an overview of the scope of the associated Technical Documentation, refer to the
following:
• Device Viewer (www.endress.com/deviceviewer): Enter the serial number from the

nameplate
• Endress+Hauser Operations app: Enter serial number from nameplate or scan

matrix code on nameplate.

1.5  Registered trademarks

1.5.1  Microsoft®, Windows®
Microsoft and Windows are registered trademarks of the Microsoft Corporation

1.5.2  ModbusTM

Modbus is a registered trademark of Schneider Electric USA, Inc.

1.5.3  Java®
Java is a registered trademark of Sun Microsystems, Inc.

1.5.4  Mozilla® Firefox®
Mozilla and Firefox are registered trademarks of the Mozilla Foundation

1.5.5  Legal notice concerning trademarks
All company/product names and/or all company logos may be trade names, trademarks
and/or registered trademarks of Endress+Hauser, its affiliates or of their respective
owners with which they are associated.

https://www.endress.com/deviceviewer
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2  Basic safety instructions

2.1  Requirements for the personnel
The personnel for installation, commissioning, diagnostics and maintenance must fulfill
the following requirements:
‣ Trained, qualified specialists must have a relevant qualification for this specific function

and task.
‣ Are authorized by the plant owner/operator.
‣ Are familiar with federal/national regulations.
‣ Before starting work, read and understand the instructions in the manual and

supplementary documentation as well as the certificates (depending on the
application).

‣ Follow instructions and comply with basic conditions.

The operating personnel must fulfill the following requirements:
‣ Are instructed and authorized according to the requirements of the task by the facility's

owner-operator.
‣ Follow the instructions in this manual.

2.2  Intended use

2.2.1  Intended use of Tankvision Professional NXA85 software
Tankvision Professional is specifically designed for operators of bulk storage facilities,
marketing terminals, refineries and pipelines. It is designed to handle all the data
acquisition, supervisory control and monitoring required in a single fully integrated
solution.

Tankvision Professional integrates all major types of tank measurement instruments into
one system.

All measured and calculated tank parameters are accessible to your tank farm and
terminal operators as well as to connected host systems.

Multi-user operation is provided by the inbuilt Web Server offering the opportunity to
access data at any connected location (local/remote) e.g. for administrative and accounting
purposes.

2.3  Product safety
This measuring device is designed in accordance with good engineering practice to meet
state-of-the-art safety requirements, has been tested, and left the factory in a condition in
which it is safe to operate. It meets general safety standards and legal requirements.

2.4  IT security
Our warranty is valid only if the product is installed and used as described in the Operating
Instructions. The product is equipped with security mechanisms to protect it against any
inadvertent changes to the settings.

IT security measures, which provide additional protection for the product and associated
data transfer, must be implemented by the operators themselves in line with their security
standards.
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3  Product description

3.1  Product identification
The following options are available for identification of the software:

• Nameplate specifications
• Order code with breakdown of the software features on the delivery note
• Enter serial numbers from nameplates in Device Viewer

(www.endress.com/deviceviewer): All information about the software is displayed.

For an overview of the technical documentation provided, enter the serial number from
the nameplate in the Device Viewer (www.endress.com/deviceviewer).

3.1.1  Nameplate
The information that is required by law and is relevant to the product is shown on the
nameplate, e.g.:
• Manufacturer identification
• Product name
• Order code
• Extended order code
• Serial number
• Barcode

3.1.2  Manufacturer address

Endress+Hauser SE+Co. KG
Hauptstraße 1
79689 Maulburg, Germany
Place of manufacture: See nameplate.

3.1.3  Order code and product version
To find out the version of your software, enter the order code indicated on the
nameplate in the search screen at the following address:
www.products.endress.com/order-ident
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4  Home Page
When Tankvision Professional is launched from the Start menu or its desktop shortcut the
Home Page is loaded.

Each tank configured in the system has its own graphical window.

The Home Page has a menu bar, a tool bar, an application work space and a status bar at
the bottom of the Window.

The system starts with the Home Page maximized and with all Tank windows open as
shown.

 1 Home Page

The most frequently used functions are accessed using the toolbar, the rest are accessed
through the menus.
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4.1  Multiple Windows

 2 Multiple Home Pages

The menu items that control the multiple windows feature are found in the Home Page
menus: Window → New Window, Close Window and Annotate Window.
• New Window – Opens a new window.
• Close Window – Closes the current window (not available on ‘master’ window).
• Annotate Window – Alters the caption of the current window.

Each instance of the home page window can be annotated with an identifying name to
enable the user to identify them on the Windows taskbar. Different instances of the Home
Page can be configured to show different sets of tanks. This enables, for example, general
products and LPG products to be displayed in separate windows. If more than one monitor
is available, the home pages can be arranged on different monitors for greater clarity.

Closing the application will close all windows. Reopening the application will cause all the
windows to be restored to their original locations.

4.2  Tank View
This is the default view for individual tanks when displayed in the Home Page. See the
following picture for an example.
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 3 Typical tank mimic

Each window or tank mimic is fixed in its general appearance and size. They are scalable.

When multiple tank mimics are open they will be tiled to the available area of the Home
page window. When there are more windows open than available space, scroll bars will
automatically appear down the right hand side of the parent window.

The tank mimic has been equipped with a number of short-cut links to other display
features, and a context sensitive pop-up menu for quick access to other features.

4.3  The Basic Tank View Window
The window shows:
• The tank number of the tank
• A graphical representation of the tank denoting the tank type, e.g. cone roof, floating

roof etc.
• The product allocated to the tank
• A bar graph showing the level in the tank
• A selection of numeric and textual data fields which can be configured by the user
• Whether an alarm is currently active for the tank
• Whether the numeric data is in manual or automatic mode where relevant
• The movement status of the tank, i.e. static, filling, emptying
• The connection status of the gauge, i.e. Connected, Disconnected, Connecting,

Disconnecting

If the connection status is anything other than Connected then ALL data for the tank
is from the last time it was connected and is therefore NOT LIVE.

4.3.1  Data Display in Manual Mode
Any data value in manual mode is denoted as such by being displayed as blue colored text.

The following window indicates that the product temperature is in manual mode.

The data is therefore updated by using the Manual Data Entry facility. Please refer to the
Section on Manual Data Entry for further details.

 4 Tank mimic displaying a manual temperature
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4.3.2  Shortcut access to Manual Data Entry
When a numeric value is in Manual Mode as shown, the user can gain quick access to the
manual data entry display by double-clicking the manual data item. This will launch the
Manual Data Entry module.

4.3.3  Shortcut to TAD Statuses and Modes
When one of the TAD values: Tank Mode, Tank Status and Product Status is displayed a
double-click on the field will display a Windows dialog to permit the tank value to be
changed.

For more details on TAD refer to section "TAD Maintenance".

4.3.4  Shortcut access to Single Tank Overview
If you double click the tank window the Single Tank Overview display is launched for that
tank.

See the section on the Single Tank Overview module for a complete description (refer to
"Single Tank Overview").

Access to Single Tank Overview is also available from the tool bar.

4.3.5  Tank in alarm
When a tank has any active alarm an alarm horn icon appears on the tank as shown.

 5 Tank mimic displaying a tank with an active alarm

In addition an abbreviated label is placed below the horn indicating the type of alarm. If
there are multiple active alarms the highest priority alarm is displayed. In the illustrated
case LAHH is Level High High alarm.

See the table below for details.

Alarm Codes

Alarm Code Alarm Description

LAHH Level Alarm High High (Software)

LAH Level Alarm High (Software)

LAL Level Alarm Low (Software)

LALL Level Alarm Low Low (Software)

HH Level Alarm High High (Gauge)

H Level Alarm High (Gauge)

L Level Alarm Low (Gauge)

LL Level Alarm Low Low (Gauge)

NO REPLY No reply from gauge
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Alarm Code Alarm Description

BAD ALARM Incongruous collection of alarms active
(i.e. High alarm and Low alarm at the same time)

GT H High temperature (Gauge)

GT L Low temperature (Gauge)

PT H High temperature (Software)

PT L Low temperature (Software)

GD H High density (Gauge)

GD L Low density (Gauge)

PD H High density (Software)

PD L Low density (Software)

PD DA Density deviation (Software)

PT DA Temperature deviation (Software)

PW H High water (Software)

PW L Low water (Software)

PL VA Variable alarm

PF HF High flow

PF LF Low flow

UMA Unauthorised movement by volume

UMAL Unauthorised movement by level

PL FR Roof alarm

PL DA Software difference alarm

PU 1...8 Programmable user defined alarm 1...8

4.3.6  Identifying the alarm after it has occurred
When an alarm first occurs, an event is generated, a horn appears on the tank and the
Alarm Event Viewer sounds an audible warning or optionally voice message can be
played.

After the alarm has been acknowledged the remaining indication is an alarm horn on the
tank mimic and line in the Alarm Event Viewer, both of which will generally persist until
the alarm condition passes. In addition the active alarm summary will also show any active
alarms.

To get further information on the active alarms double click the horn icon.

The Alarm Summary module will be loaded. See illustration below.
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 6 Alarm Summary screen

The Alarm Summary module will show each of the alarms that are active. An active alarm
will have its corresponding check box ticked.

4.3.7  Identifying moving tanks

 7 Moving tank indication

The Tank View window identifies moving tanks in several ways:
• By displaying a fill direction indicator, i.e. an arrow pointing up or down dependent on

the direction of movement (as shown in the figure above).
• By the magnitude and sign of the Flow Rate, e.g. a positive flow rate represents filling, a

negative flow rate represents emptying.
• Finally, depending on whether it is configured, the color of the product in the tank can

be used to represent movement status. For example, blue represents filling, brown
represents emptying, and green represents static.

See the System Configuration manual BA00390G (section "System Settings", Use
Product Colour check box) for how to enable this feature.

4.3.8  Connection status
The connection status of the tank is displayed on the right hand side.

It will be one of four states:
• Connected
• Disconnecting
• Disconnected
• Connecting
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The Connected status means that the external devices, e.g. tank gauges, are being polled
for data continuously. For modem connections data might only be requested periodically.

If the connection status is anything other than Connected then ALL data for the tank
dates from the last time it was connected and is therefore NOT LIVE.

 8 Tank in disconnected state

In the above screenshot the tank is in a Disconnected state and will show diagnostic code
DN00 for no reply from gauge.

4.4  Context Menu Options
A context menu is available. Right mouse click within any Tank View window and the
popup menu will appear, as illustrated below.

 9 Context menu in action

Some of the options within the pop-up menu are sensitive to the configuration of the tank.
These will be discussed in the remainder of this chapter.

4.4.1  Product
The Product menu item has a further sub-menu which contains the products sorted in
order of usage (the one which is allocated to most tanks first). This option is used to
change the product allocated to the tank. The currently allocated product is highlighted by
an adjacent tick mark and is greyed out. If there are more than twelve products currently
allocated to tanks, then there is a final entry in the menu which displays a product
selection screen:

 10 Product selection screen
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A Product can be selected by clicking on the arrow which will display a list of all products
(again sorted in order of usage). Alternatively the name of the required product can be
typed in. As the product name is entered a reduced list of products matching the entered
text is displayed:

 11 Filtering product selection by name

4.4.2  Manual data
The Manual mode menu item has a further sub-menu which contains all of the available
manual mode options. This option is used to switch values between manual and automatic
mode.

Any value in manual mode will be highlighted by an adjacent tick mark.

4.4.3  Alarm enable
If visible, this menu option leads to a sub-menu that will show whether the alarm is
enabled or disabled. A tick mark will appear adjacent to the menu option showing that the
alarm for that data item is enabled.

4.4.4  Movements
If visible, and enabled, this menu option provides a convenient way to access the product
movements for the tank. Selecting a movement listed on the sub-menu will show the
details of that movement.

4.4.5  Device Commands
The Device Commands menu item has a further sub-menu which contains all of the
available device commands within this context.
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 12 Device commands tank mimic

Details of the commands are given below.

Servo Check
Perform a repeatability check on a servo based gauging instrument. This command will
attempt to raise the displacer by at least 300 mm and then return it to the product level.
The level prior to raising the sensor is compared to the level after the sensor has returned
to the product surface. If both are within the defined tolerance the servo check function is
considered to have passed. If created, this will generate an event.
This command is only available to servo based gauging instruments.

Stow
Stow the sensor of the gauging instrument to the locked or top stop position. This
command is only available to servo based gauging instruments.

Unstow
Cancel the Stow command and return the sensor to the product level. It can also be used to
cancel any command currently in operation.

Freeze
Causes the displacer to remain at its current position.

Unfreeze
Releases the last Freeze command and allows the displacer to return to the product level.

Water Scan
Selecting this option will cause the gauge to try to find the water interface, and return the
product level. Note that this command will only work if your gauge supports water scan.

Density Scan
Selecting this option will cause the gauge to perform a density profile scan, and return the
average observed density. Note that this command will only work if your gauge supports
density profiling.

Alarm Test
Selecting this option will raise the displacer position to the top of the tank, which will raise
any enabled alarms.
NOTE: Depending on gauge type, commands can generate an alarm. Status changes can
also occur during command executions.
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Scan Mode
Off Scan, Normal Scan and Fast Scan are mutually exclusive options that control the
frequency with which the gauge is scanned.
• Off Scan

The gauge is not polled.
• Normal Scan

The gauge is polled at the normal intervals.
• Fast Scan

The gauge is polled every other poll (i.e. more frequently), at the expense of the other
gauges.

• Manual Scan
Used when the gauge is Off Scan, to cause it to be polled once.

Connection Status
Connect, Disconnect, Connect Once are mutually exclusive options, that determine the
connection state of the interface port that the tank is connected to. Therefore if one of
these commands is sent to a tank, then it will apply to ALL tanks connected to the same
COM port or Modem on the PC.
• Connect

The interface will connect to the COM port or Modem and continue polling the gauges
for data indefinitely or until a disconnect command is sent by the user.

• Disconnect
The interface will disconnect from the COM port or modem and remain disconnected.
Data from the last refresh will be displayed.

• Connect Once
The interface will connect to the COM port or Modem and automatically disconnect
when it has retrieved all data from the gauges. Data retrieved from the connection will
be displayed.

A confirmation dialog will be displayed if the Disconnect command is selected, as this
command will stop ALL gauges on the same interface from being updated. Be aware that
sending a command to one tank will affect all other tanks on the same interface and
therefore these commands should be used with caution as they could lead to loss of data
for critical tanks.

4.5  Use of the function keys
Function keys can be customised to act as ”one key press” shortcuts to other functions and
features installed on the computer. A Function key first needs to be set to an executable, in
this example gridview.

Locate the file FunctionKey.ini in the application folder
(C:\Program Files\Endress+Hauser\Tankvision Professional\).

Then edit the file.

text= Add the text for the menu item in this case it will be F2 GridView.
exe= Path name for the executable. Do not forget .exe on the end.
Icon= Path name for the icon. Do not forget .ico on the end.
hide= Use 0 to make the item appear on the Function Key menu.

Example for F2 key starts Grid view.
[F2]
text = GridView
exe = GridView.exe
icon = myicons\myicon.ico
hide = 0
Stop and restart homepage to initialize the functionality.
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5  Single Tank Overview
The Single Tank Overview provides a detailed display of all data for a single tank.

It can be launched:
• By double clicking a Tank View window
• By clicking the Single Tank Overview tool bar button

Once the Single Tank Overview module has been loaded, further tanks can be viewed by
selecting them from the drop down list provided.

The displayed data is organised into logical groups; Primary Gauging data, Flow Rates,
Inventory Data, and Alarm Settings.

Any data values in manual mode will be displayed in in blue colored text.

Any data values unavailable for any reason will be replaced by a diagnostic number.

See the illustration below for a typical example.

 13 Typical Single Tank Overview screen

Tool tips are used throughout to provide further information to the user on each of the
data display fields.

5.1  Tank in alarm
If the selected tank has an active alarm, a horn icon will be displayed on the tank. The
detail of which alarms are active can be determined by double clicking the horn to launch
the Alarm Summary display.

The Alarm Summary will show a tick mark against each alarm that is currently active. See
the illustration below.
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 14 Alarm Summary screen showing High and High High Programmable alarms active

5.2  Viewing the Element Temperatures
Some tank gauges have the capability of measuring multiple temperature points from
special temperature measurement devices. These are commonly refered to as Averaging
Thermometers, Multi-spot Temperature probes etc.

Temperature profiles can only be viewed if
• The system has been configured to poll for Element Temperatures. To do this make

sure the Average Temp. Fitted flag is ticked for the gauge in the Device
Configuration screen.

• The Trending subsystem is configured to trend the temperature elements for that
gauge. This is carried out in the Trending Configuration screen.

Refer to the configuration manual for details on the above items.

To display the Temperature Profile screen click the button in the overview screen.

Right click to add a tank to the display, see below.

 15 Typical view of element temperatures
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The data can be displayed in a graphical format using the Graph tab. In this view extra
details of the profile are also shown, such as the average value etc.

The graphical display can be configured using the following menu options:
• View → Average Temperature

Tick this item to show the average temperature.
• View → Data Points

Tick this item to show the individual data points on the graph.
• View → Data Labels

Tick this item to show the individual data values on the graph.
• Tools → Options

This displays a dialog where the colours used for the various lines on the graph can be
configured.

• Tools → Configure Element Levels
This displays a dialog where the heights of the temperature elements may be entered.
These will then be used when plotting the graph, instead of the element numbers.

By default, the temperature on the graph will be scaled using the minimum and maximum
values from the table. However this can sometimes give a misleading display. The range
can be manually set by ticking the Enable Temperature Min/Max item and then entering
the min and max range.

The graph can be saved to a bitmap by selecting File → Save Graph ...
The data can also be viewed in a tabular format by clicking on the Data tab.

 16 Tabular view of element temperatures

5.3  Viewing profile data
Some tank gauges have the capability of carrying out a density/temperature profile (or just
density for some gauges) throughout the product.

This data can then be returned as a table of densities and temperatures (if supported) and
stored in the database.

The profile data may then be viewed in a graphical or tabular format.

Single Profile Viewer
Only one profile may be displayed at a time.

Screens are opened from the Single Tank Overview screen.
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6  Logging On

6.1  Security
Access to the features of the system can be controlled through a user account. The
requirement to log on to the system can be disabled allowing any user full access to the
system. If security is enabled the following sections apply.

6.2  Logging In
1.

 17 Security menu on Home Page

Select Security → Log In... from the main menu bar, from either the Home Page (see
above) or Alarm Event Viewer. Other ways to log in are using the Security Manager
icon in the Windows system tray, or automatically when you attempt to access a
privileged feature of the system.
 A login dialog will appear.

 18 Login dialog

2. Enter the necessary username and password.
 The details will be checked against entries in the database. If the username and

password are valid the user will be logged on at their designated access level.

Each user account has a designated level of access to each feature. So even if a user is
logged on it does not necessarily mean that they have access to all functions. A user's
level of access is determined by the rights assigned to them by the System
Administrator.

When a user is logged in to the system, the username is displayed in the left most panel of
the status bar of the Home Page and Alarm Event Viewer as shown below.

 19 Status bar of Home Page, showing logged in user
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6.3  Logging Out
Select the Security → Log Out option from the main menu bar.

The system will immediately log out the currently logged on user. This will prevent access
to all functions requiring a logon.

6.4  Configuring New User Accounts
Please refer to Security Configuration section of the System Administrators manual for
further information.

Consideration should be given to new users access rights. Not all users should be
given the highest level of access. The System Administrator should be responsible for
determining who has what rights.

It is recommended that most casual users be given minimal rights to start with. They
can always be adjusted later as users become more familiar with the operation of the
system.
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7  Alarms and events

7.1  Introduction
In many sites the words alarms and events are often confused. It is worth an explanation
of the terms within the context of this tank gauging system.

Simply put; Alarms give rise to events.

Take the example of a high level alarm, a set point can be defined at which the alarm will
become active (this also implies that there is a point at which the alarm becomes inactive).
When the alarm becomes active, an event is recorded which alerts operators to this. Not all
events recorded by the system are as the result of alarms, for instance a communications
failure with the field instruments is a significant event, but has no alarm behind it.

7.2  What happens when an alarm becomes active
An alarm horn icon will be displayed on the tank within the Tank View window as seen
below.

 20 Tank mimic displaying a tank with an active alarm

The alarm status description within Grid View and Single Tank Overview will change to
reflect the highest priority alarm. For the abbreviated codes refer to table "Alarm Codes".

An event will be generated by the system and shown in the Alarm Event Viewer screen.

 21 Alarm Event Viewer
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An audible signal, if enabled will be generated. This may be in the form of an internal
buzzer, sound card or external klaxon dependent on the options fitted. A voice message
can be played via the PC sound card if this feature has been enabled.

Alarms are silenced when they are acknowledged. If security is enabled a user must be
logged on with the correct privileges to acknowledge the alarm.

All alarms and events are logged to the database. An alarm history view can be used to
look at all alarms and events that have occurred.

When an alarm is acknowledged the date and time is logged to the database. The logged
on user acknowledging the alarm is also logged.

7.3  Acknowledging Alarms
The Alarm Event Viewer displays details of alarms as shown below:

 22 Alarm Event Viewer

The status of the alarm is indicated in the leftmost and rightmost columns:
• Red

Unacknowledged and un-silenced. For the 'Active' alarm this will be flashing.
• Light Blue

Silenced, but unacknowledged.
• Green

Acknowledged.

To silence or acknowledge an alarm it is first necessary to select it by clicking on the row
with the mouse. Once the alarm is selected (indicated by the backgrond colour turning
blue) it can be silenced or acknowledged. If security is enabled, it is necessary to be logged
in to silence or acknowledge an alarm.

The selected alarm can be acknowledged by clicking the Acknowledge Alarm button ( )
or using the keyboard shortcut.

See the System Configuration manual BA00390G, section "Notification Options".

If the selected alarm has been configured to require an acknowledgement reason, an
Acknowledgement Reason screen will be displayed:
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 23 Entering an acknowledgement reason

The OK button is only available once a reason has been entered. The alarm can only be
acknowledged by clicking the OK button.

7.3.1  Silencing an alarm
The selected alarm can be silenced by clicking the Silence Alarm button ( ) or using the
keyboard shortcut.

See the System Configuration manual BA00390G, section "Notification Options".

7.3.2  Acknowledging or silencing multiple alarms
It is also possible to acknowledge or silence either single or multiple alarms by clicking on
the list of alarms using the right mouse button. This will bring up a menu of options:

 24 Context menu for Alarm Event Viewer

Operators are prevented from acknowledging multiple alarms when one or more of
those alarms requires an acknowledgement reason.

The alarms requiring a reason should be acknowledged individually first.

7.4  Event History Viewer
The Event History Viewer can be launched either by clicking the relevant button on the
toolbar on the home page, or by selecting View → Events from the menu of the Alarm
Event Viewer.
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 25 Event History

By default all events from the current day are displayed. The events displayed can be
filtered by raised date, raised device, acknowledged date and acknowledged user. For
clients connected to multiple servers it is also possible to specify the server from which the
events are to be taken. These settings are stored when the Event History Viewer is closed
and used as the defaults the next time the Event History Viewer is launched.

The event viewer also displays details of auditable actions. It is possible to filter whether
events and/or audited actions are displayed using the  and  buttons. Further details
for audited actions can be displayed by double-clicking on them. This will bring up a screen
detailing the changes:

 26 Event History detailed audit record
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8  Reports
A standard set of tank gauging and inventory reports are provided.

To access the reports, proceed as follows:

1. Choose File → Reports from the main Home Page menu.


 27 Select report screen

2. Select report (first step in wizard).

Group Selection
A report for a user defined group of tanks.

Product Selection
A report showing a summary of all tanks containing a particular product (e.g. Jet A1).

Standard Inventory Report
Shows a standard selection of inventory data for all tanks.

Standard Summary Report
Summarizes the inventory of products for all tanks by product.

Gauge Configuration
A report showing the main gauge configuration data.

Tank Configuration
A report showing the main tank configuration data.

Custom Print
Allows the selection of a report produced by a third party, to be executed by the Tank
Gauging system. You can select an RPT file from the Custom entry in the report tree.

3. At the next step in the wizard, if the user selected a report that requires further
parameters, such as a product or static group the user will be given the chance to pick
the relevant parameter. If the selected report requires no further parameters this step
is missed.

4. Finally, select print or preview to produce a hard copy of the report, or an on screen
preview of the report. If the user selects print, the report will be sent to the default
printer configured in Windows, selecting preview and then printing will allow the
user to choose the printer used.
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9  Grid View
Grid View is a tabular view of tank data.

The Grid View application is customisable and incorporates a context menu for sending the
common device commands.

The user can create their own data views and combine them with the standard tank
grouping features to completely customise data presentation.

Grid View is launched by clicking the appropriate tool bar button.

9.1  Launching the Grid View
Click the Grid View tool bar button or alternatively run the GridView.exe application from
the target folder. The illustration below is typical.

 28 Grid View

On the Grid View File menu there are two items for New Window and Close Window.

New Window opens a new window and Close Window closes the current window (not
available on ‘master’ window). The new instance can be configured to show a different set
of tanks to the first. If more than one monitor is available, windows can be arranged on
different monitors for greater clarity.

9.2  Selecting data views
Grid View comes as standard with several pre-defined data views. The available data views
are listed in the drop down list on the tool bar. See the illustration below for information.

 29 Selecting a view in Grid View
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The fixed Views are:
• Tank Gauging
• Tank Inventory
• Gauge Status
• Movements
Each view contains different columns of information, other views listed will be user
defined views. Further views can be configured by the user.

9.3  Selecting tank groups
By default the Grid View module displays all tanks.

The user can choose one of the pre-configured tank groups to display only those tanks that
appear in the group.

The available groups are listed in the drop down list on the tool bar.

An example is shown in the illustration below.

 30 Selecting a group in Grid View

If no groups have been configured the list will be empty other than the fixed All Tanks
group.

9.4  Finding a specific Tank
Grid View allows the user to locate a tank within the tank list. If the tank identity is known
it can be typed directly into the box provided; the grid rows will be scrolled until the chosen
tank is found. Alternatively the tank can be selected from the drop down list and similarly
the grid will be scrolled to display the selected tank.

9.5  Tanks in Alarm
A number of tool bar buttons are provided to quickly summarise tanks that have an active
gauge alarm.

 31 Grid View alarm state filter toolbar

9.6  Configuring a new data view
You can produce your own customised view of the tank farm data to suit your operations.
The custom view will appear on the list of views next to the pre-defined ones (refer to
"Selecting data views").
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1. To define a new view select Options → Maintain Views... from the Grid View menu.
 The Maintain Views screen will be displayed as shown below.

 32 Maintain views

2. Click New, which will open a window allowing you define the name of the view and
select the columns of data you want to display.


 33 Define a view in Grid View

Note that the same options will permit you to edit your views once you have
defined them.

For a new view, the View Name will be blank, but must be entered before the view can be
saved.

The list on the left is the list of fields that are available to be added to the view.

This list can be sorted
• by type 
• alphabetically 
• unsorted 

3. To add a field to the view, either select it and click the add ( ) button, or double-
click it. To add all fields of a given type to the view, select any field in the type and
click the add all ( ) button.

The list on the right is the list of fields that are currently in the view.
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4. To remove a field from the view, either select it and click the remove ( ) button, or
double-click it. To remove all fields from the view, click the remove all ( ) button.

5. To save the changes and exit, click the OK button. To exit without saving the changes
to the view click the Cancel button.

6. To delete a view, highlight it, and click the Delete button.
 The selected view will be deleted.

7. To exit from maintain views click the Close button.

9.7  Flow rate colour
When a flow rate column is present in the view a row displaying a moving tank is coloured
either brown or blue. Brown rows indicate that the level in the tank is moving downwards,
blue rows indicate that the level is moving up, while static tanks are displayed in the
background colour.

 34 Flow rate colours showing ascending and descending tanks

The grid maintains three user configurable threshold values to determine when a row
should be coloured. The threshold values are used depending whether the view shows a
level, mass or volume flow rate.

To configure the threshold values choose Options → Set Flow Rate Colour Thresholds...
from the menu. The Flow Rate Threshold dialog will be displayed.

 35 Dialog for configuring flow rate thresholds
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9.8  Contextual Operations
In a similar fashion to the Home Page it is possible to issue gauge commands and other
operations from the grid. In most cases right-clicking on a specific tank in the grid will
display a context menu from which these operations can be chosen.

9.8.1  Gauge Commands
Right-clicking on a particular tank will display a context menu of gauge commands. Note
that on a tank equipped with multiple gauges, the command will be sent to the gauge with
primary duty.

9.8.2  Simple Movements
There are options to set and stop movements from this screen. Setting a movement
involves calculating the target level for the movement and configuring alarm set points to
manage the operation, stopping the movement disables the alarms once the movement
operation is complete. See the Simple Movements manual BA01653G for further details.

This does NOT apply to full movements.

9.8.3  Single Tank Overview
Double-clicking on most columns will open the Single Tank Overview window (refer to
chapter "Single Tank Overview") focussed on the particular tank at the selected row.

9.8.4  TAD
Double-clicking on a column displaying TAD data will permit the operator to change that
particular setting. For more information on TAD, refer to chapter "TAD Maintenance".

9.9  Print and print preview
The current contents of the Grid View can be sent to a printer, or previewed on screen.

9.9.1  Printing a Grid View
To print the current contents of the Grid View either select File → Print from the menu, or
press the print button on the toolbar.

If the menu item is used, it is possible to change the printer and printer settings to be used
to print the Grid View.

If the toolbar button is used, the current contents of the Grid View will be printed on the
default printer.

9.9.2  Previewing a Grid View
To preview a print either select File → Print Preview from the menu, or press the print
preview button on the toolbar. An example of the Print preview window is shown below.
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 36 Previewing a print of the grid view

9.10  Select Mode
In select mode (shown in figure below) the operator is able to choose which tanks to view
as well as the data for those tanks. This means that the grid view can now be used to
provide an "on demand" view of tank gauging data. Put simply the operator can drag tanks
he is interested in onto the view panel from a list of available tanks and order them in the
way that makes most sense at that time. Once operations have finished on the tank it can
be dragged off to free up the space on the screen.

 37 Grid view in select mode

Tanks are grouped into product families in the panel on the left. Tanks and separator rows
can be dragged from that panel on to the grid on the right. Rows can be inserted at any
point in the grid.

9.10.1  Settings
To change the mode of a Grid View screen choose File → Settings from the menu. The
Grid View Settings dialogue will be shown.

The Use Select Mode option controls the mode of the grid view.
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 38 Grid View Settings window

Description
The Description field allows the user to name the particular instance of the Grid View
window. This feature is useful for multi-screen operation where there might be a number
of grids on the screen at one each fulfilling a particular role.

Use Select Mode
The Use Select Mode check box controls the mode the screen will display; when ticked the
operator can choose which tanks to show by dragging them on to the grid. A list on the left
of the screen is shown that is not present in standard mode.

Display Each Tank Once Only
When ticked the operator will be prevented from adding the same tank to the grid more
than once. This is done by removing the tank from the selection list on the left when it is
added to the grid.

Show All Tanks Group
When checked the user is presented with an All Tanks group on the selection list on the
left of the screen.

Group By
The selection list on the left of the screen typically groups the tanks together to make
location of the tank to be added to the grid easier. The list can be grouped by product or
static group, alternatively the list can be not grouped at all.

Sort By
The selection list on the left can either sort the tanks by name in alphabetical order, or by
the tank order as defined in the Tank Groups screen.

The options for filtering by alarm state, selecting groups and searching for a specific
tank are all removed when in select mode. The user can add tanks to the grid either by
dragging the header of a group onto the grid (in which case all the tanks in that group
are added), or by expanding a group and dragging a single tank onto the grid. Each
group also contains a "Separator" item to allow the user to define groups of tanks in
the grid itself. The order of tanks in the grid can be changed simply by dragging a
tank to a new location.
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9.10.2  Multi-screen Operation
Multiple grid views can be displayed at any one time. Of these grids some can be in Select
Mode, others can be in Standard Mode. The operation of the grids in Select Mode is
independent of each other so you could have a select mode grid for receiving tanks and
another for monitoring the loading operations on the site day tanks. Each grid can also
show a different set of data columns, again configured to show data that is relevant for the
operations in progress. Use File → New Window.

9.10.3  Adding tanks to the grid in select mode

To add a tank to the grid:
1. Locate the tank in the selection list on the left.

2. Click and drag the tank on to the grid in the desired position.

 39 Adding a tank in select mode

9.10.4  Removing tanks from the grid in select mode

To remove a tank from the grid:

‣ Click on the row that is to be removed and drag it off the grid.

 40 Removing a tank from grid view in select mode

9.10.5  Re-ordering tanks on the grid in select mode

To change the position of a tank on the grid:

‣ Click on the row that is to be moved and drag it into the desired position.



Tankvision Professional NXA85 Grid View

Endress+Hauser 39

 41 Reordering tanks in grid view in select mode

9.10.6  Colours
The cell colours for load and receipt can now be configured through the Customise
Colours screen. Access this through the Grid View menus; Options → Customise Colours.

 42 Customising the colours of the grid view

Using this it is possible to change the colours used to denote tanks and fields in particular
states:
• Alarm
• Error
• Failed
• Manual
• Scan Mode
• Offline
• Load
• Receipt
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10  Advanced device commands
Device commands can be gauge specific and therefore dependent on the gauge type.

For instance for Enraf gauges the following functions are supported:
• Dipping

Provides the various interface measurement modes such as Find Water Interface, Find
Product Interface, and Density Dipping features.

• Displacement
Provides gauge displacer control functions.

• Test Gauge Alarm
Provides the ability to auto-test the alarm set points of the 873 radar gauge.

• Maintenance
Allows the user to set the reference level of the gauge.

• Gauge Items
Is a general tool allowing the user to read or write any of the gauge items and view the
returned data and or responses.

Other gauges may support different commands and configuration functions.

10.1  Launching Advanced Device Commands
‣ From the Home Page menu, select Tools → Advanced Device Commands.

 The application will automatically select the primary gauge for the tank, where the
tank has more than one gauge. Users can subsequently select another gauge to
operate on by clicking on the "+" next to the tank, and selecting the gauge duty.

 43 The advanced gauge commands screen
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10.2  Sending commands
1. Select the tank from the list in the left hand panel. Expand the tank with the "+"

symbol (select the gauge in a multi-gauge setup).
 The commands supported by the gauge will be available.

 44 Executing a gauge command

2. Select the appropriate command from the list.

3. Set any required parameters and click the button to send the command. Information
regarding the progress of the gauge’s operation will be reported via the panel at the
bottom of the window.

10.3  Dipping functions
These generally apply to the Enraf 854 series of servo tank gauges, as shown below.
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 45 Dipping commands with the advanced gauge command utility

10.3.1  Product Measurement Mode
• Sends the I1 gauge item.
• Displays the status of the gauge throughout.
• The gauge will remain at I1 until the user commands the gauge otherwise.

10.3.2  Density Dip
This has two options:
• Tank Profile
• Interface Profile

‣ Select the correct option and Click the Apply button.
 The Command will be carried out.

10.3.3  Water Measurement Mode
• Sends the I3 gauge item.
• Displays the status of the gauge throughout.
• The gauge will remain at I3 until the user commands the gauge otherwise.

10.4  Displacer functions

10.4.1  Lock Test
Lock the displacer at a specified level, see figure below.
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 46 Advanced gauge command lock test

• Uses the MZ item to set the lock level, followed by the LT command.
• The user must provide the level at which the displacer will be locked.

10.4.2  Unlock
• Unlocks the gauge from the locked or calibrate position.
• Sends the UN gauge item.

10.5  Verify Calibration
Verifies the calibration of the instrument. The displacer will be raised into the calibration
chamber of the gauge.
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 47 Calibrating a servo gauge

• Uses the CA gauge item.
• The gauge will remain in the calibrate mode until told to do otherwise by the user.
• Stores and displays start level.
• Displays the various state changes that occur.
• Press the unlock button to have the displacer return to Product Measurement Mode.

10.6  Maintenance
Set gauge registers to adjust the device’s configuration.
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 48 Entering maintenance mode for a gauge

10.6.1  Set the gauge to a new level dip
If the gauge differs from an operator's manual dip it is normal to re-align the gauge to the
operator's dip.

The user must provide the new level dip and the password to access the gauge.

This function uses a whole sequence of gauge items as follows:

1. Set the password level using W2 gauge item.

2. Set the reference level using the RL gauge item.

3. Accept the reference level using the AR gauge item.

4. Exit and re-initialise the gauge using the EX gauge item.

5. Select the tank requiring the new level dip.

6. Enter the new gauge level.

7. Press the Dip button.

While the above sequence of actions shall take place, the status of each transition is
displayed.

When the EX command is finally issued the gauge data may disappear for a short
time while the gauge re-initialises itself. After re-initialisation the gauge level should
read the new value.

10.7  Gauge Items
This feature applies to Enraf and Motherwell gauges only.
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 49 Reading gauge items using advanced gauge command

NOTICE
The use of this feature requires knowledge of the specific gauging equipment and its
configuration.
‣ It is recommended that it is only used by competent persons.

This feature allows the user to read/write any of the gauge configuration items. To read an
item enter the item and click Apply, the answer will be displayed. To write an item, enter
the item and enter the data you want to write, and click Apply.

10.7.1  Enraf gauge items

Unit conversion
This tab supports units conversions from the units displayed in Tankvision LMS to units
the gauge is configured to understand. In order to avoid confusion we recommend that you
alter the displayed dimensions to match those used by the gauge, if at all possible. In this
way, the format used for settings made via a Portable Enraf Terminal (PET) will
correspond directly with the format to be used in the Gauge Items tab.

Reading a request
To read a request no Gauge Item Data needs to be supplied. The data will be converted to
the current system display units before being displayed.

Data format
When setting Items, the user must enter the data value in the exact format which is
appropriate for the selected Dimensions/Units, with +/- sign and appropriate number of
digits before and after the decimal point. If unsure of the correct format, read the current
value of the desired Item from the gauge first by leaving the Item Data "blank".

The Answer value from the gauge will be displayed in the format appropriate to the
Dimensions/Units in use. Then use the same format as the returned Answer to set the
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Item Data to the desired new value. An equals sign "=" must precede the data value when
setting Items.

The following Dimensions/Units are supported
Key:
• ± sign character (+/-)
• N numeric digit
• . decimal point

Level

Units Format

mm ± N N N N N N . N (default)

m ± N N N . N N N N

ft ± N N N . N N N N

in ± N N N N N . N N

f-i-s ± N N ' N N " N N

Temperature

Units Format

° C ± N N N . N N (default)

° F ± N N N . N N

Density

Units Format

kg/l ± N N . N N N N N (default)

kg/m3 ± N N N N N . N N

lb/ft3 ± N N N . N N N N

° API ± N N N N . N N N

Pressure

Units Format

Bar ± N N . N N N N N (default)

Pa ± N N N N N N . N

kPa ± N N N N . N N N

lb/in2 ± N N N . N N N N

10.7.2  Motherwell Gauge Items
Motherwell gauge items do not have the same unit conversion facility applied to them.
The data entered into the Gauge Item Data field is transmitted verbatim to the gauge. You
should consult your Motherwell documentation to determine the precise format of the
data.
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With Motherwell gauges you can either specify a 2-digit hexadecimal item code, as
described in the Motherwell gauge documentation or you can use a "shorthand" code for
certain data items.

Shorthand Code Description

UR Upper reference level

RL Reference level

HH High High alarm level

HA High alarm level

LA Low alarm level

LL Low Low alarm level
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11  Tank grouping
The system provides a comprehensive range of tools and utilities for the organisation and
grouping of tanks to user’s requirements.

All the tank grouping functions are generally available from the tank grouping module.

Grouping is generally organised into static and dynamic groups.
• Static groups can be organised by:

• Product
• Product group
• User defined Tank Group

• Dynamic Groups are automatically defined by their intrinsic criteria.

The tank grouping module display comprises a multi-tabbed dialogue. Each tab represents
one of the modes for tank grouping.

Access to certain of the tank grouping functions is password protected. You will be
requested where necessary to login.

11.1  Configuring and using a static group
1. Load the tank grouping module by clicking Quick View → Tank Groups on the

groups menu bar.

2. Click on the Static Groups tab.
 The Tank Groups window appears as shown below:

 50 Static groups configured in tank grouping dialog
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3. Press the Add... button.
 The Static Groups screen is displayed as shown below:

 51 Selecting tanks for a new static group

4. Enter the name of the group and then highlight a section of the Available Tanks to
add them to the group. To remove them from the group click them a second time to
remove the highlights.

5. To save the group click the OK button. To lose any changes click the Cancel button.

6. Once back at the Tank Groups window save the changes to all the groups by clicking
the OK button. To lose the changes click the Cancel button.
 The static group can now be used by selecting it from the Static Groups menu on

the groups menu bar.

11.1.1  Editing an existing static group
1. Load the tank grouping module by clicking Quick View → Tank Groups on the

groups menu bar.

2. Click on the Static Groups tab.

3. Select the group to be amended and press the Edit.. button.
 The Static Groups screen is displayed as shown below:

 52 Editing an existing static tank group

4. Click on the available tanks to add or remove them from the group. Any tanks which
are highlighted are members of the group.

5. To save the group click the OK button. To lose any changes click the Cancel button.
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6. To save the changes to all the groups, click the OK button. To lose the changes click
the Cancel button.
 The static group can now be used in its amended form by selecting it from the

Static Groups menu on the groups menu bar.

11.1.2  Deleting an existing static group
1. Load the tank grouping module by clicking Quick View → Tank Groups on the

groups menu bar.

2. Click on the Static Groups tab.

3. Select the tank group to be deleted from the group list.

4. Press the Delete button.

11.2  Product grouping
The system provides the user with the ability to view tanks containing a particular product.

11.2.1  Using a Product Group
1. Load the tank grouping module by clicking Quick View → Tank Groups on the

groups menu bar.

2. Click on the Product Groups tab.
 The list of available products will be displayed:

 53 Viewing product groups in tank grouping

If there are a lot of products the window scroll bars may be needed to locate the
product of interest.

3. Select the product of interest from the list.
 The tanks currently containing that product will be listed.

4. The product group can be used by selecting it from the Product Groups menu on the
groups menu bar.

The product to be used to filter the tanks can also be used by selecting it from the Product
Groups menu on the groups menu bar. Only products that are currently allocated to tanks
are listed and are ordered by usage (the one which is allocated to most tanks first). If there
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are more than 12 products currently allocated to tanks, only the 12 most used products are
included along with a final entry which displays a product selection screen:

 54 Selecting a product from tank grouping

5. A product can be selected by clicking on the arrow which will display a list of all
products which are allocated to tanks (again sorted in order of usage). Alternatively
the name of the required product can be typed in.
 As the product name is entered a reduced list of products matching the entered

text is displayed:

 55 Filtering the list of products

11.3  Product group totaliser
The Product Group Totaliser is opened from the Home Page, View → Product Group
Total. The Product Group Totaliser displays totalized volumes for the product groups.

See the illustration below for details.

 56 Product Group Totaliser

11.4  Dynamic grouping
The system currently provides a basic dynamic grouping function which allows the user to
view tanks that conform to certain dynamic criteria, e.g. moving tanks.

When a dynamic group is in use, as tanks no longer conform to the criteria they will be
automatically removed from display.

The number of available dynamic groups is currently fixed. These groups are automatically
defined by the system.
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11.4.1  Using a dynamic group
1. Load the tank grouping module by clicking the appropriate tool bar button.

2. Click on the Dynamic Groups tab.
 The list of available dynamic groups will be displayed:

 57 Viewing dynamic tank groups

3. Select a dynamic group.
 The tanks conforming to the criteria for the specified dynamic group will be

displayed. For example, Moving Tanks is any tank that is moving in any
direction, Receipt Tanks are those tanks currently being filled.

11.5  Set tanks to watch
1. Load the tank grouping module by selecting Quick View → Tank Groups.

2. Select the Quick View tab.
 The Quick View tab shows the tanks to be shown on the Home Page, see figure

below.

 58 Selecting tanks for the ad hoc view
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3. Highlight the tanks you wish to see on your display. The highlight is toggled by
clickingon the tanks in the list. The Invert button will toggle the highlighting on all
the tanks, so tanks that were selected become de-selected and vice versa.

To select all tanks simultaneously press the Select All button followed by the OK
button to display all tanks.

To de-select all tanks simultaneously press the Deselect All button followed by the
OK button to minimise all the tanks.

4. Press the OK button to display the selected tanks.
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12  Help and diagnostics
The system contains a help and diagnostics feature to aid the user.

Much of the help appears under the Help menu of the Home Page.

The options available under the Help menu are detailed in the following sections.

12.1  Diagnostics
To view the meaning of the diagnostic codes (DN numbers) that appear on the tank
display, double click on them to launch the Diagnostic codes module.

12.1.1  Launching the diagnostics module
‣ Select the Diagnostics option from the Help menu on the main home page menu bar.

 See figure below.

 59 Diagnostic codes

The first column lists the diagnostic code, the second column contains a brief definition,
and the final column references a file name that contains more detailed information on
the potential causes of the Diagnostic and recommended action to identify and fix any
associated problem. The right hand pane displays the contents of the file.

12.1.2  Printing the diagnostics list
The diagnostics module can prepare printed documentation of either specific error codes
or a list of error codes and their brief description.

From the Diagnostics window menu choose:
• File → Print → Diagnostics List
• File → Print → Recommended Action
• File → Print Preview → Diagnostics List
• File → Print Preview → Recommended Action
The Print commands will send the report directly to the default Windows printer. The
Print Preview commands will present a screen like below.



Help and diagnostics Tankvision Professional NXA85

56 Endress+Hauser

 60 Print preview of the diagnostics window

12.1.3  Launching the recommended action file
‣ To find out more information on the Diagnostic Code, double click the row of interest.

 This will launch Windows WordPad and open the recommended action file.

See the illustration below for a typical example.

 61 Display of recommended action file
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12.2  Versions
‣ Select Help → Versions from the Home Page menus.

 The display below shows details of the executable files that make up the tank
gauging system.

 62 Versions

Use the scroll bars to view the details of each of the files listed.

12.2.1  Printing a report of the module versions
A hardcopy report of the information displayed on the versions screen can be made using
the reporting facility built into versions. Select File → Print and File → Print Preview to do
so.

 63 Print preview of versions
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12.3  About
The Help menu on the main home page menu bar contains an option labelled About.

When selected this menu item will load a display module showing the overall version
number of your application, the licence details and the person/company the Tankvision
Professional application is registered to, including a statement on copyright.

 64 About screen

This information is invaluable to any technical support calls made to your supplier.
One of the first questions on any support call will inevitably be who the registered
user is and the license/build number of the complete application.
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13  Trending
Key Features:
• Multiple simultaneous displays on one graph
• Independent or shared axes for each process variable
• Display grid for better reading
• Data cursor for reading trend values
• Supports dynamic multi-dimensions
• Drill down into data with Zoom function
• Scroll backwards and forwards in time
• Operator programmable Y axis extents
• Operator programmable time base
• Ability to save multiple trend templates
• Ability to "Publish" trend templates for use on other networked PCs
• Simultaneously view multiple trend templates

13.1  Trending and data logging
The system comes as standard with a trending package. A Trend Logger service will log
trend data to the system’s hard drive.

There are three user interfaces for displaying trend data:
• Real-time – Shows the current tank gauging parameters over a maximum of the last

12 hours.
• Historical – Provides a graphical plot of tank gauging parameters.
• Historical (Tabular) – Provides the "numbers" from the Historical graph, for export to

other systems.

13.2  Real-time trending
The real-time trending function combines the ability to review up to the last 12 hours
worth of historical trend data with current real-time data.

13.2.1  Starting-up real-time trending
Either:
• Click the toolbar button  on the Home Page.
• Select View → Real-time Trending from the Home Page menus.
• Select Real-time trending from the Service Manager menus.

The trending parameter screen opens, as shown below.
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 65 Real-time trending parameter selection

At its simplest the process of displaying trend data consists of selecting which tank
parameters you want to view and the length of time over which you want to view these
parameters. The real-time trend view is simpler than the other screens as the time frame
for the view is always from now to a variable number of hours in the past.

13.2.2  Real time plot data
The first parameter input is the period that you want to plot on your graph, see figure
below.

 66 Entering plot intervals on single server system

The Interval is the number of hours into the past you want to view; the maximum possible
is 12 hours.

The Plot Interval is the time (in seconds) between successive data points on the graph; the
maximum interval is 900 seconds – there is not usually a need for finer plot interval than
30 seconds unless you have altered the configuration of your trending service.

13.2.3  Other configuration options
For details of the common configuration options, refer to section "Common trend
configuration".

Redundant system options
On a redundant server setup, when running the trending client on a client system there is
the additional option of choosing the source Servers as in figure below. You can choose
either of the pair of redundant servers, or Automatic which uses the server the Home
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Page is currently connected to as the data source. Additionally the option Attempt to
patch missing data using the other server may be employed if the selected server has an
incomplete data set for the period of the plot.

 67 Entering plot intervals on a redundant server system

The patching mechanism fills in gaps in the data set of the first server using the data from
the other server. If both servers have holes in their data at the same time, which is typical
of a field instrument problem in the field, then the gap remains. The facility is only useful
when one of the servers has been down during the trend plot period.

13.3  Historical Trending
Historical trending is similar to real-time trending, in that the aim is to produce a plot of
tank gauging data over a period of time. However, it differs in that the data presented is
not live (i.e. it does not scroll to the left) and there is no limit of 12 hours to the period
that can be plotted.

13.3.1  Starting-up historical trending
Either:
• Click the toolbar button  on the Home Page.
• Select View → Historical Trending from the Home Page menus.
• Select Historical trending from the Service Manager menus.

The trending parameter screen opens, as shown below.

 68 Historical trending parameter selection
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13.3.2  Historical plot data
In order to identify the period of the data to be plotted, a Date/Time Start, Date/Time
End and Plot Interval must be specified. The start and end time is self-explanatory and
the Plot Interval determines the time between neighbouring points on the plot. The
maximum Plot Interval is 900 seconds.

 69 Entering data set selection for historical trending plot

Large sets of data take a long time to plot. A month’s worth of data, plotted at
5 second intervals for 20 fields, will take a long time to compile the data for your
graph.

The default configuration of the trending server is to delete trending data after
90 days. Selecting a time period older than the data available on the server will result
in an empty graph.

13.3.3  Other configuration options
For details of the common configuration options, refer to section "Common trend
configuration".

Redundant system options
If the system is a redundant one there are some additional options available, shown in
figure below.

 70 Entering a data set selection for a historical trending plot on a redundant system

It is possible to select a specific Server as the source of the data – or Automatic, which will
choose whichever server the Home Page is currently using as its data source. The Attempt
to patch missing data using the other server option allows gaps in the source server’s
data to be filled with data retrieved from the redundant cohort.

13.4  Historical Trending (Table)
For most purposes the graphical views of the trend data provided by Real-time and
Historical for visualising the activities on a tank farm are sufficient. Should further analysis
of the underlying data be required, the tabular view is provided, the main function of
which is, to allow data to be exported in a format where it can be consumed by other
systems.
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13.4.1  Starting-up Historical Trending (Table)
Either:
• Click the toolbar button  on the Home Page.
• Select View → Historical Trending (Table) from the Home Page menus.
• Select Historical Trending (Table) from the Service Manager menus.

The trending parameter screen opens, as shown below.

 71 Tabular historical trending data selection

13.4.2  Historical trend data selection for tabular view
The selection process for the tabular data is very similar to that of the graphical view (refer
to section "Historical plot data"), the only difference is that you can choose how the data is
reported.

Storage of tank gauging data trends
The trend data is collated and stored on the server computer, by the trending service. The
service performs two tasks: it gathers the live tank gauging data and stores it in files on
the computer, and it serves the data it has gathered to the client applications when
requested to do so.

The method employed to gather the data is to periodically scan the available tank gauging
data (typically every 10 seconds) and record just the parameters that have changed since
the last 10 second scan. Taking a tank’s product level as an example, if the product level
hasn’t changed since the last scan nothing will be recorded for the tank at this scan. This
has a consequence on the data presented in the tabular historical view.

Selection of historical data
The common trend data selection options apply to this view of trend data (refer to section
"Common trend configuration").

Additionally, there are 3 options presented when selecting the historical trend data
selection, which cause the data returned in the tabular view to vary. The selection of these
might influence the statistical value of the information.
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Option:
• Logged Values Only

Process variables that don’t contain a value in the data record are left blank.
• All Implied Values

The blank records which appear in the Logged Values Only data selection are filled with
the last known value from previous scans.

• Interpolated Values
The blank records are which appear in the Logged Values Only data selection are filled
with a value synthesised using linear interpolation from the real values before and after
this time record.

 72 Tabular view of historical trend data

13.5  Common trend configuration
Many of the techniques used to design a trend plot are common to both Real time,
Historical and to a certain extent Tabular views of trending data. Those techniques are
described here.

13.5.1  Shared axes
If you are plotting related pieces of information it is often desirable to plot them on a
common axis so you can compare the values of the plot lines at various points in time.

For instance if you were plotting a tank’s product level and free water level together you
would plot both on the same axis as you would expect to see the water level some way
below the product level. If you plot them on separate axes and use the auto-scale option
you will typically see the water level as a flat, horizontal line in the centre of the plot, with
the product level fluctuating above and below it.

By using a shared level axis you will get a free water level at the bottom of the plot with
the product level fluctuating above it and in a scale with the values.
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13.5.2  Adding a shared axis
To create a shared axis click Add. This creates a new axis, initially of type level and named
New Axis as shown below.

 73 Creating a new shared axis

Change the name of the axis by entering a suitable name in to the Caption text box and
select the appropriate type for your axis. If you leave the Auto Scale option ticked the axis
will be scaled to fill as much of the plot area as possible to fit the range of values in the
trending data. This can have the effect of making small fluctuations appear much larger
than they are! If you decide not to auto scale your axis, untick the option, but enter suitable
minimum and maximum values for the axis.

13.5.3  Adding fields
There is no limit to the number of fields that can be displayed, however adding large
numbers to the same trend template can make it difficult to interpret the data. It is better
to create several templates with less trend items on each.

Click the Add Field button to add a trend item, as shown below.

 74 Adding a field to the trend plot

Select a Tank from the drop down list, then select the process variable for the tank to be
trended.

If available, a Shared Axis can be used for 1 or more process variables by checking the
box and selecting the required shared axis from the drop down list. N.B. only Shared
Axes relevant to the process variable being trended will be shown in the list, i.e. a
Temperature axis will not be shown for a Level trend process.

Optional maximum and minimum values for the y axis can be entered if required. The
smaller the range between the minimum and maximum values, the more detail that can
be seen. To enter maximum and minimum values it is first necessary to ensure that a
shared axis is not being used and to uncheck the Auto box for the field.

Repeat the procedure to add further trend fields.

Click on the  button to remove a trend field from the list. The figure below is an example
of a trend template.
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 75 An example trend field screen

Line colour and style
The colour and style of each plot line can be customized for easy identification. Click the 
button at the end of the line to open the style pallette shown below.

 76 Setting the colour and style of a plot line

Select the style and colour you desire and click the OK button. Click Use Defaults to return
to the default style selection.

The Trend Display will be configured to display the data requested.

Viewing the trend graph
Once the fields have been configured you can display the plot by clicking the back button

.
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 77 An example trend plot displaying a busy set of tanks

13.5.4  Finding a value on a trend
The values of process variables at a given point in time can be determined when the
selection mode of the graph is not None. To change the selection mode of the graph, click
File to return to the Info screen and select the Advanced… button. From the window that
opens, select Selection Mode and then the required selection mode.

 78 Selection Line Style screen
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 79 Select the required selection mode

This will be one of the following values:
• Default – Uses the Default selection mode (does not change the line colour and style,

you need to click Use Defaults to set these to the default state).
• None – It is not possible to select a time on the graph and the value of process variable

values is not displayed.
• Fixed Time – A time can be selected on the graph and the corresponding process

variable values will be displayed on the left hand side of the display. As new values are
added to the graph, the line indicating the selection will scroll across to the left,
remaining at the same time.

• Fixed Location – A time can be selected on the graph and the corresponding process
variable values will be displayed on the left hand side of the display. As new values are
added to the graph, the line indicating the selection will remain in the same place with
the process variable values scrolling past it.

If the Selection Mode is not None, the current selection can be moved backwards and
forwards in time using the left and right arrow keys. To change the selection by a larger
amount, hold down the shift key whilst using the left and right arrow keys.

13.5.5  Zooming in to more detail
The trend module allows the user to drill down into the trend data and view trends in more
detail. If the current Selection Mode is not None, it is first necessary to put the graph into
zoom mode by clicking the Zoom  toolbar button.

Identify the area of the trend where you require more detail
Using the mouse draw a box around the area of interest by pointing and clicking the left
mouse button. While holding the left mouse button down drag the mouse pointer to the
right or left and you will see a sizable box appear. Extend this box around the area of
interest and release the mouse button.

The system will zoom in to the area selected. You will notice that horizontal and vertical
scroll bars appear allowing you to move around the data at the current zoom level. You can
zoom in further as required using the same technique.

13.5.6  Zooming out
To exit zoom mode and return to selection mode, click the Undo Zoom  toolbar button. It
will now be possible to select a time on the graph when it is clicked instead of identifying
an area to be zoomed in on.

13.6  Trend templates
The selection criteria and display options you specify to create the trend data views can be
saved and then recalled in order to quickly recover the effort put in to devise the views.

Templates contain the selection criteria, line colour and style information and can be saved
either as a file on the computer’s hard disk drive or centrally in the tank gauging database.
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13.6.1  Saving a trend template
Saving a template places an MTTRT file on the computer's hard disk drive. A template once
saved will only be accessible from the computer it is saved on.

From the trend parameter page, click Save or Save As.

13.6.2  Publishing a trend template
Publishing the template is similar to saving it, except that the file is stored inside the tank
gauging database on the server (or servers, if the system is redundant). Once published the
template is accessible from all computers in the tank gauging system's network.

From the trend parameter page click Publish.

13.6.3  Opening a trend template
On the trend parameter page click Open.

 80 Opening a trend template

The system offers three options:
• Recent Templates – A list of recently used templates.
• Computer – Offers a facility to browse the computer's hard disk for previously saved

MTTRT files.
• Published Templates – Presents a list of all templates that have been published.

13.7  Printing trend data
If a hard copy of the trend graph is required, after selecting the view required, select Print
from the trend parameter screen. A preview of the report will be shown, from which the
output can be directed to a printer.

Any time selection or zoom you have applied to the graphical view will be replicated
in the print out.
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13.8  Exporting trend data
The Real Time Trending and Historical Trending (Graph) can be used to export trend data
in either graphical or .CSV format, Historical Trending (Table) module can only be used to
export trend data as a .CSV file. Once a template has been set up for trending select Export
from the configuration screen.

The following screen will be displayed for Real Time Trending and Historical Trending
(Graph):

 81 Exporting data from the trend viewer

13.8.1  Exporting Graphs
To export the data as a graph select Export Graph and click the Export button.

The normal Windows file save dialog will ensue. The option to Include selected variables
will add the selection point and values of the plots at the given time, as shown below.
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 82 Export with included selected values

13.8.2  Exporting Data
To export data values only select Export Data.

Historical Trending (Table) can only export data so there is no option to export a
graph.

 83 Export trend data options

Export Headers
If this option is checked the first data record in the exported file will contain the headers
from the table instead of data.

Data
This option controls how the data values are determined, for a discussion of the options
refer to section "Historical trending (table)".
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Data Format
This option controls the way that data is formatted.
• Exporting the trend data as Formatted Data means that the contents of the CSV file will

exactly match the data displayed in the table (Note however, that if the CSV file is
opened using Microsoft Excel, the application may reformat the data before it is
displayed).

• Exporting the trend data as Raw Data in Base Units means that the contents of the CSV
file will contain the raw data from the trend data file. This means that formatting
information (such as number of decimal places) and value translations (such as Alarm
Status) will not be exported and the CSV file will just contain numeric data.

• Exporting the trend data as Raw Data is the same as the previous option except that
fields which contain data which can be displayed using different units (such as levels,
temperatures etc.) will have their values converted using the currently selected units for
that type of field.

Click the Export button, select a file name and location and then Save.

13.9  Options
By selecting the Options button you can control and delete Published Templates and set
the Default Options for plotting trend graphs.

 84 Trend viewer options

13.9.1  Pinning templates
Templates may be pinned to the top of the list to enable them to be easily located.

There are 2 ways to pin templates:
• Right click the template and click Pin to list.
• Hover the mouse over the required template and click on the pin icon.

Templates can be unpinned from the list by clicking on the unpin icon, which is
permanently displayed on pinned templates.



Tankvision Professional NXA85 Trending

Endress+Hauser 73

13.9.2  Deleting Templates
Published templates that are no longer required may be deleted.

To delete a template click the template to highlight it and click the Delete button. Multiple
templates can be deleted at the same time.

 85 Deleting a published template

13.9.3  Graphing Options
The Graphing tab enables the user to customise the appearance of the default Selection
and Series traces.

 86 Defining the default style of series on graphs

Selection
• Colour – Select the default colour of the vertical selection line.
• Line Style – Select the default style of the vertical selection line.
• Selection Mode – Choose the default selection mode for the graphical trend

representations. For more details on selection modes refer to section "Finding a value on
a trend".
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Series
The trend viewer is supplied with a single Series Default configured. The settings for this
can be altered as follows:
• Colour – Selects the colour of the line plotted for the series.
• Text Colour – Selects the colour used to display the text on the key.
• Line Style – Sets the style of the line plotted for the series.

Additional series defaults can be added, click Add and configure in a similar way.

If your plot contains more tank gauging parameters than you have defined default series
styles for, the pattern of defaults is repeated from Series 1 onwards.
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14  Inventory Calculator
The system comes as standard with an Inventory Calculator.

The primary purpose of the Inventory Calculator is to provide the user with a means of
calculating tank inventory for conditions that do not currently exist.

For example, it could be used as a "what happens if" calculator, if a tank were to receive or
load X litres of product what would the final tank conditions be.

It may be used as a simple planning tool prior to the loading and/or receipt of product.

14.1  Launching the Inventory Calculator
Press the Inventory Calculator tool bar button .

The Inventory Calculator module will be loaded. See the illustration below for a typical
example. The Inventory Calculator is a multi-tabbed display comprising the
straightforward tank calculator, the loading/receipt movement calculator, a measurement
units converter and a linear interpolation calculator.

 87 Inventory Calculator window

14.2  Tank Calculator
The tank calculator provides the user with the facility of calculating tank inventory at user
specified conditions.

14.2.1  Viewing Current Tank Data
Select a tank from the drop down list.

The current tank gauging and inventory data will be displayed for the selected tank along
with the API table currently configured for the tank. Some data values are dependent upon
the various selections made in the drop down boxes and may not be visible in some
configurations.
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14.2.2  Entering the User Defined Criteria
The user can enter the following data:
• Product Level
• Product Temperature
• Product Density
• Water Level
• Pressure
• Molecular Mass
• Temperature Coefficient
• Density Correction Factor
• API Table
Some of the data fields are not always applicable. The user interface introduces new data
fields as they are required by the current calculation settings.

The fields that can be edited are clearly marked on the display in a white background.

To calculate data, proceed as follows:
1. Modify one of the editable fields. For example, to view the tank inventory at a

different product level, simply delete or over type the current level reading with the
new one.

2. Press the Calculate button .
 The Inventory parameters will be re-calculated for the new data.

14.3  Movement calculator
The movement calculator provides the user with the facility of simulating a receipt or load
of product to from the tank. Using this tool you can estimate the target level for your
movement and use it to set a simple movement.

 88 Calculating a movement with the Inventory Calculator

1. Prior to entering the movement details select a tank from the list.
 The current tank conditions will be displayed.

2. Select the type of movement to be performed, Load (movement out), Receipt
(movement in), Fill or Empty.
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There are several methods of declaring the movement quantity, including by several
different volumes, weights and masses. In most cases you can declare the movement
quantity as an absolute or relative quantity as well.

There is a more comprehensive description of these options in the Simple Movements
manual (BA01653G).

3. Enter the quantity to be loaded or received, unless the value is already implied by the
movement type.

4. Click the Calculate button  to calculate an estimate of the conditions in the tank
after the movement have been carried out. Should you wish to carry out the
calculated operation, you can enter some pre-alarm offsets and Set Movement to
start the movement. The simple movement facility is fully documented in the Simple
Movements manual (BA01653G).

5. To clear the form and reset it, use the Clear button .

14.4  Interpolation
The tab marked interpolation is a very simple linear interpolation calculation tool. Its
purpose is to allow the user to enter data directly from a set of tank calibration charts and
calculate the volume at an unknown level by linear interpolation.

 89 Interpolation calculation

14.5  Unit conversion
The unit conversion tab contains a simple tool to allow the user to convert a value in one
unit of measure into the corresponding value using different units.

First select the type of value from the options on the left. The user can then select from the
drop down list the measurement units of the starting value, and its numeric value and
then select another measurement unit into which the value should be converted.

Click on the Calculate button to perform the conversion.
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 90 Unit conversion calculation

1. Select the type of value from the options on the left.

2. Select from the drop down list the measurement units of the starting value.

3. Enter the numeric value to convert.

4. Select another measurement unit into which the value should be converted.

5. Click the Calculate button .
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15  Scan Controller
The scanning/polling status of individual gauges may be set using the Scan Controller tool.
To access the scan controller choose Tools → Scan Controller from the main Home Page
menu.

 91 Scan controller

The details of all gauges configured in the database are displayed including the current
Scan Status.

From this page one or more gauges may have their scan state set in one operation.

Selecting Gauges
• To select a gauge, click on it in the table.
• To select more gauges, keep the Control key pressed and click on the block at the start of

the line for the next gauge.
• Alternatively, click on the Select All button to select all gauges in the database.

Setting the scan status
To set the scan status click on one of the buttons along the top of the screen.

• Set Normal Scan
Sets all highlighted gauges to the normal polling status.

• Set Fast Scan
Sets all highlighted gauges to the fast polling status. Fast polling rate is determined by
the Fast Scan Interleave Rate set in the Comms Monitor.

• Set Off Scan
Stops polling for all the highlighted gauges. This affects any connected Mini Receivers,
Multiscans and Datacons as well as the DCC communications.

• Set Manual Scan
Sets all highlighted gauges to the manual polling. Gauges will only be polled when
commanded by an operator.

• Set Offline
Sets all highlighted gauges to the Offline mode in the DCC Comms. This affects only the
DCC communications, any connected Datacons will still poll for gauges but Tankvision
Professional will not poll the Datacons.

The scan status of the all gauges will be automatically updated in the Scan Controller
display after any actions.
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16  TAD Maintenance
The TAD (Tank Additional Data) Maintenance module serves three purposes.

• Tank Mode – Fluctuations in the product level or volume of a tank may generate
Unauthorized Movement or Theft alarms. These alarms can be temporarily disabled on a
per tank basis without the need to turn off the alarm. Tanks may also be switched into
Background Mode, where tank data is only polled for and updated on the Background
Scan. For more information refer to section "Background mode".

• Tank/Product Status – The module is used to specify whether or not Movements are
permitted from a tank based on the status of the tank or the product it contains.

• Tank Pump – Pumps are defined and each pump may be allocated to a tank using the
module.

TAD Maintenance is found under the Configuration → TAD Maintenence in the Home
Page menus.

16.1  Tank Mode

 92 Tank Mode page in TAD Maintenance

Tank modes are used to allow operators to declare that the tank in their charge are in a
particular mode of usage. The modes can then be used to control the way the system treats
tanks while in these modes. For instance, if a site has a regular operation required to drain
free water from the bottom of the tanks, during which time it is expected that the level in
the tank will fall a mode called "Water Drain-off" could be created that when set will
temporarily suppress the Unauthorised Movement Alarms and with a duration of 2 hours.

When the operators determine that a water drain-off is necessary on a particular tank, the
mode can be set, the drain-off commenced. After 2 hours the operators will be reminded
of the drain-off mode through the Alarm Event Viewer, when they set the tank back into
the default static mode the unauthorised movement alarms will be automatically re-
enabled at the new level. As a consequence the operator does not require security
clearance to change the unauthorised movement alarm settings, but can be allowed to
temporarily suppress the creation of unauthorised movement alerts.

There is a fixed Default Tank Mode which does not suppress Unauthorized Movement or
Theft alarms or put a tank in Background Mode. This mode cannot be deleted or altered
but may be renamed to suit your preferences.
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16.1.1  Adding a tank mode
Clicking the Add button will create a New Mode, configure the following attributes:
• Name – Give the mode a unique identifier. This name will be used for selecting the tank

mode.
• Description – Optional description for the tank mode. This is only visible within the

configuration screen.
• Alarms Suppressed – When ticked, tanks that have been set to this mode will not

generate Unauthorized Movement or Theft alarms.
• Background Mode – When ticked, tanks that have been set to this mode will only be

polled for data on the Background Scan.
• Default Duration – A non-zero value indicates that suppressing Unauthorized

Movement or Theft alarms by putting a tank into Background Mode is only intended to
be a temporary measure. An alarm will be raised to warn that the tank is still in a
suppressing/background mode if not disabled within the defined time. Set a time in
minutes (maximum 2880, the equivalent to 48 hours) to raise the alarm after the mode
has been set. Setting this value to 0 will disable the warning alarm. The timer can only
be set if either Alarms Suppressed and/or Background Mode is ticked.

• Exclude Sump from Inventory – When ticked, the tank sump volume entered in the
Tank Metrics page will not be included in the inventory calculations.

• Force product level to zero – When ticked, if the value from the level gauge is invalid
(DN number) or the gauge is at bottom stop then the product level for the tank will be
set to 0 mm. If the Exclude Sump from Inventory flag is also set then the level will
always be set to 0 mm regardless of the value returned from the gauge. This is normally
set for a tank mode where the tank is assumed to be empty.

• Automatic Reversion to Default Tank Mode – When ticked, the tank mode will be
automatically changed to the Default Mode if the product level goes above the Empty
Tank Threshold setpoint for more than 30 seconds. The Threshold value is configured
in the Tank Metrics page.

16.1.2  Background mode
Tanks in Background Mode will only be polled for data on the Background Scan. This can
be useful for reducing system resources used for example on empty or inactive tanks.

When a Tank is in Background Mode, the status on the Tank in the Home Page will
change to Off Scan.

Effect on alarms
When a tank is in Background Mode certain alarms are suppressed.

NOTICE
Danger from deactivated Alarms
If the alarm is enabled in Alarm Configuration the Background Mode will override the
setting and not test for the alarm condition.
‣ If an affected alarm is active when the mode is set, then the alarm will deactivate thus

removing it from the alarm event viewer display.

This feature is particularly useful for sites interested in reducing the number of active
alarms present in the Alarm Event Viewer.

The alarms affected are as follows:
• Programmable Low Alarm
• Programmable Low Low Alarm
• Hardware Low Alarm
• Hardware Low Low Alarm
• Programmable High Temperature Alarm
• Programmable Low Temperature Alarm
• Any Programmable User Defined Alarm based on Low Levels
• Any Programmable User Defined Alarm based on Temperature
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• Programmable Variable Alarm
• [All] Flow Alarms
• Target Level Achieved
• Floating Roof Alarm
• "Simple" movement alarms (not full movements)

• Pre Alarms 1 - 4*
• Target Level Exceeded*

The Unauthorised Movement and Theft Alarms are not suppressed by setting a
background tank mode. When the mode is set the start values are recorded; initialising
these alarms. The alarms will still be evaluated when new levels are obtained, though on a
less regular basis than normal.

Should an Unauthorised Movement or Theft be detected the tank mode shall be
automatically set to the default mode returning the tank to normal scanning and
switching all the alarms back on.

The Unauthorised Movement Alarm and Theft Alarm must be enabled in Alarm
Configuration for this feature to work. If the Tank Mode is also flagged as
suppressing Unauthorised Movement Alarms, then again this feature will not work as
the suppression of these alarms overrides this feature.

Effect on "Full" movements
A tank in a Background Mode can be used in a planned movement. When a movement is
opened on a tank in Background Mode, the mode is automatically changed to the Default
Mode. However, closing a movement on a tank does not automatically change the mode
back again.

Effect on "Simple" movements
When a movement is set on a tank, the mode is automatically changed to the Default
Mode. Closing a movement on a tank will not automatically place the tank back into a
Background Mode.

16.1.3  Deleting a Tank Mode
Highlight the required tank mode and click Delete.

16.1.4  Setting a Tank Mode
Tank modes are applied from the SCADA screens. It is necessary to configure a Tank Mode
Data Entry item. When configured, click on the data entry item and a selection window
will open showing the current tank mode.

 93 Setting a Tank Mode

Select the required Tank Mode from the drop down list. If a suppressing mode is selected
the Tank Mode Timer Alarm is set to the preconfigured Timer value. This may be
ammended if required.

Click OK to accept the changes or Cancel to discard them.

The selected tank mode will be shown in the Data Entry control.
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Access to the Tank Mode settings is controlled by the User security system.

16.2  Tank Status

 94 Configuring Tank Status in TAD Maintenance

There may arise a situation where it is either not possible or desirable to use a tank for
loading or receiving product (e.g. the tank is undergoing maintenance). In this case a Tank
Status can be set to block movements.

The Default Tank Status can not be made to block movements; neither can it be deleted,
but it may be renamed to suit your preferences.

16.2.1  Adding a Tank Status
Clicking the Add button will create a New Status. Configure the following attributes:
• Name – Give the status a unique identifier. This name will be used for selecting the tank

status.
• Description – Optional description for the tank status. This is only visible within the

configuration screen.
• Movements Blocked – When ticked, tanks that have been set with this status will block

Movements from being initiated, however an override option will be offered in the
movements package.
Note: This applies only for "Full" movements.

16.2.2  Deleting a Tank Status
Highlight the required tank status and click Delete.

16.2.3  Setting a Tank Status
Tank statuses are applied from SCADA screens such as Single Tank Overview. It is
necessary to configure a Tank Status Data Entry item. When configured, click on the data
entry item and a selection window will open showing the current Tank Status.
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 95 Setting the Tank Status

Select the required Status from the list and click OK.

The selected Tank Status will be shown in the Data Entry control.

Access to the Tank Status settings is controlled by the User security system.

16.3  Product Status

 96 Configuring Product Status in the TAD Maintenance

There may arise a situation where it is either not possible or desirable to use a product
within a tank (e.g. the product is contaminated). In this case a Product Status can be set to
block movements.

The Default Product Status is fixed: this status cannot be deleted or altered but may be
renamed to suit your preferences, neither can it be made to block movements.

16.3.1  Adding a Product Status
Clicking the Add button will create a New Status. Configure the following attributes:
• Name – Give the status a unique identifier. This name will be used for selecting the

product status.
• Description – Optional description for the product status. This is only visible within the

configuration screen.
• Movements Blocked – When ticked, products that have been set with this status will

block Movements from being initiated, however an override option will be offered in the
movements package.
Note: This applies only for "Full" movements.

16.3.2  Deleting a Product Status
Highlight the required product status and click Delete.
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16.3.3  Setting a Product Status
Product statuses are applied from SCADA screens such as Single Tank Overview. It is
necessary to configure a Product Status Data Entry item. When configured, click on the
data entry item and a selection window will open showing the current Product Status.

Select the required Status from the list and click OK.

The selected Product Mode will be shown in the Data Entry control.

Access to the Product Mode settings is controlled by the User security system.

16.4  Tank Pump

 97 Configuring Tank Pumps in TAD Maintenance

This screen is used to show which pump is currently connected to a tank. There is no
physical control over the pumps from this screen, it is for reference only.

16.4.1  Adding a Pump
Clicking the Add button will create a New Pump. Configure the following attributes:
• Name – Give the pump a unique identifier. This name will be used for assigning the

pump to a tank.
• Description – Optional description for the pump.
• Tank ID – Select the tank that the pump is attached to; this should be left blank if the

pump is not currently attached to a tank.

A pump may only be attached to one tank at a time, however multiple pumps may be
attached to the same tank.

16.4.2  Deleting a Pump
Highlight the required pump and click Delete.

16.4.3  Assigning Pumps to Tanks
Pumps are allocated to tanks using the Single Tank SCADA screens. It is necessary to
configure a Pumps Data Entry item (only one such item is supported on any SCADA
screen).

When configured open the Single Tank Overview for the tank you wish to add a pump to
and click on the Pumps data entry item. A selection window will open showing all pumps
and their current allocation.
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 98 Allocating/deallocating pumps to a tank

Highlight the pump(s) that you want to allocate to the current tank and click OK. If any
pumps are already allocated to a tank they will be removed from that tank as pumps can
only be allocated to one tank at a time.

The selected pump will be shown in the Data Entry control. If more than one pump is
allocated to a tank only the first pump is shown followed by a plus (+) sign to indicate that
there are further pumps allocated to the tank, hover the mouse over the data entry control
to reveal a full list of tanks.

Access to the Pumps settings is controlled by the User Security System.

16.4.4  Removing Pump Allocation
Open the Single Tank Overview for the tank you wish to remove a pump from and click
on the Pumps data entry item. A selection window will open showing all pumps and their
current allocation.

 99 Allocating/deallocating pumps to a tank

Pumps currently allocated to the tank will be highlighted. To remove a pump from the
tank press the Ctrl key and click the pump to remove the highlight.
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