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• Make sure the document is stored in a safe place such that it is always available when
working on or with the device.

• To avoid danger to individuals or the facility, read the "Basic safety instructions" section
carefully, as well as all other safety instructions in the document that are specific to
working procedures.

• The manufacturer reserves the right to modify technical data without prior notice. Your
Endress+Hauser sales organization will supply you with current information and updates
to this manual.
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Change history
BA01701G/01.17
• Valid for software version: 18.0.2 and 18.0.3
• Initial version

BA01701G/02.18
• Valid for software version: 18.1.1
• Changes to the previous version:

Compatibility with Windows 10 and Windows Server 2016

BA01701G/03.22
• Valid for software version: 18.3.2
• Changes to the previous version:

Basic safety instruction updated

BA01701G/04.24
• Valid for software version: 18.3.3
• Changes to the previous version:

Compatibility with Windows 11 and Windows Server 2022. Minor changes to existing
functionality.
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1  About this document

1.1  Document function
This manual should support during the installation of Tankvision LMS NXA86B.

Beside basic PC operating knowledge no special training is needed to perform the Tank
Gauging System operations. Nevertheless it is recommended receiving a training on the
system by Endress+Hauser.

1.2  Symbols

1.2.1  Safety symbols
DANGER

This symbol alerts you to a dangerous situation. Failure to avoid this situation will result in
serious or fatal injury.

WARNING

This symbol alerts you to a potentially dangerous situation. Failure to avoid this situation
can result in serious or fatal injury.

CAUTION

This symbol alerts you to a potentially dangerous situation. Failure to avoid this situation
can result in minor or medium injury.

NOTICE

This symbol alerts you to a potentially harmful situation. Failure to avoid this situation can
result in damage to the product or something in its vicinity.

1.2.2  Symbols for certain types of information and graphics
 Tip

Indicates additional information

Reference to documentation

Reference to graphic

Notice or individual step to be observed

1. , 2. , 3.

Series of steps

Result of a step

1, 2, 3, ...
Item numbers

A, B, C, ...
Views
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1.3  Documentation
For an overview of the scope of the associated Technical Documentation, refer to the
following:
• Device Viewer (www.endress.com/deviceviewer): Enter the serial number from the

nameplate
• Endress+Hauser Operations app: Enter serial number from nameplate or scan

matrix code on nameplate.

1.4  Registered trademarks

1.4.1  Microsoft®, Windows®
Microsoft and Windows are registered trademarks of the Microsoft Corporation

1.4.2  ModbusTM

Modbus is a registered trademark of Schneider Electric USA, Inc.

1.4.3  Java®
Java is a registered trademark of Sun Microsystems, Inc.

1.4.4  Mozilla® Firefox®
Mozilla and Firefox are registered trademarks of the Mozilla Foundation

1.4.5  Android®
Android, Google Play and the Google Play logo are registered trademarks of Google Inc.

1.4.6  iPhone®, iPad®
iPhone and iPad are trademarks of Apple® Inc., registered in the U.S. and other countries.

https://www.endress.com/deviceviewer
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2  Basic safety instructions

2.1  Requirements for the personnel
The personnel for installation, commissioning, diagnostics and maintenance must fulfill
the following requirements:
‣ Trained, qualified specialists must have a relevant qualification for this specific function

and task.
‣ Are authorized by the plant owner/operator.
‣ Are familiar with federal/national regulations.
‣ Before starting work, read and understand the instructions in the manual and

supplementary documentation as well as the certificates (depending on the
application).

‣ Follow instructions and comply with basic conditions.

The operating personnel must fulfill the following requirements:
‣ Are instructed and authorized according to the requirements of the task by the facility's

owner-operator.
‣ Follow the instructions in this manual.

2.2  Intended use

2.2.1  Intended use of Tankvision LMS NXA86B software
Tankvision LMS is a total LNG Tank Storage and Management solution for Peak Shaving,
Receiving and Production LNG facilities. The LMS system has been designed to interface to
all instruments commonly found on LNG storage tanks, and to collect and present the
instrument data through a range of intuitive graphical user interfaces. A typical LNG Tank
will have a wide range of measurement instruments to measure Liquid Level, Liquid
Density, Liquid and Vapour Temperature, Liquid and Vapour Pressure, Skin Temperature
and much more.

Typically each tank would be fitted with an LTD gauge, two further level gauges configured
as a Primary and Secondary, and an Alarm Gauge. The LTD gauge is a servo operated unit
mounted on the tank roof. The purpose of the LTD gauge is to take accurate profiles of
temperature and density throughout the liquid, and whilst not profiling provide
continuous liquid level, temperature and density measurement. The Primary and
Secondary gauges can be either servo and or radar operated units also mounted on the
tank roof. The purpose of these gauges is to provide continuous liquid level measurement,
and average liquid temperature measurement. They provide redundancy on the
measurement of level and temperature. The average liquid temperature is derived from a
multi point temperature sensor device. The alarm gauge is often a servo or radar based
gauge configured to provide volt free contact alarm status to an independent system.

An LMS system can operate in a simple standalone configuration or as a fully redundant
system where security and integrity are of paramount importance. The LMS system has a
flexible and scalable architecture allowing it to be tailored to a number of different
applications easily.

2.3  IT security
Our warranty is valid only if the product is installed and used as described in the Operating
Instructions. The product is equipped with security mechanisms to protect it against any
inadvertent changes to the settings.

IT security measures, which provide additional protection for the product and associated
data transfer, must be implemented by the operators themselves in line with their security
standards.
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3  Incoming acceptance and product
identification

3.1  Incoming acceptance
On receipt of the delivery:

1. Check the packaging for damage.
 Report all damage immediately to the manufacturer.

Do not install damaged components.

2. Check the scope of delivery using the delivery note.

3. Compare the data on the nameplate with the order specifications on the delivery
note.

4. Check the technical documentation and all other necessary documents, e.g.
certificates, to ensure they are complete.

If one of the conditions is not satisfied, contact the manufacturer.

3.2  Product identification
The following options are available for identification of the software:

• Nameplate specifications
• Order code with breakdown of the software features on the delivery note
• Enter serial numbers from nameplates in Device Viewer

(www.endress.com/deviceviewer): All information about the software is displayed.

For an overview of the technical documentation provided, enter the serial number from
the nameplate in the Device Viewer (www.endress.com/deviceviewer).

3.2.1  Nameplate
The information that is required by law and is relevant to the product is shown on the
nameplate, e.g.:
• Manufacturer identification
• Product name
• Order code
• Extended order code
• Serial number
• Barcode

3.2.2  Manufacturer address

Endress+Hauser SE+Co. KG
Hauptstraße 1
79689 Maulburg, Germany
Place of manufacture: See nameplate.

3.2.3  Order code and product version
To find out the version of your software, enter the order code indicated on the
nameplate in the search screen at the following address:
www.products.endress.com/order-ident
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4  Introduction
The system is intuitive and easy to operate.

A default toolbar is provided which is configured to launch the commonly used functions.
All applications including those on the toolbar are also available from the menu bar.

The content of the toolbar can be customised.

The Data Status and Change Dimensions sections below apply to the whole package and
are therefore not repeated anywhere else in this manual.

4.1  Data Status
The status of data is represented by colour and diagnostic codes.

Foreground and background colour are used to denote a variety of different conditions.
• Blue text means that the data is in manual mode.
• Red text on a black background represents an alarm or invalid data. Invalid data will be

displayed using a Diagnostic Number.

Descriptions of the various diagnostic numbers can be displayed by selecting the Help →
Diagnostics menu option.

4.2  Change Dimensions
The Change Dimensions feature allows the user to determine the engineering units that
each of the numeric fields are displayed in.

The Change Dimensions feature is a global setting. i.e. all the pages display data in the
same engineering units.

The Change Dimensions module is launched from the toolbar icon . This will open the
window shown below.

 1 Dimensions
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5  Home Page
The Home Page comprises:
• Menu Bar
• Tool Bar
• Tank Bar
• Status Bar
• Application work space

See the illustration below for a typical example.

 2 Home Page

Within the application workspace there will be a single window for each tank. Each
window contains the key data for all instruments on a particular tank.

In an LNG application there are typically 4 instruments on a single tank:
• Primary Level and Temperature Gauge
• Secondary Level and Temperature Gauge
• Level Alarm Gauge
• Level, Temperature and Density gauge (LTD)

Each window contains a graphic representation of the tank with numeric data fields and a
summary table.

A context sensitive pop-up menu allows the user to send a range of commands to each of
the instruments.

The list of available commands will vary according to the type of instrument.

A number of short cuts exist:
• Double clicking the Primary or Secondary Gauge level bar will launch the Tank Inventory

display.
• Double clicking the LTD Gauge level bar will launch the LTD Detail display.
• Double clicking a row in the data grid will launch the Tank Inventory display for the

Primary, Secondary and Alarm gauges and it will launch the LTD detail display for the
LTD gauge.

When a user double clicks the bar graph representing the Secondary gauge the Tank
Inventory Page will be launched as shown in below.
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 3 Tank Inventory Page

The following changes will be made:
• Primary Gauge Data section will become the Secondary Gauge data.
• Tank Inventory Data will be that calculated from the Secondary Gauge.
• Tank Graphic will be animated from the Secondary Gauge data.
• Flow Rate data will come from the Secondary Gauge.
• Alarm Status will come from the Secondary Gauge.
• Stratification Status will come from the LTD Gauge.

The following will remain unchanged:
• LTD Gauge Data
• Energy Data

5.1  Stratification Detection
For the stratification detection option, the last profile from the LTD is used to determine
the status of the tank. The profile is analysed and a model will determine that the liquid is
in one of the following states:
• Unknown
• Homogeneous
• Stratified

An underlying mathematical model analyses an LTD Profile each time one is performed to
determine whether the tank is Homogeneous or Stratified. At start up, or if the tank status
can’t be determined, it will have a status of Unknown.

A display field in the Home page indicates the status of the tank.
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5.2  Multiple Windows

 4 Multiple Windows

The multiple window functionality is accessed from the Window menu option. There are
three relevant options available:
• New Window – Opens a new window.
• Close Window – Closes the current window (not available on ‘master’ window).
• Annotate Window – Allows you to annotate the caption of the current window so you

can identify it on the windows task bar.

A new instance of the Home Page can be configured to show a different set of tanks to the
first, so you can put your general products tanks on the first page and your LPG tanks on
the second. If you have more than one monitor, you can arrange the home pages on
different monitors for greater clarity. You may have as many windows as you wish.

Closing the application will close all windows. Reopening the application will cause all the
windows to be restored.

5.3  Logging On

5.3.1  Security
Access to the features of the system can be controlled through a user account. The
requirement to log on to the system can be disabled allowing any user full access to the
system. If security is enabled the following sections apply.
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5.3.2  Logging In
1.

 5 Log in

Select Security → Log In... from the main menu bar.
 This will open a login prompt as shown below.

 6 Login Prompt

2. Enter the necessary username and password.
 The details will be checked against entries in the database. If the username and

password are valid the user will be logged on at their designated access level.

Each user account has a designated level of access to each feature. So even if a user is
logged on it does not necessarily mean that they have access to all functions. A user's
level of access is determined by the rights assigned to them by the System
Administrator.

When a user is logged in to the system, the username is displayed in the left most panel of
the status bar as shown below.

 7 Username

5.3.3  Logging Out
Select the Security → Log Out option from the main menu bar.

The system will immediately log out the currently logged on user. This will prevent access
to all functions requiring a logon.

5.3.4  Configuring New User Accounts
Please refer to Security Configuration section of the Configuration manual BA00390G
for further information.

Consideration should be given to new users access rights. Not all users should be
given the highest level of access. The System Administrator should be responsible for
determining who has what rights.

It is recommended that most casual users be given minimal rights to start with. They
can always be adjusted later as users become more familiar with the operation of the
system.
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6  Tank Summary
The Tank Summary page is a simple read only display providing a summary of all the key
data for each tank in a tabular grid style.

For each tank, the display shows:
• Tank ID
• Primary Gauge Level
• Primary Gauge Temperature
• Secondary Gauge Level
• Secondary Gauge Temperature
• LTD Position
• LTD Temperature
• LTD Density
• LTD Status

See figure below for an example of a typical screen.

 8 Tank Summary

Double clicking a tank row in the grid will launch the Tank Inventory Page for that tank.

Data status is also supported through the normal means.
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7  Tank Inventory
The Tank Inventory page is a simple read only display providing an overview of all the
main tank gauging and tank inventory data in a simple graphical view.

For a selected tank the screen shows:
• Tank Id
• Primary Gauge Position
• Primary Gauge Level
• Primary Gauge Temperature
• LTD Position
• LTD Level
• LTD Average Temperature
• LTD Average Density
• Gauge Alarm Status
• Programmable Alarm Status
• Total Observed Volume (TOV)
• Usable Volume
• Ullage Volume
• Total Mass
• Level Flow Rate

See figure below for a typical screen.

 9 Tank Inventory

The inventory data is based upon the Primary Gauge Level and the Last Average Density
measured by the LTD gauge.

The TOV is a direct interpolation from the tank strapping table using the Primary Gauge
Level. Similarly, the Usable and Ullage volumes are calculated from the Minimum and
Maximum Operating Volumes.

An alarm condition is represented by colour. An inactive alarm is shown as green and an
active alarm is shown as red.

A text description of the highest priority alarm is also displayed.
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Data status is also supported through the normal means.

8  Element Temperatures
The Element Temperature page is a simple read only display showing the temperature
and or status of each of the temperature elements within a multi-spot or multi-element
averaging thermometer for both the Primary and Secondary Gauges. In addition the profile
of the temperature points are plotted on to an adjacent graph. See figure below for a
typical screen.

 10 Element Temperatures
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9  Manual Data
Normally tank data is collected from the field instruments automatically.

Where primary data values are no longer available due to a gauge fault or similar, data
values can be switched from automatic mode to manual mode.

When in manual mode the data value has to be provided by the operator.

Data that is in manual mode is normally displayed with a green foreground on black
background.

9.1  Launching the Manual Data Module
In order to enter Edit mode and modify manual data values you must be logged on with
the correct access rights. If you are unable to modify manual data please check with your
system administrator.

Select the Manual Data option from the Configuration menu. A typical display is shown
below.

 11 Manual Data

A list of all tanks will be displayed on the left, together with the manual data entry fields
for the selected tank.

By default a reduced set of the most common fields will be displayed. To view the
additional fields for a tank click on the Advanced  button.

The window display will extend to show the advanced parameters as shown below.
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 12 Advanced Parameters

By default any changes to the manual data for a tank will apply to ALL gauges on that
tank. The individual gauges assigned to a tank can be viewed and edited by clicking on the
ShowHide Gauges  button.

The window display will change as shown below.

 13 Gauges shown

In this mode the manual data can be configured for individual gauges.

9.2  Entering Manual Data
Select the required tank/gauge from the list. Edit the value.

If the variable is not already in manual mode tick the Enabled tick box. When saved this
will switch the value to manual mode. Note that observed density and observed



Manual Data Tankvision LMS NXA86B

20 Endress+Hauser

temperature are enabled and disabled together, (i.e. you cannot put the density into
manual mode without also providing a suitable observed temperature).

After all required data has been entered, press the Apply button to save the changes to the
database.

Any problems in writing the data to the database will be reported to the user via the Status
bar of the display.

Press the Cancel button to discard any changes and or exit the application.

9.3  Putting a Variable into Manual Mode
Manual data can be modified regardless of whether the value being modified is in manual
mode or not. When a parameter is switched to manual mode the current data stored in the
manual value will be utilised. The inventory data will also be calculated using values that
are in manual mode.

Parameters can be individually set to manual mode so that as much data that is available
from the instrument can continue to be collected automatically. For example, if Product
Temperature is set to manual and Product Level is set to automatic, the Product
Temperature used to calculate tank inventory will be the manual value and the Product
Level will be the automatic value.

There are essentially two techniques to putting a parameter into manual mode:
• Checking the tick box adjacent to the parameter in the Manual Data entry module.
• Selecting the Manual Data option from the pop-up menu on the tank graphic view.

Either has the same effect.

If the pop-up menu is used, the current manual data will replace the automatic value.
If the current manual values are incorrect you would need to use the Manual Data
module to update them.
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10  Gauge Commands
All appropriate screens support the ability to send a gauge command. The gauge
commands are sent through a context sensitive pop-up menu.

The menu is loaded by right mouse clicking on something related to a particular
instrument.

For example:
In a Grid View, right mouse clicking on a row in the grid will invoke the pop-up menu. In a
graphic view, right mouse clicking on any of the instrument data will invoke the pop-up
menu.

The entries that appear and or are enabled in the pop-up menu will be dependent on the
type of instrument selected. For example the commands supported by the LTD gauge are
different from those supported by a servo gauge.

See the figure below for a typical pop-up menu for a servo gauge.

 14 Popup Device Commands

Some of the commands may require further details and as such another dialogue will
appear where it is required. For example, the Top Scan profile supported by the
6280/6290 LTD requires a start, stop and interval specifying.

10.1  Top Scan
The LTD Gauge has the ability to carry out a Top Scan profile. This is a user definable
profile to allow the user to perform a profile at a position of interest.

Right click over the LTD display and select Top Scan from the menu as shown below.
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 15 Top Scan

The following screen will appear.

 16 Profile screen

From here the user defines the profile parameters and requests the Profile to be carried
out. The profile will begin at the Start Position and record data at every Interval distance
until the Stop Position is reached. When the data is logged at each Interval, it will wait
for the users specified Wait Time before actually recording the data.

When the profile is complete, the data can be displayed in the LTD Profiles Screen (refer to
"LTD Profiles").
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11  Inventory Calculator
The system comes as standard with an Inventory Calculator.

The primary purpose of the Inventory Calculator is to provide the user with a means of
calculating tank inventory for conditions that do not currently exist.

For example, it could be used as a "what happens if" calculator, if a tank were to receive or
load X litres of product what would the final tank conditions be.

It may be used as a simple planning tool prior to the loading and/or receipt of product.

11.1  Launching the Inventory Calculator
Press the Inventory Calculator tool bar button .

The Inventory Calculator module will be loaded. See the illustration below for a typical
example. The Inventory Calculator is a multi-tabbed display comprising the
straightforward tank calculator, the loading/receipt movement calculator, a measurement
units converter and a linear interpolation calculator.

 17 Inventory Calculator window

11.2  Tank Calculator
The tank calculator provides the user with the facility of calculating tank inventory at user
specified conditions.

11.3  Viewing Current Tank Data
Select a tank from the drop down list.

The current tank gauging and inventory data will be displayed for the selected tank along
with the API table currently configured for the tank. Some data values are dependent upon
the various selections made in the drop down boxes and may not be visible in some
configurations.
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11.4  Entering User Defined Criteria
The user can enter the following data:
• Product Level
• Product Temperature
• Product Density
• Water Level
• Pressure
• Molecular Mass
• Temperature Coefficient
• Density Correction Factor
• API Table
Some of the data fields are not always applicable. The user interface introduces new data
fields as they are required by the current calculation settings.

The fields that can be edited are clearly marked on the display in a white background.

To calculate data, proceed as follows:
1. Modify one of the editable fields. For example, to view the tank inventory at a

different product level, simply delete or over type the current level reading with the
new one.

2. Press the Calculate button .
 The Inventory parameters will be re-calculated for the new data.

The user configurable data will be validated prior to doing the calculations.

For example, if the level goes beyond the operating extents of the tank a warning will be
generated in the status bar along with an audible sound. The description of the warning
should be sufficient to determine the error. In most cases the maximum or minimum limit
will be displayed where applicable.

11.5  Interpolation
The tab marked interpolation is a very simple linear interpolation calculation tool. Its
purpose is to allow the user to enter data directly from a set of tank calibration charts and
calculate the volume at an unknown level by linear interpolation.

 18 Interpolation
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11.6  Dimensions
This feature allows the user to convert from one engineering unit to another.

 19 Dimensions

1. Select the parameter, e.g. Level.

2. Enter a level in a specified unit, e.g. mm.

3. Select a new unit to convert to, e.g. f-i-s.

4. Click  and the level will be converted to f-i-s.

11.7  Composition
If you have licensed the composition option, you will be able to use the Composition tab of
the Inventory Calculator module to estimate the resultant tank composition of a cargo
being unloaded into a tank.

 20 Composition
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To use the calculator proceed as follows:

1. Click on the Composition tab and select the tank you are interested in.
 The application will automatically populate the form with the current tank

composition and mass.

2. Alter the current tank composition information, if necessary, and enter the
composition of the cargo and its mass.

3. When you have entered the data, click  to see the resulting composition.

4. Clicking  will reset the Window to how it was when you first selected the tank,
discarding any changes you have made.

5. Save will write the calculated values to the database, updating the tanks live
composition details, this will save you re-keying the calculated data into the
Composition module.
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12  LTD Gauge Detail
The LTD Gauge Detail page allows a more advanced view (and control) of the data
returned by the LTD.

For a selected tank the screen shows:
• Tank Id
• LTD Gauge Position
• LTD Gauge Level
• LTD Gauge Average Temperature
• LTD Gauge Average Density
• Last Profile Date/Time
• Last Profile Average Temperature
• Last Profile Average Density
• LTD Gauge Status
• LTD Sensor Status
• LTD Alarm Status

See figure below for a typical screen.

 21 LTD Gauge Details

Toolbar buttons provide access to related functions.

Gauge Commands are supported via a context sensitive pop-up menu. Certain commands
(Raise, Lower and Stop) are also available via buttons, allowing faster control.

When the LTD is moving in the tank, the direction and speed of travel are indicated by a
set of arrows to the right of the tank picture as shown below.
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 22 Direction Indication

The speed is indicated by the number of arrows displayed, one for slow, two for medium
and three for fast speed.

When Raise or Lower commands are issued to the gauge, the initial speed will be slow
speed. Sending more Raise/Lower commands will increase the speed first to medium, and
then to fast.
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13  LTD Profiles
There are two profile viewers available in the application. The Single Profile Viewer
displays a single profile at a time. The Profile Viewer allows multiple profiles to be
displayed simultaneously allowing for an evaluation of how the profile has changed over
time.

13.1  Single Profile Viewer
The Single Profile Viewer comprises a list of all the available profiles for a selected tank, a
table of profile data and two graphs - one to display the Temperature Profile and the other
to display the Density Profile.

The list of available profiles is a tree view; each branch of the tree can be expanded to see
individual profiles performed on a particular day.

An entry appears in the list for each day in which at list one profile was performed. Each
profile is identified by the date and time it was performed.

See figure below for a typical screen. To view the profiles for a particular tank, select that
tank from the drop down list.

 23 Single Profile Viewer

To view a profile proceed as follows:

1. Scroll the list to find the day on which the profile was performed.

2. Expand the branch to see all the profiles performed on that day.

3. Select the profile time required.

4. To print the page select the File → Print option.

13.2  Profile Viewer
The Profile Viewer comprises a list of all the available profiles for a selected tank, a table
of profile data, two graphs - one to display the Temperature Profile and the other to
display the Density Profile and a details panel displaying details of the profile at a selected
level.

The list of available profiles is a tree view; each branch of the tree can be expanded to see
individual profiles performed on a particular day.
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An entry appears in the list for each day in which at list one profile was performed. Each
profile is identified by the date and time it was performed.

See figure below for a typical screen.

 24 Profile Viewer

To view the profiles for a particular tank, select that tank from the drop down list. To view
a profile proceed as follows:

1. Scroll the list to find the day on which the profile was performed.

2. Expand the branch to see all the profiles performed on that day.

3. Right mouse click on the profile time required, a pop-up menu will appear.

4. Select Add Profile from the list, the data for that profile will be plotted onto the
graphs.
 The selected profile time will change colour representing the colour that the

profile is plotted on the graph.

To add further profiles to the same graph repeat the above process. Each profile will be
plotted as a different colour.

Up to 6 profiles can be plotted onto the same graph.

To print the selected profiles select the File → Print option.

To view the profile data in a tabular display, click on the Data tab. The display will change
to a tabular display as shown below.
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 25 Profile Data
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14  Composition
The composition of the LNG stored in the vessels becomes important if you are using
corrected volumes.

The following calculation methods make use of the composition information:
• Klosek-McInley
• COSTALD
• COSTALD-Tait
• Enhanced COSTALD

The composition features of the system are licensed separately from the main application,
and are therefore not available in all systems.

Using the composition screen you can specify the molar percentages of up to 8 species;
these values will be fed into the Inventory calculation routines in order to derive a density.

The composition screen (see below) is launched from the Configuration → Chemical
Composition menu. You then select the tank whose composition you want to view or alter
from the list on the left-hand panel.

 26 Chemical Composition
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15  Alarms and events
Acknowledgement of Alarms and Events is probably one of the most common operator
actions. All Alarms and Events are displayed on the Alarm Event Viewer screen which is
displayed automatically when Windows starts up. This displays all unacknowledged
alarms/events and any acknowledged alarms that are still active.

The Alarm Event Viewer may be configured as a "floating" pop-up style display, or docked
to one edge of the screen.

15.1  What Happens When an Alarm Occurs
An event will be generated by the system and shown in the Alarm Event Viewer screen.

 27 Alarm Event Viewer

An audible signal, if enabled will be generated. This may be in the form of an internal
buzzer, sound card or external klaxon dependent on the options fitted. A voice message
can be played via the PC sound card if this feature has been enabled.

Alarms are silenced when they are acknowledged. If security is enabled a user must be
logged on with the correct privileges to acknowledge the alarm.

All alarms and events are logged to the database. An alarm history view can be used to
look at all alarms and events that have occurred.

When an alarm is acknowledged the date and time is logged to the database. The logged
on user acknowledging the alarm is also logged.

15.2  Acknowledging Alarms
The Alarm Event Viewer displays details of alarms (refer to figure "Alarm Event Viewer").

The status of the alarm is indicated in the leftmost and rightmost columns:
• Red

Unacknowledged and un-silenced. For the 'Active' alarm (see Alarm Event Viewer
Options) this will be flashing.

• Light Blue
Silenced, but unacknowledged.

• Green
Acknowledged.
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To silence or acknowledge an alarm it is first necessary to select it by clicking on the row
with the mouse. Once the alarm is selected (indicated by the backgrond colour turning
blue) it can be silenced or acknowledged. If security is enabled, it is necessary to be logged
in to silence or acknowledge an alarm.

The selected alarm can be acknowledged by clicking the Acknowledge Alarm button ( )
or using the keyboard shortcut (see Alarm Event Viewer Options).

The selected alarm can be silenced by clicking the Silence Alarm button ( ) or using the
keyboard shortcut (see Alarm Event Viewer Options).

It is also possible to acknowledge or silence either single or multiple alarms by clicking on
the list of alarms using the right mouse button. This will bring up a menu of options as
shown below.

 28 Right-click Menu

15.3  Event History Viewer
The Event History Viewer can be launched either by clicking the relevant button on the
toolbar on the home page, or by selecting View → Events from the menu of the Alarm
Event Viewer.

 29 Event History

By default all events from the current day are displayed. The events displayed can be
filtered by raised date, raised device, acknowledged date and acknowledged user. For
clients connected to multiple servers it is also possible to specify the server from which the
events are to be taken. These settings are stored when the Event History Viewer is closed
and used as the defaults the next time the Event History Viewer is launched.
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16  Reports
The system comes with a standard set of tank gauging and inventory reports. The reports
have been created with Seagate Crystal Reports. Reports can be customised according to
your requirements. Please contact Endress+Hauser for further details.

16.1  Loading the Reports Module
To access the reports, proceed as follows:

‣ Choose File → Reports from the main Home Page menu.

 30 Reports window

• Group Selection
Prints a report showing a summary of the tank farm contents of a particular group of
products (e.g. Distillates).

• Product Selection
A report showing a summary of all tanks containing a particular product (e.g. Jet A1).

• Standard Inventory
Report Shows a standard selection of inventory data for each tank on the farm.

• Standard Summary Report
Summarizes the inventory of products for all tanks by product.

• Gauge Configuration
Produces a list of configuration items for the gauges on the farm. Useful for
documenting the configuration of your hardware.

• Tank Configuration
Lists the configuration settings for your tanks. Use for documenting the configuration of
your site.

• Custom Print
Allows the selection of a report produced by a third party, to be executed by the Tank
Gauging system. You can select a RPT file from the drop down list box.

• Preview
Displays a copy of the selected report on the computer screen.

• Print
Prints the report to your default Windows printer.
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17  Trending
Key Features:
• Multiple simultaneous displays on one graph
• Independent or shared axes for each process variable
• Display grid for better reading
• Data cursor for reading trend values
• Supports dynamic multi-dimensions
• Drill down into data with Zoom function
• Scroll backwards and forwards in time
• Operator programmable Y axis extents
• Operator programmable time base
• Ability to save multiple trend templates
• Ability to "Publish" trend templates for use on other networked PCs
• Simultaneously view multiple trend templates

17.1  Trending and data logging
The system comes as standard with a trending package. A Trend Logger service will log
trend data to the system’s hard drive.

There are three user interfaces for displaying trend data:
• Real-time – Shows the current tank gauging parameters over a maximum of the last

12 hours.
• Historical – Provides a graphical plot of tank gauging parameters.
• Historical (Tabular) – Provides the "numbers" from the Historical graph, for export to

other systems.

17.2  Real-time trending
The real-time trending function combines the ability to review up to the last 12 hours
worth of historical trend data with current real-time data.

17.2.1  Starting-up real-time trending
Either:
• Click the toolbar button  on the Home Page.
• Select View → Real-time Trending from the Home Page menus.
• Select Real-time trending from the Service Manager menus.

The trending parameter screen opens, as shown below.



Tankvision LMS NXA86B Trending

Endress+Hauser 37

 31 Real-time trending parameter selection

At its simplest the process of displaying trend data consists of selecting which tank
parameters you want to view and the length of time over which you want to view these
parameters. The real-time trend view is simpler than the other screens as the time frame
for the view is always from now to a variable number of hours in the past.

17.2.2  Real time plot data
The first parameter input is the period that you want to plot on your graph, see figure
below.

 32 Entering plot intervals on single server system

The Interval is the number of hours into the past you want to view; the maximum possible
is 12 hours.

The Plot Interval is the time (in seconds) between successive data points on the graph; the
maximum interval is 900 seconds – there is not usually a need for finer plot interval than
30 seconds unless you have altered the configuration of your trending service.

17.2.3  Other configuration options
For details of the common configuration options, refer to section "Common trend
configuration".

Redundant system options
On a redundant server setup, when running the trending client on a client system there is
the additional option of choosing the source Servers as in figure below. You can choose
either of the pair of redundant servers, or Automatic which uses the server the Home
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Page is currently connected to as the data source. Additionally the option Attempt to
patch missing data using the other server may be employed if the selected server has an
incomplete data set for the period of the plot.

 33 Entering plot intervals on a redundant server system

The patching mechanism fills in gaps in the data set of the first server using the data from
the other server. If both servers have holes in their data at the same time, which is typical
of a field instrument problem in the field, then the gap remains. The facility is only useful
when one of the servers has been down during the trend plot period.

17.3  Historical Trending
Historical trending is similar to real-time trending, in that the aim is to produce a plot of
tank gauging data over a period of time. However, it differs in that the data presented is
not live (i.e. it does not scroll to the left) and there is no limit of 12 hours to the period
that can be plotted.

17.3.1  Starting-up historical trending
Either:
• Click the toolbar button  on the Home Page.
• Select View → Historical Trending from the Home Page menus.
• Select Historical trending from the Service Manager menus.

The trending parameter screen opens, as shown below.

 34 Historical trending parameter selection
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17.3.2  Historical plot data
In order to identify the period of the data to be plotted, a Date/Time Start, Date/Time
End and Plot Interval must be specified. The start and end time is self-explanatory and
the Plot Interval determines the time between neighbouring points on the plot. The
maximum Plot Interval is 900 seconds.

 35 Entering data set selection for historical trending plot

Large sets of data take a long time to plot. A month’s worth of data, plotted at
5 second intervals for 20 fields, will take a long time to compile the data for your
graph.

The default configuration of the trending server is to delete trending data after
90 days. Selecting a time period older than the data available on the server will result
in an empty graph.

17.3.3  Other configuration options
For details of the common configuration options, refer to section "Common trend
configuration".

Redundant system options
If the system is a redundant one there are some additional options available, shown in
figure below.

 36 Entering a data set selection for a historical trending plot on a redundant system

It is possible to select a specific Server as the source of the data – or Automatic, which will
choose whichever server the Home Page is currently using as its data source. The Attempt
to patch missing data using the other server option allows gaps in the source server’s
data to be filled with data retrieved from the redundant cohort.

17.4  Historical Trending (Table)
For most purposes the graphical views of the trend data provided by Real-time and
Historical for visualising the activities on a tank farm are sufficient. Should further analysis
of the underlying data be required, the tabular view is provided, the main function of
which is, to allow data to be exported in a format where it can be consumed by other
systems.
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17.4.1  Starting-up Historical Trending (Table)
Either:
• Click the toolbar button  on the Home Page.
• Select View → Historical Trending (Table) from the Home Page menus.
• Select Historical Trending (Table) from the Service Manager menus.

The trending parameter screen opens, as shown below.

 37 Tabular historical trending data selection

17.4.2  Historical trend data selection for tabular view
The selection process for the tabular data is very similar to that of the graphical view (refer
to section "Historical plot data"), the only difference is that you can choose how the data is
reported.

Storage of tank gauging data trends
The trend data is collated and stored on the server computer, by the trending service. The
service performs two tasks: it gathers the live tank gauging data and stores it in files on
the computer, and it serves the data it has gathered to the client applications when
requested to do so.

The method employed to gather the data is to periodically scan the available tank gauging
data (typically every 10 seconds) and record just the parameters that have changed since
the last 10 second scan. Taking a tank’s product level as an example, if the product level
hasn’t changed since the last scan nothing will be recorded for the tank at this scan. This
has a consequence on the data presented in the tabular historical view.

Selection of historical data
The common trend data selection options apply to this view of trend data (refer to section
"Common trend configuration").

Additionally, there are 3 options presented when selecting the historical trend data
selection, which cause the data returned in the tabular view to vary. The selection of these
might influence the statistical value of the information.
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Option:
• Logged Values Only

Process variables that don’t contain a value in the data record are left blank.
• All Implied Values

The blank records which appear in the Logged Values Only data selection are filled with
the last known value from previous scans.

• Interpolated Values
The blank records are which appear in the Logged Values Only data selection are filled
with a value synthesised using linear interpolation from the real values before and after
this time record.

 38 Tabular view of historical trend data

17.5  Common trend configuration
Many of the techniques used to design a trend plot are common to both Real time,
Historical and to a certain extent Tabular views of trending data. Those techniques are
described here.

17.5.1  Shared axes
If you are plotting related pieces of information it is often desirable to plot them on a
common axis so you can compare the values of the plot lines at various points in time.

For instance if you were plotting a tank’s product level and free water level together you
would plot both on the same axis as you would expect to see the water level some way
below the product level. If you plot them on separate axes and use the auto-scale option
you will typically see the water level as a flat, horizontal line in the centre of the plot, with
the product level fluctuating above and below it.

By using a shared level axis you will get a free water level at the bottom of the plot with
the product level fluctuating above it and in a scale with the values.
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17.5.2  Adding a shared axis
To create a shared axis click Add. This creates a new axis, initially of type level and named
New Axis as shown below.

 39 Creating a new shared axis

Change the name of the axis by entering a suitable name in to the Caption text box and
select the appropriate type for your axis. If you leave the Auto Scale option ticked the axis
will be scaled to fill as much of the plot area as possible to fit the range of values in the
trending data. This can have the effect of making small fluctuations appear much larger
than they are! If you decide not to auto scale your axis, untick the option, but enter suitable
minimum and maximum values for the axis.

17.5.3  Adding fields
There is no limit to the number of fields that can be displayed, however adding large
numbers to the same trend template can make it difficult to interpret the data. It is better
to create several templates with less trend items on each.

Click the Add Field button to add a trend item, as shown below.

 40 Adding a field to the trend plot

Select a Tank from the drop down list, then select the process variable for the tank to be
trended.

If available, a Shared Axis can be used for 1 or more process variables by checking the
box and selecting the required shared axis from the drop down list. N.B. only Shared
Axes relevant to the process variable being trended will be shown in the list, i.e. a
Temperature axis will not be shown for a Level trend process.

Optional maximum and minimum values for the y axis can be entered if required. The
smaller the range between the minimum and maximum values, the more detail that can
be seen. To enter maximum and minimum values it is first necessary to ensure that a
shared axis is not being used and to uncheck the Auto box for the field.

Repeat the procedure to add further trend fields.

Click on the  button to remove a trend field from the list. The figure below is an example
of a trend template.
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 41 An example trend field screen

Line colour and style
The colour and style of each plot line can be customized for easy identification. Click the 
button at the end of the line to open the style pallette shown below.

 42 Setting the colour and style of a plot line

Select the style and colour you desire and click the OK button. Click Use Defaults to return
to the default style selection.

The Trend Display will be configured to display the data requested.

Viewing the trend graph
Once the fields have been configured you can display the plot by clicking the back button

.
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 43 An example trend plot displaying a busy set of tanks

17.5.4  Finding a value on a trend
The values of process variables at a given point in time can be determined when the
selection mode of the graph is not None. To change the selection mode of the graph, click
File to return to the Info screen and select the Advanced… button. From the window that
opens, select Selection Mode and then the required selection mode.

 44 Selection Line Style screen
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 45 Select the required selection mode

This will be one of the following values:
• Default – Uses the Default selection mode (does not change the line colour and style,

you need to click Use Defaults to set these to the default state).
• None – It is not possible to select a time on the graph and the value of process variable

values is not displayed.
• Fixed Time – A time can be selected on the graph and the corresponding process

variable values will be displayed on the left hand side of the display. As new values are
added to the graph, the line indicating the selection will scroll across to the left,
remaining at the same time.

• Fixed Location – A time can be selected on the graph and the corresponding process
variable values will be displayed on the left hand side of the display. As new values are
added to the graph, the line indicating the selection will remain in the same place with
the process variable values scrolling past it.

If the Selection Mode is not None, the current selection can be moved backwards and
forwards in time using the left and right arrow keys. To change the selection by a larger
amount, hold down the shift key whilst using the left and right arrow keys.

17.5.5  Zooming in to more detail
The trend module allows the user to drill down into the trend data and view trends in more
detail. If the current Selection Mode is not None, it is first necessary to put the graph into
zoom mode by clicking the Zoom  toolbar button.

Identify the area of the trend where you require more detail
Using the mouse draw a box around the area of interest by pointing and clicking the left
mouse button. While holding the left mouse button down drag the mouse pointer to the
right or left and you will see a sizable box appear. Extend this box around the area of
interest and release the mouse button.

The system will zoom in to the area selected. You will notice that horizontal and vertical
scroll bars appear allowing you to move around the data at the current zoom level. You can
zoom in further as required using the same technique.

17.5.6  Zooming out
To exit zoom mode and return to selection mode, click the Undo Zoom  toolbar button. It
will now be possible to select a time on the graph when it is clicked instead of identifying
an area to be zoomed in on.

17.6  Trend templates
The selection criteria and display options you specify to create the trend data views can be
saved and then recalled in order to quickly recover the effort put in to devise the views.

Templates contain the selection criteria, line colour and style information and can be saved
either as a file on the computer’s hard disk drive or centrally in the tank gauging database.
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17.6.1  Saving a trend template
Saving a template places an MTTRT file on the computer's hard disk drive. A template once
saved will only be accessible from the computer it is saved on.

From the trend parameter page, click Save or Save As.

17.6.2  Publishing a trend template
Publishing the template is similar to saving it, except that the file is stored inside the tank
gauging database on the server (or servers, if the system is redundant). Once published the
template is accessible from all computers in the tank gauging system's network.

From the trend parameter page click Publish.

17.6.3  Opening a trend template
On the trend parameter page click Open.

 46 Opening a trend template

The system offers three options:
• Recent Templates – A list of recently used templates.
• Computer – Offers a facility to browse the computer's hard disk for previously saved

MTTRT files.
• Published Templates – Presents a list of all templates that have been published.

17.7  Printing trend data
If a hard copy of the trend graph is required, after selecting the view required, select Print
from the trend parameter screen. A preview of the report will be shown, from which the
output can be directed to a printer.

Any time selection or zoom you have applied to the graphical view will be replicated
in the print out.
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17.8  Exporting trend data
The Real Time Trending and Historical Trending (Graph) can be used to export trend data
in either graphical or .CSV format, Historical Trending (Table) module can only be used to
export trend data as a .CSV file. Once a template has been set up for trending select Export
from the configuration screen.

The following screen will be displayed for Real Time Trending and Historical Trending
(Graph):

 47 Exporting data from the trend viewer

17.8.1  Exporting Graphs
To export the data as a graph select Export Graph and click the Export button.

The normal Windows file save dialog will ensue. The option to Include selected variables
will add the selection point and values of the plots at the given time, as shown below.
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 48 Export with included selected values

17.8.2  Exporting Data
To export data values only select Export Data.

Historical Trending (Table) can only export data so there is no option to export a
graph.

 49 Export trend data options

Export Headers
If this option is checked the first data record in the exported file will contain the headers
from the table instead of data.

Data
This option controls how the data values are determined, for a discussion of the options
refer to section "Historical trending (table)".
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Data Format
This option controls the way that data is formatted.
• Exporting the trend data as Formatted Data means that the contents of the CSV file will

exactly match the data displayed in the table (Note however, that if the CSV file is
opened using Microsoft Excel, the application may reformat the data before it is
displayed).

• Exporting the trend data as Raw Data in Base Units means that the contents of the CSV
file will contain the raw data from the trend data file. This means that formatting
information (such as number of decimal places) and value translations (such as Alarm
Status) will not be exported and the CSV file will just contain numeric data.

• Exporting the trend data as Raw Data is the same as the previous option except that
fields which contain data which can be displayed using different units (such as levels,
temperatures etc.) will have their values converted using the currently selected units for
that type of field.

Click the Export button, select a file name and location and then Save.

17.9  Options
By selecting the Options button you can control and delete Published Templates and set
the Default Options for plotting trend graphs.

 50 Trend viewer options

17.9.1  Pinning templates
Templates may be pinned to the top of the list to enable them to be easily located.

There are 2 ways to pin templates:
• Right click the template and click Pin to list.
• Hover the mouse over the required template and click on the pin icon.

Templates can be unpinned from the list by clicking on the unpin icon, which is
permanently displayed on pinned templates.
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17.9.2  Deleting Templates
Published templates that are no longer required may be deleted.

To delete a template click the template to highlight it and click the Delete button. Multiple
templates can be deleted at the same time.

 51 Deleting a published template

17.9.3  Graphing Options
The Graphing tab enables the user to customise the appearance of the default Selection
and Series traces.

 52 Defining the default style of series on graphs

Selection
• Colour – Select the default colour of the vertical selection line.
• Line Style – Select the default style of the vertical selection line.
• Selection Mode – Choose the default selection mode for the graphical trend

representations. For more details on selection modes refer to section "Finding a value on
a trend".
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Series
The trend viewer is supplied with a single Series Default configured. The settings for this
can be altered as follows:
• Colour – Selects the colour of the line plotted for the series.
• Text Colour – Selects the colour used to display the text on the key.
• Line Style – Sets the style of the line plotted for the series.

Additional series defaults can be added, click Add and configure in a similar way.

If your plot contains more tank gauging parameters than you have defined default series
styles for, the pattern of defaults is repeated from Series 1 onwards.
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18  Advanced device commands
Device commands can be gauge specific and therefore dependent on the gauge type.

For instance for Enraf gauges the following functions are supported:
• Dipping

Provides the various interface measurement modes such as Find Water Interface, Find
Product Interface, and Density Dipping features.

• Displacement
Provides gauge displacer control functions.

• Test Gauge Alarm
Provides the ability to auto-test the alarm set points of the 873 radar gauge.

• Maintenance
Allows the user to set the reference level of the gauge.

• Gauge Items
Is a general tool allowing the user to read or write any of the gauge items and view the
returned data and or responses.

Other gauges may support different commands and configuration functions.

18.1  Launching Advanced Device Commands
‣ From the Home Page menu, select Tools → Advanced Device Commands.

 The application will automatically select the primary gauge for the tank, where the
tank has more than one gauge. Users can subsequently select another gauge to
operate on by clicking on the "+" next to the tank, and selecting the gauge duty.

 53 The advanced gauge commands screen
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18.2  Sending commands
1. Select the tank from the list in the left hand panel. Expand the tank with the "+"

symbol (select the gauge in a multi-gauge setup).
 The commands supported by the gauge will be available.

 54 Executing a gauge command

2. Select the appropriate command from the list.

3. Set any required parameters and click the button to send the command. Information
regarding the progress of the gauge’s operation will be reported via the panel at the
bottom of the window.

18.3  Dipping functions
These generally apply to the Enraf 854 series of servo tank gauges, as shown below.
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 55 Dipping commands with the advanced gauge command utility

18.3.1  Product Measurement Mode
• Sends the I1 gauge item.
• Displays the status of the gauge throughout.
• The gauge will remain at I1 until the user commands the gauge otherwise.

18.3.2  Density Dip
This has two options:
• Tank Profile
• Interface Profile

‣ Select the correct option and Click the Apply button.
 The Command will be carried out.

18.3.3  Water Measurement Mode
• Sends the I3 gauge item.
• Displays the status of the gauge throughout.
• The gauge will remain at I3 until the user commands the gauge otherwise.

18.4  Displacer functions

18.4.1  Lock Test
Lock the displacer at a specified level, see figure below.
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 56 Advanced gauge command lock test

• Uses the MZ item to set the lock level, followed by the LT command.
• The user must provide the level at which the displacer will be locked.

18.4.2  Unlock
• Unlocks the gauge from the locked or calibrate position.
• Sends the UN gauge item.

18.5  Verify Calibration
Verifies the calibration of the instrument. The displacer will be raised into the calibration
chamber of the gauge.
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 57 Calibrating a servo gauge

• Uses the CA gauge item.
• The gauge will remain in the calibrate mode until told to do otherwise by the user.
• Stores and displays start level.
• Displays the various state changes that occur.
• Press the unlock button to have the displacer return to Product Measurement Mode.

18.6  Maintenance
Set gauge registers to adjust the device’s configuration.
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 58 Entering maintenance mode for a gauge

18.6.1  Set the gauge to a new level dip
If the gauge differs from an operator's manual dip it is normal to re-align the gauge to the
operator's dip.

The user must provide the new level dip and the password to access the gauge.

This function uses a whole sequence of gauge items as follows:

1. Set the password level using W2 gauge item.

2. Set the reference level using the RL gauge item.

3. Accept the reference level using the AR gauge item.

4. Exit and re-initialise the gauge using the EX gauge item.

5. Select the tank requiring the new level dip.

6. Enter the new gauge level.

7. Press the Dip button.

While the above sequence of actions shall take place, the status of each transition is
displayed.

When the EX command is finally issued the gauge data may disappear for a short
time while the gauge re-initialises itself. After re-initialisation the gauge level should
read the new value.

18.7  Gauge Items
This feature applies to Enraf and Motherwell gauges only.
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 59 Reading gauge items using advanced gauge command

NOTICE
The use of this feature requires knowledge of the specific gauging equipment and its
configuration.
‣ It is recommended that it is only used by competent persons.

This feature allows the user to read/write any of the gauge configuration items. To read an
item enter the item and click Apply, the answer will be displayed. To write an item, enter
the item and enter the data you want to write, and click Apply.

18.7.1  Enraf gauge items

Unit conversion
This tab supports units conversions from the units displayed in Tankvision LMS to units
the gauge is configured to understand. In order to avoid confusion we recommend that you
alter the displayed dimensions to match those used by the gauge, if at all possible. In this
way, the format used for settings made via a Portable Enraf Terminal (PET) will
correspond directly with the format to be used in the Gauge Items tab.

Reading a request
To read a request no Gauge Item Data needs to be supplied. The data will be converted to
the current system display units before being displayed.

Data format
When setting Items, the user must enter the data value in the exact format which is
appropriate for the selected Dimensions/Units, with +/- sign and appropriate number of
digits before and after the decimal point. If unsure of the correct format, read the current
value of the desired Item from the gauge first by leaving the Item Data "blank".

The Answer value from the gauge will be displayed in the format appropriate to the
Dimensions/Units in use. Then use the same format as the returned Answer to set the
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Item Data to the desired new value. An equals sign "=" must precede the data value when
setting Items.

The following Dimensions/Units are supported
Key:
• ± sign character (+/-)
• N numeric digit
• . decimal point

Level

Units Format

mm ± N N N N N N . N (default)

m ± N N N . N N N N

ft ± N N N . N N N N

in ± N N N N N . N N

f-i-s ± N N ' N N " N N

Temperature

Units Format

° C ± N N N . N N (default)

° F ± N N N . N N

Density

Units Format

kg/l ± N N . N N N N N (default)

kg/m3 ± N N N N N . N N

lb/ft3 ± N N N . N N N N

° API ± N N N N . N N N

Pressure

Units Format

Bar ± N N . N N N N N (default)

Pa ± N N N N N N . N

kPa ± N N N N . N N N

lb/in2 ± N N N . N N N N

18.7.2  Motherwell Gauge Items
Motherwell gauge items do not have the same unit conversion facility applied to them.
The data entered into the Gauge Item Data field is transmitted verbatim to the gauge. You
should consult your Motherwell documentation to determine the precise format of the
data.
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With Motherwell gauges you can either specify a 2-digit hexadecimal item code, as
described in the Motherwell gauge documentation or you can use a "shorthand" code for
certain data items.

Shorthand Code Description

UR Upper reference level

RL Reference level

HH High High alarm level

HA High alarm level

LA Low alarm level

LL Low Low alarm level

18.8  Scientific Instruments Gauge Commands
The 6290 densitometer gauge from Scientific Instruments supports a wide range of
diagnostic and configuration parameters. The parameters are grouped together into a
number of pages, these being:
• System Settings
• Current Mode
• Current Status
• Current Data
• Profile Configuration
• Alarm Configuration
• Drive Configuration
• Sensor Configuration
• Sensor Calibration
• Host Configuration
• Host 1 Modbus Scaling
• Host 2 Modbus Scaling
• Diagnostics

The data displayed in a page is automatically retrieved from the gauge when it is opened.
Therefore all data is considered live.

The meanings of the data parameters in the pages are not described in this document. For
more information on these parameters, refer to the appropriate Scientific Instruments
manual.

18.8.1  Page Selection
To display the parameters on a page, click on that page in the list.
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 60 Page Selection

The parameters will initially be displayed with ?? until the data is returned from the gauge.

 61 Data returned

18.8.2  Editing a Parameter
To edit a parameter on a page, double click on the parameter.
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 62 Edit a parameter

Enter the new parameter in the dialog, and then click on Set as shown above.

A confirmation screen will be displayed as shown below. Click Yes to write the data to the
gauge.

 63 Confirm Action

If the confirmation screen is not required then tick the Do not show this page again
option. This will only last until the Gauge Commands utility is closed.

The parameter will be shown as Waiting for an Answer until the new data has been
written to the gauge and then read back, after which the new value will be displayed in the
page.

Many of the parameters are read-only. These have a code that starts with the character R.
If an attempt to write to one of these is carried out then the message shown below will be
displayed.
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 64 Read only

18.8.3  Auto Refresh
To set a page to auto refresh the data at periodic interval, set the field Auto Update
Screen Every to the interval period required, and then click on the Start button.

The data will now be refreshed at the rate determined. Do not set the period too low as the
page will be continually refreshing, during which time the Waiting for Answer may be
displayed. A refresh period of 10 seconds is the lowest value recommended, with
30 seconds as the more normal value.

18.8.4  Saving the data to file
The full set of data parameters may be updated and saved to an XML format file. This may
then be printed or sent to SI for investigation if problems occur with the gauge. The file
will always be saved to the Logs sub-directory of the install directory.

To save the data, click on the page Save To File.

 65 Save to file

Select the File name in the Logs directory, and then click on the Execute button. All the
data for all pages will now be automatically retrieved from the gauge. This may take some
time, during which a progress bar will be displayed as shown below.
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 66 Progress Bar

When complete, click OK. The data saved in the file will be formatted and displayed on the
screen as shown below.

 67 Data displayed

Previously saved files may be viewed by selecting the File name then clicking on the View
button.
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19  Scan Controller
The scanning/polling status of individual gauges may be set using the Scan Controller tool.
To access the scan controller choose Tools → Scan Controller from the main Home Page
menu.

 68 Scan controller

The details of all gauges configured in the database are displayed including the current
Scan Status.

From this page one or more gauges may have their scan state set in one operation.

Selecting Gauges
• To select a gauge, click on it in the table.
• To select more gauges, keep the Control key pressed and click on the block at the start of

the line for the next gauge.
• Alternatively, click on the Select All button to select all gauges in the database.

Setting the scan status
To set the scan status click on one of the buttons along the top of the screen.

• Set Normal Scan
Sets all highlighted gauges to the normal polling status.

• Set Fast Scan
Sets all highlighted gauges to the fast polling status. Fast polling rate is determined by
the Fast Scan Interleave Rate set in the Comms Monitor.

• Set Off Scan
Stops polling for all the highlighted gauges. This affects any connected Mini Receivers,
Multiscans and Datacons as well as the DCC communications.

• Set Manual Scan
Sets all highlighted gauges to the manual polling. Gauges will only be polled when
commanded by an operator.

• Set Offline
Sets all highlighted gauges to the Offline mode in the DCC Comms. This affects only the
DCC communications, any connected Datacons will still poll for gauges but Tankvision
LMS will not poll the Datacons.

The scan status of the all gauges will be automatically updated in the Scan Controller
display after any actions.
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20  Skin Temperatures
This is not a standard feature, it is an option licensed separately and available at extra cost.
Skin Temperature sensors, located around the base, sides and roof of the LNG tank, are
used to detect any anomalies in the shell insulation that may cause a leak of product. They
are particularly used during the cool down period of a tank.

Up to 256 skin temperatures are supported per tank when used in conjunction with
Endress+Hauser Temperature Multiplexer devices.

The new skin temperature application displays a list of tanks that have skin temperature
sensors fitted as shown below after selecting View Menu → Skin Temperatures.

 69 Skin Temperatures

The main screen is divided into three sections. On the left is the list of tanks that have skin
temperature sensors fitted; in the middle is the details of the skin temperature sensors for
the selected tank, and on the right is a visualisation of the skin temperature for a specific
shell layer. The visualisation is only present if a single shell layer is selected in the middle
section as shown below.
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 70 Visualisation

Tank List
Contains the list of tanks that have skin temperature sensors fitted.

Shell Layer
Drop down list contains selection of:
• All – All sensors for the tank are listed.
• All Defined – All sensors that have a location defined are listed.
• Specific Shell Layers – Lists the sensors that are defined as belonging to the specified

shell layer.

Visualisation
Drop down list contains the temperature maps that can be used to visualise the tank.
Upper image is a three dimensional visualisation of the selected shell layer. The user can
zoom in and out using the left hand scroll bar, rotate the tank using the bottom scroll bar,
and tilt the tank using the right hand scroll bar. The lower image is a two dimensional
visualisation of the selected shell layer.
When the mouse is moved over a sensor location (indicated by a dot) more information on
the sensor is displayed as shown below.

 71 Sensor information

If the status of a sensor indicates that it is invalid, the dot representing the sensor will
flash. If the temperature reading for a sensor differs by more than a configured threshold
from the average reading of the sensors in that portion of the tank (roof, floor, wall below
product level, wall above product level) it is considered to indicate a hot spot or a leak. Hot
spots are indicated by the sensor turning red, whilst leaks are indicated by the sensor
turning blue. This is demonstrated below.
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 72 Visualisation

If the user clicks on the two dimensional image, the three dimensional image is rotated
and tilted so that the selected point becomes visible.
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