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1 Safety

1.1 Designated use

ControlCare is a field-based control system comprising hardware and software components. It can 

be used to visualize, monitor and control production processes. The approved usage of the 

individual units used in the system can be taken from the corresponding parts of the operating 

instructions.

The software described in this particular manual allows the direct integration of local I/Os, 

PROFIBUS I/Os and Modbus I/Os into an embedded hybrid function block in a ControlCare 

SFC162 FOUNDATION Fieldbus or SFC173 PROFIBUS Field Controller. This can then be 

programmed in IEC 61131-3 language, e.g. Structured Text as shown in the examples.

1.2 Installation, commissioning and operation 

ControlCare Field Controllers have been designed to operate safely in accordance with current 

technical safety and EU directives. Essential to their use is the ControlCare Application Designer 

software suite, which allows control strategies to be created for FOUNDATION Fieldbus and 

PROFIBUS I/O applications. Field devices, links, junction boxes, cables and other hardware 

comprising the Fieldbus sytem must also be designed to operate safely in accordance with current 

technical safety and EU directives. 

If devices are installed incorrectly or used for applications for which they are not intended, or if the 

controller is not configured correctly, it is possible that dangers may arise. For this reason, the system 

must be installed, connected, configured, operated and maintained according to the instructions in 

this and the associated manuals: personnel must be authorised and suitably qualified.

1.3 Operational safety

Location Field Controllers must be mounted in a permanent and weather-protected location in a safe area. 

The environment shall be a metal cabinet or an installation frame with a well grounded mounting 

plane. The environment shall be protected. 

Hazardous areas The controller must be connected to networks operating in explosion hazardous areas via barriers 

or other safety components. When installing components in explosion hazardous areas:

•  Ensure that all installion and maintenance personnel are suitably qualified

•  Check that all equipment has the appropriate safety certificates

•  Observe the specifications in the device certificates as well as national and local regulations.

This topic is discussed in BA013S (FF Guidelines) and BA034S (PROFIBUS Guidelines).

EMC All modules are suitable for industrial use and conform with the following standard, see Appendix:

•  EN 61326: 1997/A1: 1998

Interference emmision: Class A apparatus

Interference immunity: as per Annex A, industrial environment

Depending upon the environment in which the bus is operating, particular attention should be paid 

to the grounding of the bus cables. This topic is discussed in BA013S (FF Guidelines) and BA034S 

(PROFIBUS Guidelines).
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IP Address A ControlCare Field Controller is normally configured from a workstation connected into the 

control system backbone. You will require a unique IP address to set it up.

Warning

• The use of IP addresses is strictly controlled. Usually your system administrator will be authorised 

to allocate unique addresses. Assigning an unauthorised address to a Field Controller may result 

in conflicts within your system and the failure of the associated devices!

Since the system can be accessed and manipulated through the various ControlCare tools, it is 

advisable to control access both to the workstation and the folders in which the configuration is 

stored. Always make a back-up of the project.

Technical improvement Endress+Hauser reserves the right to make technical improvements to its software and equipment 

at any time and without prior notification. Where such improvements have no effect on the 

operation of the equipment, they are not documentated. If the improvements effect operation, a 

new version of the operating instructions is normally issued. 

1.4 Conventions and icons

In order to highlight safety relevant or alternative operating procedures in the manual, the following 

conventions have been used, each indicated by a corresponding icon in the margin. 

Safety conventions Icon Meaning

A note highlights actions or procedures which, if not performed correctly, may indirectly affect operation or 

may lead to an instrument response which is not planned

Caution!

Caution highlights actions or procedures which, if not performed correctly, may lead to personal injury or 

incorrect functioning of the instrument

Warning!

A warning highlights actions or procedures which, if not performed correctly, will lead to personal injury, a 

safety hazard or destruction of the instrument
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1.5 ControlCare documents

Table 1.1 indicates the documents, planned and realized, containing safety relevant information, 

installation, commissioning and operating instructions for the equipment and software associated 

with ControlCare.

All documentation available at the time of release is included on the ControlCare CD-ROM and is 

installed in Start=>Programs=>Endress+Hauser=ControlCare=Manuals during set-up.

Tab. 1-1: ControlCare Documentation

Component Description Document type Designation Order No.

System ControlCare System Overview Operating manual BA016S/04/en 56004883

ControlCare System Design Operating manual BA039S/04/en Planned

ControlCare System Specifications Operating manual BA040S/04/en 56004888

Software Application Designer Overview Operating manual BA017S/04/en 70104301

Application Designer: Local I/O Tutorial Operating manual BA032S/04/en 71095009

Application Designer: FF Tutorial Operating manual BA019S/04/en 70101151

Application Designer: PROFIBUS Tutorial Operating manual BA036S/04/en 70101152

Application Designer: MODBUS Tutorial Operating manual BA037S/04/en 70101153

Application Designer: IEC 61131-3 

Ladder Logic Tutorial 

Operating manual BA038S/04/en 70101386

Application Designer: IEC 61131-3

Structured Text Tutorial

Operating manual BA056S/04/en 71060063

Field Control (OPC) Servers Operating manual BA018S/04/en 71031428

SFC162 Visitor Operation manual BA069S/04/en 71113457

Field Controller Hardware Installation Guide Operating manual BA021S/04/en 56004885

Commissioning and Configuration Operating manual BA035S/04/en 56004887

Function Blocks Function Block Manual Operating manual BA022S/04/en 56004886

Set-Up Getting Started Operating manual BA020S/04/en 56004884

General FOUNDATION Fieldbus Guidelines Operating manual BA013S/04/en 70100707

PROFIBUS Guidelines Operating manual BA034S/04/en 56004242



2 Task Description ControlCare Application Designer: I/O Mapping Tool Tutorial

8 Endress+Hauser

2 Task Description

This tutorial describes use of the ControlCare I/O mapping tool. This allows:

•  the direct integration of Field Controller local I/O signals into the embedded hybrid block

•  the direct integration of PROFIBUS I/O signals into the embedded hybrid block

•  the mapping of embedded hybrid block I/O signals to Modbus

Accordingly, the Tutorial is split into three parts:

•  Use of the I/O mapping tool with a FOUNDATION Fieldbus application

•  Use of the I/O mapping tool with a PROFIBUS controller

•  Additional steps required to map the I/O signals to Modbus, whereby the Field Controller acts 

a) as a Modbus slave, and b) as a Modbus master

To illustrate the use of the I/O mapping tool a simple blending and mixing application has been 

taken, which differs slightly in its realization, depending upon whether FOUNDATION Fieldbus or 

PROFIBUS instrumentation is used.

2.1 Mixing and blending application

Fig. 2-1 shows the basic application to be considered in this tutorial. 

Fig. 2-1:  Overview of mixing and blending application

A reactor is used to blend and mix two liquids. Each liquid stream is equipped with a flowmeter and 

an on/off valve. The flowmeter measures the quantity of liquid which has been fed to the tank. The 

valve starts and stops the filling action. 

The mixing and blending sequence starts with an empty tank and with Valve 3 closed. When the 

Start button in the HMI is pressed, Liquid 1 is fed to the tank. The flow continues until the required 

mass has entered the tank, at which point the Valve 1 is closed. When the level of liquid passes the 

stirrer limit switch, the stirrer motor is switched on. On completion of the filling of Liquid 1, Liquid 

2 is fed into the tank. Valve 2 opens and filling continues until the correct mass has been added, at 

which point the Valve 2 is closed. 

The liquid is now stirred for 5 minutes. When this time has elapsed, the stirrer is stopped. Emptying 

now begins: the pump is switched on and Valve 3 opens. The emptying continues until the level 

reaches the level switch in the outlet pipe. At this point the pump is switched off and the valve is 

closed. The mixing sequence is complete.

In order to prevent overspill a third level switch is built into the reactor. In addition, the sequence 

can be stopped by both a HMI Stop switch and a latched stop button.
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2.2 FOUNDATION Fieldbus solution

A possible solution for the application using the SFC162 FOUNDATION Fieldbus Field Controller 

is described in this section.

2.2.1 Network

Fig. 2-2 shows a solution based on the FOUNDATION Fieldbus SFC162 with local I/O. 

•  The flow signals FT1 and FT2 are supplied by FOUNDATION Fieldbus devices

•  The level dry run, stirrer and overspill signals (LS1, LS2 and LS3) are simulated by a SFC420 

Switch Input module - in practice a SFC411 module would probably be used.

•  The stirrer motor, pump and solenoid valves (M1, P1, SV1, SV2, SV3 are connected to a 

SFC428 high density NO relay output module.

Fig. 2-2  Network for application example

2.2.2 Signals

Fig-2-3, overleaf, gives an overview of the signals and how they are acquired: 

•  Totalized flow is available by connecting the appropriate channel to a flowmeter Analog Input 

block; the totalizer is reset by a change in status of the CAS_IN_D parameter of the flowmeter 

Discrete Output block. 

•  The HMI start and stop buttons are internal parameters in the embedded hybrid block.

•  Overspill protection, dry run protection and emergency stop are connected to inputs DI-0 to 

DI-2 inputs of a Field Controller SFC420 Discrete Input module: 0 V = False, 24 V = True.

•  Input DI-3 is connected to the emergence stop button: 0V = False, 24V = true

•  The solenoid valves are connected to outputs DO-0, DO-2 and DO-3 of a Discrete Output 

module SFC428. 

NO relay: False = Valve Closed, True = Valve Open, Fail Safe = Valve Closed

•  The stirrer motor is connected to output DO-1 and the pump motor to output DO-5

NO relay, False = Pump OFF, True = Pump ON, Fail Safe = Pump OFF

For the tutorial all control is done in a FOUNDATION Fieldbus SFC162 Field Controller and all 

I/Os are integrated directly into the embedded hybrid block.

High Speed Ethernet
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Field Controller
with local I/O
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FT2
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Fig. 2-3  Signal overview for possible FOUNDATIION Fieldbus solution

2.2.3 Rack assembly

The SFC162 Field Controller and SFC432 Discrete I/O module have combined power demand of 

132 mA @ 24 VDC and 760 mA@ 5 VDC. Even allowing for a tolerance of 20%, this is easily 

covered by a SFC050 or SFC056 rack power module (300 mA @ 24 VDC and 3000 mA @ 5 VDC). 

The SFC353 module is powered by the SFC252 fieldbus power supply and need not be considered 

in the calculation. See Chapter 10 of BA040S/04/en, ControlCare, System Specifications.

The Field Controller and local I/O are mounted on two SFC901A rack assemblies with addresses 

0 and 1 (I/O cannot be mounted on a rack with the address "0".) The parameters for commissioning 

the Field Controller are shown in Table 2-1.

Tab. 2-1: Parameter settings for rack in hardware configuration and function blocks

Note!

• The I/O mapping tool does not require the entry of a channel to connect the local I/O to the 

hybrid embedded I/O block. 

• If the local I/O is to be connected to any other block, a channel must be entered in the associated 

block as given by Rack (R), Slot (S), Group (G) and I/O point (P) indices = RRGSP, whereby 

counting starts at "0". 

• If Multiple Input and Output blocks are being used for the discrete signals, the I/O point index is 

"9", see BA035S/04/en, Field Controller, Commissioning and Configuration.

External devices ControlCare local I/O modules are available with passive electrical circuits only, so that any 

connected devices or external circuits must have their own power supply, see BA035S/04/en, 

Field Controller, Commissioning and Configuration.

Rack 0 Rack 1

Slot 0 Slot 1 Slot 2 Slot 3 Slot 0 Slot 1 Slot 2 Slot 3

Module SFC050 SFC162 SFC252 SFC353 SFC420 SFC428 Dummy Dummy

IO_TYPE_Rx No I/O No I/O No I/O No I/O 8 DiscIn 16 DiscOut No I/O No I/O
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2.2.4 Control strategy

Fig. 2-4 shows a schematic diagram of the blending and mixing application. 

Fig. 2-4  Control strattegy of blending and mixing application

The Analog Input block of each flowmeter supplies the totalized value to the hybrid embedded 

I/O block. The totalized value is obtained by setting the appropriate channel parameter. The 

totalizer reset signal is linked to the DO block of the flowmeter, the channel parameter determining 

the function to be executed.

2.2.5 Parameters

The I/O mapping tool assigns the inputs and outputs of the hybrid block to the modules in the order 

in which they appear in the hardware configuration block. Since there is no way of determining 

whether an individual input or output is being used, a block of 4, 8 or 16 parameters is automatically 

reserved for the entire module. The parameters are numbered from _In_1 and _Out_1 upwards, 

according to the the next free block. All parameters can be assigned an alias. 

For this tutorial, the following parameter assignment will be made. 
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2.2.6 Truth table

The truth table for the hybrid function block has is as follows: 

I/O signals

The limit switches are wired or configured such that the conditions:

•  Dry_Run_Protection = True when the liquid level drops below the limit switch

•  Stirrer_Protection = True when the liquid level drops below the limit switch

•  Overspill_Protection = True when the liquid level rises above the limit switch

HMI Start/Stop

Function In_1 In_2 In_3 In_4 Out_1 Out_2 Out_3 Out_4 Out_5

Open Valve SV1 – – – – True – – – –

Close Valve SV1 – – – – False – – – –

Switch on Motor M1 – – – – – True – – –

Switch off Motor M1 – – – – – False – – –

Open Valve SV2 – – – – – – True – –

Close Valve SV2 – – – – – – False – –

Open Valve SV3 – – – – – – – True –

Close Valve SV3 – – – – – – – False –

Switch on Pump P1 – – – – – – – – True

Switch off Pump P2 – – – – – – – – False

Dry Run Protection True – – – – – – False False

Stirrer Protection – True – – – False – – –

Overspill Protection – – True – False – False – –

Emergency Stop – – – True False False False False False

Function Out_1 Out_2 Out_3 Out_4 Out_5

Liquid 1Start/Stop True/False – – – –

Liquid 2 Start/Stop – – True/False – –

Stirrer on/off – True/False – – –

Emptying Stop/Start – – – False/True False/True
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2.3 PROFIBUS solution

A possible solution for the application using the SFC173 PROFIBUS Field Controller is described in 

this section.

2.3.1 Network

The project uses a PROFIBUS SFC173 Field Controller . The network is assumed to be constructed 

as shown in Fig. 2-5. 

•  Flow signals are supplied by PROFIBUS DP flowmeters

•  The level overspill, dry run and pump signals are acquired PROFIBUS PA Liquiphants

•  The motor, pump and valve power supplies are connected to Remote I/O.

Fig. 2-5  Network for application example

2.3.2 Signals

Fig-2-6, overleaf, gives an overview of the signals and how they are acquired: 

•  Totalized flow is acquired by direct I/O integration in the embedded hybrid block. Similarly, 

the totalizer is reset by toggling a direct output from the I/O block. 

•  The HMI start and stop buttons are internal parameters in the embedded hybrid block.

•  Overspill protection, dry run protection and emergency stop are also directly integrated in the 

embedded I/O block.

•  The emergence stop button is connected to a discrete input DI-0 of the Remote I/O: 

0V = False, 24V = true

•  The solenoid valves are connected to discrete outputs DO-0, DO-2 and DO-3 of the Remote 

I/O: NO relay: False = Valve Closed, True = Valve Open, Fail Safe = Valve Closed

•  The stirrer motor is connected to output DO-1 and the pump motor to output DO-5 of the 

Remote I/O: NO relay, False = Pump OFF, True = Pump ON, Fail Safe = Pump OFF

For the tutorial all control is done in a PROFIBUS SFC173 Field Controller and all 

I/Os are integrated directly into the embedded hybrid block.
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Fig. 2-6  Signal overview for possible PROFIBUS solution

2.3.3 Control strategy

Fig. 2-7 shows a schematic diagram of the blending and mixing application. 

Fig. 2-7  Control strattegy of blending and mixing application

All I/O parameters from the PROFIBUS network are integrated into the embedded hybrid block by 

means of the I/O mapping tool. The control strategy in the hybrid block is written in structured text 

or other IEC 61131-3 language
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2.3.4 Truth table

The truth table for the hybrid function block has is as follows: 

I/O signals

The limit switches are wired or configured such that the conditions:

•  Dry_Run_Protection = True when the liquid level drops below the limit switch

•  Stirrer_Protection = True when the liquid level drops below the limit switch

•  Overspill_Protection = True when the liquid level rises above the limit switch

HMI Start/Stop

Function In_1 In_2 In_3 In_4 Out_1 Out_2 Out_3 Out_4 Out_5

Open Valve SV1 – – – – True – – – –

Close Valve SV1 – – – – False – – – –

Switch on Motor M1 – – – – – True – – –

Switch off Motor M1 – – – – – False – – –

Open Valve SV2 – – – – – – True – –

Close Valve SV2 – – – – – – False – –

Open Valve SV3 – – – – – – – True –

Close Valve SV3 – – – – – – – False –

Switch on Pump P1 – – – – – – – – True

Switch off Pump P2 – – – – – – – – False

Dry Run Protection True – – – – – – False False

Stirrer Protection – True – – – False – – –

Overspill Protection – – True – False – False – –

Emergency Stop – – – True False False False False False

Function Out_1 Out_2 Out_3 Out_4 Out_5

Liquid 1Start/Stop True/False – – – –

Liquid 2 Start/Stop – – True/False – –

Stirrer on/off – True/False – – –

Emptying Stop/Start – – – False/True False/True
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2.4 Preliminaries

2.4.1 Installation and commissioning

Before you can start the IEC 61131-3 Structured Text tutorial, the Application Designer Suite must 

be installed on your computer, the SFC162 FOUNDATION Fieldbus Controller installed and 

commissioned and a connection made to your computer. Instructions on how to do this are to be 

found in:

•  Operating Instructions BA020S/04/en, Getting Started

•  Operating Instructions BA021S/04/en, Field Controller: Hardware Installion

•  Operating Instructions BA035S/04/en, Field Controller: Commissioning and Configuration

Not all project steps are described in detail, so it is recommended that you also have the 

FOUNDATION Fieldbus or PROFIBUS tutorials at hand:

•  Operating Instructions BA019S/04/en, Application Designer: FOUNDATION Fieldbus tutorial

•  Operating Instructions BA036S/04/en, Application Designer: PROFIBUS tutorial

2.4.2 Rack assembly for FOUNDATION Fieldbus solutioin

The SFC162 Field Controller and SFC432 Discrete I/O module have combined power demand of 

132 mA @ 24 VDC and 760 mA@ 5 VDC. Even allowing for a tolerance of 20%, this is easily 

covered by a SFC050 or SFC056 rack power module (300 mA @ 24 VDC and 3000 mA @ 5 VDC). 

The SFC353 module is powered by the SFC252 fieldbus power supply and need not be considered 

in the calculation. See Chapter 10 of BA040S/04/en, ControlCare, System Specifications.

The Field Controller and local I/O are mounted on two SFC901A rack assemblies with addresses 

0 and 1 (I/O cannot be mounted on a rack with the address "0".) The parameters for commissioning 

the Field Controller are shown in Table 2-1.

Tab. 2-2: Parameter settings for rack in hardware configuration and function blocks

Note!

• The I/O mapping tool does not require the entry of a channel to connect the local I/O to the 

hybrid embedded I/O block. 

• If the local I/O is to be connected to any other block, a channel must be entered in the associated 

block as given by Rack (R), Slot (S), Group (G) and I/O point (P) indices = RRGSP, whereby 

counting starts at "0". 

• If Multiple Input and Output blocks are being used for the discrete signals, the I/O point index is 

"9", see BA035S/04/en, Field Controller, Commissioning and Configuration.

2.4.3 External devices

ControlCare local I/O modules are available with passive electrical circuits only, so that any 

connected devices or external circuits must have their own power supply, see BA035S/04/en, 

Field Controller, Commissioning and Configuration.

Rack 0 Rack 1

Slot 0 Slot 1 Slot 2 Slot 3 Slot 0 Slot 1 Slot 2 Slot 3

Module SFC050 SFC162 SFC252 SFC353 SFC420 SFC428 Dummy Dummy

IO_TYPE_Rx No I/O No I/O No I/O No I/O 8 DiscIn 16 DiscOut No I/O No I/O
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3 FOUNDATION Fieldbus Solution

3.1 Create a physical network

3.1.1 Create a FF project

1 Start ControlCare Application Designer by clicking on the icon on your destop or via Start => 

Programs => Endress+Hauser => ControlCare => ControlCare Application Designer

2 The project starts from a blank application screen

– With the right mouse key select Project File=>New

1 The Document Type box appears: Click the option Project

2 The New Project dialog box opens:

1. Choose the folder where the project will be saved.

2. Type the name of the project in the File Name box.

3. Click Save. 

If the new project is not to be created, click Cancel.

3 ControlCare Application Designer automatically creates a folder with the entered file name 

within the selected folder.
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3.1.2 Determine the naming preferences

Before you start, you can set preferences for the way your project is created. Of particular interest 

at this stage is the labelling of the function blocks.

1 Press Project File => Preferences

– The Preferences Dialog appears

Tag Policy Tag Policy determines how the blocks are labelled by default if no tag names are entered

1 Select the folder Block and the subfolder Tag Policy, then check the following buttons

– Device

– Update Block Tag

2 Press OK to confirm your selection

– Application Designer will now automatically rename any blocks created in the control

strategy window as they are assigned to the devices by adding the device tag as prefix.

Tag Composition Tag Composition determines how the block identifiers are added to the block tag if no block name 

is entered.

1 Select the subfolder Tag Composition:

– Enter a mnemonic separator: for this manual the setting was "-"

Default setting is "_" and mandatory for if flexible function blocks are to be used

– Check Prefix

2 Press OK to confirm your selection

– Application Designer will now automatically compose the blocks according to your

selection, e.g. TagName-Block-n or TagName_Block_n.

Export Tag Export Tag causes tags to be automatically exported every time the project goes online

1 Select the subfolder Export Tag

– Check the Automatic button

– Press OK to confirm your selection

Strategy Strategy determines the default shape of the function block icons in the stratagy window and also 

whether the aliasing function is enabled

1 Select the subfolder Strategy

– Select the default shape for function block objects

– Select "Alias Input Dialog Box" 

– Press OK to confirm your selection
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3.1.3 Add a bridge (SFC162)

1 On saving, ControlCare Application Designer automatically creates a project, adding the HSE 

fieldbus network and the HSE Host: 

2 Now right-click on the HSE Network leaf and select New=>Bridge

3 The New Bridge dialog box appears:

Select the SFC162 Field Controller and type in a device TAG, in our case FC_01

If you do not type in a tag, the default will be "Bridge n", where n is a consecutive number. 

4 Press OK to create the Bridge.

5 Repeat Steps 1 to 4 for as many SFC162 Field Controllers as you have in your network.
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3.1.4 Add a fieldbus segment

1 The project now looks like this:

2 Right click on the bridge you just created, here "FC_01", and select New Fieldbus.

3 The New Fieldbus dialog box appears:

– Enter a Fieldbus TAG, 

– Select the fieldbus port on the SFC162

– If you do not type in a tag, the default will be "Fieldbus n", where n is a consecutive number. 

4 Press OK to create the Fieldbus.

5 Open Project File, then press Save, to save the project.

6 Repeat Steps 1 to 5 for as many fieldbus segments as are in use.
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3.1.5 Add the devices

1 Click on the newly created Fieldbus 1 leaf and select Expand

2 A new work space Fieldbus 1 opens:

– Right-click on the Fieldbus 1 leaf and select New then Device

3 The New Device dialog appears

– Select the Device Manufacturer = Endress+Hauser

– Select the Device Type = Promag53

– Enter the Device Tag = FT1

If you do not type in a tag, the default will be "Device n", where n is a consecutive number 

– Press OK to create the device

Note! 

• Application Designer follows the latest DD and CF revisions by default. 

• If you are working with devices with older DD and CF revisions, uncheck the checkbox and select 

the correct Device Revision. 
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4 Your project now looks like this:

5 Repeat Steps 2 and 3 for the second Promag 53 flowmeter

– Micropilot M:

Manufacturer = Endress+Hauser

Device Type = Promag53

Device Tag = FT2

6 Your project should now look like this:

7 Now expand the FT1 node: for a Revision 4 device, six transducer blocks have been created 

– FT1_FLOW = flow transducer block 

– FT1_VISION = diagnosis block

– FT1_DISP = display block

– FT1_TOT = totalizer transducer block, 

– FT1_SOC = solids content block (required for Promag55 only)

– FT1_DIAG = advanced diagnosis block

Note!

In earlier revisions of the Promag 53 the blocks may be fewer and have different names

8 Open Project File, then press Save, to save the project.
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3.1.6 Export tags

Note! 

• You should use the Export Tags function everytime you change the configuration of the project, 

so that the OPC server information is always up-to-date.

• Application Designer can be set up to automatically export tags everytime the system goes online, 

see Chapter 3.1.2

1 Active the project view by clicking in its workspace

2 Right click on the project name, a context menu appears

3 Select the option Export Tags...

– The Export Tags dialog confirms the successful export

– Press OK to close the dialog

4 Open Project File, then press Save, to save the project
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3.2 Create a Control Strategy

Having created a physical view of the process, the next step is to create control strategy. This is done 

in the logical view of the plant. This represents the plant as Areas/Process Cells in accordance with 

ISA S88/IEC 61518.

3.2.1 Add a Process Cell

1 Click on the "Area 1" leaf in the project and select Attributes...

2 The Area dialog box appears

– Enter a name for the area, e.g. Magnasol Production

– Click OK to store your changes

3 Click on the Area leaf again and select New Process Cell...

4 The Process Cell dialog box appears

– Enter a name for the process cell, e.g. Blending

– Click OK to store your changes

5 Open Project File, then press Save Entire Configuration, to save the project.
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3.2.2 Add a Control Module

1 Right-click on the Process Cell leaf you just created and select Expand

1 A new window with the name of the leaf opens

– Right-click on the top leaf and select New Control Module

2 The Control Module dialog box appears

– Enter a name for the control module, e.g. Reactor Control

– Click OK to store your changes

3 The project now looks something like this:

4 For a real project, Step 2 and 3 would be repeated until all the required control modules for a 

particular process cell have been added.

5 Open Project File, then press Save Entire Configuration, to save the project.
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3.2.3 Create the function blocks

Note! 

• The function blocks used in the tutorial are selected from the device manufacturer’s device list. 

It is also possible to select standard function blocks from the "Fieldbus Foundation" list. This 

ensures that the control strategy can be executed in any FF device that supports a particular 

standard block, irrespective of vendor.

• Endress+Hauser devices support standard function blocks and offer them in the manufacturer 

specific list.

1 Double-click on the control module leaf or right-click and select Expand to open the Control 

Strategy workspace - this has the same name as the leaf

2 Press the Function Block button  in the toolbar and click in the workspace

– The New Block dialog appears

– Select the Manufacturer = Endress+Hauser

– Select the Device Type = Promag53

– Select the Block Type = Analog Input

– Press OK to create the function block

3 The block now appears in the strategy window with the default name
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4 Repeat Steps 2 and 3 for the following blocks

Note! 

• Although the function blocks can be created in any order, they must be attached to the devices 

in the order required by the FB macrocycle schedule sequence, see Chapter 3.4

5 The control strategy now looks like this

6 Open Project File, then press Save Entire Configuration, to save the project.

Device Number Manufacturer Device Type Block Type

Promag 53 1x Endress+Hauser Promag53 Analog Input (AI)

2x Endress+Hauser Promag53 Discrete Output (DO)*

SFC162 1x Endress+Hauser SFC162 Hybrid With Embedded I/Os

(HY_EMB_IO)
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3.2.4 Add the Function Block Links

1 In the Control Strategy workspace position the blocks according to your strategy

– The blocks can be dragged and dropped by selecting and holding down the right mouse key

– The blocks can be aligned by selecting, then via Tools => Alignment => e.g. Middle 

followed by a click on the block to which the alignment is to be made

– The Tools menu also contains other standard drawing functions such as toolbars, standard 

shapes, line thickness, colours etc.

– Texts can be added to the strategy by opening the drawing toolbar via

Tools => Tool Boxes => Drawing then clicking on the "ABC" button and placing the 

cursor at the desired position in the strategy workspace

– The text font can be changed by activating the text box in the strategy and right clicking: 

Properties => Text Attributes => Font
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2 Click on Function Block Link  button in the tool bar, the cursor changes to a cross

– Select the Reactor control AI_1block: the Output Parameter Selection dialog appears

3 Click the box next to OUT – it changes color – then click on OK

– The Output Parameter Selection dialog closes

– The cursor is now connected to a blue dotted line

– Place the Cursor in the Reactor control HY_EMB_IO_1 block and click to make the link

4 When the link is made, the Input Parameter Selection dialog for the HY_EMB_IO_1 block 

appears

Click the box next to IN_1 – it changes color – then click on OK

5 The Rename dialog now appears: 

– Enter the name in the table in Chapter 2.3.1: Totalizer_FT1

– Press OK
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6 When the Rename dialog disappears, the link is made and appears as below:

– The link appears as a dotted line because the function block has yet to be attached to a device 

– The parameter legends "IN_1" and "OUT" by moved by drag & drop

7 Repeat steps 2 to 5 and make the following links between the function blocks

– AI_2 and HY_EMB_IO_1= OUT to IN_2, Alias name: Totalizer_FT2

– HY_EMB_IO_1 and DO_1 = OUT_D1 to CAS_IN_D, Alias name: Reset_Totalizer_FT1

– HY_EMB_IO_1 and DO_2 = OUT_D2 to CAS_IN_D, Alias name: Reset_Totalizer_FT2

8 Since the input and output signals for a particular link now have the same names, you may 

want to hide some:

– Right click on the link, select Labels and click on the parameter you want to hide

– The label is hidden when there is no tick on the "Show...." parameter

9 Your Control Strategy now looks something like this (only inputs shown)

10 Open Project File, then press Save Entire Configuration, to save the project.
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3.3 Configure the strategy

At this point we have a created a network with devices and a control strategy. In this section, we 

describe how the strategy is configured. You may prefer to configure the devices first, see 

Chapter 3.5, then the strategy. In strategies using many blocks and links you my decide that it is 

simpler to create and configure the devices and strategy piece by piece. Application Designer allows 

all these options.

3.3.1 Changing parameters

Procedure 1 Right click on the function block and select Offline Characterization

– The Offline Characterization dialog opens with a predefined list of parameters

– If required, the complete set of parameters can be viewed by pressing the All button

2 If necessary expand the parameter tree

– Double-click on the "Value space" next to the parameter

– Either select a parameter offered by the drop-down menu, or if no menu is present 

enter the parameter by hand

3 Press End Edit to register your change

– Cancel Edit will cancel the Edit and close the value space

– Clear will delete the selected parameter 

– When all parameters have been edited, press Close to close the dialog

Order of parameters Some block parameters have a write check based on the value of other parameters. It is therefore 

important to set the parameters in the order in which they are displayed in the Off Line 

Characterization dialog. After characterization of the block, the parameters will appear in the 

FOUNDATION Fieldbus and Process Cell trees. If you find a parameter in the wrong position, it can 

be move by dragging and dropping to the correct one. 
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3.3.2 Analog Input (flow totalizer)

The Analog Input function blocks Reactor control_AI_1 and Reactor control AI_2 of the 

Promass 53 flowmeters must now be configured, see Table 4-2. A full description of the parameters 

is to be found in Operating Instructions BA051DEN.

Tab. 3-1: Basic parameters for Analog Input blocks

Procedure 1 In the Control strategy workspace, double-click on the Reactor control_AI_1 block

2 The Off Line Characterization dialog opens, see Chapter 3.3.1

– Expand the Mode Block node and set the Target to Auto

– Set CHANNEL to Totalizer 1

– Set LTYPE to Direct

– Remember to press End Edit after every change

– When all parameters have been entered, press Close to quit the Characterization dialog

3 Repeat Step 2 for the Reactor control AI_2 block

4 Open Project File, then press Save Entire Configuration, to save the project.

Parameter Function Value

MODE BLOCK/TARGET Normal operating mode of block Auto

CHANNEL Output channel of Promass 53 Transducer Block 

connected to Analog Input Block.

• Totalizer 1

Totalizer 1

LTYPE Type of linearization Direct
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3.3.3 Discrete Output (flowmeter)

The Discrete Output block of the Promass 53 flowmeter is used to set a number of measurement 

options. It is connected to the Promass53 transducer block by through channel 16, which is set in 

the CHANNEL parameter. The trigger for resetting is a change of the input parameter CAS_IN_D 

(which appears with the alias e.g. "Reset_Totalizer_FT1" from 0 to 8. This change is initiated by 

the hybrid embedded I/O block. 

Tab. 3-2: Basic parameters for Multiple Discrete Input block

Procedure 1 In the Control strategy workspace, double-click on the Reactor control_DO_1 block

2 The Off Line Characterization dialog opens, see Chapter 3.3.1

– Expand the Mode Block node and set the Target to Cas

– Set CHANNEL to Discrete Output

– Set SHED_OPT to NormalShed_NormalReturn

– Remember to press End Edit after every change

– When all parameters have been entered, press Close to quit the Characterization dialog

3 Repeat Step 2 for the Reactor control DO_2 block

4 Open Project File, then press Save Entire Configuration, to save the project.

Parameter Function Value

MODE BLOCK/TARGET Normal operating mode of block Cas

CHANNEL Signal channel connected to Promag 53 by block

• Discrete Output

Discrete Output

SHED_OPT Control Shed option NormalShed_Normal

Return
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3.3.4 Promass 53 Totalizer Transducer Block

Full details of how to parametrize the Promass 53 totalizer transducer block are to be found in 

Operating Instructions BA051D/06/en.

In the tutorial, the totalizer must be set up to measure volume flow: the parameters are in Table 3-6. 

Tab. 3-3: Basic parameters for totalizer transducer block

Procedure 1 In the Fieldbus network workspace, expand the FT1 tree until the function blocks are visible

– Right click on the FT1_TOT_1 block and select Off Line Characterization...

2 The Off Line Characterization dialog opens

– Expand the Mode Block parameter tree and set Target to Auto

– Set HMIACCESSCODE= 4444

– Set TOTUNIT1 = m³

– Set TOTASSIGN1 = Volume Flow

– Set TOTMODE1 = Forward

– Press Close to quit the Characterization dialog

3 Press Close to quit the On Line Characterization dialog

– Answer Yes to the request to store the parameters: are settings are then retained for 

any subsequent download to the device

4 Repeat Steps 1 to 3 for the FT2_TOT_1 block in the FT2 tree.

5 Open Project File, then press Save Entire Configuration, to save the project.

Parameter Function Positionere 

FCV102

MODE BLOCK/TARGET Normal operating mode of block Auto

HMIACCESSCODE Enter a 4-digit code to protect the block parameters

• A HMI must write this code to the parameter 

HMIACCESSCODE if parameters are to be changed

• If write protection is enabled, access to the manufacturer-

specific parameters is blocked even if the right code is 

entered. The jumpers on the I/O board must be set to 

enable writing (see Operating Instructions for Promag53FF, 

BA052D/06/en)

e.g. 4444

TOTUNIT1 Enter the unit in which the totalizer counts m³

TOTASSIGN1 Enter the measured value that the totaliZzer will follow Volume Flow

TOTMODE1 Enter the mode in which the totalizer counts Forward
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3.3.5 Hybrid Embedded I/O block

The Hybrid Embedded I/O block adds the logic to the control strategy. It contains the local I/O 

inputs and outputs and can also be connected to upstream and downstream function blocks. A 

logical algorithm that may be programmed in any of the IEC 61131-3 function block langúages 

provides the logic between inputs and outputs. The programming of the function block is described 

in Chapter 5. 

At this point only three parameters should be set/checked. The assignment and alaising of the local 

I/O is done within the I/O mapping tool and is automatically taken over by the HY_EMB_IO block 

itself. 

Tab. 3-4: Basic parameters for Multiple Discrete Input block

Procedure 1 In the Control strategy workspace, double-click on the Reactor control_HY_EMB_IO_1 

block

2 The Off Line Characterization dialog opens, see Chapter 3.3.1

– Expand the Mode Block node and check that the Target is set to Auto

– Double lick on the value space of HYB_STATUS_OPS and select Set Outputs to Good 

Non Cascade

3 Open Project File, then press Save Entire Configuration, to save the project.

Parameter Function Value

MODE BLOCK/TARGET Normal operating mode of block Auto

HYB_STATUS_OPTS Sets status options of IEC 61131-3 variables

• None: the status will be set within the block

• Set Outputs to Good Non Cascade: all outputs will be 

automatically set to good, ifrrespective of input

Outputs to Good Non 

Cascade

EXEC_TIME_TARGET Target time for execution of the hybrid block 10 ms (default)
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3.3.6 Store the strategy as a template

FOUNDATION Fieldbus offers the possibility of storing complete control strategies as fully 

configured generic templates. This is especially useful when particular control strategies occur 

several times within a project. The strategies are stored independent of device assignment, which is 

performed as a separate step. The IEC 61131-3 algorithm is not stored in the template.

After configuration, the strategy can be stored as a template for similar applications using the same 

devices.

1 In the Strategy workspace, drag the mouse across the complete strategy with the left button 

depressed, until all function blocks are selected

2 Now press the Strategy Export button  in the toolbar

– The Save As dialog appears

– If appropriate, browse to another folder

– Enter a File Name

– Press Save to save the strategy

3 The strategy can be imported again pressing the Strategy Import button  in the toolbar and 

double-clicking on the appropriate file name.
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3.4 Attach the Function Blocks to the devices

Now attach the function blocks in the control strategy to the devices where they are to run. The 

order of attachment determines the order of execution in the Field Controller and FF devices.

•  First attach the input blocks

•  Then attach the control and logic blocks in the order of execution

•  Finally attach the output blocks

If necessary, the order of the blocks can be adjusted by drag & drop.

1 Expand the Fieldbus workspace (Fieldbus 1) and the Process Cell workspace (Blending) 

– Note that the Reactoir Control tree now contains all the function blocks that you created in 

the Control Strategy workspace. 

– A question mark in a block means that the block has still to be attached to a device.

2 Now drag and drop the Reactor control_AI_1 block to the greyed Function Block Application 

leaf of the FT1 tree

– When you drop the block, it is attached to tree

– Its name changes to FT1_AI_1 in both views 

(according to the tag naming policy selected in preferences)

– You have now assigned the Totalizer AI block to the flow transmitter

3 Repeat Step 2 for the other function blocks, dragging them across in the required order of 

execution:

– Reactor control_AI_2 => FT2

– Reactor control_HY_EMB_IO_1 => FC_01

– Reactor control_DO_1 => FT1

– Reactor control_DO_1 => FT2

4 Your project now looks like this
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and the strategy looks like this:

5 Click on the Project View workspace and Export Tags..., see Chapter 3.5

6 Open Project File, then press Save Entire Configuration, to save the project.

Note! 

• Function blocks can also be attached to devices by right-clicking on the FB VFD or FBAP node of 

the appropriate device in the Fieldbus workspace and selecting Attach Block...
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3.5 Parameter the Devices

It is important to remember that the device parameters in the Transducer Block are an integral part 

of any FOUNDATION Fieldbus project. This has consequences in the way the devices can be 

parametered:

•  The most secure method is to parametrize offline with the Application Designer - this ensures 

that you are downloading a complete set of parameters to the devices

•  For devices with display operation or a service interface, it is possible to parametrize at the 

device itself. If you wish to parametrize by this method, it is important that only the Mode 

Block Target is parametrized in Application Designer. 

•  If the device has a HistoROM, this must be activated in the offline configuration, otherwise the 

device will show a HistoROM error after the download.

•  Application Designer does not support device parameter upload at the moment: this means that 

if you have used a service tool or the display to parametrize, the device parameters are not 

stored centrally in the project. A device failure means that the replacement device has to 

parametrized anew. This can be avoided by ensuring that the parameters are downloaded to 

the DAT or HistoROM, or by manually transferring the parameters displayed in the Online 

Characterization to the Offline Characterization dialog

This tutorial tells you how to parametrize the Field Controller offline with Application Designer. It 

is also possible to parametrize field devices off line, but in the case of the Promass 53, there are 

dependencies in the transducer block which makes this impossible. The online parametrization of 

this devce is descrtibed in Chapter 3.13.4.

Order of parameters Some block parameters have a write check based on the value of others parameters. It is therefore 

important to set the parameters in the order shown in the various tables, i.e. the same order in 

which they are displayed in the Off Line Characterization dialog. 

After parametrization of the block, the parameters will appear in the FOUNDATION Fieldbus tree. 

If you find a parameter in the wrong position, it can be move by dragging and dropping to the correct 

one.

3.5.1 Field Controller Hardware Configuration block

1 Double click on the HSE Network leaf, the HSE Network window opens:

– Expand the FC_01 and FBAP leaves

2 Double-click on the FC_01_HC_1 leaf to open the Off Line Characterization dialog

To change parameters, see Chapter 3.3.1: 

– Expand the parameter leaf

– Double click on value space

– Enter the parameter or select it from the drop-down menu

– Confirm with End Edit

3 Expand the MODE_BLK parameter left and check that Target is set to Auto
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4 Expand the IO_TYPE_R0 parameter leaf and set the following parameters, see Table 2-1, 

Chapter 2.2.2

– Slot_0: No I/O

– Slot_1: No I/O

– Slot_2: No I/O

– Slot_3: No I/O

5 Expand the IO_TYPE_R1 parameter leaf and set the following parameters, see Table 2-1, 

Chapter 2.2.2

– Slot_0: 8 Discrete Input

– Slot_1: 16 Discrete Output

– Slot_2: No I/O

– Slot_3: No I/O

6 Click Close, then save the configuration 

– Right-click on the Project File menu and select Save Entire Configuration to save the

project – the FC_01_HC_1 node now looks like this.

3.5.2 Field Controller Hybrid Embedded I/O block

After configuration of the hardware block, Chapter 3.5.1, the local I/O can be configured in the 

hybrid embedded block. 

1 Open the I/O mapping tool by right-clicking on the FC_01_HY_EMB_OI_1 node and selecting 

Map I/Os to hybrid block
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2 Click on the empty box in the Rack/Slot/Module type column: 

– a drop-down menu shows the I/O modules already configured in the FC_01_HC_1 block

– select Rack:1 Slot:0 Module:8-Discrete Input, 

– the associated inputs are automatically created

3 Repeat Step 2 for the option Rack:1 Slot:1 Module:16-Discrete Output
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4 The alias tags can now be entered by clicking on the appropriate line

– You can copy & paste e.g. direct from an Excel table

5 The Export button allows the configuration to be exported to a CSV file which can be 

imported into e.g. Excel:

6 Press OK to complete the mapping procedure

– The tag LOC_ IO appears under the hybrid block in the Fieldbus 1 dialogue

Block/Module Signal/Point Block/Module Signal/Point Alias (IEC Variable)

SFC420 A0 HY_EMB_IO In_1 Dry_Run_Protection_LT1

A1 In_2 Stirrer_Protection_LT2

A2 In_3 Overspill_Protection_LT3

A3 In_4 Emergency_Stop_B1

HY_EMB_IO Out_1 SFC428 A0 State_Valve_SV1

Out_2 A1 State_Motor_M1

Out_3 A2 State_Valve_SV2

Out_4 A3 State_Valve_SV3

Out_5 A4 State_Pump_P1
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3.5.3 Export tags

Note! 

• You should use the Export Tags function everytime you change the configuration of the project, 

so that the OPC server information is always up-to-date.

• Application Designer can be set to automatically export the tags every time the project goes 

online, see Chapter 3.1.2.

1 Activate the project view by clicking in its workspace

– Right click on the project name, a context menu appears

2 Select the option Export Tags...

– The Export Tags dialog confirms the successful export

– Press OK to close the dialog

3 Open Project File, then press Save Entire Configuration, to save the project.
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3.6 Program the Hybrid Function Block

3.6.1 Set the IEC 61131-3 programming language

1 In the HSE Network 1 tree, right click on FC_01_HY_EMB_IO_1 and select Attributes

2 The Attributes dialog opens:

– In the IEC 61131-3 Programming Language menu select ST (Structured Text)

– Tick the box "Map as FF Data Structure"

– Press OK to confirm the selection

3.6.2 OpenPCS programming tool

1 In the HSE Network 1 tree, right click on FC_01_HY_EMB_IO_1 and select 

Program Hybrid Block
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2 The OpenPCS programming tool opens:

– The Files pane of the Project window shows the program files

– The Resources pane shows the hybrid block task attached to the Field Controller

– The Lib pane shows the libraries available

– The Help pane opens the Online help tree

– The Catalog window might also appear – it can be closed by pressing the "x"

– The Log window tracks program events – it can be closed by pressing the "x"

3 Double-click on FC_01_HY_EMB_IO_1.ST: the editor opens with the declared external and 

mapped local I/O variables

– The upper right-hand pane contains the variables we have declared, Chapter 3.2.4, 3.5.2

– The lower right-hand pane contains the structuctured text program, which is empty 

on starting
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3.6.3 Declare additional variables

Additional variables used by the structured text program must be declared with name and data type 

in the upper right-hand pane before programming starts. Table 6-1 lists the various types of 

declaration supported. The declaration opens with the variable type and is closed with END_VAR. 

The various types are created with default value zero for real and integer variables and FALSE for 

booleans. 

Tab. 3-5: Variable declaration types

Attributes The declarations can be modified to define a particular behaviour of the variables contained within 

them by adding one of the attributes in Table 6.2.

Tab. 3-6: Declaration attribute types

Example For this exercise, we will declare the booleans "HMI_Start" and "HMI_Stop" as an OPC variable to 

enable a SCADA program to start and if necessary stop the blending sequence. In addition, the user 

is able to set the quantities of liquid to be blended in kg ("Quantity_Liquid_1" and 

"Quantity_Liquid_2"). The stirring time is set at 120s using the timer provided (TON); it is declared 

as shown in the example..

In order to keep track of the filling process, the retained variable "Process_Step" will be incremented 

every time a process Step is completed.

Variable type Access Rights Function

External Internal

VAR – RW Local variable that is readable and writable to its own block only

VAR_INPUT RW R Input variable that is readable and writable to an external block, but 

only readable to its own block

VAR_OUTPUT R RW Output variable that is readable and writable to its own block, but only 

readable to an external block

VAR_IN_OUT RW RW I/O variable readable and writable to its own and an external block

(call be reference)

VAR_EXTERNAL RW RW External I/O variable, declared as global in its own block, that is 

readable and writable to its own and an external block, whereby any 

change is immediately effective in all blocks where it is used

VAR_GLOBAL RW RW Global I/O variable, declared as external in its own block, that is 

readable and writable to it own and an external block, whereby any 

change is immediately effective in all blocks where it is used

VAR_ACCESS RW RW Global I/O variable (access path) that is readable and writable in its 

own and an external block resident in a different controller, whereby 

any change is immediately effective in all blocks where it is used

Attribute type Function

RETAIN Variable that retains its value when the controller is switched off or restarted

CONSTANT Variable that retains a constant value, i.e. not writable

OPC Variable that is readable and writable in the IEC OPC Server

– Local varibles declared with the prefix OPC_ are also visible in the IEC OPC server

Block Signal/Point Block Signal/Point Alias

Output from OPC Server HY_EMB_IO Bool HMI_Start

Bool HMI_Stop

Real Quantity_Liquid_1

Real Quantity_Liquid_2

TON Timer

HY_EMB_IO Integer Input to OPC Server Process_Step
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Procedure In the upper right-hand pane do the following:

1 Declare IEC OPC Server variables

VAR OPC

HMI_Start_Stop: BOOL;

Quantity_Liquid_1: REAL;

Quantity_Liquid_2: REAL;

END_VAR

2 Now add the retained variable

VAR RETAIN

Process_Step: INT;

END_VAR

3 Now add the timer

VAR

Timer : TON;

END VAR

Note! 

• An alternative method to declare IEC OPC Server variables not used in this tutorial 

is to add the OPC_ prefix:

VAR

OPC_HMI_Start_Stop: BOOL;

END_VAR

VAR_RETAIN

OPC_Process_Step: INT;;

END_VAR
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3.6.4 Activate the libraries

The FF variables used in IEC 61311-3 programming must be converted to a data type appropriate 

to programming language. To this end ControlCare activates two libraries by default:

•  CC_FF_CUSTOM_LIB to map the custom FF function blocks

(Data type conversion DS65, DS66)

•  CC_FF_STANDARD_LIB to map the standard FF function blocks

(FF status handling)

These appear red in the library pane (select the Lib tab)

Note! 

• For ControlCare Product Version 2.01.xx, the libraries have to be activated by hand

• For SFC programming the sfclib must be activated, see below and the OpenPCS online help

Activating a library In order to activate additional libraries, e.g. sfclib for SFC programming, the following procedure is 

used:

1 Select the Lib pane:

– Right-click on e.g sfclib and select Use in Current Project

– The project book turns red = active

Installing a library If the libraries are not installed:

1 Right-click on Libraries, select Install New..., 

2 Browse to the folder containing the LIB files and select the library required

3 Press OK twice to install.
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3.6.5 Create the structured text program

For simplicity, the structured text program will be written as follows

•  Step 0: Reset of Totalizer

•  Step 1: Filling of liquid 1, with stirrer switched on when Stirrer_Protection_LT2=False

•  Step 2: Filling of liquid 2

•  Step 3: Stirring for 2 minute (to demonstrate timer)

•  Step 4: Emptying of vessel, with reset of timer

•  Step 5: Prepare totalizer reset and stop process

The strategy is created according to the truth table in Chapter 2.1.2.

Step 0 1 (*Step 0: Initialize process*)

IF  HMI_Start_Stop=1 AND Process_Step<1 THEN

Reset_Totalizer_FT1.value:=0; (*Set Totalizer FT1*)

Reset_Totalizer_FT2.value:=0; (*Set Totalizer FT2*)

Process_Step:=1;

END_IF;

Step1 2 (*Step 1: Start filling liquid 1 provided no stop signal and start button pressed*)

IF HMI_Start_Stop=1 AND Emergency_Stop_B1=0 AND Overspill_Protection_LT3=0

AND Process_Step=1 THEN (*Start Condition*)

IF (Quantity_Liquid_1>Totalizer_FT1.value)THEN 

State_Valve_SV1:=1; (*Valve SV1 open*)

IF Stirrer_Protection_LT2=0 THEN (*Protection off*)

State_Motor_M1:=1; (*Motor M1 on*)

ELSE 

State_Motor_M1:=0; (*Motor M1 off*)

END_IF;

ELSE

State_Valve_SV1:=0; (*Close valve*)

Process_Step:=2; (*Step 1 completed*)

END_IF;

ELSE 

State_Valve_SV1:=0; (*Close valve*)

END_IF;

Step2 3 (*Step 1: Start filling liquid 1 provided no stop signal and start button pressed*)

IF HMI_Start_Stop=1 AND Emergency_Stop_B1=0 AND Overspill_Protection_LT3=0

AND Process_Step=2 THEN (*Start Condition*)

IF (Quantity_Liquid_2>Totalizer_FT2.value)THEN 

State_Valve_SV2:=1; (*Valve SV2 open*)

IF Stirrer_Protection_LT2=0 THEN (*Protection off*)

State_Motor_M1:=1; (*Motor M1 on*)

ELSE 

State_Motor_M1:=0; (*Motor M1 off*)

END_IF;

ELSE

State_Valve_SV2:=0; (*Close valve*)

Process_Step:=3; (*Step 1 completed*)

END_IF;

ELSE 

State_Valve_SV2:=0; (*Close valve*)

END_IF;
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Step 3 4 (*Step 3: Stir for 2 minutes*)

IF HMI_Start_Stop=1 AND Emergency_Stop_B1=0 AND Stirrer_Protection_LT2=0 

AND Process_Step=3 THEN (*Start condition*)

State_Motor_M1:=1; (*Motor M1 on*)

Timer(IN :=1 , PT :=T#120s); (*Start timer, 120 s*)

IF Timer.Q=1 THEN (*If timer stopped*) 

Timer (IN :=0); (*Set IN to 0*)

State_Motor_M1:=0; (*Motor M1 off*)

Process_Step:=4;

END_IF; (*Step 3 completed*)

END_IF;

Step 4 5 (*Step 4: Empty vessel*)

IF HMI_Start_Stop=1 AND Emergency_Stop_B1=0 AND Process_Step=4 THEN

WHILE Dry_Run_Protection_LT1=0 DO (*Empty condition*)

State_Pump_P1:=1; (*Pump on*)

State_Valve_SV3:=1; (*Open valve*)

END_WHILE;

State_Pump_P1:=0; (*Pump off*)

State_Valve_SV3:=0; (*Close valve*)

Process_Step:=5; (*Step 4 completed*)

ELSE 

State_Pump_P1:=0; (*Pump off*)

State_Valve_SV3:=0; (*Close valve*)

END_IF;

Step 5 6 *Step 5: Reset process*)

IF HMI_Start_Stop = 1 AND Process_Step=5 THEN;

Reset_Totalizer_FT1.value:=1; (*Reset Totalizer FT1*)

Reset_Totalizer_FT2.value:=1; (*Reset Totalizer FT2*)

HMI_Start_Stop:=0; (*Stop Process*)

Process_Step:=0;

End_IF;
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3.6.6 Trouble-shoot the project 

Now that the project is complete, it is recommended that the project is checked for errors.

1 Open the File menu and select Check Syntax

2 OpenPCS runs a check on all syntax in your program and publishes a log at the bottom of the 

workspace.

– If errors are found eliminate them and check the syntax again

– You can move from error to error with the F4 and Shift F4 keys

3 When the program is free of errors, this is reported in the log at the bottom of the workspace

4 Now open the File menu and select Save All.
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3.7 IEC 61131-3 Simulation

OpenPCS allows the simulation of the IEC 61131-3 program without the need for hardware. It is 

recommended that the program is tested with this function before it is downloaded to the Field 

Controller.

3.7.1 Resources

1 Click on PLC and select Resource Properties from the PLC menu

– The Edit Resource Specifications dialog opens

2 In the Edit Resource Specifications dialog

– Select Hardware Module: ControlCareSIM

– Select Network Connection: EHSIM

– Select Optimization: Size only

– Press OK to confirm the changes and close the dialog

3 Click on PLC and select Rebuild Active Resources (alternatively, press CTRL+F7)

– You can now go "Online" with the simulation.
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3.7.2 Go "Online"

1 Click on PLC and select Online from the PLC menu

– If appropriate an OpenPCS Online Server 32 message appears

– Press Yes to download the resource to the server

2 Press the Resource tab and click on the Field Controller in the project window

Note! 

• If there is more than one Field Controller in the project, it appears green and the others red.

• To activate different Field Controller, right click on it and select Set Active, its colour changes to 

green

3 Click on PLC and select Coldstart from the PLC menu

– The Field Controller simulation now runs

– The buttons Power Off, Run and Stop simulate the corresponding operating modes of the 

Field Controller

– The Cycles display show number of cycles simulated and cycle time in ms

– The LEDs simulate the LEDs on the Field Contoller

– To change the macrocycle time, press the >> button and enter a new value in the Cycle 

Time dialog, confirming with OK

4 The simulation is closed by clicking on PLC and select Offline from the PLC menu
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3.7.3 Watch list

By placing selected input and ouput variables in a watch list, the logic can then be checked.

1 Press the Resource tab and expand the FC_01_HY_EMB_IO_1 node

– A list of input and output variables appears

2 Double-click on a parameter to place it in the watch list

– Parameters can be deleted by selecting the parameter line and pressing DEL

3 Check the logic of each action by seeing the effect of parameter changes on the outputs

– Right-click on the watch list "value field" and enter a value in the Set Variable dialog

– Press OK to confirm the entry and close the dialog

4 When you are satisfied that the program does what it should, prepare for download by 

optimizing the preformance
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3.7.4 OPC tag monitoring

OpenPCS also allows the monitoring of the tags in the OPC and HSE servers. These include both 

the declared variables and contained variables. Thus it is possible to monitor, e.g. the current value 

of the block mode. Before it can be used, the function must be activated. It remains activated on 

aubsequent restarts of the program, independent of project.

Activating OPC tag 

monitoring

1 Select Extras=>Options=>Browser

2 In the Options menu, select the Extended Settings tab

– Select the option "Show OPC pane in browser"

– Press OK to store the change

3 You are now prompted to restart OpenPCS

– Close OpenPCS

– Restart OpenPCS from the Hybrid Embedded IO function block mode by selecting 

Program Hybrid Block

4 On restart you will find an extra tab "OPC-I/O" in the project window

Setting up the monitoring 1 Click on the tab "OPC-I/O" to reveal the OPC servers available
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2 Expand the Endress.hseserver tag to reveal all FOUNDATION Fieldbus tags in the project 

(may take some minutes)

3 Expand the tag you require and right click on the parameter to be monitored

– Select "Watch Tag" to add it to the monitoring list

4 Now expand the Endress.iecserver tag to reveal all IEC Variables (may take some minutes)

5 Expand the tag you require and right click on the parameter to be monitored

– Select "Watch Tag" to add it to the monitoring list

6 The parameters appear in the watch list under the OPC Variables tab where they can be 

monitored when the Project is online
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3.8 Optimize performance

If the IEC 61131-3 simulation was used, the resources must be respecified before the project is 

compiled and downloaded, see Chapter 3.7. 

OpenPCS allows the hybrid function block to be optimized for speed or size during compilation. 

Default setting is optimized for speed. Optimizing for size causes the block to run slower than if it 

is speed optimized, and is recommended only when there are memory problems, e.g. when a large 

number of hybrid function blocks with long programs are in use or when simulating without Field 

Controller hardware.

The settings below are those recommended for normal applications.

Changing the performance 

settings

The settings are made in both the resources and the hybrid function block

1 Click on the Resources tab, then right-click on Controller leaf and select Properties

2 The Edit Resource Specifications dialog appears

– Select Hardware Module: ControlCare SFC162/Rev 4

– Select Network Connection: FC_01

– Select Optimization: Speed only

– Press OK to confirm the changes and close the dialog

3 Now right-click on the Function Block leaf and select Properties

– The Edit Task Specifications dialog appears

– In the Optimization pull-down menu select e.g. "speed only", then press OK

4 Save your settings and close OpenPCS
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3.9 Go On-line

3.9.1 Connect to the Field Controller

In order to download the project, the host computer and Field Controllers must be allocated 

IP addresses in the same address range. It is possible to do this on the workbench before installation 

or after the Field Controller and other components have been physically installed in the Fieldbus 

network (subnet). 

Warning

• The use of IP addresses is strictly controlled. Usually your system administrator will be authorised 

to allocate unique addresses. Assigning an unauthorised address to a Field Controller may result 

in conflicts within your system and the failure of the associated devices!

Note!

• The tools that setup the network use Ethernet services that may be blocked by Windows Firewall. 

Normally the firewall will be unblocked for the tools during installation, but it might be necessary 

to stop the firewall should they not function properly. If you are not sure how to stop the firewall, 

consult your system administrator.

Before starting, check the following:

•  Internet Protocol TCP/IP is installed on your computer

•  You have administration rights for your computer

•  You have an set of IP addresses that have been authorized by your IT department

•  Any proxy server for your Internet Browser is disabled

The procedures described in this chapter are for Windows XP. For other Windows systems consult 

your system administrator.

Note!

• When the Field Controllers are physically connected together with the Host computer via 

Ethernet, HSE Network Setup will see the them irrespective of the IP address domain to which 

they belong
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3.9.2 Set the IP address of the host computer

SFC162 Field Controllers are delivered with the default IP address:

•  192.168.164.100 

In order that the host computer can communicate with the Field Controller Web Server, it must be 

allocated an IP address in the same address domain, e.g. 192.168.164.200. If you are not sure how 

to do this, consult your network administrator. 

Procedure 1 Right-click Start =>Settings =>Control Panel =>Network Connections

2 Right-click Local Area Connection => Properties

3 Using the left mouse button, double-click Internet Protocol (TCP/IP) or

click once, then click Properties. 

4 Note the original values of IP address and Subnet Mask of the computer to restore them if 

necessary at end of the operation. 
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5 Change the IP address and the Subnet Mask of the host computer to those required by the 

application. In the example, an address in the same subnet as the Field Controller. 

– IP Address 192.168.164.XXX and network mask (Subnet Mask) 255.255.255.0.

– Do not use the address 192.168.164.100,as these are reserved as default addresses for 

Field Controller SFC162

6 Click on the OK button to complete the procedure, close the other dialogs with OK and 

Close.

3.9.3 Set the Field Controller IP address

Note!

• It is recommended that Field Controllers of the same type are introduced one by one to the 

network.

1 Call HSE Network Setup: 

Programs =>Endress+Hauser=>ControlCare=>Tools=>HSE Network Setup

2 HSE Network Setup is launched and searches for Field Controllers in the Ethernet network.

– All Field Controllers in the network appear, irrespective of their IP domain. 

If this is not the case:

– Check that the proxy server of your Internet Browser is switched off

– Check that the windows firewall is not blocking the program (switch off)

– Check all cables and switches

– If you find two or more Field Controllers with the same IP address, disconnect all but one 

from the network

3 If your computer has more than one NIC card, select the one you want to use for 

communication with the Field Controllers by ticking "Active NIC" and Press .
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4 Right-click on the Field Controller, the address of which is to be changed:

the Field Controller Web Server opens

– The Web Server will only open if the host computer and the Field Controller have 

IP addresses in the same IP domain.

5 Expand the Setup node and click Network

– Enter User Name "pcps" and Password "pcps" to open the Network Configuration dialog

– Enter the required IP address, in our example 10.125.35.180

– Enter a netmask, normally 255.255.255.0

– If required, enter a default gateway, usually address xxx.xxx.xxx.1 in the selected domain

6 Press Update to change the IP address, then close the Web browser

– The Field Controller is restarted automatically

– Wait until the Field Controller address canges in HSE Network Setup

7 Now set the address of he host computer to the same domain as the Field Controller, see 

Chapter 3.9.2 - in our example 10.125.35.200

– In HSE Network Setup, tick the Field Controller, so that it appears in the HSE Live List 

associated with the computer’s active NIC card.

– Press  to save the configuration.

– You are now ready to download the project

Note!

• If you have more than one Field Controller on the network, Repeat Steps 4 to 6 for all other Field 

Controllers, introducing them one by one to the network.
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3.10 Generate the live lists

3.10.1 HSE live list

Once the Computer and Field Controller are able to communicate with each other, the connection 

to the network can be checked by creating a live list. 

1 Press the On-Line button  in the menu toolbar

– The project goes on on-line

– A red cross appears against the Field Controller in the Project workspace

2 In the Project workspace, right click on HSE Network and select Live List

– A live list is generated of the devices on the HSE network

Note! 

• It may take sometime to generate the live list 

– The devices found first go grey 

– Their profiles (all important device-specific data) including IP address are read

– On successful completion of profile reading, the devices are shown in full black
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3.10.2 Assign the HSE Device IDs

1 In the Project workspace, right click on the Field Controller (CO104) and select Attributes...

2 The Attributes dialog opens

– Open the drop-down menu of the Device ID and select the Field Controller associated

with the displayed TAG (in our case FC_01) - the serial number is on the front panel

– Do this even though the correct ID is already displayed - the program expects it!

– Confirm your choice with OK

– If Application Designer detects a mismatch in version, this is logged at the bottom of the page

(for remedy, see Chapter 7.2)

3 In the project window, the red crosses disappear from the Controller anf Fieldbus nodes

4 If several SFC162s were in use, Steps 1 and 4 would be repeated for all.

5 Click on the Project View workspace and Export Tags..., see Chapter 3.5.3

– Open Project File, then press Save Entire Configuration, to save the project.
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3.10.3 Create the FOUNDATION Fieldbus live list

1 In the Fieldbus network workspace, right-click on Fieldbus 1 and select the option Live List

2 The Fieldbus live list is created

– Check that devices in the project appear in the live list. If not, check connections etc.

3.10.4 Assign the Fieldbus Device IDs

1 In the fieldbus workspace, right click on FT1 and select Attributes...

2 The Attributes dialog opens

– Open the drop-down menu of the Device ID and select the device ID associated

with the displayed TAG (in our case FT1) - the serial number is on the nameplatel

– Confirm your choice with OK

– After a period of time, the red cross disappears from the device in the Fieldbus network

– If Application Designer detects a mismatch in version, this is logged at the bottom of the page

(for remedy, see Chapter 7.2)

3 Repeat the process for the rest of the devices in the Fieldbus network (FT2)

– After a period of time, the red cross disappears from the device in the Fieldbus network

4 Click on the Project View workspace and Export Tags..., see Chapter 3.10

– Open Project File, then press Save Entire Configuration, to save the project.
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3.10.5 Assign All Tags

1 In the Fieldbus workspace, right-click on the Fieldbus node at the top of the tree and select 

Assign All Tags

2 The Assign All Tags dialog appears with the list of device and a progress bar

– On completion, the message "Profile reading done" stands next to the Field Controller

and "Tag has been confirmed" next to the devices

– If there are any failures in tag assignment these are logged with reasons at the bottom of the 

screen.

3 As the assignment proceeds, the Field Controller transmits the change to the device

– The device goes grey in the live list

– The Field Controller initiates a new network scan

– After about 1 - 2 minutes, the device goes black and appears with the new tag

4 At the end of the process the live list looks like this

– The "bright" dot next to the SFC162 Field Controller indicates that it is the ACTIVE LAS 

of this segment
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3.11 Download the project

Both the project in ControlCare Application Designer and that in Open PCS must be downloaded 

to the Field Controller. The downloads can be made in any order.

Note! 

• The procedure below describes the initial download for the entire HSE network. 

• Partial downloads can be made later from lower leaves, when changes are confined to this level

• Incremental downloads can be made to a running project by checking the boxes Incremental 

Download and Compare Parameters: Unaffected Local I/Os will hold their last values.

3.11.1 Download the control strategy

1 In the Project workspace right-click on HSE Network 1and select Download

2 The Download dialog appears

– Press Start to start the download

3 The download will be interrupted if the project has not been configured properly, e.g.

– The Controller Tag has not been assigned correctly => Assign Field Controller tags, 

Chapter 3.10.2

– The I/O modules have not been correctly defined, see Chapter 3.5.1 and 3.5.2

4 When the download is successfully completed, the dialog is closed, and you are ready to 

download the hybrid block configuration

Note!

• At this point you can assign the Device Class LAS to the Promag, if you want to have a back-up 

LAS in the system, see FOUNDATION Fieldbus Tutorial, BA019/04/en.
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3.11.2 Download the OpenPCS project

1 Start OpenPCS by right clicking on FC_01_HY_EMB_IO_1 in the HSE Network 1 tree and 

selecting Program Hybrid Block: 

– If OpenPCS is already running, close it before performing this step

– The attribute settings are exported to OpenPCS

– Click OK to open the OpenPCS workspace

1 Click on PLC and select Online from the PLC menu

– If appropriate an OpenPCS Online Server 32 message appears

– Press Yes to download the resource to the server

2 Press the Resource tab and click on the Field Controller in the project window

3 Click on PLC and select Coldstart from the menu: the hybrid block is started (set to Auto). 

4 If there is more than one controller in the project, each must be cold-started as follows:

– Right click on the controller and select Set Active, its colour changes from red to green

– Click on PLC and select Coldstart from the menu

– All hybrid blocks attached to the controller are forced to Auto

5 Now check the project files

– You will see that the names in watch list are now replaced by values

6 OpenPCS offers a number of options for monitoring values and changing the program without 

stopping execution, e.g. on-line editing –see the on-line help for details.
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3.12 Check the control stategy

3.12.1 Control strategy

1 Click in the Control Strategy workspace (Pump control) and press the button  in the menu 

toolbar – the control strategy also goes "on-line"

– Values appear in green when the status is good

– Values appear in red if the status is bad - at this stage this is an indication of a communication, 

block configuration, strategy configuration or device parametrization error

2 If you have the possibility of changing the signals, change each input in turn and check the 

effect on your strategy.
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3.12.2 Optimization of hybrid block execution time

1 Open the HSE Network 1 dialog, then click on the "details" icon in the menu bar

– The execution times are shown next to each block

– The FC_01_HY_EMB_IO_1 block executes at the default time of 10 ms

2 Right-click on the FC_01_HY_EMB_IO_1 block and select On Line Characterization

– The parameter EXEC_TIME_ACTUAL shows the time in which the block is executing

– Observe the value for a couple of minutes and note the highest value

3 Now change the function block execution time to the new value

– Right-click on FC_01_HY_EMB_IO_1 and select On Line Characterization

– Double-click on the "value space" next to the parameter EXEC_TIME_TARGET

– Enter a value 10% to 20% higher than the highest observed actual execution time

– Press End Edit to store the value and Close to quit the dialog.

4 Right-click on the Bridge node (FC_01) and select FB Schedule Download 

– The new value is downloaded to the Field Controller

– The strategy now runs with the new target execution time

5 Repeat Steps 1 to 4 for all hybrid blocks in the strategy

Note!

• EXEC_TIME_ACTUAL will be too high if the ST program is being monitored on-line by 

OpenPCS. Close the application before checking the value.
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3.13 Modify the project

3.13.1 On-line characterization

Once the project is on-line you may want to change parameters to e.g. tune the control-loop or 

eliminate configuration errors. With the exception of the SP parameter, the function block must be 

put out of service before the parameter is changed:

1 In the Control strategy workspace double-click on the function block you want to modify, or in 

the HSE network 1 or Control module workspace, right-click on the function block and select 

On-line Characterization

2 The function block On-line Characterization dialog appears:

– Open the Mode leaf and double-click in the space next to Target

– Set the Target to OOS (Out of Service)

– Click End Edit to set the parameter

3 Change the parameters you wish to modify

– If appropriate, open the parameter leaf and double-click in the space next to the parameter 

you require

– Enter the new parameter or select it from the drop-down menu

– Click End Edit to set the parameter

– Repeat the procedure for all the parameters you wish to modify

4 Put the function block back into standard operating mode

– Open the Mode leaf and double-click in the space next to Target

– Set the Target back to the original value (Auto (Automatic) or Cas (Cascade))

– Click End Edit to set the parameter

– Check that the Mode really changes to the Target Mode (failure to do so indicates a 

configuration error)

– Press Close to store the values (if you are prompted - answer with Yes)

5 Click on the Project View workspace and Export Tags..., see Chapter 3.10

– Open Project File, then press Save Entire Configuration to save the project

6 Put the Control stategy back "on-line" to check the results of your modification, Chapter 6.4.
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3.13.2 Off-line characterization

You may prefer to change parameters off-line, e.g. when modifying the control strategy or adding 

new functions to the project. 

1 If you are on-line, press the Off-line button  in the menu toolbar

alternatively, in the PROFIBUS network or Control module workspace, right-click on the 

function block and select Off-line Characterization

– The function block Off-line Characterization dialog appears

2 Change the parameters you wish to modify

– If appropriate, open the parameter leaf and double-click in the space next to the parameter 

you require

– Enter the new parameter or select it from the drop-down menu

– Click End Edit to set the parameter

– Repeat the procedure for all the parameters you wish to modify

– Press Close to store the values

3 Click on the Project View workspace and Export Tags..., see Chapter 3.10

– Open Project File, then press Save Entire Configuration to save the project

4 Press the On-line button  in the menu toolbar to go on-line again

5 Download the modified project

– In the Project workspace right-click on HSE Network 1and select Download

– Follow the procedure in Chapter 6.3

6 Put the Control stategy back "on-line" to check the results of your modification, Chapter 6.4.
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3.14 Packing and unpacking the project

In order to install the project at the customer’s site, the project can be packed and unpacked. It is 

important to remember, especially if you have not been using the actual project devices to test your 

project, that the instruments on site may be have newer (or even older) DD/GSD/CFF files than 

the ones you use. The latest DD/GSD/CFF files must then be uploaded to the project and 

corresponding corrections must be made to configuration, before it is downloaded to the Field 

Controller. The is done with the Import Device Support... item in the Project File menu, see 

Operating Instructions BA017S/04/en, Chapter 3.1.5.

3.14.1 Pack the project

1 Select Project File => Pack Project...

– The Pack Project dialog appears

– Browse to the folder where the files will be created

You can create a folder with the Make New Folder button 

– Enter the name of the project

– Press Save to save the packed project

– Press OK to close the successful packing message dialog

3.14.2 Unpack the project

1 Select Project File => Unpack Project...

– In the Unpack Project dialog

– Browse to the folder where the packed project is located

– Click on the name of the project

– Press Open to save the packed project

2 In the Browse for Folder dialog:

– Browse to the folder where the project is to be installed

You can create a folder with the Make New Folder button 

– Press OK to start upacking

– Press OK to acknowledge the successful unpacking of the project

3.14.3 Unpack the OPC data base only

For some applications it may be necessary to update the OPC data base of a SCADA program that 

has no provision for importing new DDs etc.. This can be done in Application Designer, which 

allows the separate unpacking of the OPC data base.

1 Go online, then right-click on the HSE OPC Server icon in the system tray

2 Select Unpack Configuration...:

– Unpack the OPC data base to the folder required according to the Steps 1 and 2 in

Chapter 7.6.2 above.
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3.15 Export the configuration

For documentation purposes, the project configuration can be exported to an existing ODBC file 

data source, e.g. Oracle, a machine database, e.g. Excel to provide a record of the current status of 

the project or to an XML sheet for viewing with a browser.

3.15.1 File data source folder

The file data source must have been created before the export.

1 In the Project window, right-click on the Project icon and select Export Configuration:

2 The Select Data Source dialog box appears

3 In the File Data Source folder, select the source that describes the driver that you wish to 

connect to. You can use any file data source that refers to an ODBC driver which is installed on 

your machine.

– Use the New... button and Look In dropdown menu to browse or 

– Click the data source icon to select the driver:

– Press OK to make the connection

3.15.2 Machine data source folder

The Machine Data Source is specific to the machine, and cannot be shared. "User" data sources 

are specific to a user on the machine; "System" data sources can be used by all users on the machine, 

or by a system-wide service. The Machine Data Source must have been created before export.

Procedure 1 In the Project window, right-click on the Project icon and select Export Configuration:

2 The Select Data Source dialog box appears

– Click on the Machine Data Source tab to open the folder

– Double-click the data source name to select the machine, e.g. Excel:

3 The Select Workbook dialog box will appear:

– Select the folder where the data file is and double-click the workbook icon.

– Your project configuration will be exported to the workbook file.

– A message box appears on completion - press OK

4 Open the Excel file to check the result:

3.15.3 XML file

1 Click in the Project workspace and select Project File =>Export => Configuration as XML

– The Export Configuration as XML dialog appears

2 Enter a File Name and Save In location, then press Save

– The project is saved as an XML file at the selected location
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3.16 Close Application Designer and OpenPCS

When you have completed your session, close Application Designer and OpenPCS

3.16.1 Application Designer

1 If you are on-line, press the Off-line button  in the menu toolbar

2 If you have made any modifications while you were on line, you will be prompted to store 

them

– If appropriate answer with Yes

3 Close the project by clicking on Project File => Close

4 Exit Application Designer by clicking on Project File => Exit

5 The Field Controller continues to operate with the project configured according to the last 

download/on-line correction

– If you switch off the Controller, the project remains stored in its memory

(provided the battery DIP switch is on, see BA021S/04/en: Field Controller, Hardware 

Installation)

– It is initialized and re-executed as soon as the Controller is switched on again

3.16.2 OpenPCS

1 Open the PLC menu and select Offline

2 Open the File menu and select Exit

– You will be prompted to save if your project has been changed since the last download

3.16.3 Reconnecting Application Designer

Provided your computer is operating in the same IP address domain as the Field Controller, you can 

reconnect at any time.

1 Start up Application Designer and select the Project you require

2 Press the On-line button  in the menu toolbar

3 Expand the various workplaces as required

4 Click in the Control Strategy workspace and press the button  in the menu toolbar – the 

control strategy goes "on-line" with the last configuration that was downloaded.

3.16.4 Reconnecting OpenPCS

Provided your computer is operating in the same IP address domain as the Field Controller, you can 

reconnect at any time.

1 Start up OpenPCS, open the File menu and select the project you require

– Open the File menu and run Check Syntax

2 Open the PLC menu and select Online
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4 PROFIBUS Solution

4.1 Create a physical network

4.1.1 Create a PROFIBUS project

1 Start ControlCare Application Designer by clicking on the icon on your destop or via Start => 

Programs => Endress+Hauser => ControlCare => ControlCare Application Designer

2 The project starts from a blank application screen

– With the right mouse key select Project File=>New

1 The Document Type box appears: Click the option Project

2 The New Project dialog box opens:

1. Choose the folder where the project will be saved.

2. Type the name of the project in the File Name box.

3. Click Save. 

If the new project is not to be created, click Cancel.

3 ControlCare Application Designer automatically creates a folder with the entered file name 

within the selected folder.
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4.1.2 Determine the naming preferences

Before you start, you can set preferences for the way your project is created. Of particular interest 

at this stage is the labelling of the function blocks.

1 Press Project File => Preferences

– The Preferences Dialog appears

Tag Policy Tag Policy determines how the blocks are labelled by default if no tag names are entered

1 Select the folder Block and the subfolder Tag Policy, then check the following buttons

– Device

– Update Block Tag

2 Press OK to confirm your selection

– Application Designer will now automatically rename any blocks created in the control

strategy window as they are assigned to the devices by adding the device tag as prefix.

Tag Composition Tag Composition determines how the block identifiers are added to the block tag if no block name 

is entered.

1 Select the subfolder Tag Composition:

– Enter a mnemonic separator: for this manual the setting was "-"

Default setting is "_" and mandatory for if flexible function blocks are to be used

– Check Prefix

2 Press OK to confirm your selection

– Application Designer will now automatically compose the blocks according to your

selection, e.g. TagName-Block-n or TagName_Block_n.

Export Tag Export Tag causes tags to be automatically exported every time the project goes online

1 Select the subfolder Export Tag

– Check the Automatic button

– Press OK to confirm your selection

Strategy Strategy determines the default shape of the function block icons in the stratagy window and also 

whether the aliasing function is enabled

1 Select the subfolder Strategy

– Select the default shape for function block objects

– Select "Alias Input Dialog Box" 

– Press OK to confirm your selection
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4.1.3 Add a gateway (SFC173)

1 On saving, ControlCare Application Designer automatically creates a project, adding the HSE 

fieldbus network and the HSE Host

– Click on + to expand the tree:

2 Now right-click on the HSE Network leaf and select New=>Gateway

3 The New Gateway dialog box appears:

Select the SFC173 Field Controller and type in a device TAG = FC_01

If you do not type in a tag, the default will be "Gateway n", where n is a consecutive number. 

4 Press OK to create the Gateway.
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4.1.4 Add a PROFIBUS segment

1 The project now looks like this:

2 Right click on the gateway you just created, here "Gateway 1", and select New Profibus.

3 The New Profibus dialog box appears:

– At this point you can enter a PROFIBUS segment TAG

– If you do not type in a tag, the default will be "Profibus n", where n is a consecutive number. 

4 Press OK to create the PROFIBUS segment.

5 The ControlCare PROFIBUS Configurator opens with the SFC173 Field Controller inserted 

as PROFIBUS master/host with the default address 1

– Use the default address "1" for the Field Controller - use higher addresses for other masters

– Do not use address "0" for either master or Field Controller
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4.2 Set the PROFIBUS parameters

1 Click on the SFC173 master, select the menu Settings => Bus Parameter...

– The Bus Parameter dialog appears

– Select the Baudrate you require - it must be supported by all PROFIBUS DP slaves

– Select the optimize option By User, if you want to check and edit parameters

The optimize option Standard sets SK3 standard parameters for the selected baudrate

2 To check and/or optimize the parameters, press the Edit button

– The Edit Bus Parameters dialog appears

– Make any changes necessary and press OK to confirm and store them

3 As devices are added to the bus, see Chapter 3.7, the Master checks whether they support the 

selected baudrate

– A warning message appears if a device does not support the selected rate

– PROFIBUS DP slaves normally listen to the bus and adjust automatically to the baudrate. 

If this is not the case, their baudrate must be changed to that of the coupler.

– For the SK3, the special GSD file "Yxxx ...." must be used for PROFIBUS PA slaves

Standard GSD files for PROFIBUS PA slaves support baudrates 93.75 kbit/s (P+F SK1) and 

45.45 kbit/s (Siemens coupler) by default

– If a PROFIBUS DP master is added to the bus, e.g. FXA720 Class 2 Master, then its bus 

parameters must be set to those of the Field Controller. In such cases it may be necessary to 

increase the target rotation time, e.g. by 10,000.

P+F SK1 coupler 1 For the SK1 coupler select 93.75 kbit/s (default) and optimize By User, then press Edit

– The Edit Bus Parameters dialog appears

2 Check and if necessary enter the following parameters (P+F SK1 coupler):

– Slot time: 4095

– Min station delay: 22

– Max station delay: 1000

– Set-up time: 250

– GAP actualization factor: 100

– Max retry limit: 3

– Token rotation time: 90000

– Press OK to store the parameters followed by OK to exit the Edit dialog
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4.3 Configure the PROFIBUS master

1 Double-click on the SFC173 Node, the Master Configuration dialog box opens:

– Enter the controller tag in the Description, i.e. FC_01 

– Set the Station Address to 1

2 A click on the DP Master Settings... button opens the DP Master Settings dialog:

– A description of the parameters is to be found in the on-line help

– For our application no changes need be made

– Press OK to close the dialog and return to the Master Configuration dialog

3 Press OK to confirm the changes in the configuration and to return to the PROFIBUS 

Configurator workspace
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4.4 Add the PROFIBUS devices

Note! 

• For information on GSD files, see the PDF Content CC_GSD_Library in the Manuals folder

• GSD files of 3rd party devices can be added to the library by selecting File=>Copy GSD

• The P+F SK3 power link may require special GSD files for PROFIBUS PA devices. 

As of CC release 2.03.xx, standard files can be used for Endress+Hauser devices, but for earlier 

releases or 3rd party devices select the files with the suffix "Yxxx" or "SK2"

1 For the tutorial, add two Endress+Hauser Promag 53 DP devices, three liquiphant and a Allen-

Bradley Remote I/O 1794-APB/B

– Add the slaves in the order they are required in the function block schedule. 

– If you prefer, the slave can be configured before the next one is added, see Chapter 4.8.

2 Select Insert =>Slave... a large S appears as cursor. 

Move this to the position on the PROFIBUS line, below the SFC173 Field Controller icon, 

where you want to place the device. 

3 Right-click to begin placing: the Insert Slave dialog box appears

– Select the Vendor and if required Type of Slave (All, General, I/O Slave)

– Select a device from the Available Slaves list

– Press Add to move it to the Selected Slaves list

– Designate a unique slave address >3 (0 - 2 are reserved for masters)

– Enter a symbolic slave name, e.g. Slave 1

– Press OK to add the slave to the segment

4 Your project should now look something like this:
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4.5 Configure the PROFIBUS slaves

The device configuration is done in the Slave Configuration dialog box. Although the basic actions 

are identical, it varies slightly according to the type of slave. 

4.5.1 Promag 53 configuration

1 Double-click on the Promag Node, the Slave Configuration dialog box opens:

– The General box contains the parameters as set in the Insert Slave dialog (these can be 

changed if required - use underscores instead of spaces, as the latter and invalid characters)

– Enter the preset Station Address = 10

– Enter the device tag as Decription = FT1,

– In the Parameter Box you can select the GSD modules that define the data to be sent to and 

from the Field Controller

– The parameters for the Promass 53 must be configured in a fixed order, see BA064F

– Use Empty_Module/Free_Space parameters to fill gaps made by unused GSD modules

– Select the EMPTY_MODULE parameter and press the Append Module button, the 

parameter is added to the I/O parameters box

– Select the SETTOT_TOTAL parameter (=totalizer with reset) and press the Append 

Module button, the parameter is added to the I/O parameters box

2 Press DPV1 Settings... and make sure that DPV1 Activated checkbox is not checked 

(this avoids download problems)

– Press OK to confirm your settings

3 Press OK to complete the configuration

4 Repeat Steps 1 and 2 for the second Promass 53:

– Station Address = 11

– Description = FT2

– Modules: EMPTY_MODULE; SETTOT_TOTAL
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4.5.2 Liquiphant configuration

1 Double-click on the Liquiphant Node, the Slave Configuration dialog box opens:

– The General box contains the parameters as set in the Insert Slave dialog (these can be 

changed if required - use underscores instead of spaces, as the latter and invalid characters)

– Enter the preset Station Address = 12

– Enter the device tag as Decription = LT1

– In the Parameter Box select the GSD modules to be sent to the Field Controller

Discrete_In is preselected in he I/O parameters box

– Press DPV1 Settings... and make sure that DPV1 Activated checkbox is not checked

– Press OK to confirm your settings

2 Press OK to complete the configuration

3 Repeat steps 1 and two for the other Liquiphants:

– Station Address = 13 and 14

– Description = LT2 and LT3

– Module: Discrete_In
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4.5.3 Remote I/O configuration

1 Double-click on the Node, the Slave Configuration dialog box opens:

– The General box contains the parameters as set in the Insert Slave dialog (these can be 

changed if required - use underscores instead of spaces, as the latter are invalid characters)

– Enter the preset Station Address = 21

– Enter the device tag as Decription = RIO_01

– In the Parameter Box select all modules that are used in the Remote I/O in full format:

– Press the Append Module button to add the modules to the I/O parameters box

– IN our case we had the APB status, IB10, IP4, OB16, OV16 and IRT8 modules

– Press DPV1 Settings... and make sure that DPV1 Activated checkbox is not checked

– Press OK to confirm your settings

2 Press OK to complete the configuration

Note! 

• When the project is online, the raw data offered by the Remote I/O can be viewed as follows:

– Double-click on the ROI_01 Node, the Slave Configuration dialog box opens

– Select the e.g. the IB10 module in the I/O parameter list

– Press the Parameter Data button, the Parameter Data dialog with raw data appears

3 In the Parameter Data dialog, press the Common button – the parameters common to the 

entire I/O can be modified, e.g. fault action: see manufacturer’s instructions for more details

– A double-click on the parameter calls a list of possible options

– Press OK to confirm your choice

– After all common parameters have been configured, press OK to confirm your selections
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4 To change module, press the Module button: the Select module dialog opens

– Select a module and press OK

5 The corresponding module dialog appears

– Set the I/O module parameters, see Remote I/O manufacturer’s instructions

6 Repeat Steps 4 and 5 until all modules have been configured

7 Press OK to complete the configuration: your project should now look like this:

– Select Save then Exit to close PROFIBUS configuration
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4.6 PROFIBUS I/O mapping

The PROFIBUS I/O mapping connects the GSD modules, which are responsible for cyclic 

communication with the PROFIBUS devices, to function blocks. Depending upon device type these 

may be simple Input/Output blocks with one OUT or IN value, or Multiple Input/Output blocks 

with several OUT or IN values. In the latter case, the values are connected the order they appear in 

the Mapping dialog, i.e. Value 1 = OUT_1/IN_1 etc. The PROFIBUS function blocks can then be 

used to create the control strategy, see Chapter 4.

4.6.1 Configuring the Remote I/O

Before you begin to map a component, it is important that you read the appropriate operating 

manual, since it is necessary to know what parameters are offered by the device and in what format 

they are transmitted across the PROFIBUS network.

1 After the PROFIBUS Configurator is closed, the PROFIBUS I/O Mapping dialog appears, 

showing Device/Function Block and Module/Submodule views

– For most PROFIBUS PA and PROFIBUS DP devices, the function blocks are preconfigured 

and appear in the Device/Function Block View as yellow boxes. If the parameter in the 

right-hand pane has a question mark, it must be configured, see Chapter 4.6.1.

– For Remote I/Os you will always see a series of question marks: this means that the 

submodule data format must be configured

2 Click on the 1794-APB/B submodule leaf of the Remote I/O - a bit map appears at the top of 

the page

– Click on Bit 0, then right-click over the bit map and select the output type and data format

– For the 1794-APB/B module 2 bytes are transmitted, each bit representing a status: 

To view individual statuses, this is mapped by two bytes "Packed Digital Values without 

status"

– The same applies to the output bytes
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3 Repeat Step 2 for the I/O modules (in the tutorial we require only the APB status, and 

IB10XOB6 module, but the system used for the documentation contained other modules)

– Analog values are mapped by two or four bytes, with or without status

– Discrete values are normally mapped as packed digital values with or without status - this 

ensures that a separate parameter is assigned to each bit

4 On selection, the question mark disappears and the appropriate Function Block appears in the 

Device/Function Block view

5 Now right-click on each byte and select Attributes - the Parameter Attributes dialog box 

appears:

– Status for packed values is always = SLAVE_VALUE_WITHOUT_STATUS

– Select Status Value = Good NonCascade or Good Cascade, depending on role in loop

– The selection applies to the all parameters mapped to the byte

– You can also enter a Parameter Tag - this will appear in the project tree

– Press OK to confirm your choice and close the dialog box. 
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4.6.2 Assignment to the hybrid block

Once the mapping of the PROFIBUS devices is complete, the inputs and outputs can be assigned to 

an embedded hybrid block. This can be done in one step by assigning all I/Os to the block, or for 

individual devices. In this tutorial, all I/Os will be assigned in one step.

1 Right-click on the FC_01 node of the Device/Function block view of the PROFIBUS mapping 

tool and select "Assign all devices to the Hybrid function block...":

– The Assign to Hybrid Function Block dialog opens

2 The "Assign all devices to the Hybrid function block..." shows the list of available hybrid 

function blocks, in our case none, and allows additional function blocks to be created:

3 In the Add New Block.. field at the bottom, enter the block tag - in our case "reactor" and 

click on the button Add New HFB to add it to the block list

4 Now select the "Reactor" block in the upper work space and press OK

– Press Yes to confirm the action in the message which appears:
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5 The I/Os are all assigned to the Reactor block

– The function blocks previously attached to the PROFIBUS devices are replaced by the

hybrid block
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4.6.3 Adding the alias names

After the I/Os have been added to the hybrid block, the parameters can be given alias names:

1 In the Device/Function Blocks view of the PROFIBUS Mapping Tool, expand the Reactor 

block of all the devices in the tree:

– Depending upon the PROFIBUS function block configuration, the each parameter is mapped 

to the hybrid function block as a Parameter_x, and where appropriate a Parameter_x_Status

2 Right click on the FT1 node and select Edit IEC variables...

– The IEC Variables dialog opens

3 In the IEC Variables dialog, double click on the first parameter and enter its alias name:

– The aliases are shown in the table on the next page

– Values and status of the same parameter should be assigned the same name

– If you prefer to map individual parameters, the IEC Variables dialog can be opened from each 

device node

– You can copy & paste e.g. direct from an Excel table
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Alias names

4 When all parameters have been entered press OK to register the changes

– The parameters under the "Reactor" nodes now have aliases

5 Press OK to close the PROFIBUS I/O Mapping tool and complete the mapping

– The project looks something like this

6 Open Project File, then press Save, to save the project, it should look like this

Device IEC Variable Alias Name

FT1 (Promag) Parameter_1 Totalizer_FT1

FT1 (Promag) Parameter_1_Status Totalizer_FT1_Status

FT1 (Promag) Parameter_2 Reset_Totalizer_FT1

FT2 (Promag) Parameter_3 Totalizer_FT2

FT2 (Promag) Parameter_3_Status Totalizer_FT2_Status

FT2 (Promag) Parameter_4 Reset_Totalizer_FT2

LT1 (Liquiphant) Parameter_5 Dry_Run_Protection_LT1

LT1 (Liquiphant) Parameter_5_Status Dry_Run_Protection_LT1_Status

LT2 (Liquiphant) Parameter_6 Stirrer_Protection_LT2

LT2 (Liquiphant) Parameter_6_Status Stirrer_Protection_LT2_Status

LT3 (Liquiphant) Parameter_7 Overspill_Protection

LT3 (Liquiphant) Parameter_7_Status Overspill_Protection_Status

RIO_01 1794 IB10xOB6 (input) Parameter_33 Emergency_Stop_B1

RIO_01 1794 IB10xOB6 (output) Parameter_49 State_Valve_SV1

RIO_01 1794 IB10xOB6 (output) Parameter_50 State_Motor_M1

RIO_01 1794 IB10xOB6 (output) Parameter_51 State_Valve_SV2

RIO_01 1794 IB10xOB6 (output) Parameter_52 State_Valve_SV3

RIO_01 1794 IB10xOB6 (output) Parameter_53 State_Pump_P1
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4.6.4 Export tags

Note! 

• You should use the Export Tags function everytime you change the configuration of the project, 

so that the OPC server information is always up-to-date.

• Application Designer can be set to automatically export the tags every time the project goes 

online, see Chapter 3.2.

1 Activate the project view by clicking in its workspace

2 Right click on the project name, a context menu appears

3 Select the option Export Tags...

– The Export Tags dialog confirms the successful export

– Press OK to close the dialog

4 Open Project File, then press Save to save the project
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4.7 Create a Control Strategy

Having created a physical view of the process instrumentation, the next step is to create control 

strategy. This is done in the logical view of the plant. This represents the plant as Areas/Process 

Cells in accordance with ISA S88/IEC 61518. Only one Area is allowed in the project, but this may 

have any number of Process Cells.

4.7.1 Add a Process Cell

1 Click on the "Area 1" leaf in the project and select Attributes...

2 The Attributes dialog box appears

– Enter a name for the area, e.g. Magnasol Production

– Click OK to store your changes

3 Click on the Area leaf again and select New Process Cell...

4 The Process Cell dialog box appears

– Enter a name for the process cell, e.g. Blending

– Click OK to store your changes

5 Your project should now look something like this:

6 Open Project File, then press Save Entire Configuration, to save the project.
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4.7.2 Add a Control Module

1 Double-click on the Process Cell leaf - a new window with the name of the leaf opens

2 Right-click on the top leaf and select New Control Module

3 The Control Module dialog box appears

– Enter a name for the control module, e.g. Reactor Control

– Click OK to store your changes

4 The project now looks something like this:

5 For a real project, Step 2 and 3 would be repeated until all the required control modules for a 

particular process cell have been added. This allows each control loop or control loop group to 

be set up and viewed in its own control strategy window.

6 Double-click on the control module leaf to open the Control Strategy workspace - this has the 

same name as the leaf
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4.7.3 Add Function Blocks to the Control Strategy

Note! 

• For PROFIBUS devices, Application Designer automatically executes the function blocks in the 

order input, control logic, output. 

• The order of execution of the control logic blocks is determined by their order of creation in the 

Field Controller, see Chapter 3.10. The order of these blocks only can be changed by dragging 

and dropping them in the Control Module workspace, see below.

• The order of execution of the input and output blocks depends on the order of creation of the 

associated devices in Profibus Configurator, see Chapter 3.7.

1 Take the Profibus workspace and expand the Profibus tree until you see all function blocks. 

Place the workspace next to the Control Strategy workspace

2 Now drag and drop the Reactor block from FC_01 FBAP node of the Profibus tree into the 

Control Strategy workspace

3 As you do this, you will see that the function block also appears in the Control Module 

workspace

4 Open Project File, then press Save Entire Configuration, to save the project.

4.7.4 Add the Function Block links

Normally at this stage, links would be made between function blocks which run in the controller 

and the I/O blocks created for the PROFIBUS devices in the PROFIBUS Configurator, see Chapter 

3.2.4. In this application, however, all inputs and outputs have been mapped to the hybrid 

embedded block, so that this step is not necessary. 
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4.8 Characterize the function blocks

After the network and a control strategy have been created, the function blocks can be characterized 

offline. You may prefer to configure the devices first, e.g. with FieldCare or the local display, see 

Chapter 4.20. In strategies using many blocks and links you my decide that it is simpler to create 

and configure the devices and strategy piece by piece. Application Designer allows all these options.

In this tutorial, we have only one block, the Hybrid Embedded I/O block.

4.8.1 Hybrid Embedded I/O block

The Hybrid Embedded I/O block adds the logic to the control strategy. It contains local I/O inputs 

and outputs and can also be connected to upstream and downstream function blocks. A logical 

algorithm that may be programmed in any of the IEC 61131-3 function block langúages provides 

the logic between inputs and outputs. The programming of the function block is described in 

Chapter 4.9. 

At this point only three parameters should be set/checked. The assignment and alaising of the local 

I/O is done within the I/O mapping tool and is automatically taken over by the HY_EMB_IO block 

itself. 

Tab. 4-1: Basic parameters for Multiple Discrete Input block

Procedure 1 In the Control strategy workspace, double-click on the Reactor block

2 The Off Line Characterization dialog opens, see Chapter 3.3.1

– Expand the Mode Block node and check that the Target is set to Auto

– Double lick on the value space of HYB_STATUS_OPS and select Set Outputs to Good 

Non Cascade

3 Open Project File, then press Save Entire Configuration, to save the project.

Parameter Function Value

MODE BLOCK/TARGET Normal operating mode of block Auto

HYB_STATUS_OPTS Sets status options of IEC 61131-3 variables

• None: the status will be set within the block

• Set Outputs to Good Non Cascade: all outputs will be 

automatically set to good, ifrrespective of input

Set Outputs to Good 

Non Cascade

EXEC_TIME_TARGET Target time for execution of the hybrid block 10 ms (default)
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4.9 Program the Hybrid Function Block

4.9.1 Set the IEC 61131-3 programming language

1 In the HSE Network 1 tree, right click on the Reactor block and select Attributes

2 The Attributes dialog opens:

– In the IEC 61131-3 Programming Language menu select ST (Structured Text)

– Tick the box "Map as FF Data Structure"

– Press OK to confirm the selection

4.9.2 OpenPCS programming tool

1 In the HSE Network 1 tree, right click on the Reactor block and select 

Program Hybrid Block



4 PROFIBUS Solution ControlCare Application Designer: I/O Mapping Tool Tutorial

98 Endress+Hauser

2 The OpenPCS programming tool opens:

– The Files pane of the Project window shows the program files

– The Resources pane shows the hybrid block task attached to the Field Controller

– The Lib pane shows the libraries available

– The Help pane opens the Online help tree

– The Catalog window might also appear – it can be closed by pressing the "x"

– The Log window tracks program events – it can be closed by pressing the "x"

3 Double-click on Reactor.ST: the editor opens with the declared external PROFIBUS variables

– The upper right-hand pane contains the variables we have declared, Chapter 4.6

– The lower right-hand pane contains the structured text program, which is empty 

on starting
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4.9.3 Declare additional variables

Additional variables used by the structured text program must be declared with name and data type 

in the upper right-hand pane before programming starts. Table 6-1 lists the various types of 

declaration supported. The declaration opens with the variable type and is closed with END_VAR. 

The various types are created with default value zero for real and integer variables and FALSE for 

booleans. 

Tab. 4-2: Variable declaration types

Attributes The declarations can be modified to define a particular behaviour of the variables contained within 

them by adding one of the attributes in Table 6.2.

Tab. 4-3: Declaration attribute types

Example For this exercise, we will declare the booleans "HMI_Start" and "HMI_Stop" as an OPC variable to 

enable a SCADA program to start and if necessary stop the blending sequence. In addition, the user 

is able to set the quantities of liquid to be blended in kg ("Quantity_Liquid_1" and 

"Quantity_Liquid_2"). The stirring time is set at 120s using the timer provided (TON); it is declared 

as shown in the example..

In order to keep track of the filling process, the retained variable "Process_Step" will be incremented 

every time a process Step is completed.

Variable type Access Rights Function

External Internal

VAR – RW Local variable that is readable and writable to its own block only

VAR_INPUT RW R Input variable that is readable and writable to an external block, but 

only readable to its own block

VAR_OUTPUT R RW Output variable that is readable and writable to its own block, but only 

readable to an external block

VAR_IN_OUT RW RW I/O variable readable and writable to its own and an external block

(call be reference)

VAR_EXTERNAL RW RW External I/O variable, declared as global in its own block, that is 

readable and writable to its own and an external block, whereby any 

change is immediately effective in all blocks where it is used

VAR_GLOBAL RW RW Global I/O variable, declared as external in its own block, that is 

readable and writable to it own and an external block, whereby any 

change is immediately effective in all blocks where it is used

VAR_ACCESS RW RW Global I/O variable (access path) that is readable and writable in its 

own and an external block resident in a different controller, whereby 

any change is immediately effective in all blocks where it is used

Attribute type Function

RETAIN Variable that retains its value when the controller is switched off or restarted

CONSTANT Variable that retains a constant value, i.e. not writable

OPC Variable that is readable and writable in the IEC OPC Server

– Local varibles declared with the prefix OPC_ are also visible in the IEC OPC server

Block Signal/Point Block Signal/Point Alias

Output from OPC Server HY_EMB_IO Bool HMI_Start

Bool HMI_Stop

Real Quantity_Liquid_1

Real Quantity_Liquid_2

TON Timer

HY_EMB_IO Integer Input to OPC Server Process_Step
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Procedure In the upper right-hand pane do the following:

1 Declare IEC OPC Server variables

VAR OPC

HMI_Start_Stop: BOOL;

Quantity_Liquid_1: REAL;

Quantity_Liquid_2: REAL;

END_VAR

2 Now add the retained variable

VAR RETAIN

Process_Step: INT;

END_VAR

3 Now add the timer

VAR

Timer : TON;

END VAR

Note! 

• An alternative method to declare IEC OPC Server variables not used in this tutorial 

is to add the OPC_ prefix:

VAR

OPC_HMI_Start_Stop: BOOL;

END_VAR

VAR_RETAIN

OPC_Process_Step: INT;;

END_VAR
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4.9.4 Activate the libraries

The FF variables used in IEC 61311-3 programming must be converted to a data type appropriate 

to programming language. To this end ControlCare activates two libraries by default:

•  CC_FF_CUSTOM_LIB to map the custom FF function blocks

(Data type conversion DS65, DS66)

•  CC_FF_STANDARD_LIB to map the standard FF function blocks

(FF status handling)

These appear red in the library pane (select the Lib tab)

Note! 

• For ControlCare Product Version 2.01.xx, the libraries have to be activated by hand

• For SFC programming the sfclib must be activated, see below and the OpenPCS online help

Activating a library In order to activate additional libraries, e.g. sfclib for SFC programming, the following procedure is 

used:

1 Select the Lib pane:

– Right-click on e.g sfclib and select Use in Current Project

– The project book turns red = active

Installing a library If the libraries are not installed:

1 Right-click on Libraries, select Install New..., 

2 Browse to the folder containing the LIB files and select the library required

3 Press OK twice to install.
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4.9.5 Create the structured text program

For simplicity, the structured text program will be written as follows

•  Step 0: Reset of Totalizer

•  Step 1: Filling of liquid 1, with stirrer switched on when Stirrer_Protection_LT2=False

•  Step 2: Filling of liquid 2

•  Step 3: Stirring for 2 minute (to demonstrate timer)

•  Step 4: Emptying of vessel, with reset of timer

•  Step 5: Prepare totalizer reset and stop process

The strategy is created according to the truth table in Chapter 2.1.2.

Step 0 1 (*Step 0: Initialize process*)

IF  HMI_Start_Stop=1 AND Process_Step<1 THEN

Reset_Totalizer_FT1.value:=0; (*Set Totalizer FT1*)

Reset_Totalizer_FT2.value:=0; (*Set Totalizer FT2*)

Process_Step:=1;

END_IF;

Step1 2 (*Step 1: Start filling liquid 1 provided no stop signal and start button pressed*)

IF HMI_Start_Stop=1 AND Emergency_Stop_B1=0 AND Overspill_Protection_LT3=0

AND Process_Step=1 THEN (*Start Condition*)

IF (Quantity_Liquid_1>Totalizer_FT1.value)THEN 

State_Valve_SV1:=1; (*Valve SV1 open*)

IF Stirrer_Protection_LT2=0 THEN (*Protection off*)

State_Motor_M1:=1; (*Motor M1 on*)

ELSE 

State_Motor_M1:=0; (*Motor M1 off*)

END_IF;

ELSE

State_Valve_SV1:=0; (*Close valve*)

Process_Step:=2; (*Step 1 completed*)

END_IF;

ELSE 

State_Valve_SV1:=0; (*Close valve*)

END_IF;

Step2 3 (*Step 1: Start filling liquid 1 provided no stop signal and start button pressed*)

IF HMI_Start_Stop=1 AND Emergency_Stop_B1=0 AND Overspill_Protection_LT3=0

AND Process_Step=2 THEN (*Start Condition*)

IF (Quantity_Liquid_2>Totalizer_FT2.value)THEN 

State_Valve_SV2:=1; (*Valve SV2 open*)

IF Stirrer_Protection_LT2=0 THEN (*Protection off*)

State_Motor_M1:=1; (*Motor M1 on*)

ELSE 

State_Motor_M1:=0; (*Motor M1 off*)

END_IF;

ELSE

State_Valve_SV2:=0; (*Close valve*)

Process_Step:=3; (*Step 1 completed*)

END_IF;

ELSE 

State_Valve_SV2:=0; (*Close valve*)

END_IF;
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Step 3 4 (*Step 3: Stir for 2 minutes*)

IF HMI_Start_Stop=1 AND Emergency_Stop_B1=0 AND Stirrer_Protection_LT2=0 

AND Process_Step=3 THEN (*Start condition*)

State_Motor_M1:=1; (*Motor M1 on*)

Timer(IN :=1 , PT :=T#120s); (*Start timer, 120 s*)

IF Timer.Q=1 THEN (*If timer stopped*) 

Timer (IN :=0); (*Set IN to 0*)

State_Motor_M1:=0; (*Motor M1 off*)

Process_Step:=4;

END_IF; (*Step 3 completed*)

END_IF;

Step 4 5 (*Step 4: Empty vessel*)

IF HMI_Start_Stop=1 AND Emergency_Stop_B1=0 AND Process_Step=4 THEN

WHILE Dry_Run_Protection_LT1=0 DO (*Empty condition*)

State_Pump_P1:=1; (*Pump on*)

State_Valve_SV3:=1; (*Open valve*)

END_WHILE;

State_Pump_P1:=0; (*Pump off*)

State_Valve_SV3:=0; (*Close valve*)

Process_Step:=5; (*Step 4 completed*)

ELSE 

State_Pump_P1:=0; (*Pump off*)

State_Valve_SV3:=0; (*Close valve*)

END_IF;

Step 5 6 *Step 5: Reset process*)

IF HMI_Start_Stop = 1 AND Process_Step=5 THEN;

Reset_Totalizer_FT1.value:=1; (*Reset Totalizer FT1*)

Reset_Totalizer_FT2.value:=1; (*Reset Totalizer FT2*)

HMI_Start_Stop:=0; (*Stop Process*)

Process_Step:=0;

End_IF;
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4.9.6 Trouble-shoot the project 

Now that the project is complete, it is recommended that the project is checked for errors.

1 Open the File menu and select Check Syntax

2 OpenPCS runs a check on all syntax in your program and publishes a log at the bottom of the 

workspace.

– If errors are found eliminate them and check the syntax again

– You can move from error to error with the F4 and Shift F4 keys

3 When the program is free of errors, this is reported in the log at the bottom of the workspace

4 Now open the File menu and select Save All.
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4.10 IEC 61131-3 Simulation

OpenPCS allows the simulation of the IEC 61131-3 program without the need for hardware. It is 

recommended that the program is tested with this function before it is downloaded to the Field 

Controller.

4.10.1 Resources

1 Click on PLC and select Resource Properties from the PLC menu

– The Edit Resource Specifications dialog opens

2 In the Edit Resource Specifications dialog

– Select Hardware Module: ControlCare SIM

– Select Network Connection: EHSIM

– Select Optimization: Size only

– Press OK to confirm the changes and close the dialog

3 Click on PLC and select Rebuild Active Resources (alternatively, press CTRL+F7)

– You can now go "Online" with the simulation.
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4.10.2 Go "Online"

1 Click on PLC and select Online from the PLC menu

– If appropriate an OpenPCS Online Server 32 message appears

– Press Yes to download the resource to the server

2 Press the Resource tab and click on the Field Controller in the project window

Note! 

• If there is more than one Field Controller in the project, it appears green and the others red.

• To activate different Field Controller, right click on it and select Set Active, its colour changes to 

green

3 Click on PLC and select Coldstart from the PLC menu

– The Field Controller simulation now runs

– The buttons Power Off, Run and Stop simulate the corresponding operating modes of the 

Field Controller

– The Cycles display show number of cycles simulated and cycle time in ms

– The LEDs simulate the LEDs on the Field Contoller

– To change the macrocycle time, press the >> button and enter a new value in the Cycle 

Time dialog, confirming with OK

4 The simulation is closed by clicking on PLC and select Offline from the PLC menu
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4.10.3 Watch list

By placing selected input and ouput variables in a watch list, the logic can then be checked.

1 Press the Resource tab and expand the FC_01_HY_EMB_IO_1 node

– A list of input and output variables appears

2 Double-click on a parameter to place it in the watch list

– Parameters can be deleted by selecting the parameter line and pressing DEL

3 Right-click on the watch list "value field" and enter a value in the Set Variable dialog

– Press OK to confirm the entry and close the dialog

4 Check the logic of each action by seeing the effect of parameter changes on the outputs

5 When you are satisfied that the program does what it should, prepare for download by 

optimizing the preformance
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4.10.4 OPC tag monitoring

OpenPCS also allows the monitoring of the tags in the OPC and HSE servers. These include both 

the declared variables and contained variables. Thus it is possible to monitor, e.g. the current value 

of the block mode. Before it can be used, the function must be activated. It remains activated on 

aubsequent restarts of the program, independent of project.

Activating OPC tag 

monitoring

1 Select Extras=>Options=>Browser

2 In the Options menu, select the Extended Settings tab

– Select the option "Show OPC pane in browser"

– Press OK to store the change

3 You are now prompted to restart OpenPCS

– Close OpenPCS

– Restart OpenPCS from the Hybrid Embedded IO function block mode by selecting 

Program Hybrid Block

4 On restart you will find an extra tab "OPC-I/O" in the project window

Setting up the monitoring 1 Click on the tab "OPC-I/O" to reveal the OPC servers available
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2 Expand the Endress.hseserver tag to reveal all FOUNDATION Fieldbus tags in the project 

(may take some minutes)

3 Expand the tag you require and right click on the parameter to be monitored

– Select "Watch Tag" to add it to the monitoring list

4 Now expand the Endress.iecserver tag to reveal all IEC Variables (may take some minutes)

5 Expand the tag you require and right click on the parameter to be monitored

– Select "Watch Tag" to add it to the monitoring list

6 The parameters appear in the watch list under the OPC Variables tab where they can be 

monitored when the Project is online
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4.11 Optimize performance

If the IEC 61131-3 simulation was used, the resources must be respecified before the project is 

compiled and downloaded, see Chapter 6. 

OpenPCS allows the hybrid function block to be optimized for speed or size during compilation. 

Default setting is optimized for speed. Optimizing for size causes the block to run slower than if it 

is speed optimized, and is recommended only when there are memory problems, e.g. when a large 

number of hybrid function blocks with long programs are in use or when simulating without Field 

Controller hardware.

The settings below are those recommended for normal applications.

Changing the performance 

settings

The settings are made in both the resources and the hybrid function block

1 Click on the Resources tab, then right-click on Controller leaf and select Properties

2 The Edit Resource Specifications dialog appears

– Select Hardware Module: ControlCare SFC173/Rev 4

– Select Network Connection: FC_01

– Select Optimization: Speed only

– Press OK to confirm the changes and close the dialog

3 Now right-click on the Function Block leaf and select Properties

– The Edit Task Specifications dialog appears

– In the Optimization pull-down menu select e.g. "speed only", then press OK

4 Save your settings and close OpenPCS
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4.12 Go On-line

4.12.1 Connect to the Field Controller

In order to download the project, the host computer and Field Controllers must be allocated 

IP addresses in the same address range. It is possible to do this on the workbench before installation 

or after the Field Controller and other components have been physically installed in the Fieldbus 

network (subnet). 

Warning

• The use of IP addresses is strictly controlled. Usually your system administrator will be authorised 

to allocate unique addresses. Assigning an unauthorised address to a Field Controller may result 

in conflicts within your system and the failure of the associated devices!

Note!

• The tools that setup the network use Ethernet services that may be blocked by Windows Firewall. 

Normally the firewall will be unblocked for the tools during installation, but it might be necessary 

to stop the firewall should they not function properly. If you are not sure how to stop the firewall, 

consult your system administrator.

Before starting, check the following:

•  Internet Protocol TCP/IP is installed on your computer

•  You have administration rights for your computer

•  You have an set of IP addresses that have been authorized by your IT department

•  Any proxy server for your Internet Browser is disabled

The procedures described in this chapter are for Windows XP. For other Windows systems consult 

your system administrator.

Note!

• When the Field Controllers are physically connected together with the Host computer via 

Ethernet, HSE Network Setup will see the them irrespective of the IP address domain to which 

they belong

4.12.2 Set the IP address of the host computer

SFC173 Field Controllers are delivered with the default IP address:

•  192.168.164.101 

In order that the host computer can communicate with the Field Controller Web Server, it must be 

allocated an IP address in the same address domain, e.g. 192.168.164.200. If you are not sure how 

to do this, consult your network administrator. 

Procedure 1 Right-click Start =>Settings =>Control Panel =>Network Connections
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2 Right-click Local Area Connection => Properties

3 Using the left mouse button, double-click Internet Protocol (TCP/IP) or

click once, then click Properties. 

4 Note the original values of IP address and Subnet Mask of the computer to restore them if 

necessary at end of the operation. 

5 Change the IP address and the Subnet Mask of the host computer to those required by the 

application. In the example, an address in the same subnet as the Field Controller. 

– IP Address 192.168.164.XXX and network mask (Subnet Mask) 255.255.255.0.

– Do not use the address 192.168.164.100,as these are reserved as default addresses for 

Field Controller SFC162

6 Click on the OK button to complete the procedure, close the other dialogs with OK and 

Close.
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4.12.3 Set the Field Controller IP address

Note!

• It is recommended that Field Controllers of the same type are introduced one by one to the 

network.

1 Call HSE Network Setup: 

Programs =>Endress+Hauser=>ControlCare=>Tools=>HSE Network Setup

2 HSE Network Setup is launched and searches for Field Controllers in the Ethernet network.

– All Field Controllers in the network appear, irrespective of their IP domain. 

If this is not the case:

– Check that the proxy server of your Internet Browser is switched off

– Check that the windows firewall is not blocking the program (switch off)

– Check all cables and switches

– If you find two or more Field Controllers with the same IP address, disconnect all but one 

from the network

3 If your computer has more than on NIC card, select the one you want to use for 

communication with the Field Controllers by ticking "Active NIC" and Press .

4 Right-click on the Field Controller, the address of which is to be changed:

the Field Controller Web Server opens

– The Web Server will only open if the host computer and the Field Controller have 

IP addresses in the same IP domain.
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5 Expand the Setup node and click Network

– Enter User Name "pcps" and Password "pcps" to open the Network Configuration dialog

– Enter the required IP address, in our example 10.125.35.176

– Enter a netmask, normally 255.255.255.0

– If required, enter a default gateway, usually address xxx.xxx.xxx.1 in the selected domain

6 Press Update to change the IP address

– You are now asked to restart the Field Controller

– Select the Restart node

– Select "No additional options" from the drop-down menu and press Restart

– Close the Web Browser

– The Field Controller disappears from HSE Network Setup and reappears with the new 

IP address

7 Now set the address of he host computer to the same domain as the Field Controllers, see 

Chapter 6.1.1 - in our example 10.125.35.200

– Restart HSE Network Setup

– Tick the Field Controller, so that it appears in the HSE Live List associated with the 

computer’s active NIC card.

– Press  to save the configuration.

– You are now ready to download the project

Note!

• If you have more than one Field Controller on the network, Repeat Steps 4 to 6 for all other Field 

Controllers, introducing them one by one to the network.
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4.13 Generate the live lists

4.13.1 HSE live list

Once the Computer and Field Controller are able to communicate with each other, the connection 

to the network can be checked by creating a live list. 

1 Press the On-Line button  in the menu toolbar

– The project goes on on-line

– Red crosses appear against the Field Controller and PROFIBUS network in the 

Project workspace

2 In the Project workspace, right click on HSE Network and select Live List

– A live list is generated of the devices on the HSE network

Note! 

• It may take sometime to generate the live list 

– The devices found first go grey 

– Their profiles (all important device-specific data) including IP address are read

– On successful completion of profile reading, the devices are shown in full black
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4.13.2 Assign the Field Controller Device ID

1 In the project workspace, right click on the Field Controller (CO104) and select Attributes...

2 The Attributes dialog opens

– Open the drop-down menu of the Device ID and select the Field Controller associated

with the displayed TAG (in our case CO104) - the serial number is on the front panel

– Do this even though the correct ID is already displayed - the program expects it!

– Confirm your choice with OK

– After a period of time, the red crosses disappear from the devices in the Profibus network

– If several SFC173 were in use, Steps 1 and 2 would be repeated for all.

3 Open Project File, then press Save, to save the project

4.13.3 Assign All Tags

1 In the Plant workspace, right-click on the HSE network node and select Assign All Tags

2 The Assign All Tags dialog appears with the list of Field Controllers and a progress bar

On completion, the message "Profile reading done" stands next to the Field Controller

and "Tag has been confirmed" next to the devices

– If there are any failures in tag assignment these are logged with reasons at the bottom of the 

screen.
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4.13.4 PROFIBUS live list

1 In the PROFIBUS network workspace, right-click on Profibus 1and select the option Live List

2 The PROFIBUS live list is created

– Check that all the devices in your project appear and that the addresses (shown in 

hexadecimal format) correspond to those used in your project. 

– At this point only the Field Controller has the correct tag.
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4.14 Download the project

Note! 

• The procedure below describes the initial download for the entire HSE network. 

• Partial downloads can be made later from lower leaves, when changes are confined to this level

• Incremental downloads can be made to a running project by checking the boxes Incremental 

Download and Compare Parameters: Unaffected PROFIBUS devices will hold their last values.

When the devices in the PROFIBUS live list correspond to those configured in the project, the 

download can begin.

1 In the Project workspace right-click on HSE Network and select Download

2 The Download dialog appears

– Press Start to start the download

3 The download will be interrupted if the project has not been configured properly, e.g.

– The Project tags are not up-to-date => Export Tags, Chapter 3.10

– The Controller Tag has not been assigned correctly => Assign Field Controller tags, 

Chapter 6.2.2

– The "DPV1 activated" box in the PROFIBUS Configurator has been checked for a device,

Chapter 3.8.1 etc.

4 When the download is successfully completed, the dialog is closed, and you are ready to test 

the control strategy

5 The PROFIBUS live list will now show the the correct tags:
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4.15 Check the control stategy

At this point it would be normal to check the control strategy by clicking in the Control Strategy 

workspace and pressing the button  in the menu toolbar – the control strategy also goes "on-line"

– Values appear in green when the status is good

– Values appear in red if the status is bad - at this stage this is an indication of a communiction, 

PROFIBUS configuration, strategy configuration or device parametrization error

As the complete strategy is contained within the hybrid function block, however, the check cannot 

be made here. Instead it can be viewed in open PCS.

1 In the HSE Network 1 tree, right click on the Reactor block and select 

Program Hybrid Block

– The OpenPCS programming tool opens

2 Press the Resource tab and click on the Field Controller in the project window

3 Click on PLC and select Online from the PLC menu

– If appropriate an OpenPCS Online Server 32 message appears

– Press Yes to download the resource to the server

4 Click on PLC and select Coldstart from the PLC menu

– The values from the controller now appear in the watch list

– Set HMI_Start_Stop to TRUE to start the project

– Check that the project runs properly by generating the appropriate signals

Note! 

• The totalizers can be simulated by creating the network in FieldCare and selecting the Simulation 

option for the Promag flowmeters.

• The Liquiphant can be toggled by holding gently holding the forks
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4.15.1 Optimization of hybrid block execution time

1 Open the HSE Network 1 dialog, then click on the "details" icon in the menu bar

– The execution times are shown next to each block

– The FC_01_HY_EMB_IO_1 block executes at the default time of 10 ms

2 Right-click on the FC_01_HY_EMB_IO_1 block and select On Line Characterization

– The parameter EXEC_TIME_ACTUAL shows the time in which the block is executing

– Observe the value for a couple of minutes and note the highest value

3 Now change the function block execution time to the new value

– Right-click on FC_01_HY_EMB_IO_1 and select On Line Characterization

– Double-click on the "value space" next to the parameter EXEC_TIME_TARGET

– Enter a value 10% to 20% higher than the highest observed actual execution time

– Press End Edit to store the value and Close to quit the dialog.

4 Right-click on the Gatewaye node (FC_01) and select FB Schedule Download 

– The new value is downloaded to the Field Controller

– The strategy now runs with the new target execution time

5 Repeat Steps 1 to 4 for all hybrid blocks in the strategy

Note!

• EXEC_TIME_ACTUAL will be too high if the ST program is being monitored on-line by 

OpenPCS. Close the application before checking the value.
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4.16 Modify the project

Warning

• Do not change the PROFIBUS cyclic data configuration parameters in the PROFIBUS Function 

Blocks. These may be changed with the PROFIBUS Configurator only. Application Designer then 

extracts the information it requires from the device GSD files. 

• If you change the PROFIBUS configuration in PROFIBUS Configurator, the project must be 

downloaded again

4.16.1 On-line characterization

Once the project is on-line you may want to change parameters to e.g. tune the control-loop or 

eliminate configuration errors. With the exception of the SP parameter, the function block must be 

put out of service before the parameter is changed:

1 In the Control strategy workspace double-click on the function block you want to modify, or in 

the PROFIBUS network or Control module workspace, right-click on the function block and 

select On-line Characterization

2 The function block On-line Characterization dialog appears:

– Open the Mode leaf and double-click in the space next to Target

– Set the Target to OOS (Out of Service)

– Click End Edit to set the parameter

3 Change the parameters you wish to modify

– If appropriate, open the parameter leaf and double-click in the space next to the parameter 

you require

– Enter the new parameter or select it from the drop-down menu

– Click End Edit to set the parameter

– Repeat the procedure for all the parameters you wish to modify

4 Put the function block back into standard operating mode

– Open the Mode leaf and double-click in the space next to Target

– Set the Target back to the original value (Auto (Automatic) or Cas (Cascade))

– Click End Edit to set the parameter

– Check that the Mode really changes to the Target Mode (failure to do so indicates a 

configuration error)

– Press Close to store the values (if you are prompted - answer with Yes)

5 Click on the Project View workspace and Export Tags..., see Chapter 3.10

– Open Project File, then press Save Entire Project to save the project

6 Put the Control stategy back "on-line" to check the results of your modification, Chapter 6.4.
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4.16.2 Off-line characterization

You may prefer to change parameters off-line, e.g. when modifying the control strategy or adding 

new functions to the project. 

1 If you are on-line, press the Off-line button  in the menu toolbar

alternatively, in the PROFIBUS network or Control module workspace, right-click on the 

function block and select Off-line Characterization

– The function block Off-line Characterization dialog appears

2 Change the parameters you wish to modify

– If appropriate, open the parameter leaf and double-click in the space next to the parameter 

you require

– Enter the new parameter or select it from the drop-down menu

– Click End Edit to set the parameter

– Repeat the procedure for all the parameters you wish to modify

– Press Close to store the values

3 Click on the Project View workspace and Export Tags..., see Chapter 3.10

– Open Project File, then press Save Entire Project to save the project

4 Press the On-line button  in the menu toolbar to go on-line again

5 Download the modified project

– In the Project workspace right-click on HSE Network and select Download

– Follow the procedure in Chapter 6.3

6 Put the Control stategy back "on-line" to check the results of your modification, Chapter 6.4.
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4.17 Packing and unpacking the project

In order to install the project at the customer’s site, the project can be packed and unpacked. It is 

important to remember, especially if you have not been using the actual project DD/CFF/GSD files 

than the ones you use. The latest DD/CFF/GSD files must then be uploaded to the project and 

corresponding corrections must be made to configuration, before it is downloaded to the SFC173 

Field Controller, see Chapter 7.2.

4.17.1 Pack the project

1 Select Project File => Pack Project...

– The Pack Project dialog appears

– Browse to the folder where the files will be created

You can create a folder with the Make New Folder button 

– Enter the name of the project

– Press Save to save the packed project

– Press OK to close the successful packing message dialog

4.17.2 Unpack the project

1 Select Project File => Unpack Project...

– In the Unpack Project dialog

– Browse to the folder where the packed project is located

– Click on the name of the project

– Press Open to save the packed project

2 In the Browse for Folder dialog:

– Browse to the folder where the project is to be installed

You can create a folder with the Make New Folder button 

– Press OK to start upacking

– Press OK to acknowledge the successful unpacking of the project

4.17.3 Unpack the OPC data base only

For some applications it may be necessary to update the OPC data base of a SCADA program that 

has no provision for importing new DDs etc.. This can be done in Application Designer, which 

allows the separate unpacking of the OPC data base.

1 Go online, then right-click on the HSE OPC Server icon in the system tray

2 Select Unpack Configuration...:

– Unpack the OPC data base to the folder required according to the Steps 1 and 2 in

Chapter 6.6.2 above
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4.18 Export the configuration

For documentation purposes, the project configuration can be exported to an existing ODBC file 

data source, e.g. Oracle, a machine database, e.g. Excel to provide a record of the current status of 

the project or to an XML sheet for viewing with a browser.

4.18.1 File data source folder

The file data source must have been created before the export.

1 In the Project window, right-click on the Project icon and select Export Configuration:

2 The Select Data Source dialog box appears

3 In the File Data Source folder, select the source that describes the driver that you wish to 

connect to. You can use any file data source that refers to an ODBC driver which is installed on 

your machine.

– Use the New... button and Look In dropdown menu to browse or 

– Click the data source icon to select the driver:

– Press OK to make the connection

4.18.2 Machine data source folder

The Machine Data Source is specific to the machine, and cannot be shared. "User" data sources 

are specific to a user on the machine; "System" data sources can be used by all users on the machine, 

or by a system-wide service. The Machine Data Source must have been created before export.

Procedure 1 In the Project window, right-click on the Project icon and select Export Configuration:

2 The Select Data Source dialog box appears

– Click on the Machine Data Source tab to open the folder

– Double-click the data source name to select the machine, e.g. Excel:

3 The Select Workbook dialog box will appear:

– Select the folder where the data file is and double-click the workbook icon.

– Your project configuration will be exported to the workbook file.

– A message box appears on completion - press OK

4 Open the Excel file to check the result:

4.18.3 XML file

1 Click in the Project workspace and select Project File =>Export => Configuration as XML

– The Export Configuration as XML dialog appears

2 Enter a File Name and Save In location, then press Save

– The project is saved as an XML file at the selected location
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4.19 Close Application Designer and OpenPCS

When you have completed your session, close Application Designer and OpenPCS

4.19.1 Application Designer

1 If you are on-line, press the Off-line button  in the menu toolbar

2 If you have made any modifications while you were on line, you will be prompted to store 

them

– If appropriate answer with Yes

3 Close the project by clicking on Project File => Close

4 Exit Application Designer by clicking on Project File => Exit

5 The Field Controller continues to operate with the project configured according to the last 

download/on-line correction

– If you switch off the Controller, the project remains stored in its memory

(provided the battery DIP switch is on, see BA021S/04/en: Field Controller, Hardware 

Installation)

– It is initialized and re-executed as soon as the Controller is switched on again

4.19.2 OpenPCS

1 Open the PLC menu and select Offline

2 Open the File menu and select Exit

– You will be prompted to save if your project has been changed since the last download

4.19.3 Reconnecting Application Designer

Provided your computer is operating in the same IP address domain as the Field Controller, you can 

reconnect at any time.

1 Start up Application Designer and select the Project you require

2 Press the On-line button  in the menu toolbar

3 Expand the various workplaces as required

4 Click in the Control Strategy workspace and press the button  in the menu toolbar – the 

control strategy goes "on-line" with the last configuration that was downloaded.

4.19.4 Reconnecting OpenPCS

Provided your computer is operating in the same IP address domain as the Field Controller, you can 

reconnect at any time.

1 Start up OpenPCS, open the File menu and select the project you require

– Open the File menu and run Check Syntax

2 Open the PLC menu and select Online



5 Modbus ControlCare Application Designer: I/O Mapping Tool Tutorial

126 Endress+Hauser

5 Modbus

The I/O Mapping Tool also supports the mapping of Modbus variables to the embedded hybrid 

function block. There are two use cases: 

•  Mapping of Modbus slave variables (Field Controller acting as Modbus master)

•  Mapping of Modbus master variables (Field Controller acting as Modbus slave)

Full details of the use of Modbus with the Field Controller can be found in Modbus Tutorial, 

Operating Instructions BA037S/04/en. This section of the manual will concentrate on the mapping 

procedure, and not on the creation of a project.

5.1 Field Controller as Modbus Master

This chapter deals with the mapping of variables into an embedded hybrid function block obtained 

from or to be transmitted to Modbus slaves connected to the Field Controller, which is configured 

as Modbus master. 

For the tutorial, it is assumed that the signals required for the application described in Chapter 2 are 

obtained as follows:

•  Slave 1: Modbus Remote I/O

•  Slave 2: Modbus flowmeter

•  Slave 3: Modbus flowmeter

Fig. 5-1 shows the signal flow - please note that there are no analog outputs to the field.

Fig. 5-1:  Signal flow for Field Controller configured as a Modbus Master

Digital Input Digital Output Analog Input Analog Output

D
ry

_R
un

_P
ro

te
ct

io
n_

LT
1

D
I1

 (S
la

ve
 1

)

D
I2

 (S
la

ve
 1

)

D
I3

 (S
la

ve
 1

)

D
O

4 (S
lave 1)

D
O

3 (S
lave 1)

D
O

2 (S
lave 1)

D
O

1 (S
lave 1)

D
O

0 (S
lave 1)

A
I0

 (S
la

ve
 2

)

A
I0

 (S
la

ve
 3

)

N
ot used

Discrete inputs
(497 - 500)

Coils
(497 - 501 /    2608)

Input registers
(2610)

Holding registers
(xxxx)

Discrete inputs
(10497 - 10500)

Coils
(497 - 501 /   2608)

Input registers
(32610)

Holding registers
(4xxxx)

S
tir

re
r_

P
ro

te
ct

io
n_

LT
2

O
ve

rs
pi

ll_
P

ro
te

ct
io

n_
LT

3

E
m

er
ge

nc
y_

S
to

p_
B

1

S
tate_Valve_S

V
1

S
tate_Valve_S

V
2

S
tate_Valve_S

V
3

S
tate_M

otor_M
1

S
tate_P

um
p_P

1

To
ta

liz
er

_F
T1

To
ta

liz
er

 F
T2

Remote I/O
modules

Remote I/O
registers

Field Controller
access through

Hybrid block

Hybrid block
I/O signals

Signals to/from
field

D
O

0 (S
lave 3)

D
O

0 (S
lave 2)

R
eset_Totalizer_FT1

R
eset_Totalizer_FT2

D
I0

 (S
la

ve
 1

)

N
ot used



ControlCare Application Designer: I/O Mapping Tool Tutorial 5 Modbus

Endress+Hauser 127

5.1.1 Create the project

1 Create a FOUNDATION Fieldbus Project as described in Chapter 3.1

2 Right-click on the Fieldbus 1 leaf and select Expand

– A new window opens with the name Fieldbus 1

– Expand the tree until all leaves until you see FBAP under the Field Controller

– Right-click on FBAP and select New Block

– Add the Modbus Configuration block MBCF

– Repeat the procedure and add the block Hybrid with Embedded IOs

3 Now add any FOUNDATION Fieldbus devices required in the project

– In the Fieldbus 1 window, right-click on the Fieldbus 1 leaf and select New => Device

– The New Device dialog appears

– Select Manufacturer and Device Type; enter a Device Tag then press OK 

– Repeat until all devices have been created. 

5.1.2 Configure the MBCF block

1 Configure the Modbus Configuration MBCF block as a Serial Master with the Off Line 

Characterization dialog as follows:

2 If FOUNDATION Fieldbus devices were in the project, they can also be configured at this 

stage, see Chapter 3.5

Parameter Function MBCF

MODE BLOCK.TARGET Normal operating mode of block Auto

MEDIA Channel for Modbus communication Serial (+TCP/IP)

MASTER_SLAVE Role of Field Controller in Modbus network Master

TIMEOUT Time allowed for slave response

If there is no response, the slave status is set to BAD

1000

SERIAL_CONFIG

BAUDRATE

STOP_BITS

PARITY

Configures serial interface (default for Promass 83)

Baudrate used for communcation 

Number of stop bits used in telegram

Parity used in telegram

38400

1

Even

MASTER_CONFIG

NUMBER_OF_RETRIES

Configures Controller when acting as master

Number of retransmits if no response from a slave 3
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5.1.3 Map the Modbus I/Os

1 Arrange the input and output variables in e.g. an Excel table as below

.

2 Right click on the xx_HY_EMB_IO_xx node and select Map I/Os to Hybrid Block 
– The I/O Mapping dialog opens

3 Select the Modbus Master tab

– Enter the slave address and register into the table

– The I/O mapping tool fills in the other parameters and automatically assigns an input 

or output name to the IEC variable

4 Select all IEC variables and copy and paste the aliases into the table:

– Press OK to complete the mapping

Slave Register Register Type IEC Parameter Data Type Size Direction

1 10497 Discrete inputs Dry_Run_Protection_LT1 BOOL 1 Input

1 10498 Discrete inputs Stirrer_Protection_LT2 BOOL 1 Input

1 10499 Discrete inputs Overspill_Protection_LT3 BOOL 1 Input

1 10500 Discrete inputs Emergency_Stop_B1 BOOL 1 Input

1 497 Coils State_Valve_SV1 BOOL 1 Output

1 498 Coils State_Valve_SV2 BOOL 1 Output

1 499 Coils State_Valve_SV3 BOOL 1 Output

1 500 Coils State_Motor_M1 BOOL 1 Output

1 501 Coils State_Pump_P1 BOOL 1 Output

2 32610 Input registers Totalizer_FT1 REAL 4 Input

2 2608 Coils Reset_Totalizer_FT1 BOOL 1 Output

3 32610 Input registers Totalizer_FT2 REAL 4 Input

3 2608 Coils Reset_Totalizer_FT2 BOOL 1 Output
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5.1.4 Program the Hybrid block

1 Right click on the xx_HY_EMB_IO_xx node and select Attributes 
– The Attributes dialog opens
– If required, enter a block tag
– Select therequired programming language

2 Right click on the xx_HY_EMB_IO_xx node and select Program Hybrid Block 
– The OpenPCS opens
– In the Files menu, clock on the HY_EMB_IO_xx.ST node

– Application designer has automatically mapped the Modbus I/O to OpenPCS:

3 Program the block as described in Chapter 3.6

5.1.5 Finish the project

Finish the project as described as described in Chapter 3:

•  If other function blocks are in use, create control strategy, Chapter 3.2

•  Configure the control strategy, Chapter 3.3

•  Attach the function blocks to the devices, Chapter 3.4

•  Configure the devices, Chapter 3.5

•  Test the hybrid block program, download and optimize the project, Chapter 3.7 onwards

•  The Modbus application is strated by toggling the ON_APPLY parameter in the 

Online Characterization dialog



5 Modbus ControlCare Application Designer: I/O Mapping Tool Tutorial

130 Endress+Hauser

5.2 Field Controller as Modbus Slave

This chapter deals with the mapping of variables into an embedded hybrid function block obtained 

from or to be transmitted to one or more Modbus masters connected to the Field Controller, which 

is configured as Modbus slave. 

For the tutorial, it is assumed that all the signals acquired from the PROFIBUS devices in the project 

described in Chapter 4 are to be mapped for use by a Modbus master. In reality, it would be unlikely 

that a PROFIBUS Remote I/O would be mapped to Modbus as such devices are available with 

Modbus protocol. However, the mapping of Field Controller local I/Os, e.g. as used in the FF project 

in Chapter 3, proceeds in exactly the same manner. 

Fig. 5-2 shows the signal flow - please note that there are no analog outputs to the master.

Fig. 5-2:  Signal flow for Field Controller configured as a Modbus Master
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5.2.2 Configure the MBCF block

1 Configure the Modbus Configuration MBCF block as a TCP/IP Slave with the Off Line 

Characterization dialog as follows:

5.2.3 Map the Modbus I/Os

1 Right click on the Reactor (xx_HY_EMB_IO_xx) node and select Map I/Os to Hybrid 

Block 
– The I/O Mapping dialog opens

2 Select the Profibus I/O tab

– For each variable that must be mapped, click on the box Mapped to Modbus

– To map the complete set of variables, right click in the Mapped to Modbus header

and select Map all from the context menu

Parameter Function MBCF

MODE BLOCK.TARGET Normal operating mode of block Auto

MEDIA Channel for Modbus communication TCP/IP (+TCP/IP)

MASTER_SLAVE Role of Field Controller in Modbus network Slave

TIMEOUT Time allowed for OUT value update

If there is no update, the output status is set to BAD

e.g. 1000 (ms)

TCP/IP_CONFIG

SECOND_MOD_PORT

Configures TCP/IP interface

Second communication port (Port 502 is always open) e.g. 1024

SLAVE_CONFIG

DEVICE_ADDRESS

Configures Controller when acting as slave

Modbus address of Field Controller e.g. 1

TCP_ACCESS_LIST

IP_x

List of up to eight masters that are allowed to access field 

controller registers

IP address of TCP master x e.g. 10.125.35.90



5 Modbus ControlCare Application Designer: I/O Mapping Tool Tutorial

132 Endress+Hauser

3 Select the Modbus Slave tab to view the mapping

4 Press OK, when all have been mapped

5.2.4 Program the Hybrid block

1 Right click on the xx_HY_EMB_IO_xx node and select Attributes 
– The Attributes dialog opens
– If required, enter a block tag
– Select therequired programming language

2 Right click on the xx_HY_EMB_IO_xx node and select Program Hybrid Block 
– The OpenPCS opens
– In the Files menu, clock on the Reactor.ST node

– Application designer has automatically mapped the Modbus I/O to OpenPCS:
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3 The current version of ControlCare Application designer now requires that the Mobus 

parameters are set equal to the equivalent Profibus parameters in the program section of 

OPenPCS. This is done by the expression

MB_parameter_name:=parameter_name

4 The program (if any) can now be written as before

5.2.5 Finish the project

Finish the project as described as described in Chapter 4:

•  Test the hybrid block program, download and optimize the project, Chapter 4.11 onwards

•  The Modbus application is strated by toggling the ON_APPLY parameters in the 

Online Characterization dialog.
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6 Trouble-Shooting

6.1 Factory initialisation and reset

Warning!

• Do not use the pushbuttons located in the Field Controller unless you are certain that you want 

to reset the system.

Two pushbuttons located on the SFC173 module, see Fig 8.1, allow the system to be initialised and 

reset. The function and effect of the buttons is described in the table below.

•  To "click " the pushbuttons use a pointed instrument (e.g. a ballpoint pen). 

Other functions of the two buttons are to be found Chapter 7 of the Operating Instructions 

BA035S/04/en, Field Controller: Commissioning and Configuration..

Function Effect Procedure

Reset Resets system: the last 

configured IP Address 

is used

• Click the right pushbutton - the system resets (takes several seconds)

• If no IP Address is found, a new one is assigned automatically

• Verify that the RUN and ETH LNK LEDs are lit.

Factory Init Deletes application, 

the last configured IP 

Address is retained

• Keeping the left pushbutton pressed, click the right pushbutton

• Check that the FORCE LED flashes once a second. 

• Release the left push button. The system resets, see above.
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6.2 Trouble-shooting tables

6.2.1 Field Controller

Problem Remedy

1 HSE Network Setup/FC Tools does not find any 

Field Controller

• Disable the Windows firewall (normally a message 

appears ask whether you should unbock the program)

• Disable the proxy server for your Internet browser

• Check that you are using the correct Ethernet cables, 

see ETH LINK below

• Check that all etehrnet switches are powered up

• Check that the network adapter is on and OK: Execute a 

PING command to its own IP, via DOS PROMPT.

• Check if the Ethernet connection is OK: Execute a PING 

command to the Field Controller.

2 Field Controller appears intermittently in FC Tools Host and Field Controller are in different subnets.

• Normal behaviour, but for firmware download both host 

and Field Controller must be in the same subnet

3 HSE Network Setup/FC Tools does not show all the 

Field Controllers that are in the network

There is probably an IP address conflict in the network.

• Disconnect all the Field Controllers except one from the 

from the sub-network

• If necessary, change its IP address

• Now reconnect the other Field Controllers one after the 

other, if necessary changing their IP addresses

4 Field Controller Web Server does not open No Ethernet connection

• Disable the Windows firewall

• Disable the proxy server for your Internet browse

• Wrong subnet IP address

Host and Field Controller must be in same subnet

• Wrong subnet mask

Host and Field Controller must have same subnet mask

5 Firmware begins to execute but after a certain time it 

stops

It might be a configuration problem. 

• Use the Factory Init procedure and configure the Field 

Controller again. 

• If the problem persists, see the relevant chapter in 

Operating Instructions BA035S/04/en, Field Controller, 

Commissioning and Configuration

6 HOLD LED remains lit If the HOLD LED remains lit after the Field Controller has 

been turned on, the firmware may be invalid. 

• Update the firmware, see the relevant chapter in 

Operating Instructions BA035S/04/en, Field Controller, 

Commissioning and Configuration

7 ETH LNK LED does not light Check if the cable is connected correctly, or that the cable is 

not damaged. Check the specification of the cables:

• SFC954 - Cable Standard.  To be used in a network 

between the Field Controller and a Switch/Hub.

(preferred configuration)

• SFC955 - Crossed Cable (Cross).  To be used point to 

point between a PC and the Field Controller

(some PCs/laptops may have problems with crossed 

cable)
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6.2.2 Application Designer

Problem Remedy

1 Field Controller does not appear in HSE live list No connection to Field Controller

• See Remedies for Items 1, 2 and 4, Chapter 7.4.1

• Field Controller is on HOLD, set it to RUN mode

• IP address is not configured correctly, use PING to check

2 Field Controller appears but always stays grey in HSE 

Live List

No connection to Field Controller

• Check that host and Field Controller are in same subnet

3 Red cross appears on the Field Controller No communication with Field Controller

• No Ethernet connection with Field Controller, 

check connection, IP address etc, see above

• No Device ID set in the Field Controller (Attributes)

4 Red cross appears on Fieldbus/Profibus No communication with fieldbus/Profibus

• No communicaton with Field Controller, see above

• Fieldbus/Profibus not connected to controller

• DP bus parameter mismatch (Profibus)

5 Red cross appears on field device No communication with fieldbus device

• No communicaton with Field Controller, see above

• No communicaton with fieldbus/Profibus, see above

• No Device ID set (Attributes)

• Tag not assigned (Assign Tag)

• DP address is not unique (Profibus)

• DP address at device not the same as that configured in 

PROFIBUS configurator (Profibus)

6 A device does not appear in the live list Communication error

• The device is not powered up

• The project has been updated but no download has been 

made yet

7 Configuration will not download You have either a communication problem or the 

configuration is not complete

• Check that you are on-line - press the On-line button

• Check that your computer is in the same address subnet

• Check that you have assigned the Field Controller tag

• Check that you have exported all tags OPC server

• Check that the parameters are in the recommended order

• Check that the OPC server is running (look for icon in 

bottom line)

• Try "Update" from the Field Controller node (SFC162 

only, takes several minutes) and download again

8 PROFIBUS configuration will not download You have either a communication problem or the 

configuration is not complete

• Try downloading from HSE Network node, see above, if 

this does not work, check points below

• Configuration mismatch between PROFIBUS Configurator 

and Application Designer

– Have PROFIBUS device blocks been deleted?

– If so, reconfigure project in PROFIBUS Configurator

9 Parameter appears red in the on-line control strategy The parameter has a bad status

• Check that the Block Mode is Auto (or Cas)

• Check that the block has been correctly configured

• Check that the device is still live (live list)

• Check that the device address is the same as that you 

have in your configuration (live list)

• Check that the parameter has been correctly configured

• Check that the tags were exported (Export Tags)

10 FB links do not work Project not downloaded correctly, e.g. partial download 

when bridge has HSE links

• Repeat full download from the HSE Network node
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6.2.3 PROFIBUS Configurator

Problem Remedy

1 Error message on trying to leave the configuration 

dialog

Configuration not correct

• Device name has spaces instead of underscores

2 How are the cyclic I/O data configured? • For Endress+Hauser devices each parameter has a fixed 

position in the configuration list, see the manuals. If you 

want to see Parameters 1 and 5 only, for example, free 

spaces/empty modules must be appended at slots 2, 3 and 

4.

• For other devices, see operators instructions

3 What baudrates are supported? The SFC173 Field Controller supports all baudrates with the 

exception of 31.25 kBit

• The 31.25 kBit used by the PROFIBUS PA segment is not 

connected directly to the Field Controller but via a 

segment coupler.

4 What baudrate should I use? Only baudrates supported by all devices can be used:

• For a P+F SK1 coupler = 93.75kbit/s

• For a Siemens coupler = 45.45 kbit/s

• For a P+F or Siemens link, check what baudrates are 

supported by all DP devices

5 Where do I set the device baudrates? Only PROFIBUS DP devices must be set

• Most PROFIBUS DP slaves sense the baudrate and do not 

need to be set up

• For others, check the manufacturer’s instructions

6 What bus parameters should I use? Use the parameters recommended by the coupler/link 

manufacturer or those in this manual

• For the P+F SK2, the parameters are automatically set 

according to the rate selected in the Configurator

• For the P+F SK1 use the ones in the PROFIBUS tutorial

BA036S/04/en

7 Can I go on-line in PROFIBUS Configurator? Yes. 

• Select the appropriate menu, enter the IP address of the 

Field Controller and generate a live list

Beware of timeout: if there is no activity after 2 min:

– Select Settings => Device Assignment...

– Driver Select (if TCP/IP driver)

– Select requested IP address

– Press OK

8 Can I change a bus address in the PROFIBUS 

configurator?

Yes. 

• You can go online and change a bus address by selecting 

the device followed by the the appropriate menu and 

typing in the old, then the new address

• The device must support software address setting

• Software address setting must be enabled

• The address must be unique to the bus

9 A device does not appear in the live list Communication error

• Another device has the same address

• The device is not powered up

• Device does not support autosense of baudrate 

– Set correct baudrate
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6.2.4 Modbus

Problem Remedy

No communication via Modbus RS-232 • If you have changed the configuration of a Modbus block, 

check that you have restarted the bus by using the 

ON_APPLY parameter, Chapter 3.17

• Check that the MEDIA parameter is correct, 

TCP or serial, Chapter 3.5.1

• Check that the Field Controller and Modbus device are 

using the same communication settings: RTU/ASCII, 

Data bytes, Stop bits, Parity, Baudrate, Chapter 3.5.1

• Check that you are using the correct Modbus Block, 

Chapter 3.5.2, Chapter 4.3.2

• Check that you are using the correct Modbus addresses

• Check that the Controller connector, all cables and any 

interfaces, e.g. RS-232/RS-485 are correctly wired

No communication via Modbus TCP • Check that the IP addresses are in the same domain

• Check that any slave IP addresses have been property 

entered, Chapter 6.2

• Check that the correct cables have been used, see 

Chapter 5.2, ETH LNK LED and any switches etc. are 

powered

• If you have changed the configuration of a Modbus block, 

check that you have restarted the bus by using the 

ON_APPLY parameter, Chapter 3.17

A Modbus block does not switch to "Auto" but remains 

"OOS"

• Check that the Mode Block target is set to "Auto"

• Check that the Local Mod Map of each Modbus Block 

has a unique identifier between 0 and 15

• Check that the Modbus has been started by using the 

ON_APPLY parameter, Chapter 3.17

A static value in the Modbus Block was changed, but the 

value does not update.

• Put the block out of service (OOS) before editing the 

parameter. 

• After the edit, put the block back to "Auto" and restart the 

bus with ON_APPLY

The Modbus parameters cannot be found or displayed • Check that you are looking at the correct registers

• Check that the data format has been set correctly

Chapter 6.

Status of Modbus value always bad • Check TIMEOUT parameter is greater than Modbus 

master write cycle, see Chapter 4.3.1
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