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1 Safety

1.1 Designated use

ControlCare is a field-based control system comprising hardware and software components. It can 

be used to visualize, monitor and control production processes. The approved usage of the 

individual units used in the system can be taken from the corresponding parts of the operating 

instructions.

The software described in this particular manual allows the programming of the hybrid function 

block in IEC 61131-3 language as well as the engineering, configuring and commissioning of a 

ControlCare SFC162 FOUNDATION Fieldbus or SFC173 PROFIBUS Field Controller. Ladder Logic 

language has been taken as an example, and the building of appropriate control strategies using 

these and the function blocks contained in the Field Controller and connected devices are described.

1.2 Installation, commissioning and operation 

ControlCare Field Controllers have been designed to operate safely in accordance with current 

technical safety and EU directives. Essential to their use is the ControlCare Application Designer 

software suite, which allows control strategies to be created for FOUNDATION Fieldbus and 

PROFIBUS I/O applications. Field devices, links, junction boxes, cables and other hardware 

comprising the Fieldbus sytem must also be designed to operate safely in accordance with current 

technical safety and EU directives. 

If devices are installed incorrectly or used for applications for which they are not intended, or if the 

controller is not configured correctly, it is possible that dangers may arise. For this reason, the system 

must be installed, connected, configured, operated and maintained according to the instructions in 

this and the associated manuals: personnel must be authorised and suitably qualified.

1.3 Operational safety

Location Field Controllers must be mounted in a permanent and weather-protected location in a safe area. 

The environment shall be a metal cabinet or an installation frame with a well grounded mounting 

plane. The environment shall be protected. 

Hazardous areas The controller must be connected to networks operating in explosion hazardous areas via barriers 

or other safety components. When installing components in explosion hazardous areas:

•  Ensure that all installion and maintenance personnel are suitably qualified

•  Check that all equipment has the appropriate safety certificates

•  Observe the specifications in the device certificates as well as national and local regulations.

This topic is discussed in BA013S (FF Guidelines) and BA034S (PROFIBUS Guidelines).

EMC All modules are suitable for industrial use and conform with the following standard, see Appendix:

•  EN 61326: 1997/A1: 1998

Interference emmision: Class A apparatus

Interference immunity: as per Annex A, industrial environment

Depending upon the environment in which the bus is operating, particular attention should be paid 

to the grounding of the bus cables. This topic is discussed in BA013S (FF Guidelines) and BA034S 

(PROFIBUS Guidelines).



1 Safety ControlCare Application Designer: IEC 61131-3 Ladder Logic Tutorial

4 Endress+Hauser

IP Address A ControlCare Field Controller is normally configured from a workstation connected into the 

control system backbone. You will require a unique IP address to set it up.

Warning

• The use of IP addresses is strictly controlled. Usually your system administrator will be authorised 

to allocate unique addresses. Assigning an unauthorised address to a Field Controller may result 

in conflicts within your system and the failure of the associated devices!

It is recommended that ControlCare Field Controllers and OPC servers are not installed in an office 

network, as the large data packets exchanged between office equipment may lead to timeouts and 

intermittent communication errors. Ideally, the ControlCare system network should operate within 

its own IP domain; if this is not possible it should be separated from other parts of the network by 

a managed switch.

Since the system can be accessed and manipulated through the various ControlCare tools, it is 

advisable to control access both to the workstation and the folders in which the configuration is 

stored. Always make a back-up of the project.

Technical improvement Endress+Hauser reserves the right to make technical improvements to its software and equipment 

at any time and without prior notification. Where such improvements have no effect on the 

operation of the equipment, they are not documentated. If the improvements effect operation, a 

new version of the operating instructions is normally issued. 

1.4 Conventions and icons

In order to highlight safety relevant or alternative operating procedures in the manual, the following 

conventions have been used, each indicated by a corresponding icon in the margin. 

Safety conventions Icon Meaning

A note highlights actions or procedures which, if not performed correctly, may indirectly affect operation or 

may lead to an instrument response which is not planned

Caution!

Caution highlights actions or procedures which, if not performed correctly, may lead to personal injury or 

incorrect functioning of the instrument

Warning!

A warning highlights actions or procedures which, if not performed correctly, will lead to personal injury, a 

safety hazard or destruction of the instrument
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1.5 ControlCare documents

Table 1.1 indicates the documents, planned and realized, containing safety relevant information, 

installation, commissioning and operating instructions for the equipment and software associated 

with ControlCare.

All documentation available at the time of release is included on the ControlCare CD-ROM and is 

installed in Start=>Programs=>Endress+Hauser=ControlCare=Manuals during set-up.

Tab. 1-1: ControlCare Documentation

Component Description Document type Designation Order No.

System ControlCare System Overview Operating manual BA016S/04/en 56004883

ControlCare System Design Operating manual BA039S/04/en Planned

ControlCare System Specifications Operating manual BA040S/04/en 56004888

Software Application Designer Overview Operating manual BA017S/04/en 70104301

Application Designer: Local I/O Tutorial Operating manual BA032S/04/en 71095009

Application Designer: FF Tutorial Operating manual BA019S/04/en 70101151

Application Designer: PROFIBUS Tutorial Operating manual BA036S/04/en 70101152

Application Designer: MODBUS Tutorial Operating manual BA037S/04/en 70101153

Application Designer: IEC 61131-3 

Ladder Logic Tutorial 

Operating manual BA038S/04/en 70101386

Application Designer: IEC 61131-3

Structured Text Tutorial

Operating manual BA056S/04/en 71060063

Field Control (OPC) Servers Operating manual BA018S/04/en 71031428

SFC162 Visitor Operation manual BA069S/04/en 71113457

Field Controller Hardware Installation Guide Operating manual BA021S/04/en 56004885

Commissioning and Configuration Operating manual BA035S/04/en 56004887

Function Blocks Function Block Manual Operating manual BA022S/04/en 56004886

Set-Up Getting Started Operating manual BA020S/04/en 56004884

General FOUNDATION Fieldbus Guidelines Operating manual BA013S/04/en 70100707

PROFIBUS Guidelines Operating manual BA034S/04/en 56004242
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2 Task Description

This tutorial describes the steps necessary for setting up the project described below. It does not aim 

to give an exhaustive account of Application Designer functions, but rather shows you one of a 

number of methods to reach your goal. The tags and names used in the tutorial are imaginary and 

will be different in a proper application. A full description of Application Designer functions is to be 

found in Application Designer Overview BA017S/04/en and Drawing Tool BA032S/04/en (in 

preparation). Function block descriptions are to be found in BA022/04/en, Function Block manual.

2.1 Pump control for tank level

For this tutorial, the case of pump control for tank level will be used, see Fig. 2-1. 

Fig. 2-1:  Overview of pump control for tank filling

A centrifugal pump is used to fill the tank with liquid. The level of liquid in a tank is monitored by 

a level transmitter which outputs a corresponding 4 mA to 20 mA signal. When the tank is full 

(=95%) the pump must be switched off. In order to provide overspill protection for the tank, should 

the level transmitter fail, a level limit switch with relay output is built in at an appropriate height. 

The pump itself provides Overheat and Running signals, and a switch is provided for pump reset. 

The signals are acquired by Field Controller I/O modules as follows:

•  4 mA to 20 mA level to AI-0 input of a SFC444 Analog Input module

•  Level Overflow, Pump Reset, Pump Overheat and Pump Running signals to DI-0 to DI-3 inputs 

of a SFC432 Mixed Discrete I/O module: 0 V = False, 24 V = True

•  Pump output current from DO-0 output of the SFC432 Mixed Discrete I/O module:

NO relay, False = Pump ON, True = Pump OFF, Fail Safe = Pump OFF

For the tutorial the control is done in a PROFIBUS SFC173 Field Controller, but since there is no 

PROFIBUS DP network connected to it, the procedure described also applies to the FOUNDATION 

SFC162 Fieldbus Controller.
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Fig. 2-2 shows a schematic diagram of the pump control application. The analog level input is fed 

to an Analog Alarm block that generates a true signal when the "full" level is reached. This is a 

standard function block, and eliminates the need to provide a similar signal conditioning program 

within the hybrid block. All discrete signals are connected directly to the hybrid function block 

which generates an output signal according to the status of the application. 

Fig. 2-2:  Schematic diagram of pump control application

2.1.1 Control strategy

Fig. 2-3 shows the corresponding control strategy. The level signal is fed to the Analog Input block, 

and after scaling to 0% to 100% is passed on to the Analog Alarm block. This generates a true or 

false signal according to the level in the tank. The discrete input signals are collected in a Multiple 

Discrete Input block and the pump output control signal is fed to a Multiple Discrete Output block. 

The control algorithm is programmed in the hybrid block. 

It should be noted that the control strategy can also be created with 4x Discrete Input blocks and 

and 1x Discrete Output block.

Fig. 2-3  Control strategy for pump control application
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2.1.2 Control algorithm

The tank overflow and pump overheat conditions must lead to immediate switch off of the pump. 

The pump running signal is automatically generated by the pump itself, and is provided, e.g. for a 

visualization of the application. The truth table for the hybrid function block has is as follows:

2.1.3 Aliasing

For this tutorial the signals will be aliased as follows:

2.1.4 Network

The project uses a PROFIBUS SFC173 Field Controller with local I/O. The procedure for a 

FOUNDATION Fieldbus SFC162 is exactly the same. The network is assumed to be constructed as 

shown in Fig. 2-4. 

•  The level signal is acquired via a SFC444 Analog Input module

•  The level overspill and pump signals are acquired by a SFC432 Discrete Input/Output module

•  The pump is connected to a SFC432 Discrete Input/Output module.

Fig. 2-4  Network for application example

Function IN_D1 IN_D2 IN_D3 IN_D4 IN_D5 IN_6 OUT_D1

Tank "Empty" – – – – False – False

Tank Full – – – – True – True

Tank Overflow – True – – – – True

Pump Reset True – – – – – True

Pump Overheat – – True – – – True

Pump Running – – – True – – False

Pump Emergency Off – – – – – True True

Block Signal Block Signal Alias

MDI OUT_D1 HY_MD_IO IN_D1 Pump_01_Reset

OUT_D2 IN_D2 Tank_Level_01_Alarm

OUT_D3 IN_D3 Tank_01_Overflow

OUT_D4 IN_D4 Pump_01_Overheat_Signal

AALM OUT_ALM IN_D5 Pump_01_Running_Signal

Input via IEC OPC Server IN_D6 Pump_01_Operator_Entry_Emergency

HY_MD_IO OUT_D1 MDO IN_D1 Pump_01_Output_Control

High Speed Ethernet

SFC173
PROFIBUS 
Field Controller
with local I/O

ControlCare
Application
Designer

FC_01

Level transmitter Level limit switch

Pump
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2.2 Preliminaries

2.2.1 Installation and commissioning

Before you can start the IEC 61131-3 Ladder Logic tutorial, the Application Designer Suite must be 

installed on your computer, the SFC173 PROFIBUS Controller installed and commissioned and a 

connection made to your computer. Instructions on how to do this are to be found in:

•  Operating Instructions BA020S/04/en, Getting Started

•  Operating Instructions BA021S/04/en, Field Controller: Hardware Installion

•  Operating Instructions BA035S/04/en, Field Controller: Commissioning and Configuration

Not all project steps are described in detail, so it is recommended that you also have the PROFIBUS 

or FOUNDATION Fieldbus tutorials at hand:

•  Operating Instructions BA019S/04/en, Application Designer: FOUNDATION Fieldbus tutorial

•  Operating Instructions BA036S/04/en, Application Designer: PROFIBUS tutorial

2.2.2 Rack assembly

The SFC173 Field Controller, SFC444 Analog Input module and SFC432 Discrete I/O module have 

combined power demand of 132 mA @ 24 VDC and 940 mA@ 5 VDC. Even allowing for a 

tolerance of 20%, this is easily covered by a SFC050 or SFC056 rack power module (300 mA @ 24 

VDC and 3000 mA @ 5 VDC). See Chapter 10 of BA040S/04/en, ControlCare, System 

Specifications.

The Field Controller and local I/O are mounted on a SFC901A rack assembly with address = 1 

(I/O cannot be mounted on a rack with the address "0".) The parameters for commissioning the 

Field Controller are shown in Table 2-1.

Tab. 2-1: Parameter settings for rack in hardware configuration and function blocks

Note!

• The channels used to connect to the modules to the function blocks are given by the 

Rack (R), Slot (S), Group (G) and I/O point (P) indices = RRGSP, whereby counting starts at "0". 

• Since Multiple Discrete Input and Output blocks are being used for the discrete signals, the I/O 

point index is "9", see BA035S/04/en, Field Controller, Commissioning and Configuration.

2.2.3 External devices

ControlCare local I/O modules are available with passive electrical circuits only, so that any 

connected devices or external circuits must have their own power supply, see BA035S/04/en, 

Field Controller, Commissioning and Configuration.

Rack 1 Slot 0 Slot 1 Slot 2 Slot 3

Module SFC050 SFC173 SFC444 SFC432

IO_TYPE_Rx No I/O No I/O 8 Analog Input 8 DiscIn 4 DiscOut

Channel Group A – – 1209 1309

Channel Group B – – – 1319
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3 Create a PROFIBUS Network

3.1 Create a new project

1 Start ControlCare Application Designer by clicking on the icon on your destop or via Start => 

Programs => Endress+Hauser => ControlCare => ControlCare Application Designer

2 The project starts from a blank application screen

– With the right mouse key select Project File=>New

3 The Document Type box appears: Click the option Project

4 The New Project dialog box opens:

1. Choose the folder where the project will be saved.

2. Type the name of the project in the File Name box.

3. Click Save. 

If the new project is not to be created, click Cancel.

5 ON saving, ControlCare Application Designer 

– automatically creates a folder with the entered file name within the selected folder

– automatically creates a project, adding the HSE Network network and the HSE Host
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3.2 Determine the naming preferences

Before you start, you can set preferences for the way your project is created. Of particular interest 

at this stage is the labelling of the function blocks.

1 Press Project File => Preferences

– The Preferences Dialog appears

Tag Policy Tag Policy determines how the blocks are labelled by default if no tag names are entered

1 Select the folder Block and the subfolder Tag Policy, then check the following buttons

– Device

– Update Block Tag

2 Press OK to confirm your selection

– Application Designer will now automatically rename any blocks created in the control

strategy window as they are assigned to the devices by adding the device tag as prefix.

Tag Composition Tag Composition determines how the block identifiers are added to the block tag if no block name 

is entered.

1 Select the subfolder Tag Composition:

– Default setting is "_". 

– This is mandatory if hybrid function blocks are to be used

– Check Prefix

2 Press OK to confirm your selection

– Application Designer will now automatically compose the blocks according to your

selection, e.g. TagName_Block_n.

Export Tag Export Tag causes tags to be automatically exported every time the project goes online

1 Select the subfolder Export Tag

– Check the Automatic button

– Press OK to confirm your selection

Strategy Strategy determines the default shape of the function block icons in the stratagy window and also 

whether the aliasing function is enabled

1 Select the subfolder Strategy

– Select the default shape for function block objects

– Select "Aliasing Input Dialog Box" 

– Press OK to confirm your selection
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3.3 Add a gateway (SFC173)

Note!

• If you are using a FOUNDATION Fieldbus SFC162 Field Controller, the procedure is exactly the 

same, except that you must add a "bridge" not a "gateway".

1 In the project workspace, click on "+" to expand the tree:

2 Now right-click on the HSE Network leaf and select New=>Gateway

3 The New Gateway dialog box appears:

Select the SFC173 Field Controller and type in a device TAG = FC_01_DP

If you do not type in a tag, the default will be "Gateway n", where n is a consecutive number.

4 Press OK to create the Gateway.

5 Right-click on the Project File menu and select Save Entire Configuration to save the 

project.
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3.4 Set up the Hardware Configuration block

1 Double click on the HSE Network leaf, the HSE Network window opens:

– Expand the FC_01_PB and FBAP leaves

2 Double-click on the FC_01_PB_HC_1 leaf to open the Off Line Characterization dialog

To change parameters: 

– Expand the parameter leaf

– Double click on value space

– Enter the parameter or select it from the drop-down menu

– Confirm with End Edit

3 Expand the MODE_BLK parameter left and check that Target is set to Auto

4 Expand the IO_TYPE_R1 parameter leaf and set the following parameters, see Table 2-1, 

Chapter 2.2.2

– Slot_0: No I/O

– Slot_1: No I/O

– Slot_2: 8 Analog Input

– Slot_3: 8 DiscIn 4 DiscOut

5 Click Close, then save the configuration 

– Right-click on the Project File menu and select Save Entire Configuration to save the

project, which now looks like this.
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4 Create a Control Strategy

Having created a physical view of the process instrumentation, in this case the Field Controller, the 

next step is to create control strategy. This is done in the logical view of the plant. This represents 

the plant as Areas/Process Cells in accordance with ISA S88/IEC 61518. Only one Area is allowed 

in the project, but this may have any number of Process Cells.

4.1 Add a Process Cell

1 Click on the "Area 1" leaf in the project and select Attributes...

2 The Attributes dialog box appears

– Enter a name for the area, e.g. East Side

– Click OK to store your changes

3 Click on the Area leaf again and select New Process Cell...

4 The Process Cell dialog box appears

– Enter a name for the process cell, e.g. Utilities

– Click OK to store your changes

5 Your project should now look something like this:

6 Open Project File, then press Save Entire Configuration, to save the project.
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4.2 Add a Control Module

1 Double-click on the Process Cells leaf - a new window with the name of the leaf opens

2 Right-click on the top leaf and select New Control Module

3 The Control Module dialog box appears

– Enter a name for the control module, e.g. Pump Control

– Click OK to store your changes

4 The project now looks something like this:

5 For a real project, Step 2 and 3 would be repeated until all the required control modules for a 

particular process cell have been added. This allows each control loop or control loop group to 

be set up and viewed in its own control strategy window.

6 Open Project File, then press Save Entire Configuration, to save the project.
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4.3 Add Function Blocks to the Control Strategy

Note! 

• The function blocks used in the tutorial are selected from the device manufacturer’s device list. 

It is also possible to select standard function blocks from the "Fieldbus Foundation" list. This 

ensures that the control strategy can be executed in any device that supports a particular standard 

block, irrespective of vendor.

• Endress+Hauser devices support standard function blocks and offer them in the manufacturer 

specific list.

1 Double-click on the control module leaf or right-click and select Expand to open the Control 

Strategy workspace - this has the same name as the leaf

2 Press the Function Block button  in the toolbar and click in the workspace

– The New Block dialog appears

– Select the Manufacturer = Endress+Hauser

– Select the Device Type = SFC173

– Select the Block Type = Analog Input

– Press OK to create the function block

3 The block now appears in the strategy window with the default name
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4 Repeat Steps 2 and 3 for the Analog Alarm, Multiple Discrete Input, Hybrid with Discrete I/Os 

and Multiple Discrete Output blocks

– Level Analog Alarm: 

Manufacturer = Endress+Hauser

Device Type = SFC173

Block Type = Analog Alarm

– Level Overspill and Pump Signal Inputs

Manufacturer = Endress+Hauser

Device Type = SFC173

Block Type = Multiple Discrete Input

– IEC 61131-3 Programming

Manufacturer = Endress+Hauser

Device Type = SFC173

Block Type = Hybrid with Discrete I/Os

– Pump Control

Manufacturer = Endress+Hauser

Device Type = SFC173

Block Type = Multiple Discrete Output

5 The control strategy now looks like this

6 Open Project File, then press Save Entire Configuration, to save the project.

°Note! 

• If you are using the FOUNDATION Fieldbus SFC162 Field Controller, select the blocks from the 

corresponding SFC162 Block Type list
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4.4 Add the Function Block links

1 In the Control Strategy workspace position the blocks according to your strategy

– The blocks can be dragged and dropped by selecting and holding down the right mouse key

– The blocks can be aligned by selecting, then via Tools => Alignment => e.g. Middle 

followed by a click on the block to which the alignment is to be made

– The Tools menu also contains other standard drawing functions such as toolbars, standard 

shapes, line thickness, colours etc.

2 Click on Function Block Link  button in the tool bar, the cursor changes to a cross

– Select the Pump Control_A1_1 block with the cross: 

the Output Parameter Selection dialog appears

– OUT contains the level value
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3 Click the box next to OUT – it changes color – then click on OK

– The Output Parameter Selection dialog closes

– The cursor is now connected to a blue dotted line

– Place the Cursor in the Pump Control_AALM_1 block and click to make the link

4 When the link is made, the Input Parameter Selection dialog for the Alarm block appears

– Click the box next to IN – it changes color – then click on OK

5 The Rename dialog now appears: in this tutorial the alias function will be used when the I/O 

blocks are characterized, Chapter 4.6, for this reason:

– Press OK without making an entry - the link retains the standard name

6 When the Rename dialog disappears, the link is made and appears as below:

– You may have to move the parameter legends "IN" and "OUT" by selecting and positioning 

with the left mouse key depressed

7 Repeat steps 2 to 5 and make the following links between the function blocks

– Pump Control_AALM_1 to Pump Control_HY_MD_IO_1

OUT_ALM to IN_D5

– Pump Control_MDI_1 to Pump Control_HY_MD_IO_1= 

OUT_D1 to IN_D1

OUT_D2 to IN_D2

OUT_D3 to IN_D3

OUT_D4 to IN_D4

– Pump Control_HY_MD_IO_1 to Pump Control_MDO_1

OUT_D1 to IN_D1
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8 Your Control Strategy now looks something like this

9 By using the Tools => Drawings => Text option, you can now add text to the strategy to 

make clear the function of each block and parameter:

10 Click on the Project View workspace and Export Tags..., see Chapter 4.7

– Open Project File, then press Save Entire Configuration, to save the project.
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4.5 Attach the function blocks to the Field Controller

The blocks that are always necessary for the Field Controller (RS, PBTR0, HC and DIAG) are created 

automatically when it is added to the Fieldbus Network. Do not delete these blocks! The order of 

attachment of the strategy function blocks to the Field Controller determines the order of execution.

•  First attach the input blocks

•  Then attach the control and logic blocks in the order of execution

•  Finally attach the output blocks

If necessary, the order of the blocks can be adjusted by drag & drop.

1 Close the Control Strategy window and place the Utilities (Control Module) and 

HSE Network 1 dialogs side-by-side

– The function blocks and links you created have been added to the Utilities tree

– There is a question mark "?" in each function block icon

2 Drag and drop the Pump Control_AI_1 block from the Utilities into the HSE Network 1 dialog 

and place it on the FB VCF leaf

– The block is attached to the Field Controller

– The name changes (set to do so in Preferemces, see Chapter 3.2)

– The question mark disappears from the block in the Utilities dialog

3 Repeat step 2 for all blocks - your project now looks like this:

4 Open Project File, then press Save Entire Configuration, to save the project.
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4.6 Characterize the I/O function blocks

The Analog and Digital I/O blocks can now be characterized as follows.

1 In the HSE Network 1 dialog, double-click on the block leaf

– The Off Line Characterization dialog for the block appears

2 To change parameters: 

– Expand the parameter leaf

– Double click on value space

– Enter the parameter or select it from the drop-down menu

– Confirm with End Edit

3 Click Close to close the block and 

4.6.1 Analog Input block

The AI block is attached to the SFC444 Analog Input module. This delivers a 4 mA to 20 mA signal 

that must be scaled to 0 % to 100%. The channel parameter is that in Table 2-1, Chapter 2.2.2.

1 Double-click on FC_01_PB_AI_1 and enter the following parameters

– MODE_BLK

TARGET: Auto

– XD_SCALE

EU_100: 20

EU_0: 4

UNITS_INDEX: mA

– OUT_SCALE

EU_100: 100

EU_0: 0

UNITS_INDEX: %

– CHANNEL: 1200

– L_TYPE: Indirect

2 Press Close to close the dialog

3 Open Project File, then press Save Entire Configuration, to save the project.
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4.6.2 Analog Alarm block

The Analog alarm block monitors the incoming level signal. When the signal exceeds the HI limit 

= 95%, the OUT_ALM signal changes from FALSE to TRUE

1 Double-click on FC_01_PB_AALM_1 and enter the following parameters

– MODE_BLK

TARGET: Auto

– OUT_ALM_SUM: Hi

– HI_LIM: 95

2 Now alias the OUT_ALM parameter by changing the standard name

(must start with a letter, use underlines not spaces):

– Select the OUT_ALM line by clicking over it with the mouse then click over the parameter

– Enter the new name: "Pump_01_Running_Signal", see Chapter 2.1.3

– Press End Edit to store the change

3 Press Close to close the dialog

4 Open Project File, then press Save Entire Configuration, to save the project.
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4.6.3 Multiple Discrete Input block

The MDI block is attached to the SFC432 Discrete Input/Output module. This delivers FALSE for 

a 0 VDC signal and TRUE for a 24 VDC signal. The channel parameter is that in Table 2-1, 

Chapter 2.2.2.

1 Double-click on FC_01_PB_MDI_1 and enter the following parameters

– MODE_BLK

TARGET: Auto

– CHANNEL: 1309

2 Now alias the IN_D1 to IN_D4 parameters by changing the standard names

(must start with a letter, use underlines not spaces):

– Select the IN_Dx line by clicking over it with the mouse then click over the parameter

– Enter the new names, see Chapter 2.1.3

IN_D1: Pump_01_Reset

IN_D2: Tank_Level_01_Alarm

IN_D3: Tank_01_Overflow

IN_D4: Pump_01_Overheat_Signal

– Press End Edit are each entry to store the change

– Press Enter to store

3 Press Close to close the dialog

4 Open Project File, then press Save Entire Configuration, to save the project.
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4.6.4 Multiple Discrete Output block

The MDO block is attached to the SFC432 Discrete Input/Output module to which the pump 

power is connected. A FALSE signal causes the relay to close and the pump runs. A TRUE signal 

causes the relay to open and the pump stops. The relays are Normally Open (NO) so that a in the 

event of a power failure, the pump fails to safe = stop. The channel parameter is that in Table 2-1, 

Chapter 2.2.2.

1 Double-click on FC_01_PB_MDO_1 and enter the following parameters

– MODE_BLK/ TARGET: Auto

– CHANNEL: 1319

2 Now alias the OUT_D1 parameter by changing the standard name

(must start with a letter, use underlines not spaces):

– Select the OUT_DI line by clicking over it with the mouse then click over the parameter

– Enter the new name: "Pump_01_Output_Control", see Chapter 2.1.3

– Press End Edit to store the change

3 Press Close to close the dialog

4 Open Project File, then press Save Entire Configuration, to save the project.
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4.6.5 Hybrid Discrete I/O block

The HY_MD_IO block adds the logic to the control strategy. It must be put into Auto. At this point 

the target execution time EXEC_TIME_TARGET should be left at the default value of 30 ms.

1 Double-click on FC_01_PB_HY_MD_IO_1

– Expand the Mode Block node and check that the Target is set to Auto

– Set the parameter HYB_STATUS_OPTS to Set Ouputs to Good Non Cascade

2 Parameters that should receive an OPC Tag for use by e.g. a SCADA program must also be 

aliased in the hybrid block, in our example we want to allow the operator to switch off the 

pump in an emergency by using IN_D6:

– Select the IN_D6 line by clicking over it with the mouse then click over the parameter

– Enter the new name: "Pump_01_Operator_Entry_Emergency"

– Press End Edit to store the change

3 Press Close to close the dialog

4 Open Project File, then press Save Entire Configuration, to save the project.

5 If you open the strategy window again, you will see the links now have the alias names

6 Since the input and output signals for a particular link now have the same names, you may 

want to hide some:

– Right click on the link, select Labels and click on the parameter you want to hide

– The label is hidden when there is no tick on the "Show...." parameter
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4.7 Export tags

Note! 

• You should use the Export Tags function everytime you change the configuration of the project, 

so that the OPC server information is always up-to-date.

• Application Designer can be set to automatically export the tags every time the project goes 

online, see Chapter 3.2.

1 Activate the project view by clicking in its workspace

– Right click on the project name, a context menu appears

2 Select the option Export Tags...

– The Export Tags dialog confirms the successful export

– Press OK to close the dialog

3 Open Project File, then press Save Entire Configuration, to save the project.Program the 

Hybrid Function Block

The hybrid function block can now be programmed using IEC 61131-3 Ladder Logic. 
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5 Program the Hybrid Function Block

5.1 Set the IEC 61131-3 programming language

1 In the HSE Network 1 tree, right click on FC_01_PB_HY_MD_IO_1 and select Attributes

2 The Attributes dialog opens:

– In the IEC 61131-3 Programming Language menu select LD (Ladder Logic)

– Map as FF Data Structure should now have no tick, if this is not the case, untick

– Press OK to confirm the selection
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5.2 Program the hybrid function block

5.2.1 OpenPCS programming tool

1 In the HSE Network 1 tree, right click on FC_01_PB_HY_MD_IO_1 and select 

Program Hybrid Block

2 The OpenPCS programming tool opens:

– The Files pane of the Project window shows the program files

– The Resources pane shows the hybrid block task attached to the Field Controller

– The Lib pane shows the libraries available

– The Help pane opens the Online help tree

– The Catalog window might also appear – it can be closed by pressing the "x"

– The Log window tracks program events – it can be closed by pressing the "x"



5 Program the Hybrid Function Block ControlCare Application Designer: IEC 61131-3 Ladder Logic Tutorial

30 Endress+Hauser

3 Double-click on FC_01_PB_HY_MD_IO_1.LDD: the editor opens with the declared external 

variables (the log window at the bottom was closed for this screenshot)

5.2.2 Declare additional variables

Additional variables used by the structured text program must be declared with name and data type 

in the upper right-hand pane before programming starts. Table 6-1 lists the various types of 

declaration supported. The declaration opens with the variable type and is closed with END_VAR. 

The various types are created with default value zero for real and integer variables and FALSE for 

booleans. 

Tab. 5-1: Variable declaration types

Variable type Access Rights Function

External Internal

VAR – RW Local variable that is readable and writable to its own block only

VAR_INPUT RW R Input variable that is readable and writable to an external block, but 

only readable to its own block

VAR_OUTPUT R RW Output variable that is readable and writable to its own block, but only 

readable to an external block

VAR_IN_OUT RW RW I/O variable readable and writable to its own and an external block

(call by reference)

VAR_EXTERNAL RW RW External I/O variable, declared as global in its own block, that is 

readable and writable to its own and an external block, whereby any 

change is immediately effective in all blocks where it is used

VAR_GLOBAL RW RW Global I/O variable, declared as external in its own block, that is 

readable and writable to it own and an external block, whereby any 

change is immediately effective in all blocks where it is used

VAR_ACCESS RW RW Global I/O variable (access path) that is readable and writable in its 

own and an external block resident in a different controller, whereby 

any change is immediately effective in all blocks where it is used
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Attributes The declarations can be modified to define a particular behaviour of the variables contained within 

them by adding one of the attributes in Table 6.2.

Tab. 5-2: Declaration attribute types

In this exercise there are no additional variables to declare.

5.2.3 Activate the libraries

ControlCare activates two libraries by default:

•  CC_FF_CUSTOM_LIB to map the custom FF function blocks

•  CC_FF_STANDARD_LIB to map the standard FF function blocks

These appear red in the library pane (select the Lib tab)

Note! 

• For ControlCare Product Version 2.01.xx, the libraries have to be activated by hand

• For SFC programming the sfclib must be activated, see below and the OpenPCS online help

Activating a library In order to activate additional libraries, e.g. sfclib for SFC programming, the following procedure is 

used:

1 Select the Lib pane:

– Right-click on e.g sfclib and select Use in Current Project

– The project book turns red = active

Installing a library If the libraries are not installed:

1 Right-click on Libraries, select Install New..., 

2 Browse to the folder containing the LIB files and select the library required

3 Press OK twice to install.

Attribute type Function

RETAIN Variable that retains its value when the controller is switched off or restarted

CONSTANT Variable that retains a constant value, i.e. not writable

OPC Variable that is readable and writable in the IEC OPC Server

– Local varibles declared with the prefix OPC_ are also visible in the IEC OPC server
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5.2.4 Create the ladder logic

1 If required, insert a comment indicating the function performed by double clicking in the space 

below the scissors and entering the text

2 Now insert the diagram elements by right clicking on the selected rung and selecting 

Insert Contact

– A contact can be negated by right-clicking on the contact and selecting Negate

– An OR can be created by right-clicking on the contact and selecting Insert Branch (OR)

– An AND can be created by right-clicking on the contact and selecting 

Insert Sequence (AND)

3 Now proceed to create the logic sequence:

– OR Contact

– 4x negated contacts

4 Now right-click on the first contact and select Insert Variable

– The Insert variable dialog Opens
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5 Select Pump_01_Running_Signal_value

– The variable is assigned to the contact

6 Repeat Steps 1 and 2 for the variables 

Pump_01_Reset_B_value, 

Tank_01_Overflow_value, 

Pump_01_Overheat_Signal_value, 

Pump_01_Operator_Entry_Emergency_value, 

Tank_01_Level_Alarm_value, 

Pump_01_Control_Output_value

7 The logic is now complete

5.2.5 Trouble-shoot the project 

Now that the project is complete, it is recommended that the project is checked for errors.

1 Open the File menu and select Check Syntax

2 OpenPCS runs a check on all syntax in your program and publishes a log at the bottom of the 

workspace.

– If errors are found eliminate them and check the syntax again

– You can move from error to error with the F4 and Shift F4 keys

3 When the program is free of errors, open the File menu and select Save All.
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5.3 IEC 61131-3 Simulation

OpenPCS allows the simulation of the IEC 61131-3 program without the need for hardware. It is 

recommended that the program is tested with this function before it is downloaded to the Field 

Controller.

5.3.1 Resources

1 Click on PLC and select Resource Properties from the PLC menu

– The Edit Resource Specifications dialog opens

2 In the Edit Resource Specifications dialog

– Select Hardware Module: ControlCare SIM/Rev 3

– Select Network Connection: EHSIM

– Select Optimization: Size only

– Press OK to confirm the changes and close the dialog

3 Click on PLC and select Rebuild Active Resources (alternatively, press CTRL+F7)

– You can now go "Online" with the simulation.
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5.3.2 Go "Online"

1 Click on PLC and select Online from the PLC menu

– If appropriate an OpenPCS Online Server 32 message appears

– Press Yes to download the resource to the server

2 Press the Resource tab and click on the Field Controller in the project window

Note! 

• If there is more than one Field Controller in the project, it appears green and the others red.

• To activate different controller, right click on it and select Set Active, its colour changes to green

3 Click on PLC and select Coldstart from the PLC menu

– The Field Controller simulation now runs

– The buttons Power Off, Run and Stop simulate the corresponding operating modes of the 

Field Controller

– The Cycles display show number of cycles simulated and cycle time in ms

– The LEDs simulate the LEDs on the Field Contoller

– To change the macrocycle time, press the >> button and enter a new value in the Cycle 

Time dialog, confirming with OK

4 The simulation is closed by clicking on PLC and select Offline from the PLC menu
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5.3.3 Watch list

By placing selected input and ouput variables in a watch list, the logic can then be checked.

1 Press the Resource tab and expand the FC_01_HY_MAD_IO_1 node

– A list of input and output variables appears

2 Double-click on a parameter to place it in the watch list

– Parameters can be deleted by selecting the parameter line and pressing DEL

3 Right-click on the watch list "value field" and enter a value in the Set Variable dialog

– Press OK to confirm the entry and close the dialog

4 Check the logic by seeing the effect of parameter changes on the outputs
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5.4 Optimize performance

If the IEC 61131-3 simulation was used, the resources must be respecified before the project is 

compiled and downloaded, see Chapter 6. 

OpenPCS allows the hybrid function block to be optimized for speed or size during compilation. 

Default setting is optimized for speed. Optimizing for size causes the block to run slower than if it 

is speed optimized, and is recommended only when there are memory problems, e.g. when a large 

number of hybrid function blocks with long programs are in use or when simulating without Field 

Controller hardware, see Chapter 5.3. 

Changing the performance 

settings

The settings are made in both the resources and the hybrid function block

1 Click on the Resources tab, then right-click on Controller leaf and select Properties

2 The Edit Resource Specifications dialog appears

– Select Hardware Module: ControlCare SFC173/Rev 3

– Select Network Connection: FC_01_PB

– Select Optimization: Speed only

– Press OK to confirm the changes and close the dialog

3 Now right-click on the Function Block leaf and select Properties

– The Edit Task Specifications dialog appears

– In the Optimization pull-down menu select e.g. "speed only", then press OK
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6 Go On-line

6.1 Connect to the Field Controller

In order to download the project, the host computer and Field Controllers must be allocated 

IP addresses in the same address range. It is possible to do this on the workbench before installation 

or after the Field Controller and other components have been physically installed in the Fieldbus 

network (subnet). 

Warning

• The use of IP addresses is strictly controlled. Usually your system administrator will be authorised 

to allocate unique addresses. Assigning an unauthorised address to a Field Controller may result 

in conflicts within your system and the failure of the associated devices!

Note!

• The tools that setup the network use Ethernet services that may be blocked by Windows Firewall. 

Normally the firewall will be unblocked for the tools during installation, but it might be necessary 

to stop the firewall should they not function properly. If you are not sure how to stop the firewall, 

consult your system administrator.

Before starting, check the following:

•  Internet Protocol TCP/IP is installed on your computer

•  You have administration rights for your computer

•  You have an set of IP addresses that have been authorized by your IT department

•  Any proxy server for your Internet Browser is disabled

The procedures described in this chapter are for Windows XP. For other Windows systems consult 

your system administrator.

Note!

• When the Field Controllers are physically connected together with the Host computer via 

Ethernet, HSE Network Setup will see the them irrespective of the IP address domain to which 

they belong
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6.1.1 Set the IP address of the host computer

SFC173 Field Controllers are delivered with the default IP address:

•  192.168.164.101 

In order that the host computer can communicate with the Field Controller Web Server, it must be 

allocated an IP address in the same address domain, e.g. 192.168.164.200. If you are not sure how 

to do this, consult your network administrator. 

Procedure 1 Right-click Start =>Settings =>Control Panel =>Network Connections

2 Right-click Local Area Connection => Properties

3 Using the left mouse button, double-click Internet Protocol (TCP/IP) or

click once, then click Properties. 

4 Note the original values of IP address and Subnet Mask of the computer to restore them if 

necessary at end of the operation. 
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5 Change the IP address and the Subnet Mask of the host computer to those required by the 

application. In the example, an address in the same subnet as the Field Controller. 

– IP Address 192.168.164.XXX and network mask (Subnet Mask) 255.255.255.0.

– Do not use the address 192.168.164.100, as this is reserved as default address for 

Field Controller SFC162

6 Click on the OK button to complete the procedure, close the other dialogs with OK and 

Close.

6.1.2 Set the Field Controller IP address

Note!

• It is recommended that Field Controllers of the same type are introduced one by one to the 

network.

1 Call HSE Network Setup: 

Programs =>Endress+Hauser=>ControlCare=>Tools=>HSE Network Setup

2 HSE Network Setup is launched and searches for Field Controllers in the Ethernet network.

– All Field Controllers in the network appear, irrespective of their IP domain. 

If this is not the case:

– Check that the proxy server of your Internet Browser is switched off

– Check that the windows firewall is not blocking the program (switch off)

– Check all cables and switches

– If you find two or more Field Controllers with the same IP address, disconnect all but one 

from the network

3 If your computer has more than on NIC card, select the one you want to use for 

communication with the Field Controllers by ticking "Active NIC" and Press .
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4 Right-click on the Field Controller, the address of which is to be changed:

the Field Controller Web Server opens

– The Web Server will only open if the host computer and the Field Controller have 

IP addresses in the same IP domain.

5 Expand the Setup node and click Network

– Enter User Name "pcps" and Password "pcps" to open the Network Configuration dialog

– Enter the required IP address, in our example 10.125.35.176

– Enter a netmask, normally 255.255.255.0

– If required, enter a default gateway, usually address xxx.xxx.xxx.1 in the selected domain

6 Press Update to change the IP address

– You are now asked to restart the Field Controller

– Select the Restart node

– Select "No additional options" from the drop-down menu and press Restart

– Close the Web Browser

– The Field Controller disappears from HSE Network Setup and reappears with the new 

IP address
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7 Now set the address of he host computer to the same domain as the Field Controllers, see 

Chapter 6.1.1 - in our example 10.125.35.200

– Restart HSE Network Setup

– Tick the Field Controller, so that it appears in the HSE Live List associated with the 

computer’s active NIC card.

– Press  to save the configuration.

– You are now ready to download the project

Note!

• If you have more than one Field Controller on the network, Repeat Steps 4 to 6 for all other Field 

Controllers, introducing them one by one to the network.
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6.2 Generate the live lists

6.2.1 HSE live list

Once the Computer and Field Controller are able to communicate with each other, the connection 

to the network can be checked by creating a live list. 

1 Press the On-Line button  in the menu toolbar

– The project goes on on-line

– A red cross appears against the Field Controller in the Project workspace

2 In the Project workspace, right click on HSE Network and select Live List

– A live list is generated of the devices on the HSE network

Note! 

• It may take sometime to generate the live list 

– The devices found first go grey 

– Their profiles (all important device-specific data) including IP address are read

– On successful completion of profile reading, the devices are shown in full black 
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6.2.2 Assign the Field Controller Device ID

1 In the project workspace, right click on the Field Controller (FC_01_PB) and select 

Attributes...

2 The Attributes dialog opens

– Open the drop-down menu of the Device ID and select the Field Controller associated

with the displayed TAG (in our case FC_01_PB) - the serial number is on the front panel

– Do this even though the correct ID is already displayed - the program expects it!

– Confirm your choice with OK

3 Right-click on the HSE Network 1 leaf and select Assign All Tags

4 The Tag FC_01_PB is assigned to the Field Controller

– The Field Controller in the HSE live list goes grey

– When the Tag has been assigned, it goes black again

5 Open Project File, then press Save, to save the project
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6.3 Download the project

Both the project in ControlCare Application Designer and that in OpenPCS must be downloaded to 

the Field Controller. The downloads can be made in any order.

Note! 

• The procedure below describes the initial download for the entire HSE network. 

• Partial downloads can be made later from lower leaves, when changes are confined to this level

• Incremental downloads can be made to a running project by checking the boxes Incremental 

Download and Compare Parameters: Unaffected Local I/Os will hold their last values 

(bumpless transition).

6.3.1 Download the control strategy

1 In the Project workspace right-click on HSE Network 1and select Download

2 The Download dialog appears

– Press Start to start the download

3 The download will be interrupted if the project has not been configured properly, e.g.

– The Field Controller Tag has not been assigned correctly => Assign Field Controller tags, 

Chapter 6.2.2

– The I/O moduels have not been correctly defined, see Chapter 4.6

4 When the download is successfully completed, the dialog is closed, and you are ready to 

download the hybrid block configuration
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6.3.2 Download the OpenPCS project

1 Start OpenPCS by right clicking on FC_01_PB_HY_MD_IO_1 in the HSE Network 1 tree 

and selecting Program Hybrid Block: 

– If OpenPCS is already running, close it before performing this step

– The attribute settings are exported to OpenPCS

– Click OK to open the OpenPCS workspace

1 Click on PLC and select Online from the PLC menu

– If appropriate an OpenPCS Online Server 32 message appears

– Press Yes to download the resource to the server

2 Press the Resource tab and click on the Field Controller in the project window

3 Click on PLC and select Coldstart from the menu: the hybrid block is started (set to Auto). 

4 If there is more than one controller in the project, each must be cold-started as follows:

– Right click on the controller and select Set Active, its colour changes from red to green

– Click on PLC and select Coldstart from the menu

– All hybrid blocks attached to the controller are forced to Auto

5 Now check the project files

– You will see that the names in the ladder logic are now replaced by values

6 OpenPCS offers a number of options for monitoring values and changing the program without 

stopping execution, e.g. on-line editing –see the on-line help for details.



ControlCare Application Designer: IEC 61131-3 Ladder Logic Tutorial 6 Go On-line

Endress+Hauser 47

6.4 Check the control stategy

6.4.1 Control strategy

1 Click in the Control Strategy workspace (Pump control) and press the button  in the menu 

toolbar – the control strategy also goes "on-line"

– Values appear in green when the status is good

– Values appear in red if the status is bad - at this stage this is an indication of a communication, 

block configuration, strategy configuration or device parametrization error

Note! 

In the strategy above all input signals have been hidden

2 If you have the possibility of changing the signals, change each input in turn and check the 

effect on your strategy.
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6.4.2 Optimization of hybrid block execution time

1 Open the HSE Network 1 dialog, then click on the "details" icon in the menu bar

– The execution times are shown next to each block

– The FC_01_PB_HY_MD_IO_1 block executes at the default time of 30 ms

2 Right-click on the FC_01_PB_HY_MD_IO_1 block and select On Line Characterization

– The parameter EXEC_TIME_ACTUAL shows the time in which the block is executing

– Observe the value for a couple of minutes and note the highest value

3 Now change the function block execution time to the new value

– Right-click on FC_01_PB_HY_MD_IO_1 and select On Line Characterization

– Double-click on the "value space" next to the parameter EXEC_TIME_TARGET

– Enter a value 10% to 20% higher than the highest observed actual execution time

– Press End Edit to store the value and Close to quit the dialog.

4 Right-click on the Gateway node (FC_01_DP) and select FB Schedule Download 

– The new value is downloaded to the Field Controller

– The strategy now runs with the new target execution time

5 Repeat Steps 1 to 4 for all hybrid blocks in the strategy

Note!

• EXEC_TIME_ACTUAL will be too high if the ladder logic program is being monitored on-line 

by OpenPCS. Close the application before checking the value.
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6.5 Modify the project

6.5.1 On-line characterization

Once the project is on-line you may want to change parameters to e.g. tune the control-loop or 

eliminate configuration errors. With the exception of the SP parameter, the function block must be 

put out of service before the parameter is changed:

1 In the Control strategy workspace double-click on the function block you want to modify, or in 

the HSE network 1 or Control module workspace, right-click on the function block and select 

On-line Characterization

2 The function block On-line Characterization dialog appears:

– Open the Mode leaf and double-click in the space next to Target

– Set the Target to OOS (Out of Service)

– Click End Edit to set the parameter

3 Change the parameters you wish to modify

– If appropriate, open the parameter leaf and double-click in the space next to the parameter 

you require

– Enter the new parameter or select it from the drop-down menu

– Click End Edit to set the parameter

– Repeat the procedure for all the parameters you wish to modify

4 Put the function block back into standard operating mode

– Open the Mode leaf and double-click in the space next to Target

– Set the Target back to the original value (Auto (Automatic) or Cas (Cascade))

– Click End Edit to set the parameter

– Check that the Mode really changes to the Target Mode (failure to do so indicates a 

configuration error)

– Press Close to store the values (if you are prompted - answer with Yes)

5 Click on the Project View workspace and Export Tags..., see Chapter 3.10

– Open Project File, then press Save Entire Configuration to save the project

6 Put the Control stategy back "on-line" to check the results of your modification, Chapter 6.4.
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6.5.2 Off-line characterization

You may prefer to change parameters off-line, e.g. when modifying the control strategy or adding 

new functions to the project. 

1 If you are on-line, press the Off-line button  in the menu toolbar

alternatively, in the PROFIBUS network or Control module workspace, right-click on the 

function block and select Off-line Characterization

– The function block Off-line Characterization dialog appears

2 Change the parameters you wish to modify

– If appropriate, open the parameter leaf and double-click in the space next to the parameter 

you require

– Enter the new parameter or select it from the drop-down menu

– Click End Edit to set the parameter

– Repeat the procedure for all the parameters you wish to modify

– Press Close to store the values

3 Click on the Project View workspace and Export Tags..., see Chapter 3.10

– Open Project File, then press Save Entire Configuration to save the project

4 Press the On-line button  in the menu toolbar to go on-line again

5 Download the modified project

– In the Project workspace right-click on HSE Network 1and select Download

– Follow the procedure in Chapter 6.3

6 Put the Control stategy back "on-line" to check the results of your modification, Chapter 6.4.
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6.6 Packing and unpacking the project

In order to install the project at the customer’s site, the project can be packed and unpacked. It is 

important to remember, especially if you have not been using the actual project devices to test your 

project, that the instruments on site may be have newer (or even older) DD/GSD/CFF files than 

the ones you use. The latest DD/GSD/CFF files must then be uploaded to the project and 

corresponding corrections must be made to configuration, before it is downloaded to the Field 

Controller. The is done with the Import Device Support... item in the Project File menu, see 

Operating Instructions BA017S/04/en, Chapter 3.1.5.

6.6.1 Pack the project

1 Select Project File => Pack Project...

– The Pack Project dialog appears

– Browse to the folder where the files will be created

You can create a folder with the Make New Folder button 

– Enter the name of the project

– Press Save to save the packed project

– Press OK to close the successful packing message dialog

6.6.2 Unpack the project

1 Select Project File => Unpack Project...

– In the Unpack Project dialog

– Browse to the folder where the packed project is located

– Click on the name of the project

– Press Open to save the packed project

2 In the Browse for Folder dialog:

– Browse to the folder where the project is to be installed

You can create a folder with the Make New Folder button 

– Press OK to start upacking

– Press OK to acknowledge the successful unpacking of the project

6.6.3 Unpack the OPC data base only

For some applications it may be necessary to update the OPC data base of a SCADA program that 

has no provision for importing new DDs etc.. This can be done in Application Designer, which 

allows the separate unpacking of the OPC data base.

1 Go online, then right-click on the HSE OPC Server icon in the system tray

2 Select Unpack Configuration...:

– Unpack the OPC data base to the folder required according to the Steps 1 and 2 in

Chapter 6.6.2 above.
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6.7 Export the configuration

For documentation purposes, the project configuration can be exported to an existing ODBC file 

data source, e.g. Oracle, a machine database, e.g. Excel to provide a record of the current status of 

the project or to an XML sheet for viewing with a browser.

6.7.1 File data source folder

The file data source must have been created before the export.

1 In the Project window, right-click on the Project icon and select Export Configuration:

2 The Select Data Source dialog box appears

3 In the File Data Source folder, select the source that describes the driver that you wish to 

connect to. You can use any file data source that refers to an ODBC driver which is installed on 

your machine.

– Use the New... button and Look In dropdown menu to browse or 

– Click the data source icon to select the driver:

– Press OK to make the connection
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6.7.2 Machine data source folder

The Machine Data Source is specific to the machine, and cannot be shared. "User" data sources 

are specific to a user on the machine; "System" data sources can be used by all users on the machine, 

or by a system-wide service. The Machine Data Source must have been created before export.

Procedure 1 In the Project window, right-click on the Project icon and select Export Configuration:

2 The Select Data Source dialog box appears

– Click on the Machine Data Source tab to open the folder

– Double-click the data source name to select the machine, e.g. Excel:

3 The Select Workbook dialog box will appear:

– Select the folder where the data file is and double-click the workbook icon.

– Your project configuration will be exported to the workbook file.

– A message box appears on completion - press OK

4 Open the Excel file to check the result:
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6.7.3 XML file

1 Click in the Project workspace and select Project File =>Export => Configuration as XML

– The Export Configuration as XML dialog appears

2 Enter a File Name and Save In location, then press Save

– The project is saved as an XML file at the selected location
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6.8 Close Application Designer and OpenPCS

When you have completed your session, close Application Designer and OpenPCS

6.8.1 Application Designer

1 If you are on-line, press the Off-line button  in the menu toolbar

2 If you have made any modifications while you were on line, you will be prompted to store 

them

– If appropriate answer with Yes

3 Close the project by clicking on Project File => Close

4 Exit Application Designer by clicking on Project File => Exit

5 The Field Controller continues to operate with the project configured according to the last 

download/on-line correction

– If you switch off the Controller, the project remains stored in its memory(provided the 

battery DIP switch is on, see BA021S/04/en: Field Controller, Hardware Installation)

– It is initialized and re-executed as soon as the Controller is switched on again

6.8.2 Open PCS

1 Open the PLC menu and select Offline

2 Open the File menu and select Exit

– You will be prompted to save if your project has been changed since the last download

6.8.3 Reconnecting Application Designer

Provided your computer is operating in the same IP address domain as the Field Controller, you can 

reconnect at any time.

1 Start up Application Designer and select the Project you require

2 Press the On-line button  in the menu toolbar

3 Expand the various workplaces as required

4 Click in the Control Strategy workspace and press the button  in the menu toolbar – the 

control strategy goes "on-line" with the last configuration that was downloaded.

6.8.4 Reconnecting OpenPCS

Provided your computer is operating in the same IP address domain as the Field Controller, you can 

reconnect at any time.

1 Start up OpenPCS, open the File menu and select the project you require

2 Open the PLC menu and select Online
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7 Trouble-Shooting

7.1 Factory initialisation and reset

Warning!

• Do not use the pushbuttons located in the Field Controller unless you are certain that you want 

to reset the system.

Fig. 7-1:  Front panels of SFC162 and SFC 173 Field Controllers

Two pushbuttons located on the Field Controller, see Fig. 7-1, allow the system to be initialised and 

reset. The function and effect of the buttons is described in the table below.

• To "click " the pushbuttons use a pointed instrument (e.g. a ballpoint pen). 

Other functions of the two buttons are to be found Chapter 7 of the Operating Instructions 

BA035S/04/en, Field Controller: Commissioning and Configuration..

Function Effect Procedure

Reset Resets system: the last 

configured IP Address 

is used

• Click the right pushbutton - the system resets (takes several seconds)

• If no IP Address is found, a new one is assigned automatically

• Verify that the RUN and ETH LNK LEDs are lit.

Factory Init Deletes application, 

the last configured IP 

Address is retained

• Keeping the left pushbutton pressed, click the right pushbutton

• Check that the FORCE LED flashes once a second. 

• Release the left push button. The system resets, see above.
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7.2 Trouble-shooting tables

7.2.1 Field Controller

 Problem Remedy

1 HSE Network Setup/FC Tools does not find any 

Field Controller

• Disable the Windows firewall (normally a message 

appears ask whether you should unbock the program)

• Disable the proxy server for your Internet browser

• Check that you are using the correct Ethernet cables, 

see ETH LINK below

• Check that all etehrnet switches are powered up

• Check that the network adapter is on and OK: Execute a 

PING command to its own IP, via DOS PROMPT.

• Check if the Ethernet connection is OK: Execute a PING 

command to the Field Controller.

2 Field Controller appears intermittently in FC Tools Host and Field Controller are in different subnets.

• Normal behaviour, but for firmware download both host 

and Field Controller must be in the same subnet

3 HSE Network Setup/FC Tools does not show all the 

Field Controllers that are in the network

There is probably an IP address conflict in the network.

• Disconnect all the Field Controllers except one from the 

from the sub-network

• If necessary, change its IP address

• Now reconnect the other Field Controllers one after the 

other, if necessary changing their IP addresses

4 Field Controller Web Server does not open No Ethernet connection

• Disable the Windows firewall

• Disable the proxy server for your Internet browse

• Wrong subnet IP address

Host and Field Controller must be in same subnet

• Wrong subnet mask

Host and Field Controller must have same subnet mask

5 Firmware begins to execute but after a certain time it 

stops

It might be a configuration problem. 

• Use the Factory Init procedure and configure the Field 

Controller again. 

• If the problem persists, see the relevant chapter in 

Operating Instructions BA035S/04/en, Field Controller, 

Commissioning and Configuration

6 HOLD LED remains lit If the HOLD LED remains lit after the Field Controller has 

been turned on, the firmware may be invalid. 

• Update the firmware, see the relevant chapter in 

Operating Instructions BA035S/04/en, Field Controller, 

Commissioning and Configuration

7 ETH LNK LED does not light Check if the cable is connected correctly, or that the cable is 

not damaged. Check the specification of the cables:

• SFC 954 - Cable Standard.  To be used in a network 

between the Field Controller and a Switch/Hub.

(preferred configuration)

• SFC 955 - Crossed Cable (Cross).  To be used point to 

point between a PC and the Field Controller

(some PCs/laptops may have problems with crossed 

cable)

8 FRC LED is flashing (Force) Field Controller is powered up for the first time

• Battery is not switched on (see BA021S/04/en, p50)

Field Controller is in reset mode

• Complete the RESET procedure

Field Controller is in normal operation

• Battery is flat: 

– No problem if controller remains powered up

– If power is switched off, the project will be lost and 

must be downloaded again from Application Designer 

on repowering

9 ERR LED lit (SFC173) At least one slave is not delivering cyclic data

– Slave not connected to Profibus

– Slave not switched on

– Slave not correctly configured (PROFIBUS Configurator)
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7.2.2 Application Designer

Problem Remedy

1 Field Controller does not appear in HSE live list No connection to Field Controller

• See Remedies for Items 1, 2 and 4, Chapter 7.4.1

• Field Controller is on HOLD, set it to RUN mode

• IP address is not configured correctly, use PING to check

2 Field Controller appears but always stays grey in HSE 

Live List

No connection to Field Controller

• Check that host and Field Controller are in same subnet

3 Red cross appears on the Field Controller No communication with Field Controller

• No Ethernet connection with Field Controller, 

check connection, IP address etc, see above

• No Device ID set in the Field Controller (Attributes)

4 Red cross appears on Fieldbus/Profibus No communication with fieldbus/Profibus

• No communicaton with Field Controller, see above

• Fieldbus/Profibus not connected to controller

• DP bus parameter mismatch (Profibus)

5 Red cross appears on field device No communication with fieldbus device

• No communicaton with Field Controller, see above

• No communicaton with fieldbus/Profibus, see above

• No Device ID set (Attributes)

• Tag not assigned (Assign Tag)

• DP address is not unique (Profibus)

• DP address at device not the same as that configured in 

PROFIBUS configurator (Profibus)

6 A device does not appear in the live list Communication error

• The device is not powered up

• The project has been updated but no download has been 

made yet

7 Configuration will not download You have either a communication problem or the 

configuration is not complete

• Check that you are on-line - press the On-line button

• Check that your computer is in the same address subnet

• Check that you have assigned the Field Controller tag

• Check that you have exported all tags OPC server

• Check that the parameters are in the recommended order

• Check that the OPC server is running (look for icon in 

bottom line)

• Try "Update" from the Field Controller node (SFC162 

only, takes several minutes) and download again

8 PROFIBUS configuration will not download You have either a communication problem or the 

configuration is not complete

• Try downloading from HSE Network node, see above, if 

this does not work, check points below

• Configuration mismatch between PROFIBUS Configurator 

and Application Designer

– Have PROFIBUS device blocks been deleted?

– If so, reconfigure project in PROFIBUS Configurator

9 Parameter appears red in the on-line control strategy The parameter has a bad status

• Check that the Block Mode is Auto (or Cas)

• Check that the block has been correctly configured

• Check that the device is still live (live list)

• Check that the device address is the same as that you 

have in your configuration (live list)

• Check that the parameter has been correctly configured

• Check that the tags were exported (Export Tags)

10 FB links do not work Project not downloaded correctly, e.g. partial download 

when bridge has HSE links

• Repeat full download from the HSE Network node
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For your notes
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