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1 Memobase

1.1 Features

Memobase is a software package offering central data and sensor management for Memosens 

systems that allows end-to-end documentation of data relevant to your sensor and measuring point, 

e.g.:

• Calibration history

• Sensor utilization data such as total operating hours, operating hours under extreme process 

conditions

• Assignment to a measuring point or a group of measuring points

Memobase is based on a client-server architecture and allows multiple client access. All the data are 

stored in a central database.

The software can be combined with the following databases:

• SQLite

You can install the free SQLite database provided on the Memobase CD and use it on your 

computer.

• Oracle1) over ODBC

If you are already using an Oracle database, you can use this. To do so, the appropriate ODBC 

driver for Oracle must be installed on your computer and an appropriate database client must be 

set up on your computer. Contact your database administrator if you have any queries.

Any other use than the one described here is not permitted.

The manufacturer is not liable for damage caused by improper or non-designated use.

1.2 System requirements

The following system requirements must be met when installing and using Memobase.

• Operating system: Windows XP1) SP2 or Windows Vista1)

• At least 100 MB free storage space on the hard disk

• Commubox modem FXA291 

Information on connecting and installing the FXA291 is provided in the Technical Information 

document (TI405C/07/en) and the installation CD for FXA291.

• Adobe Reader1) 7.0 or higher

To display the Operating Instructions (also required if a full version of Adobe Acrobat is installed)

• Liquiline lab device 

1) The products referred to are trademarks of their respective companies.

Version Parameter Software version

CM42-M/N********* pH glass, pH ISFET, ORP 10.05.00 or higher

CM42-K********* Conductivity 13.05.00 or higher

CM42-O********* Oxygen 20.03.00 or higher
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2 Identification

2.1 Product structure

2.2 Scope of delivery

The scope of delivery comprises:

• Installation CD with Memobase setup and Operating Instructions

• Serial number and license key

• Brief Operating Instructions

• Commubox FXA291 (optional)

Software

1 Standard

Version

1 Standard

Diagnosis

A Standard

Interface

1 Not selected

2 FXA291

Documentation language1)

D German / English

Additional options

1 Not selected

CYZ41D-

1) This option only refers to the printed Getting Started. The software contains complete Operating Instructions in all 

available user interface languages.
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3 Installation

3.1 Installation wizard

The installation wizard guides you through the installation of the Memobase software. It also 

comprises an update function. So, if you want to update your Membase software, start the 

installation wizard as well.

1. Insert the CD into your CD/DVD drive.

The Memobase installation procedure starts automatically. 

If autostart is not active, start SetupMemobase.exe directly from the CD.

2. In the dialog box displayed, select the language for the installation.

Click OK.

3. The license agreement appears.

– Please read the license agreement carefully.

– Select I agree to accept the agreement and continue installing the software.

– Click Cancel if you do not accept the agreement and want to abort the installation.

4. In the dialog box that appears, enter the serial number located on the back of the CD cover.

Click Next.
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5. Enter the license key. This is also located on the back of the CD cover.

Click Next.

6. Specify the directory where Memobase is to be installed.

Memobase is installed in the following directory as standard:

C:\Program files\Endress+Hauser\Memobase

If you want to install the program in another directory, click Browse and select the desired 

directory.

Click Install to start the installation.

7. In the Database Installer dialog box, select your database type and specify the requisite 

information on your database.

• If you are using Memobase with the SQLite database supplied: 

– Select SQLite under Database type.

– Enter the target directory where the database will be installed. 

The SQLite database is installed in the following directory as standard:

C:\Program files\Endress+Hauser\Memobase

If you want to install the database in another directory, specify the desired directory.
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• If you are using an Oracle database over ODBC:

– Make sure that the appropriate ODBC driver for Oracle is installed on your computer and 

an ODBC client is set up. Where necessary, contact your database administrator.

– Select ODBC under Database type.

– Enter your access data for the database.

Click Install to continue the installation procedure.

8. The following dialog boxes are displayed depending on the database type selected:

– If you are creating a new SQLite database the Create new database dialog box appears.

If a database already exists in the selected directory, a message appears that this database will 

be updated. We recommend to make a backup copy of the database before updating it.

Click OK.

The Memobase and database files are copied to the target directory.

– If you are updating an existing ODBC database, the Update existing ODBC database 

dialog box appears.

We recommend to make a backup copy of the database before updating it.

Click OK.

The Memosens definitions and texts are updated.

9. In the dialog box displayed, click Close to finish the installation procedure.
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4 Operation

4.1 Starting the program

1. Make sure that the drivers for the Commubox FXA291 are installed on your computer as per 

the installation instructions.

2. Make sure that the Commubox FXA291 is connected to the Liquiline and the USB port of your 

computer.

3. Select Start > Programs > Memobase > Memobase.

4. The login screen appears:

If you are starting Memobase for the first time:

– Leave Administrator as the user name.

– Do not enter any password. 

You specify user administration and passwords later in the software.

For all subsequent starts:

– Enter your user name.

– Enter your password.

Click Login.

5. The Modem selection dialog box is displayed.

– Select the COM port to which the Commubox FXA291 is connected.

– Click OK.

6. The connection to the Liquiline is established.
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7. The Memobase user interface is displayed.

4.2 Communication

4.2.1 Connecting Commubox FXA291

If the Liquiline is connected to your computer when you start Memobase, the connection is 

automatically established when you start the program. 

If the Liquiline is not connected to your computer, proceed as follows:

1. Insert the USB plug of your Commubox FXA291 into a USB socket on your computer.

2. Select Communication > Connect Commubox FXA291.

3. In the Modem selection dialog box, select USB Commubox FXA291 serial port. Click 

OK.

4. The connection to the Liquiline is established.
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4.2.2 Automatic Liquiline polling

By means of the automatic Liquiline polling function, you can automatically save every calibration 

you perform on the connected Liquiline in the Memobase database.

Automatic Liquiline polling is enabled as standard. 

Thus, if you calibrate a sensor on the Liquiline and confirm the option Store the data for 

adjustment, the calibration data are transmitted to the sensor and the Memobase database. A new 

data record with the new calibration data is automatically created in the database.

To enable the automatic Liquiline polling, proceed as follows:

1. Select Communication and click Autom. Liquiline polling. A checkmark appears beside 

Autom. Liquiline polling and a green dot appears in the task bar. 

2. To deactivate automatic polling, select Communication again and click Autom. Liquiline 

polling.

The checkmark beside Autom. Liquiline polling  disappears and a gray dot is displayed in 

the task bar.

4.3 Customizing the user interface

4.3.1 Selecting the language

Memobase is supplied in the following languages:

• German

• Dutch

• English

• Spanish

• French

• Italian

• Japanese

• Polish

• Portuguese

• Russian

• Czech

The language of the user interface can be easily changed if another user wants the user interface to 

be displayed in a different language.

To change the language:

1. Select Options > Set language.

2. The Language selection dialog box is displayed.

– Select the desired language for the user interface, e.g. English.

– Click OK.

3. Memobase switches to the selected language. This has no effect on the stored data.
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4.3.2 Viewing sensor data

You can configure the sensor data view individually so that you always have the information you 

need at your fingertips.

To customize the view:

1. Select Options > Preferences.

2. The Preferences dialog box is displayed.

– Under Preferences for sensor, select the sensor type for which you would like to 

customize the view.

Select CPSx1D for glass electrodes, for example or CLSxxD for conductivity sensors.

– Select the tab for the view you want to customize: Sensor view, Sensor user data, 

Database or Statistics.

– Tick the sensor data that should be displayed.

! Note! 

You can restore the default settings at any time. To do so, click Defaults.

– Once the sensor data view meets your requirements, click Close.

3. The ticked sensor data are displayed and the disabled data are hidden.

! Note! 

Hiding the data has no effect on the database. All data are always saved.

4.4 User administration

To protect Memobase against unintentional or undesired changes, you can restrict database access 

to only certain users with a password, and assign these users user roles. 

You can define the following user roles:

• Operator

As an operator, you can save new Memosens sensors or edit stored data records and save them 

as new data records with a new time stamp. You cannot make any changes to the user 

administration or measuring point (TAG) assignment, however.

• Specialist

As a specialist, you have all rights of the operator. In addition, you can manage the measuring 

point assignment. You cannot make changes to the user administration.

• Administrator

As the administrator, you have all the rights of the specialist. In addition, you can also manage the 

users.
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4.4.1 Creating, editing and deleting users

Proceed as follows to set up user administration:

1. Select Options > User administration.

2. The User administration dialog box is displayed.

To create a new user:

– Click Add user.

– Enter the desired user name.

– Assign a user role to the user.

– Enter the password and repeat it.

To edit an existing user:

– Click the user entry.

– Click Edit user.

– Change the user role or the password as required.

To deactivate a user:

– Click the user entry.

– Click Disable user.

3. Click Apply to save the modified settings.

4.4.2 Logging users on and off

When you exit the Memobase database, you can log off without having to close the program. 

1. To do so, select File > User logout.

2. The E+H Memobase - Login dialog box is displayed.

3. A new user just has to enter his/her user name and password in the login window to be able 

to use the Memobase database.
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4.5 Measuring point (TAG) assignment

Memobase allows you to assign your sensors to a specific measuring point or group of measuring 

points.

In order not to mistake the sensors when replacing them in the field, you can - in addition to the 

outer labeling with Memoclip (see "Accessories") - activate a sensor check in transmitters of the 

Liquiline platform. The sensors are then checked for correct measuring point assignment. An 

incorrect assignment triggers an alarm in the Liquiline.

The following measuring point assignment types are available:

• TAG:

If you assign a TAG to a sensor, the sensor is fully linked to one measuring point. It can only be 

used at this measuring point and cannot be used at any other measuring point. 

Example:

Sensor A is assigned to measuring point TAG 1.

Ç Sensor A can only be used at measuring point TAG 1. If it is connected to another measuring 

point, an alarm is triggered.

• TAG group:

If you assign a TAG group to the sensor, the sensor can be used at all the measuring points that 

belong to this TAG group. 

Example:

TAG group 1 comprises measuring points X, Y and Z.

Sensor A is assigned to TAG group 1. 

Ç Sensor A can be used at the three measuring points X, Y and Z. If it is connected to another 

measuring point, an alarm is triggered.

4.5.1 Assigning measuring points (TAGs) in Memobase

To assign the sensors that you manage in your Memobase database to a specific TAG or TAG group, 

you have to create a TAG list or TAG group list.

Proceed as follows:

1. Select Options > TAG assignment.

2. The TAG assignment dialog box appears.

To create a new entry:

– Select the TAG list or TAG group list tab.

– Click New.

– Enter the TAG name or TAG group.

Enter a comment if required.

– Repeat the two previous steps for every TAG name or TAG group that you want to add to 

your list.

To deactivate an entry:

– Select the entry you want to delete.

– Click Disable.
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3. Once the list is completed, click OK.

4. You can now assign a TAG name or TAG group to every Memosens sensor. See the "Reading 

out Memosens" section for this purpose.

4.5.2 Liquiline settings - Assigning measuring points in Liquiline

Liquiline M CM42-K/M/N/O********* offers the following functions for measuring point 

administration:

• Lab device: 

With this function you can ensure that the measuring point information saved in the sensor is not 

overwritten by calibrating on the Liquiline.

Use this function for the instruments that you use in the laboratory for central Memosens sensor 

calibration.

• Sensor check (only available with the "Advanced Version"):

Use this function to specify what sensors are accepted on a Liquiline instrument.

Activate this function for the instruments that you use in the process and to which you would like 

to assign specific sensors.

! Note! 

The two functions are mutually exclusive. In a Liquiline instrument, you can either enable the lab 

device or the sensor check function.

Lab device

Since the sensors with Memosens technology save the calibration data, you can calibrate them 

centrally in the laboratory. To do so, use a Liquiline and activate the lab function. In this way, you 

can ensure that all the measuring point information stored in the sensor (TAG, TAG group) is not 

overwritten. This means that you can use the calibrated sensor again at its assigned measuring point 

even if the sensor check is enabled.

To activate the lab function in the Liquiline:

1. Select Setup > General settings > Lab device.

2. Select On and press the navigator to confirm your entries.

Sensor check

If you assigned your measuring point certain sensors in the process, you can use the sensor check 

to ensure that only the assigned sensors, or sensors fresh from the factory with precisely the same 

order code, can be connected to this measuring point. 

If another sensor is connected to this measuring point, the Liquiline rejects this sensor and an alarm 

is displayed. 

To activate the sensor check in the Liquiline:

1. Select Setup > General settings > Sensor check. Press the navigator to confirm.

2. Depending on whether you manage your measuring point using TAG groups or TAGs, select 

TAG group or TAG. Press the navigator to confirm.

3. Depending on the setting previously made, select TAG number or TAG group. Press the 

navigator to confirm.

4. Enter the desired TAG number or TAG group. Using the navigator, scroll to OK and confirm 

by pressing the navigator.
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4.6 W@M administration

Memobase offers direct access to the Endress+Hauser W@M portal. In this portal, you can find 

further information and documents concerning your sensors.

To create the W@M access:

1. Select Options > WAM administration.

2. The W@M account settings dialog box is displayed.

– Under Login, enter your W@M user name.

– Under Password, enter your W@M plassword.

– Click OK.

Now you have direct access to the W@M information.

3. Select the desired sensor in the database view.

4. Select File > WAM.

The W@M portal automatically displays the data record of the selected sensor.

! Note! 

To access the W@M information, your PC needs an Internet access.
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4.7 Sensor view

The sensor view shows the sensor that is currently connected to your Liquiline lab device.

In the sensor view, you can 

• Read out the data of the sensor

• Add your specific information on the sensor

• Save the data record of the sensor in your database

• Assign the sensor to a specific TAG or TAG group, if required.

4.7.1 Reading out Memosens

Proceed as follows:

1. Make sure that a sensor is connected to your transmitter.

2. Select the Sensor view tab.

3. Click Read Memosens.

4. The sensor data are read out.

If the database already contains data records from the connected sensor, these records are also 

displayed.

! Note! 

• The data read out are not saved automatically. To save the data, see the "Storing data" section.

• After exchanging the sensor, click Read Memosens to update the displayed data.
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4.7.2 Adding sensor information

1. If you would like to assign specific information to the sensor, click Open sensor information.

2. The sensor information is displayed.

– If you want to assign the sensor to a TAG or TAG group, click the arrow beside the TAG or 

TAG group field.

The TAG list or TAG group list created beforehand is displayed.

Double-click the entry that you want to assign to the sensor. The assigned TAG or TAG 

group is stored in the database as well as the sensor.

! Note! 

Sensors that are operated on a measuring point with a TAG that is not yet included in the 

TAG list of the database automatically create a new entry in the list when saved. A comment 

on this measuring point can always be added to the measuring point assignment at any time.

– You can disable a sensor if you no longer want to use it. In this way, you immediately see 

that it is no longer integrated in the process.

Click the box beside Active. The checkmark is deleted and the entry changes to No. The 

sensor is indicated as not activated in the database

– To enter a Memoclip name, click the empty field beside Label Memoclip. Enter the desired 

information. 

– To enter a comment, click the empty field beside User comment. Enter the desired 

information. 

4.7.3 Storing data

1. Click Store data.

2. The data record is saved with the date and time it was read in and stored in the database.

! Note! 

A data record cannot be overwritten once it has been stored. This protects the database from being 

manipulated.

If you make changes to a data record, e.g. changes to the sensor information, a copy is created with 

a new time stamp.
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4.8 Database view

All the sensors that you stored in your database  are displayed in the database view.

To open the database view, select the desired tab.

The data are sorted as follows:

• The latest data record is always on the left.

• The data on the sensor that is currently selected are displayed in the top gray section.
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4.8.1 Information displayed

The database view displays the following information on the sensors as standard: 

pH glass ORP pH ISFET Oxygen Conductivity

Event time Event time Event time Event time Event time

Identification

Order code

Serial number

Date of manufacture

Commissioning date

Memoclip label

Active

TAG

TAG group

Identification

Order code

Serial number

Date of manufacture

Commissioning date

Memoclip label

Active

TAG

TAG group

Identification

Order code

Serial number

Date of manufacture

Commissioning date

Memoclip label

Active

TAG

TAG group

Identification

Order code

Serial number

Date of manufacture

Commissioning date

Memoclip label

Active

TAG

TAG group

Identification

Order code

Serial number

Date of manufacture

Commisssioning date

Memoclip label

Active

TAG

TAG group

Sensor information

Type of calibration

Zero point [pH]

Slope [mV/pH]

Date of pH calibration

Buffer 1 [pH]

Buffe 2 [pH]

Number of calibrations

Delta zero point [pH]

Delta slope [mV/pH]

Slope as found [mV/pH]

Zero point as found [mV/pH]

S/N calibration transmitter

Sensor information

Type of calibration

Offset ORP

Date of calibration

ORP buffer

Number of calibrations

Delta offset

S/N calibration transmitter

Sensor information

Type of calibration

Operating point [mV]

Slope [mV/pH]

Isotherm [pH]

Date of pH calibration

Buffer 1 [pH]

Buffer 2 [pH]

Number of calibrations

Delta operating point [mV]

Delta slope [mV/pH]

Slope as found [mV/pH]

Operating pnt. as found [mV/pH]

S/N calibration transmitter

Sensor information

Slope [pA/hPa]

Min. slope

Max. slope

Date of slope calibration

Type of calibration

Date of zero point calibration

Number of sensor calibrations

Number of cap calibrations

Delta slope [pA/hPa]

Delta zero point [nA]

Slope as found [pA/hPa]

Zero point as found [nA]

S/N calibration transmitter

Sensor information

Type of calibration

Cell const. [1/cm]

Delta cell const. [1/cm]

Temp. reference

Conduct. reference

Date of cell const. calibration

Number of calibrations

S/N calibration transmitter

Temperature calibration

Temperature offset [K]

Date of temp. calibration

Temperature calibration

Temperature offset [K]

Date of temp. calibration

Temperature calibration

Temperature offset [K]

Date of temp. calibration

Temperature calibration

Temperature offset [K]

Date of temp. calibration

Temperature calibration

Temperature offset [K]

Slope temp.

Type of temp. calibration

Temperature reference 1

Temperature reference 2

Date of temp. calibration

S/N calibration transmitter

Operating hours

Operating time

Number of sterilizations

Max. operating temp. [°C]

Usage > 80 °C [h]

Usage > 100 °C [h]

Usage < -300 mV

Usage > 300 mV

Operating hours

Operating time

Number of sterilizations

Max. operating temp. [°C]

Usage > 80 °C [h]

Usage > 100 °C [h]

Operating hours

Operating time

Number of sterilizations

Max. operating temp. [°C]

Usage > 80 °C

Usage > 100 °C

Usage < -300 mV

Usage > 300 mV

Operating hours

Operating time

Number of sensor sterilizations

Number of cap sterilizations

Max. operating temp. [°C]

Min. operating temp. [°C]

Usage > 40 °C [h]

Usage > 80 °C [h]

Usage > 10 nA [h]

Usage > 40 nA [h]

Charge [μAs]

Leak current [nA]

Reference voltage [mV]

Polarization voltage [mV]

Operating hours

Operating time

Number of sterilizations

Max. operating temp. [°C]

Min. operating temp. [°C]

Max. conductivity

Min. conductivity

Usage > 80 °C [h]

Usage > 120 °C [h]

Usage > 140 °C [h]

Usage > 80 °C < 100 nS [h]

CIP count

Customized sensor 

information

User name

User role

User comment

Customized sensor 

information

User name

User role

User comment

Customized sensor 

information

User name

User role

User comment

Customized sensor 

information

User name

User role

User comment

Customized sensor 

information

User name

User role

User comment
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4.8.2 Operations in the database view

In the database view, you can

• Filter and sort the database entries

• Edit the sensor information

• Open the graphic statistics.

Filtering and sorting

1. To filter and sort your data click Search.

2. The Search dialog box is displayed.

– Under Global filter you can decide whether you want to take all the sensors, or only the 

active sensors, into account when performing the search.

– In the Event time filter, you can specify the timeframe for when the search should be 

performed.

– In the Detail filter specify the sensor properties the database entries should be filtered by. 

In the top field, select the sensor property e.g. serial number or TAG and enter the 

appropriate data in the field below, e.g. 7C024505E00 or Tag 1.

You can filger by the following entries:

– Order code

– Serial number

– Date of manufacture

– Commissioning date

– Date of calibration

– TAG

– TAG group

– S/N calibration transmitter

– Memoclip label

– User name

– User comment

Click Search to perform the filtering and sorting action.

3. To display all stored sensor entries again, deactivate the filters in the Search dialog box and 

click Search.
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Opening sensor info

1. If you want to edit the specific sensor information, click Open sensor information.

2. The sensor information is displayed.

– If you want to remove a sensor from the process - because of wear or damage, for example 

- you can disable the sensor here. You can also disable sensors that have been destroyed in 

the field.

To do so, click the box beside Active. The checkmark is deleted and the entry changes to 

No.

– To enter a Memoclip name, click the empty field beside Label Memoclip.

Enter the desired information. 

– To enter a comment, click the empty field beside User comment.

Enter the desired information.

Click Store data.

The edited data are saved as a new database entry with a current time stamp.

Opening statistics

The sensor statistics provide you with a graphic way of displaying the calibration data for the sensor. 

Here, you can immediately see how the zero point and the slope of the sensor change, and use this 

information to specify the intervals at which the sensor has to be calibrated.

1. Click Open statistics.

2. The sensor statistics are displayed.

3. If you want to close the graphic view, click Close statistics.
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4.9 Exporting data

Memobase gives you the option of exporting either individual database entries, or all the database 

entries of a specific sensor, or the entire database to various common formats such as Excel, HTML 

etc.. In this way, you can integrate the sensor data easily into other systems.

4.9.1 Sensor data export

With the Sensor data export option you can export the data of the sensor, which has just been read 

out, to an HTML file.

To start the sensor data export:

1. Click the Sensor view tab.

2. Select the database entries that you want to export.

– To select multiple consecutive entries, hold down the shift key and click the first and last 

entry in the row.

– To select multiple random entries, hold down the Ctrl key and click the desired entries.

3. Select File > Sensor data export.

4. The Sensor data export dialog box is displayed.

– Select the target directory.

– Enter a file name.

– Click Save.

5. The database entries are saved as an HTML file in the selected directory. 

4.9.2 Sensor report

The sensor report exports all the database entries for a certain sensor to an XLS file.

To create the sensor report:

1. Select File > Sensor report.

2. In the dialog box that appears, enter the serial number of the sensor for which you want to 

create the report.

3. The Create a sensor report dialog box appears.

– Memobase automatically creates a folder with the selected serial number in the directory 

C:\Programs\Endress+Hauser\Memobase\Reports.

– Enter a file name.

– Click Save to save the report in the created folder.
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4. The sensor report is saved as an XLS file.

It provides you with the following information:

– Current sensor data

– All sensor data
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– A graphic representation of the slope history

– A graphic representation of the zero point history

4.9.3 Database export

With the Database export option, you can export selected entries of your Memobase database to a 

CSV file.

To start the database export:

1. Click the Database tab.

2. Select the database entries that you want to export.

– To select multiple consecutive entries, hold down the shift key and click the first and last 

entry in the row.

– To select multiple random entries, hold down the Ctrl key and click the desired entries.

3. Select File > Database export.

4. The Database export dialog box is displayed.

– Select the target directory.

– Enter a file name.

– Click Save.

5. The database entry is saved as a CSV file in the selected directory. 
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5 Accessories

5.1 Communication

Commubox FXA291

• Interfaces module between CDI and USB-PC interface

• Technical Information TI405C/07/en

• Order no. 51516983

5.2 Transmitter

Liquiline M CM42

• Modular two-wire transmitter for Ex and non-Ex areas

• Hart®, PROFIBUS or FOUNDATION Fieldbus available

• Ordering acc. to product structure, Technical Information TI381C/07/en

5.3 Outer labeling

Memoclip

• Identification for Memosens sensors

• 100 plastic clips incl. label sheets

• order no. 71038228
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